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Quick Start to
Stand-Alone Installation

This section provides step-by-step instructions about how to install AutoCAD on your system.
You should read the entire Stand-Alone Installation Guide if you have any questions that are
not addressed in this Quick Start section.

For information about installing network-licensed or multi-seat stand-alone versions of the
program, see the Network Administrator's Guide.

How to Prepare for Installation

Before you install AutoCAD, you need to review the system requirements,
understand administrative permission requirements, locate your AutoCAD 2009
serial number, and close all running applications. After you complete these
tasks, you can install AutoCAD.

How to Review System Requirements

Make sure that the computer on which you install AutoCAD meets the system
requirements. If your system does not meet the system requirements, many
problems can occur, both within AutoCAD and at the operating system level.

To review the system requirements, see System Requirements on page 28.



How to Understand Administrative Permission
Requirements

To install AutoCAD, you must have administrator permissions. You do not
need to have domain administrative permissions. See your system administrator
for information about administrative permissions.

To run AutoCAD, you do not need administrator permissions. You can run
the program as a limited user.

How to Install Multiple or Bundled Products

Some Autodesk packages are comprised of multiple products or are part of
multi-product bundles.

In the Installation wizard for packages containing multiple products, you can
choose which products you want to install. During the install process, you
are informed whether a copy of the software is already installed, you are also
warned if your system does not meet the minimum system requirements for
the product. Each product name is displayed on its own tabbed panel; you
can configure them individually.

If you purchased a package that is a multi-product bundle, such as an
educational or institutional package, you may have a package that includes
several Autodesk products. For these bundled packages, an Installer Disk
contains information for all the products in the package. The Installer Disk
helps you install all of the products.

How to Locate Your AutoCAD 2009 Serial Number

When you activate AutoCAD, you are prompted for your serial number. Your
serial number is located on the outside of the product package. Make sure to
have this number available before you activate the program so that you don't
have to stop in the middle of the installation.
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How to Avoid Data Loss During Installation

The AutoCAD installation process may stop if some applications (such as
Microsoft® Outlook® or virus-checking programs) are running. Close all
running applications to avoid possible data loss.

How to Migrate Custom Settings from Previous
Versions

You can migrate your custom settings and files from previous releases of
AutoCAD (AutoCAD 2000 through AutoCAD 2009) to AutoCAD 20009. It is
recommended that you migrate from a previous release when you first use
AutoCAD 2009 or soon thereafter. Migrating right away prevents you from
overwriting files or having to keep track of any custom settings you may make
in the new release.

For more details regarding migration, see Migrate Custom Settings and Files
from Previous Releases on page 7.

How to Install and Run AutoCAD

To use the product, you must install the product, register and activate it, and
then launch it.

How to Install AutoCAD

AutoCAD ships on either a single DVD or three CDs. The installation process
has been streamlined by means of the Installation wizard.

1 Insert the AutoCAD DVD, or the first CD, into your computer's drive.
2 In the AutoCAD Installation wizard, click Install Products.

3 Follow the directions on each installation page.

If installing from CDs, insert the remaining AutoCAD CDs when
prompted, to complete the installation.

How to Avoid Data Loss During Installation | 3



NOTE When you select Install without making any changes, the Installation
wizard asks you to confirm you want to continue installing using the default
configuration. If you select Yes, a Typical installation takes place. For more
information, see Install AutoCAD on page 31

How to Register and Activate AutoCAD

After AutoCAD is installed, you can initiate the registration process by
launching the product. When you launch AutoCAD, the Product Activation
wizard is displayed. Follow the directions in the Product Activation wizard to
register the product.

Make sure you have your product serial number available. You cannot register
and activate AutoCAD without it.

NOTE If you are upgrading from an earlier release of AutoCAD, use your new
serial number when you register and activate the new release.

For more information about registering AutoCAD, see Register and Activate
AutoCAD on page 36.

How to Launch AutoCAD 2009

Assuming that you followed all of the previous steps outlined in this Quick
Start section, you can launch AutoCAD and start taking advantage of its new
and updated features. For more information about the new features, see the
New Features Workshop after you launch the product.

You can start AutoCAD in the following ways:

B Desktop shortcut icon. When you install AutoCAD, an AutoCAD 2009
shortcut icon is placed on your desktop unless you cleared that option
during installation. Double-click the AutoCAD 2009 icon to start AutoCAD.

B Start menu. On the Start menu (Windows), click All Programs (or Programs)
» Autodesk » AutoCAD 2009 » AutoCAD 2009.

B Location where AutoCAD is installed. If you have administrative
permissions, you can run AutoCAD in the location where you installed it.
If you are a limited-rights user, you must run AutoCAD from the Start
menu or from the desktop shortcut icon. If you want to create a custom
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shortcut, make sure that the Start In directory for the shortcut points to a
directory where you have write permissions.

How to Install and Start the CAD Manager

Control

Utility

Using the Autodesk CAD Manager Control utility, CAD managers can
selectively control which users have access to Internet-based content and
information from DesignCenter Online, Communication Center, and the
Subscription Center. They can also determine if users receive notification
when reported errors are resolved.

How to install the CAD Manager Control utility

1
2

Insert the product DVD, or the first CD, into your computer's drive.
In the Installation wizard, click Install Tools and Utilities.

On the Select the Products to Install page, select Autodesk CAD Manager
Tools, click Next.

Review the Autodesk software license agreement for your country or
region. You must accept this agreement to proceed with the installation.
Select your country or region, click I Accept, and then click Next.

NOTE If you do not agree to the terms of the license and want to terminate
the installation, click Cancel.

On the Review - Configure - Install page, click Install if you want to accept
the default install location.

When you select Install without making any changes, the Installation
wizard asks you to reconfirm you want to continue installing using the
default configuration.

I = | You have not made changes to the default configuration that will be
' used to install the chosen product(s).

Do you want to continue installing using the default configuration?

How to Install and Start the CAD Manager Control Utility | 5
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If you want the utility installed in a different installation path, click
Configure, set the path, click Configuration Complete and then Install.

6 When the Installation Complete page is displayed, click Finish.

How to start the CAD Manager Control utility

1 On the Start menu (Windows), click All Programs (or Programs) »
Autodesk » CAD Manager Tools » CAD Manager Control Utility.

2 Select the product you want to modify. Click OK.

Quick Start to Stand-Alone Installation



Move to AutoCAD 2009
from a Previous or Same
Release

If you have a previous version of AutoCAD installed on your system, you can install AutoCAD
2009 and keep other versions of the program on the same system. This is called a side-by-side
installation. If you've purchased an upgrade version of AutoCAD, you are required to uninstall
the previous version within 120 days of installing AutoCAD 2009. See your license agreement
for more information.

In this section, you learn about migrating from previous releases, using customized files from
previous releases, and locating customized files.

Migrate Custom Settings and Files from
Previous Releases

You can migrate your custom settings and files from previous releases of
AutoCAD (AutoCAD 2000 through AutoCAD) to AutoCAD 20009. It is
recommended that you migrate from a previous release when you first use
AutoCAD 2009 or soon thereafter. Migrating right away prevents you from
overwriting files or having to keep track of any custom settings you may make
in the new release.

You can use the following tools to migrate settings and files:

B Migrate Custom Settings dialog box. Migrates user profiles, CUI files,
AutoCAD and user-defined linetype files, AutoCAD and user-defined hatch
patterns, and the acad.pgp file (a file that stores command definitions and
aliases). The Migrate Custom Settings dialog box is displayed when you start



AutoCAD for the first time. You can also migrate settings later from the
Start menu (Windows).

B Customize User Interface dialog box. Converts legacy menu files (MNU
and MNY) to the CUI format while leaving the original MNU or MNS file
unchanged. Migrating user interface elements, transferring data between
customized files, and customizing user interface elements are simplified
in this dialog box. For more information about the CUI format and how
migration of menu files has been simplified, see Customize the User
Interface in the Customization Guide.

B Migration tools. Aid migration of settings or files that cannot be
automatically migrated (such as AutoLISP® files and the accompanying
MNL files) or that require you to make a decision about which files to
migrate (such as which files in a set of drawing files). Download these
migration tools by visiting www.autodesk.com and then performing a search
on Migration Tools.

NOTE For information about customizing files and settings, see the Customization
Guide, accessible from the Documentation link on the AutoCAD 2009 Installation
wizard and in the Help system.

Migrate Custom Settings

If you install AutoCAD 2009 on a computer where a previous release of
AutoCAD (AutoCAD 2000 through AutoCAD) is installed, you can migrate
some custom settings from a previous release to AutoCAD 2009.

Migrate the user profile. This file contains drawing environment settings such
as screen color, cursor size, command line window font, and the dictionary
to use for checking spelling. The user profile file also includes the folders in
which AutoCAD searches for support, driver, customization, and other files.
If you customized files in a location other than the default AutoCAD location,
the path to the location is migrated. The files themselves do not get migrated.

Migrate linetypes, hatch patterns, and command aliases that you created.
The data from these files is added to a user-defined section of the AutoCAD
2009 files, to make it easy for you to find this information and migrate this
data to future releases. You cannot use the Migrate Custom Settings dialog
box to migrate shell commands or comments that you made to your acad.pgp
file.
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NOTE If you have made changes to partial plotter configuration (PC3) files that
are located in a custom folder, those files are migrated to the AutoCAD 2009 PC3
folder, which is located under your custom PC3 folder. PC3 files are migrated to
a separate folder to maintain backward compatibility with previous AutoCAD

releases.

The following table lists the files that are migrated with the Migrate Custom

Settings dialog box, a description of each file, and file details to help you
decide if you want to migrate a file.

Files Migrated with the Migrate Custom Settings Dialog Box

File Name File Description Details

*.arg Used to back up user profile infor- ~ Changes you make to your user pro-
mation from the system registry.  file are stored in the system registry
The ARG file is not migrated. and are migrated.
Registry settings are migrated.

*.lin Stores your user-defined line- User-defined linetype files are migrat-
types. ed.

acad.lin Contains standard linetype defini-  The file itself is not migrated; howev-

tions (an AutoCAD library file).

er, any linetypes that you created in
this file are migrated to the AutoCAD
2009 acad.lin file, in the User Defined
Linetypes section of the file.

acadiso.lin

Contains metric linetype defini-
tions (an AutoCAD library file).

The file itself is not migrated; howev-
er, any linetypes that you created in
this file are migrated to the AutoCAD
2009 acadiso.lin file, in the User De-
fined Linetypes section of the file.

*.pat Stores user-defined hatch pat- User-defined hatch pattern files are
terns. migrated.
acad.pat Contains standard hatch pattern  The file itself is not migrated; howev-

definitions (an AutoCAD library
file).

er, any hatch patterns that you creat-
ed in this file are copied to the Auto-
CAD 2009 acad.pat file, in the User

Migrate Custom Settings | 9



Files Migrated with the Migrate Custom Settings Dialog Box

File Name File Description

Details

Defined Hatch Patterns section of the
file.

acadiso.pat ~ Contains metric hatch pattern The file itself is not migrated; howev-
definitions (an AutoCAD library er, any metric hatch patterns that
file). you created in this file are copied to

the AutoCAD 2009 acadiso.pat file,
in the User Defined Hatch Patterns
section of the file.

acad.pgp Stores shell commands and com-  The file itself is not migrated; howev-
mand alias definitions (a program  er, any command aliases you created
parameters file in ASCII text in this file are copied to the AutoCAD
form). 2009 acad.pgp file.

* mnu Contains menu customization The file itself is not migrated; howev-
from a version of AutoCAD earlier  er, a copy of the file is created and
than AutoCAD 2006. then is converted into a CUI file with

the same name. The new CUI file is
placed in the same folder as the main
CUI file. A MNU file is converted
when a MNS file with the same name
is not found.

*.mns Contains menu customization The file itself is not migrated; howev-
from a version of AutoCAD earlier  er, a copy of the file is created and
than AutoCAD 2006. then is converted into a CUI file with

the same name. The new CUI file is
placed in the same folder as the main
CUI file. A MNS file is converted
when a MNU file with the same
name is present or not.

*.cui Contains customizations from a If the CUI file is supplied by Autodesk,

version of AutoCAD starting with
AutoCAD 2006.

the custom changes made to the file
are migrated to the newer version of
the CUI file.
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Files Migrated with the Migrate Custom Settings Dialog Box

File Name File Description

Details

If the CUI file is not supplied by Au-
todesk, the file is migrated and is
copied to where the main CUI file is
located, unless the CUlI file is in a
network location. In that case, the
file is migrated but is not copied to
the location of the main CUI file.
Enterprise CUI files are not migrated
automatically. You must migrate
them manually.

Before the MNU, MNS, and CUI files are migrated, a backup copy of each file

is saved in the following directory:

\Documents and Settings \<user profile>\Application Data\Autodesk \<product
version>\<release number>\<language>\Previous Version Custom Files

NOTE Other custom settings and files can be migrated using Autodesk migration
tools. For more information about migration tools, see Use Migration Tools on

page 13.

To migrate custom settings when you start AutoCAD 2009

1 Start AutoCAD 2009.

2 In the Migrate Custom Settings dialog box, in the Migrate Settings From
list, select the AutoCAD release from which you want to migrate your

custom settings.

3 In the Settings and Files to Migrate box, select the custom files that you

want to migrate.

4 Click OK.

5 In the Migrate Custom Settings message, click OK to view the log file, or
click No if you do not want to view the log file now.

NOTE You can view the log file at another time. For information about
accessing the log file at another time, see View the Migration Log File on

page 12.
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Each time the Migrate Custom Settings dialog box is used, AutoCAD resets
the program’s default CUI file from the UserDataCache folder and then migrates
any customization done in a previous release forward.

To migrate custom settings from the Start menu (Windows)

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » Migrate Custom Settings » Migrate From a
Previous Release.

2 In the Migrate Custom Settings dialog box, in the Migrate Settings From
list, select the AutoCAD release from which you want to migrate your
custom settings.

3 In the Settings and Files to Migrate box, select the custom files that you
want to migrate.

4 Click OK.

5 In the Migrate Custom Settings message, click OK to view the log file, or
click No if you do not want to view the log file.

NOTE To be accessible, pull-down menus that are migrated from a MNU/MNS
file to a CUI file need to be added to a workspace.

View the Migration Log File

The migration log file (migration.xml) provides specific information about any
settings or files that were not successfully migrated to AutoCAD 2009. The
log file shows all the files that were successfully copied from a previous version
to AutoCAD 2009. It also provides information about files that were not
successfully migrated. Use the log for troubleshooting if there are unwanted
or unexpected results in your AutoCAD 2009 profiles.

After you use the Migrate Custom Settings dialog box to migrate custom
settings and files, a message is displayed from which you open the migration
log file. You can view the migration log file at that time. You can also navigate
to the file if you want to view the log details another time.

To locate and view the migration log file

1 In Windows Explorer, navigate to the following location:

\Documents and Settings \<user profile>\Application Data\ Autodesk \<product
version>\<release number>\<language>\Migration.
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2 Double-click migration.xml to open the file, and view the details of your
migration.

Restore AutoCAD 2009 Profiles After Migrating
Files from an Earlier Release

After you migrate your profiles from an earlier AutoCAD release, you may
want to restore the AutoCAD 2009 default profile settings.

To restore the AutoCAD 2009 default profiles

1 Click Tools menu » Options.

2 In the Options dialog box, Profiles tab, click the profile you want to
restore, and then click Reset.

3 Click Yes. The profile is reset to the AutoCAD 2009 default profile.

Use Migration Tools

Migration tools take the guesswork out of updating your custom files from
previous releases. The tools help you to share drawings when you upgrade to
a new release of AutoCAD. You can download the migration tools in several
languages from the Autodesk website.

NOTE Because these are public tools, product support for them is limited to the
Autodesk discussion groups.

The migration tools are as follows:

B DWG TrueView 2009. You can view, plot, and convert any AutoCAD or
AutoCAD-based drawing file for compatibility with AutoCAD Release 14,
AutoCAD 2000, AutoCAD 2004, and AutoCAD 2007 drawing file formats.

B ScriptPro. Facilitates scripting in AutoCAD. Using ScriptPro, you can apply
a set of commands to multiple drawings by simply specifying a script file
and the list of drawings to which you want to apply the script.

B AutoLISP Compatibility Analyzer. Details AutoCAD 2009 compatibility
issues found in AutoLISP files and the accompanying menu (MNL) files.
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When a compatibility issue is found, the tool provides an explanation of
the issue and suggestions on how to correct it.

Export and Import Custom Settings from the
Same Release

You can export your custom settings between systems running the same release
of AutoCAD, or export the custom settings and later re-import them on the
same computer if you need to reinstall AutoCAD. When exporting custom
settings, a migration package is created that contains an XML file. This file
contains custom settings, a listing of the custom files from local locations
used with AutoCAD, and optionally, custom files in network locations.

The migration package is a ZIP file archive, so it has the file extension ZIP.
During the import process, you select the ZIP file archive that contains the
exported custom settings you want to merge onto your computer.

The following table lists the file types that are most commonly included in
the migration package that is created from the Export Custom Settings dialog
box.

Most Common File Types Included in the Migration Package

File Name File Description

*.xml Information about the user profiles in the product and the original loca-
tions of the files in the export package.

*.lin Linetype definitions.

*.pat Hatch pattern definitions.

*.psp Shell commands and command alias definitions.

*.pc3 Configuration information for a plotter or printer.

*.pmp Calibration and paper size settings that are used with a PC3 file.
*.ini Configuration settings for some features.
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Most Common File Types Included in the Migration Package

File Name File Description

*.shx Information about text characters or shapes used with linetype definitions.

*.min Multiline style definitions.

*.ctb Settings used to control the appearance of objects when plotting; the
settings are arranged by the colors of the AutoCAD Color Index (ACI)
system.

*.sth Settings used to control the appearance of objects when plotting; the

settings are grouped into names that can be assigned to a layer or object.

*.cui Information for commands and user interface elements.

*.mnl AutoLISP commands and procedures that a customization file is dependent
on; must have the same name as a customization file in order to be
loaded by the product.

* fmp Information about font mappings for True Type Fonts used in the In-place
Text Editor.

*.cus Custom dictionary entries.

*.psf Information about font substitution when exporting to a Postscript file.

*.bmp Image used for a command in a customization file.

*.atc Tools defined on a tool palette and the tool palette catalog. The file is

not migrated from release to release, but is from computer to computer
with the migration package.

*.aws Order of the tools as they appear on a tool palette and other local settings.
The file is not migrated from release to release, but is from computer to
computer with the migration package.
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The following table lists the file types that are not included in the migration
package that is created from the Export Custom Settings dialog box.

Some of the File Types Not Included in the Migration Package

File Name File Description

*.udl Data connection settings used with dbConnect.
*.fdc Definitions for fields; should not be modified.
*.dcl Definitions for custom dialog boxes used with AutoLISP, ADS, or Objec-

tARX applications.

* i Landscape library; this file type is no longer supported due to the removal
of the LANDSCAPE command.

*.mli Render material library; this file type is no longer supported due to changes
to the MATERIALS command.

* . mnr Resource images for a customization file; must have the same name as a
customization file in order to be loaded by the product. The file is not
included because it is auto-generated by the product when it is not
present.

*.unt Unit definitions used for converting a value from one unit type to another.

NOTE For information about customizing files and settings, see the Customization
Guide, accessible from the Documentation link on the AutoCAD 2009 Installation
wizard and in the Help system.

Export Custom Settings

When exporting custom settings, the custom files stored locally and all user
profiles are exported to a migration package. You have the option to include
custom files that are stored in network locations. During the creation of the
migration package, you do not have any control over which types of files are
included in the migration package.

16 | Chapter 2 Move to AutoCAD 2009 from a Previous or Same Release



The Export Custom Settings dialog box is used to create the migration package
so it can be imported to another computer or the same computer running the
same release of the product.

NOTE You must launch AutoCAD at least once before you can export custom
settings to a migration package.

To export custom settings

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » Migrate Custom Settings » Export AutoCAD
2009 Settings.

2 In the Export Custom Settings dialog box, select the Include Custom Files
in Networked Locations option if you have files in network locations that
you want included in the migration package that is created.

R Export Custom Settings ==

You can export settings and files from your AutoCAD 2009 installztion
1o migrate to other computers

IMPORTANT: All migrated files will be replaced on the new system.

V| Include custom files from networked locations

[ Export. H Cancel || Help

3 Click Export.

4 In the Export Custom Settings file navigation dialog box, enter a name
and specify a location for the migration. Click Open.
A new ZIP file is created.

5 In the confirmation message box, click OK.

Import Custom Settings

By importing a migration package, you can configure AutoCAD in the same
way as other computers that are running the same release of the product.
Upon the successful import of the migration package, a message box is
displayed giving you the option of viewing the migration log that is created.
If any errors are encountered during the import process, they are logged in
the migration log.
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If files from a network location were added during the creation of a migration
package, the files are copied to a different location only when the original
network locations are not available when importing a migration package. If
the files from a network location are found in the same location on the
network, the files are not copied to the network location and are ignored
during import.

During the import process, if the user profile <<Unnamed Profile>> exists, the
user profile is automatically backed up before the migration package is
imported. Local paths that exist as part of a user profile in a migration package
are created automatically during the import process, but paths that are on a
network drive or a drive that uses removable media are not created
automatically.

NOTE You must launch AutoCAD at least once before you can import a migration
package.

To import custom settings from a computer with the same release of AutoCAD

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » Migrate Custom Settings » Import AutoCAD
2009 Settings.

2 In the Import Custom Settings file navigation dialog box, select the ZIP
file that contains the custom settings that were exported. Click Open.
3 On the AutoCAD 2009 message box, click OK.

Optionally, select the Display Log File After Closing This Dialog option
before clicking OK to display the log file that was created during the
importing of the migration package.

To view the migration log after custom settings imported

1 In Windows Explorer, navigate to the following location:

\Documents and Settings \<user profile>\Application Data\ Autodesk \<product
version>\<release number>\<language>\ Migration.

2 Double-click migration.xml to open the file and view the details of your
migration.
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Locate Customized Files

Beginning with AutoCAD 2004, the location of some of your customized files
has changed. The reasons for the file location changes include the following:

B Limited user rights on a workstation. You can run AutoCAD as a limited
user. This means that you no longer need power user or Administrator
permissions to run AutoCAD once it is installed.

B Roaming profiles. Roaming profiles allow you to log on to any computer
within a network and retain your user settings. Some files, such as your
personal settings and documents, follow you from computer to computer,
while other files, such as templates (including Publish to Web templates),
reside only on your system.

If roaming profiles are allowed on your network, your “roamable” files are
located in the \Application Data\ Autodesk \<Product Version> folder, and
your “nonroamable” files are located in the \Local Settings\Application
Data\ Autodesk\ <Product Version> folder.

NOTE In some operating systems, the folders that are located under your profile
are hidden by default. To display these files, you may need to change your display
settings. On the Start menu, click Control Panel » Folder Options. In the Folder
Options dialog box, on the View tab, click Show Hidden Files and Folders.

Locate Data Link Files

Beginning with AutoCAD 2004, the default location of your data link files has
changed. For information about the default location of these files, see Locate
Customized Files on page 19.

NOTE In some operating systems, the folders that are located under your profile
are hidden by default. To display these files, you may need to change your display
settings. On the Start menu, click Control Panel » Folder Options. In the Folder
Options dialog box, on the View tab, click Show Hidden Files and Folders.

To locate your data link files

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.
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3 In the Options dialog box, Files tab, click the plus sign (+) to the left of
Data Sources Location.

4 Under Data Sources Location, click the path name to view the location
of your data link files.

NOTE The changes you make do not take effect until you restart the program.

Locate Plot Style Files

Beginning with AutoCAD 2004, the default location of your plot style files
has changed. For information about the default location of these files, see
Locate Customized Files on page 19.

NOTE In some operating systems, the folders that are located under your profile
are hidden by default. To display these files, you may need to change your display
settings. On the Start menu, click Control Panel » Folder Options. In the Folder
Options dialog box, on the View tab, click Show Hidden Files and Folders.

To locate your plot style files

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of
Printer Support File Path.

4 Click the plus sign (+) to the left of the Plot Style Table Search Path file.

5 Under Plot Style Table Search Path, click the path name to view the
location of your plot style files.

NOTE You can also locate your plot style files by entering stylesmanager on the
AutoCAD command line.
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Locate Plotter Files

Beginning with AutoCAD 2004, the default location of your plotter files has
changed. For information about the default location of these files, see Locate
Customized Files on page 19.

NOTE In some operating systems, the folders that are located under your profile
are hidden by default. To display these files, you may need to change your display
settings. On the Start menu, click Control Panel » Folder Options. In the Folder
Options dialog box, on the View tab, click Show Hidden Files and Folders.

To locate your plotter files

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of
Printer Support File Path.

4 Click the plus sign (+) to the left of Printer Configuration Search Path.

5 Under Printer Configuration Search Path, click the path name to view
the location of your plotter files.

NOTE You can also locate your plotter files by entering plottermanager on the
AutoCAD command line.

Locate the PMP File

Beginning with AutoCAD 2004, the default location of your PMP file has
changed. For information about the default location of this file, see Locate
Customized Files on page 19.

NOTE In some operating systems, the folders that are located under your profile
are hidden by default. To display these files, you may need to change your display
settings. On the Start menu, click Control Panel » Folder Options. In the Folder
Options dialog box, on the View tab, click Show Hidden Files and Folders.
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To locate your PMP file

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk

» AutoCAD 2009 » AutoCAD 2009.
Click Tools menu » Options.

In the Options dialog box, Files tab, click the plus sign (+) to the left of
Printer Support File Path.

Under Printer Description File Search Path, click the path name to view
the location of your PMP file.

Locate Support Files

Beginning with AutoCAD 2004, the default location for some of your support
files has changed. For information about the default location of these files,
see Locate Customized Files on page 19.

Support files include the following:

Configuration file (acad2009.cfg)
Customization file (acad.cui)
Custom icon files

Help and miscellaneous files
Font mapping file (acad.fimp)
Alternate font file (simplex.shx)

Support path files (acad.dcl, acad.lin, acad.mnl, acad.pat, acad.pgp, acad.psf,
acad.unt, acadiso.lin, acadiso.pat, ase.dcl, base.dcl, dbcon.cui, doshelp.dcl, and
gdt.shx)

NOTE In some operating systems, the folders that are located under your profile
are hidden by default. To display these files, you may need to change your display
settings. On the Start menu, click Control Panel » Folder Options. In the Folder
Options dialog box, on the View tab, click Show Hidden Files and Folders.
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To find the default location of the configuration file

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of
Help and Miscellaneous File Names.

4 Click the plus sign (+) to the left of Configuration File.

5 Under Configuration File, click the path name to view the location of
your configuration file.

To find the default location of the customization files

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of
Customization Files.

4 Click the plus sign (+) to the left of Main Customization File.

5 Under Main Customization File, click the path name to view the location
of your main customization file.

6 Click the plus sign (+) to the left of Enterprise Customization File.

7 Under Enterprise Customization File, click the path name to view the
location of your enterprise customization files.

NOTE By default, the path to an enterprise customization file is empty until
you define the file. For more information about defining a customization file,
see “Customize the User Interface” in the Customization Guide.

To find the default location of the custom icon files

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.
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3 In the Options dialog box, Files tab, click the plus sign (+) to the left of

Customization Files.

4 Under Custom Icon Location, click the path name to view the location

for the custom button image files used with your customization files.

To find the default location of the Help and miscellaneous files

1

Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

Click Tools menu » Options.

In the Options dialog box, Files tab, click the plus sign (+) to the left of
Help and Miscellaneous File Names to expand the list.

Click the plus sign (+) to the left of the file you want to locate, and then
click the path name to view the location of the files.

To find the default location of the font mapping file

1

Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

Click Tools menu » Options.

In the Options dialog box, Files tab, click the plus sign (+) to the left of
Text Editor, Dictionary, and Font File Names.

Click the plus sign (+) to the left of Font Mapping File.

Under Font Mapping File, click the path name to view the location of
your font mapping file.

To find the default location of the alternate font file

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
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» AutoCAD 2009 » AutoCAD 2009.

Click Tools menu » Options.

In the Options dialog box, Files tab, click the plus sign (+) to the left of
Text Editor, Dictionary, and Font File Names.

Click the plus sign (+) to the left of Alternate Font File.
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5 Under Alternate Font File, click the path name to view the location of
your alternate font file.

To find the default location of the support path files

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of
Support File Search Path.

4 Under Support File Search Path, click a path name to view the location
of your support files.

Locate Drawing Template Files

Beginning with AutoCAD 2004, the default location of your drawing template
files has changed. For information about the default location of these files,
see Locate Customized Files on page 19.

NOTE In some operating systems, the folders that are located under your profile
are hidden by default. To display these files, you may need to change your display
settings. On the Start menu, click Control Panel » Folder Options. In the Folder
Options dialog box, on the View tab, click Show Hidden Files and Folders.

To locate your drawing template files

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of
Template Settings.

4 Under Template Settings, click the plus sign (+) to the left of Drawing
Template File Location.

5 Under Drawing Template File Location, click the path name to view the
location of your drawing template files.
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Locate Texture Files

Beginning with AutoCAD 2004, the default location of your texture files has
changed. For information about the default location of these files, see Locate
Customized Files on page 19.

NOTE In some operating systems, the folders that are located under your profile
are hidden by default. To display these files, you may need to change your display
settings. On the Start menu, click Control Panel » Folder Options. In the Folder
Options dialog box, on the View tab, click Show Hidden Files and Folders.

To locate your texture files

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 Click Tools menu » Options.

3 In the Options dialog box, Files tab, click the plus sign (+) to the left of
Texture Maps Search Path.

4 Under Texture Maps Search Path, click the path name to view the location
of your texture files.
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Install Autodesk
Products for an Individual
User

This section provides instructions for installing and activating your Autodesk product(s) for
an individual user on a stand-alone computer. For information about installing
network-licensed or multi-seat stand-alone versions of the program, see the Network
Administrator's Guide, located on the Documentation tab of the Installation wizard and in the
Help system.

The AutoCAD 2009 Installation Wizard

The AutoCAD Installation Wizard contains all installation-related material in
one place. From the Installation wizard, you can access user documentation,
install the product and supplemental tools, view support solutions, and learn
about deploying your product on a network.

NOTE Depending upon your locale, AutoCAD ships on either a single DVD or three
CDs. Insert the AutoCAD 2009 DVD or CD 1 to start the installation process. Follow
the prompts to complete the installation. As long as the DVD or CD 1 is in the drive,
you can access documentation by clicking the documentation link.

B Review installation documentation before you install. You can access system
requirements, the AutoCAD Stand-Alone Installation Guide, and the Readme.chm
file before you install your product. Click the Read the Documentation link
and click a document you want to view.
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NOTE To view or print any files with an extension of .pdf, Adobe® Reader
must be installed on your computer. If you do not have Adobe Reader, you
can download the latest version by visiting www.adobe.com.

B Install AutoCAD. From the Installation wizard, click Install Products. Follow
the on-screen instructions to complete the installation.

System Requirements

Before you install your product on a stand-alone computer, make sure that
your computer meets the minimum system requirements.

Whether the Windows operating system is the 32-bit or the 64-bit version is
automatically detected when installing AutoCAD. The appropriate version of
AutoCAD will be installed. The 32-bit version of AutoCAD cannot be installed
on a 64-bit version of Windows.

See the following table for hardware and software requirements.

Hardware and software requirements

Hardware/Software Requirement Notes

Operating system 32-Bit It is recommended that non-English
Windows Vista Enterprise language versions of AutoCAD be
Windows Vista Business installed on an operating system with
Windows Vista Ultimate a user interface language that
Windows Vista Home Premium matches the code page of the Auto-
Windows XP Professional, Service Pack ~ CAD language. A code page provides
2 support for character sets used in
Windows XP Home, Service Pack 2 different languages.
64-Bit

Windows Vista Enterprise
Windows Vista Business
Windows Vista Ultimate
Windows Vista Home Premium
Windows XP Professional

Web browser 32-bit You cannot install AutoCAD if Mi-
Internet Explorer 6.0 SP1 or later crosoft Internet Explorer 6.0 with
64-bit Service Pack 1 (or later) is not in-
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Hardware and software requirements

Hardware/Software Requirement

Notes

Internet Explorer 7.0 or later

stalled on the installation worksta-
tion. You can download Internet Ex-
plorer from the Microsoft website:
http://www.microsoft.com/downloads/

Processor

32-bit

Intel® Pentium® 4 processor or AMD®
Athlon, 2.2 GHz or greater

or

Intel or AMD Dual Core processor, 1.6
GHz or greater

64-bit

AMD 64 or Intel EM64T

RAM

32-bit

1 GB (Windows XP SP2)

2 GB or greater (Windows Vista)
64-bit

2 GB

Graphics card

1280 x 1024 32-bit color video display
adapter (True Color) 128 MB or greater,
OpenGL®, or Direct3D® capable work-
station class graphics card.

For Windows Vista, a Direct3D capable
workstation class graphics card with 128
MB or greater is required1024 x 768
VGA with True Color (minimum)

B Requires a Windows-supported
display adapter.

B For graphic cards that support
Hardware Acceleration, DirectX
9.0c¢, or later, must be installed.

B Installing from the ACAD.misi file
does not install DirectX 9.0c, or
later. Manual installation of Direc-
tX is required, in this circum-
stance, for Hardware Accelera-
tion to be configured.

Hard disk

750 MB for instllation (Windows XP SP2)
2 GB available not including installation
(Windows Vista)

System Requirements | 29


http://www.microsoft.com/downloads/

Hardware and software requirements

Hardware/Software Requirement

Notes

Pointing device Mouse, trackball, or other device

DVD/CD-ROM Any speed (for installation only)
32-bit
Download (ESD) and installation from
DVD or CD-ROM
64-bit
Download or DVD

Optional hardware Printer or plotter
Digitizer

Modem or access to an Internet connec-

tion
Network interface card

Additional recommendations for 3D use

Hardware/Software Requirement

Notes

Operating system 32-Bit
Windows Vista Enterprise
Windows Vista Business
Windows Vista Ultimate
Windows Vista Home Premium
Windows XP Professional, Service Pack
2
Windows XP Home, Service Pack 2
64-Bit
Windows Vista Enterprise
Windows Vista Business
Windows Vista Ultimate
Windows Vista Home Premium
Windows XP Professional

It is recommended that non-English
language versions of AutoCAD be
installed on an operating system with
a user interface language that
matches the code page of the Auto-
CAD language. A code page provides
support for character sets used in
different languages.

Whether the Windows operating
system is the 32-bit or the 64-bit
version is automatically detected
when installing AutoCAD. The appro-
priate version of AutoCAD will be in-
stalled. The 32-bit version of Auto-
CAD cannot be installed on a 64-bit
version of Windows.
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Additional recommendations for 3D use

Hardware/Software Requirement Notes
Processor Intel® Pentium® 4 processor or AMD®

Athlon, 2.2 GHz or greater

or

Intel or AMD Dual Core processor, 1.6
GHz or greater

RAM 2 GB (or greater)

Graphics card 1280 x 1024 32-bit color video display B For graphic cards that support
adapter (True Color) 128 MB or greater, Hardware Acceleration, DirectX
OpenGL®, or Direct3D® capable work- 9.0c, or later, must be installed.
station class graphics card. B Installing from the ACAD.misi file

For Windows Vista, a Direct3D capable
workstation class graphics card with 128
MB or greater is required1024 x 768
VGA with True Color (minimum)

does not install DirectX 9.0c, or
later. Manual installation of Direc-
tX is required, in this circum-
stance, for Hardware Accelera-
tion to be configured.

For more information about tested
and certified graphics cards, visit
http://www.autodesk.com/autocad-
graphicscard

Hard disk 2 GB (in addition to the 1 GB or above
required for installation)

NOTE Adobe Flash Player is no longer installed by default. If a suitable version of
Flash is not currently installed on your system, a message is displayed requesting
that you download it from Adobe’s website. If you do not have Internet access,
you can also access the Flash installer on the AutoCAD product media.

Install AutoCAD

This section contains information for installing AutoCAD on a stand-alone
computer. You must have administrative permissions to install AutoCAD.
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Your DVD or CDs are required to install AutoCAD. Insert the AutoCAD 2009
DVD or CD 1 to start the installation process. Follow the prompts to complete
the installation.

To install AutoCAD using default values on a stand-alone computer

This is the fastest means of installing AutoCAD on your system. Only default
values are used which means it is a typical installation being installed to
C:\Program Files\AutoCAD 2009. The text editor defaults for Windows NotePad
and Express Tools are included.

1
2
3
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Insert the AutoCAD DVD, or the first CD, into your computer's drive.
In the AutoCAD Installation wizard, click Install Products.

Next, select the product(s) you want to install and click Next.

NOTE AutoCAD Design Review 2009 is not installed by default when you
install AutoCAD. Some AutoCAD features require that Design Review be
installed to work properly. Design Review is the replacement viewer for DWF
Viewer. For more information about the affected features, see Features that
Require Design Review on page 40

Review the Autodesk software license agreement for your country or
region. You must accept this agreement to proceed with the installation.
Choose your country or region, click I Accept, and then click Next.

NOTE If you do not agree to the terms of the license and want to terminate
the installation, click Cancel.

On the Products and User Information page, enter your serial number
and user information and click Next.

IMPORTANT The information you enter here is permanent and is displayed
in the AutoCAD window (accessed by Menu browser » Help » About) on
your computer. Because you can't change this information later without

uninstalling the product, make sure you enter the correct information now.

If you do not wish to make configuration changes on the Review -
Configure - Install page, select Install. Then select Yes, to continue
installing using the default configuration.
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f ) 1 You have not made changes to the default configuration that will be
. used to install the chosen product(s).

Do you want to continue installing using the default configuration?

The wizard does the following;

B Uses a Typical installation, which installs the most common
application features. To see which features are included in a Typical
installation, refer to Typically Installed Features on page 42.

B Includes the Express Tools library of productivity tools that extend
the power of AutoCAD.

B Installs AutoCAD to the default install path of C:\Program Files\AutoCAD
20009.

7 Click Install.

To install AutoCAD using configured values on a stand-alone computer

With this installation method, you can fine-tune exactly what gets installed
by using the Configure option. You can alter the installation type, the install
path, license type, and the default text editor. You can also choose to install
material libraries.

1 Insert the AutoCAD DVD, or the first CD, into your computer's drive.
2 In the AutoCAD Installation wizard, click Install Products.

3 Next, select the product(s) you want to install and click Next.

4

Review the Autodesk software license agreement for your country or
region. You must accept this agreement to proceed with the installation.
Choose your country or region, click I Accept, and then click Next.

NOTE If you do not agree to the terms of the license and want to terminate
the installation, click Cancel.

5 On the Products and User Information page, enter your user information
and click Next.
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IMPORTANT The information you enter here is permanent and is displayed
in the AutoCAD window (accessed by Menu browser » Help » About) on
your computer. Because you can't change this information later without

uninstalling the product, make sure you enter the correct information now.

6 On the Review - Configure - Install page, click Configure to make
configuration changes such as installation type, installing optional tools,
or changing the installation path.

7 On the Select the License Type page, you can choose to install a
Stand-alone, or Network license. Click Next.

8 On the Select the Installation Type page, you can choose to make the
following configuration changes:

B Typical - Installs the most common application features.

B Custom - Installs only the application features that you select from
the Select Features To Install list:

CAD Standards

Contains tools for reviewing design
files for compliance with your stan-
dards.

Database

Contains database access tools.

Dictionaries

Contains multi-language dictionaries.

Drawing Encryption

Allows you to use the Security Options
dialog box to protect a drawing with
a password.

Express Tools

Contains AutoCAD support tools and
utilities (not supported by Autodesk).

Fonts

Contains AutoCAD fonts and TrueType
fonts.

Autodesk Impression
Toolbar

The Impression toolbar allows you to
quickly export any view to Autodesk
Impression for advanced line effects.
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Material Library

The Material library contains over 300
professionally built materials to apply
to your model.

New Features Work-
shop

Contains animated demos, exercises,
and sample files to help users learn the
new features.

Portable License Utility

Contains portable license manage-
ment tools.

Migrate Custom Set-
tings

Migrates custom settings and files
from a previous version of your prod-
uct to this version. See Migrate Cus-
tom Settings on page 8.

Reference Manager

Allows users to view and edit the paths
of externally referenced files associated
with a drawing.

Samples Contains various feature sample files.
Tutorials Contains tutorials.
VBA Support Contains Microsoft Visual Basic for

Applications support files.

NOTE Autodesk Impression availability is limited. Please check your local
Autodesk website to see if Impression is available in your country.

Product Install Path - Specifies the drive and location where AutoCAD

will be installed.

Create a Desktop Shortcut - Choose whether to display the AutoCAD
shortcut icon on your desktop. A product icon is displayed on your
desktop by default. Clear the check box if you do not want to display

the shortcut icon.
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9 Click another product tab to configure another product, or Next and
then Configuration Complete to return to the Review - Configure - Install
page. Then, click Install.

NOTE If you want a printed copy of your configuration settings, click the
Print button.

10 On the Installation Complete page, choose from the following:

View the installation log file If you want to view the installation log
file, its location is displayed.

View the AutoCAD Readme The Readme file is opened from this page
when you click Finish. This file contains information that was unavailable
when the AutoCAD 2009 documentation was prepared. If you do not
want to view the Readme file now, clear the check box next to Readme.

NOTE You can also view the Readme file after you have installed AutoCAD.

11 Click Finish.

You have successfully installed AutoCAD. You are now ready to register your
product and start using the program. To register the product, start AutoCAD
and follow the on-screen instructions.

NOTE Autodesk does not recommend or support the distribution of an Autodesk
product using imaging software. However, if you plan to use this method of
distribution, please review the instructions detailed in Distribute the Product Using
Imaging Software in the Network Administrator’s Guide.

Register and Activate AutoCAD

The first time you start AutoCAD, the Product Activation wizard is displayed.
You can either activate AutoCAD at that time or run AutoCAD and activate
it later. Until you register and enter a valid activation code for AutoCAD, you
are operating the program in trial mode and the Product Activation wizard is
displayed for 30 days from the first time that you run the program. If after 30
days of running AutoCAD in trial mode you have not registered and provided
a valid activation code, your only option is to register and activate AutoCAD.
You will not be able to run in trial mode after the 30 days expires. Once you
register and activate AutoCAD, the Product Activation wizard is no longer
displayed.
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The fastest and most reliable way to register and activate your product is by

using the Internet. Simply enter your registration information and send it to
Autodesk over the Internet. Once you submit your information, registration
and activation occur almost instantly.

To register and activate AutoCAD

1 Click Start menu (Windows) » All Programs (or Programs) » Autodesk
» AutoCAD 2009 » AutoCAD 2009.

2 In the AutoCAD 2009 Product Activation wizard, select Activate the
Product, and then click Next.
This starts the Register Today process.

3 Click Register and Activate (Get an Activation Code).

4 Click Next and follow the on-screen instructions.

If you do not have Internet access, or if you want to use another method
of registration, you can register and activate AutoCAD in one of the
following ways:

Email Create an email message with your registration information and
send it to Autodesk.

Fax or Post/Mail Enter your registration information, and fax or mail
the information to Autodesk.

Add or Remove Features

You can add or remove AutoCAD features at any time. For example, you may
have chosen a Custom installation option when you first installed AutoCAD,
but now you want to add features that you did not install originally. Or you
may no longer need to use all of the features that were installed originally.
You can add or remove features by using the Add or Remove Programs dialog
box.

To add or remove features

1 In the Control Panel (Windows), double-click Add or Remove Programs.

2 In the Add or Remove Programs dialog box, click AutoCAD 2009, and
then click Change/Remove.
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The AutoCAD Installation wizard re-opens in Maintenance Mode.

Click Add or Remove Features.

On the Add/Remove Features page, select a feature to install or uninstall.
The icons to the left of the selections give you an indication of the action
that will be taken.

X

Indicates a feature that was originally not installed.

*

L

Indicates a currently installed feature or a feature that you want
to add.

Indicates an originally installed feature that is chosen for removal.

NOTE If you need to revert to the AutoCAD features that you selected in
your original installation, click Cancel.

Click Next.
On the Update AutoCAD 2009 Installation page, click Next.

On the Update Complete page, you are informed when the updates have
been performed. Click Finish.

Reinstall or Repair AutoCAD

If you accidentally delete or alter files that are required by AutoCAD, AutoCAD
might not perform correctly, and you might receive error messages when you
try to execute a command or find a file. You can attempt to fix this problem
by reinstalling or repairing AutoCAD. The reinstallation or repair uses the
features that were part of the installation type you chose when you initially
installed the program.

To reinstall or repair AutoCAD

1
2
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In the Add or Remove Programs window, select AutoCAD 2009, and then
click Change/Remove.
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The AutoCAD Installation wizard re-opens in Maintenance Mode.
3 Click Repair AutoCAD 2009.

4 On the Select Repair or Reinstall page, click one of the following, and
then click Next:

B Repair My AutoCAD 2009 Installation. This option replaces all registry
entries that AutoCAD initially installed and restores AutoCAD 2009
to its default state. If you are missing AutoCAD files, use this option.

B Reinstall My AutoCAD 2009 Installation. This option repairs the registry
and reinstalls all files from the original installation. Use this option
if the Repair My AutoCAD 2009 Installation option does not solve
the problem.

5 On the Repair AutoCAD 2009 page, click Next to start the process.

6 On the Repair Complete page, you are informed when the repairs have
been performed. Click Finish.

Uninstall AutoCAD

When you uninstall AutoCAD, all components are removed. This means that
even if you've previously added or removed components, or if you've reinstalled
or repaired AutoCAD, the uninstall removes all AutoCAD installation files
from your system.

To uninstall AutoCAD

1 In the Control Panel (Windows), click Add or Remove Programs.

2 Inthe Add or Remove Programs window, select AutoCAD 2009, and then
click Change/Remove.

3 Click Uninstall.

4 On the Uninstall AutoCAD 2009 page, click Next to remove AutoCAD
from the system.

5 When informed that the product has been successfully uninstalled, click
Finish.
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NOTE Even though AutoCAD is removed from your system, the software license
remains. If you reinstall AutoCAD at some future time, you will not have to register
and re-activate the program.

Features that Require Design Review

Design Review is a tool for reviewing and working with DWF files. DWF files
are drawing files that have been converted so they can be transported over
the Internet and then shared with others. In order to work with DWEF files,
you need to have Design Review installed.

If you want to use any of the following commands or functions with a DWF
file, you neeed to have Design Review installed.

PUBLISH

PLOT

3DDWF

PUBLISH TO WEB

MARKUP

DWFUNDERLAY

|

|

|

|

B EXPORT
|

|

m AUTOPUBLISH
|

SSM
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Installation
Troubleshooting

This chapter provides solutions to installation issues and answers to commonly asked questions
that may arise while installing your product(s).

General Installation Issues

This section outlines common issues and their solutions that may arise while
performing a general install of your product(s).

How can | check my graphics card driver to see if it
needs to be updated?

It is recommended that you verify and update your graphics card driver to
optimize your program. Use the following procedure to identify your current
graphics card driver.

To identify your graphics card driver

1
2
3

Start AutoCAD.
At the command line, enter 3dconfig.

In the Adaptive Degradation and Performance Tuning dialog box, click
View Tune Log.

Review the 3D Device section for information about your system's graphics
card driver and driver version.
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TIP Many newer graphic cards offer tabbed pages where you can learn more
precise information about your specific graphic card. If specific tab pages are
present, refer to them instead of the Adapter tab.

What is the text editor used for?

The text editor you designate during installation is used for editing text files
such as PGP and CUS dictionary files while you are running your product.

When performing a Typical installation, what gets

installed?

A Typical installation includes the following features:

CAD Standards

Contains tools for reviewing design
files for compliance with your stan-

dards.
Database Contains database access tools.
Dictionaries Contains multilanguage dictionaries.

Drawing Encryption

Allows you to use the Security Options
dialog box to protect a drawing with
a password.

Express Tools

Contains AutoCAD support tools and
utilities.

Fonts

Contains program fonts. (True Type
fonts are automatically installed with
the program.)

Autodesk Impression
Toolbar

The Impression toolbar allows you to-
export any view for advanced line ef-
fects.
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New Features Work-
shop

Contains animated demos, exercises,
and sample files to help users learn
new features.

Portable License Utility

Contains a tool for moving a stand-
alone license between computers.

Migrate Custom Set-
tings

Allows you to migrate custom settings
and files from previous releases. For
more information, see Migrate Custom
Settings on page 8.

Reference Manager

Allows you to view and edit the paths
of externally referenced files associated
with a drawing.

Samples

Contains various feature sample files.

VBA Support

Contains Microsoft Visual Basic for
Applications support files.

NOTE Autodesk Impression availability is limited. Please check your local Autodesk
website to see if Impression is available in your country.

Why should I install the Materials Library?

The Materials Library contains over 300 professionally made materials that
you can immediately apply to objects in your model. They can also act as a
basis for custom materials that you want to create.

For more information regarding materials, see Materials and Textures.
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Where

are my product manuals?

All documentation created for Autodesk products are built in two different
formats: PDF and CHM.

B PDF files are made available during installation; click the Documentation
link in the installer.

B CHM files are available after the product is installed; they are accessed in
the Help system in the product.

The entire content of the PDF files are available from within your installed

product’s Help system.

Files are also installed to the \AutoCAD\Help folder.

Deployment Issues

This section outlines common issues and their solutions with regards to
software deployments.

Is there a checklist | can refer to when performing
a deployment?

Where

The Network Administrator Guide contains a complete section that describes
preliminary actions and the entire deployment process. See Preliminary Tasks
for a Network Deployment.

should deployments be located?

Shared folders are required for both network license and multi-seat stand-alone
methods of installation. The shared folder (network share) is created before you
run the Installation wizard and is where product deployments are stored.

It is recommended that you name the network share folder Deployments on
the desktop of the system where you want deployments stored. You can then
add subfolders inside the shared Deployments folder that clearly convey the
names of products you plan to deploy. For example:
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Any subfolders that are placed inside a shared folder are automatically shared.

4. Deployments
4 AutoCAD 2009
Adminlmage

AutoCAD Electrical 2009
Autodesk Impression
Design Review 2009
Inventor Pro 2009
Revit Structure 2009

TIP You must have Full Control permissions set for your shared folder when you
are creating your deployment images. Read permissions are necessary to access
the network share and administrative permissions on the workstation where the
program is deployed.

What are the default search paths and file location

settings?

Support file locations are automatically set during the installation process.
Support files include drivers, menus, and optional, user-defined settings such
as dictionary and customization files. Predefined paths are specified for the

support files.

Support File Search
Path

Specifies the folders in which the pro-
gram should look for text fonts, cus-
tomization files, plug-ins, drawings to
insert, linetypes, and hatch patterns
that are not in the current folder.

Customization Files
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various types of files.

Main Customization File:

Specifies the default location of the
main customization file (acad.cui).
Enterprise Customization File:
Specifies the location of an enterprise
customization file.

Custom Icon Location:



Specifies the location for custom icons
used in customization files.

Dictionary and Font Specifies a number of optional set-
Files tings.
Custom Dictionary File:
Specifies a custom dictionary to use (if
you have one).
Alternate Font File:
Specifies the location of the font file
to use if the original font cannot be
located and an alternate font is not
specified in the font mapping file.
Font Mapping File:
Specifies the location of the file that
defines how to convert fonts that
cannot be found.

Printer Support File Specifies search path settings for
Path printer support files.
Printer Configuration Search Path:
Specifies the path for printer configu-
ration files (PC3 files).
Printer Description File Search Path:
Specifies the path for files with a .pmp
file extension, or printer description
files.
Plot Style Table Search Path:
Specifies the path for files with an .stb
or .ctb extension, or plot style table
files (both named plot style tables and
color-dependent plot style tables).

Automatic Save File Specifies the path for the file created
Location when you select Automatic Save on
the Open and Save tab.

Color Book Locations  Specifies the path for color book files
that can be used when specifying col-
ors in the Select Color dialog box. You
can define multiple folders for each
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path specified. This option is saved
with the user profile.

Data Sources Location  Specifies the path for database source
files. Changes to this setting do not
take effect until you close and restart
the program.

Template Settings Specifies the drawing template set-
tings.
Drawing Template File Location:
Specifies the path to locate drawing
template files used by the Start Up
wizard and New dialog box.
Sheet Set Template File Location:
Specifies the path to locate sheet set
template files used by the Create Sheet
Set wizard.
Default Template File Name for
QNEW:
Specifies the drawing template file
used by the QNEW command.
Default Template for Sheet Creation
and Page Setup Overrides:
Specifies the default template file that
is used for creating new sheets and for
storing page setup overrides that can
be applied to Publish operations from
the Sheet Set Manager.

Tool Palette File Loca-  Specifies the path for tool palette
tions support files.

Log File Locations Specifies the path for the log file creat-
ed when you select Maintain a Log File
on the Open and Save tab.

Plot and Publish Log Specifies the path for the log file that
File Location is created if you select the Automatical-
ly Save Plot and Publish Log option on
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the Plot and Publish tab of the OP-
TION command.

Temporary Drawing Specifies the location to store tempo-

File Location rary files. This program creates tempo-
rary files and then deletes them when
you exit the program. If you plan to
run the program from a write-protect-
ed folder (for example, if you are
working on a network or opening files
from a CD), specify an alternate loca-
tion for your temporary files. The
folder you specify must not be write-
protected.

Temporary External Specifies the location of external refer-

Reference File Location  ence (xref) files. This location is used
for the copy of the xref when you se-
lect Enabled with Copy in the Demand
Load Xrefs list on the Open and Save
tab.

Texture Maps Search Specifies the folders to search for ren-
Path dering texture maps.

i-drop Associated File  Specifies the location of data files asso-

Location ciated with i-drop content. When the
location is not specified, the location
of the current drawing file is used.

Along with defining search paths and file location,
can files be added?

Using the Add button, you can set paths to folders where files are stored. You
cannot add specific files.
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Where can | check if service packs are available for
my software?

To find out if a patch or Service Pack is available for your product, visit the
Autodesk Product Support page at http://support.autodesk.com/.

How do | extract an MSP file?

A Microsoft Patch (MSP) file is usually contained in a Service Pack executable
that you download from the Autodesk Product Support website. To extract
the MSP file from the executable, run the patch program from the Windows
command prompt using the /e switch.

Pay particular attention to the location where the files are extracted. For details
about using the patch file, review the Readme file for that patch.

Can Online Resource settings be modified later?

Where

Yes. If you want to change the state of online resources after a product is
installed, you can do that from the CAD Manager Control utility. The CAD
Manager Control utility is installed separately from AutoCAD.

From the Installation wizard, select Install Tools and Utilities and then select
the CAD Manager Control utility. After installation is complete, you can start
the utility from the Start menu (Windows). Click All Programs (or Programs)
» Autodesk » CAD Manager Tools » CAD Manager Control Utility.

can | learn about InfoCenter?

You can use InfoCenter to enter a question for help, display the
Communication Center panel for product updates and announcements, or
display the Favorites panel to access saved topics. For more information, refer
to Search For and Receive Information.
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What are information channels?

The Communication Center component of InfoCenter allows you to receive
announcements from various information channels. Through information
channels, you can receive the following:

B Product Support information, including maintenance patch notifications.

B Subscription Center announcements and subscription program news, as
well as links to e-Learning Lessons, if you are an Autodesk subscription
member.

B Notifications of new articles and tips posted on Autodesk websites.

What are the benefits to enabling CAD Manager
Channels?

CAD Manager Channels allow access to Internet-based content and information
feeds from a specified feed location.

What are RSS feeds and how do they benefit my
installation?

An RSS feed is a live link you initiate by subscribing to someone’s website.
Once subscribed, the primary benefit is a constantly updating stream of content
that is delivered to your system in the form of summarized articles, forum

threads, blog posts, and so on. RSS stands for Rich Site Summary (or Really
Simple Syndication).

Where can | learn about InfoCenter search
locations?

You can use InfoCenter to search multiple sources (for example, Help and
specified files) at one time, or choose to search a single file or location.

For more information, refer to Search for Information.
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How do | set or customize search locations?

InfoCenter Search and Communication Center settings can be set in the
InfoCenter Settings dialog box or in the CAD Manager Control utility. You
must use the CAD Manager Control utility to specify CAD Manager Channel
settings.

See Specify InfoCenter Settings for more information regarding the settings
you can configure.

Licensing Issues

This section outlines common issues and their solutions with regards to
software licenses and licensing your product(s).

What is the difference between a stand-alone license
and a network license?

Stand-alone licensed products are registered and activated to an individual
workstation. While the software can be installed on multiple systems in your
facility, the license only allows one system to be operational. The Portable
License Utility can be used if a license needs to be transferred to another
system. If you need to run more systems, you need to purchase more
stand-alone licensed products, or consider converting to network licenses.

Network licensed products rely on the Network License Manager to keep track
of software licenses. The software can be installed and run on multiple systems,
up to the maximum number of licenses you’ve purchased. The Network License
Manager “checks out” licenses until they are all in use. No further systems
can run the program until a license is “checked in.” If you need to run more
systems, you can purchase additional licenses for the Network License Manager
to maintain.
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What is the benefit to using a network licensed
version of the software?

Network licensed products are recommended for large drafting/design facilities,
classrooms, and lab environments. The main advantage is that you can install
products on more systems than the number of licenses you have purchased
(for example, purchasing 25 licenses but installing on 40 workstations). At
any one time, products will run on the maximum number of systems for
which you have licenses. This means you get a true floating license. If software
needs to be run on more systems, additional licenses can be purchased.

Registration and activation occurs only once and the licenses are maintained
on your Network License Server.

What is Internet Explorer used for?

After installing your product, you can operate in trial mode for a given number
of days. Whenever you launch the program, you are prompted to activate the
software. When you choose to activate the software, Internet Explorer makes
this process much faster. Once you entered your registration data and submit
it to Autodesk, an activation code is returned and you are not prompted again
during startup.

Networking Issues

This section outlines common issues and their solutions with regards to
performing a network installation or configuring your network license server(s).

When installing tools and utilities, which selections
are applicable for a multi-seat stand-alone
installation?

Since a multi-seat stand-alone licensed product does not rely upon a license
server to manage or activate the license, the only tool that is beneficial is the
Autodesk CAD Manager tool.
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You need the CAD Manager tool if you want to make changes to CAD Manager
Channels.

When installing tools and utilities, which selections
are applicable for a stand-alone installation?

The Autodesk CAD Manager tool is the only tool that is beneficial to a
stand-alone licensed product. With the CAD Manager tool, you can modify
CAD Manager Channels.

Where do | find my server name?

When installing a network licensed product, you must specify the name of
the server that will run the Network License Manager. If you don’t know the
server name, you can quickly find it by opening a Windows command prompt
on the system that will be the Network License Manager. At the prompt, enter
ipconfig /all and note the Host Name entry.

If I choose to create a log file, what kind of
information does the log file contain?

There are two types of log files that can be generated that monitor information
about deployments and installations.

The Network log file keeps a record of all workstations that run the
deployment. The log lists the user name, workstation name, and the status of
the installation. Refer to this file for status information and details about
problems that users may have encountered during installation.

The Client log file contains detailed installation information for each
workstation. This information may be useful in diagnosing installation
problems. The client log is located in the \Temp directory of each client
workstation.
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When specifying user workstation settings,I’m given
the option to specify a profile.What are profiles?

Profiles are created on the Profiles tab of the Options dialog box. Profiles can
contain configuration settings for just about anything that is not a drawing
based system variable. For example, a profile can contain things like support
paths, grip settings, and plot settings.

When you specify a profile on the Specify User Preferences page during the
deployment process, it ensures that all workstations that use that deployment
to install the product will be configured the same way.

Can | create custom desktop shortcuts?

You can choose to create custom desktop shortcuts that use command line
switches to specify several options when you start the program. For example,
command line switches can be set to run a script during program launch,
create a drawing based on a template or prototype drawing, or designate a
workspace that should be restored on startup.

For more information, see Customize Startup.

What happens when you choose to append or merge
service packs?

When you append a service pack, the service pack is applied to the current
deployment only. Multiple service packs may be appended to a deployment.
The service pack file is included in the deployment and the service pack is
applied after the product is deployed.

When you merge a service pack, the service pack is merged into the
administrative image. Once merged, a service pack may not be removed from
the administrative image. Multiple service packs may be included in a single
administrative image.

You can choose to append or merge service packs from the Include Service
Packs page when creating a deployment.
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What is an administrative image (MSI) file?

An administrative image is a collection of shared file resources created during
the deployment process and is used by deployments to install the program to
networked workstations. Service packs (patches) can be applied to an
administrative image when you create the deployment. A .misi file is a Microsoft
Installer file.

What is the impact of selecting all products to be
included in the administrative image?

If you elect to include all products in your deployment, the administrative
image will be larger. You should select all products only when you create
multiple deployments from this image and prefer not to use the installation
disk. If there are products you rarely or never use, and you do not expect to
create additional deployments, you should only select a subset of products.

You can still create a deployment at a later date, and include additional
products, but you need to create a new administrative image. You need the
installation media to do so.

Uninstall and Maintenance Issues

This section outlines common issues and their solutions with regards to adding
and removing features, reinstalling or repairing your installation, and
uninstalling products.

When adding or removing features, how can | tell
what features get installed by default?

To quickly see what gets installed during a typical, default installation, click
the Restore Defaults button on the Add/Remove Features page.

CAD Standards Contains tools for reviewing design
files for compliance with your stan-
dards.
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Database

Contains database access tools.

Dictionaries

Contains multilanguage dictionaries.

Drawing Encryption

Allows you to use the Security Options
dialog box to protect a drawing with
a password.

Express Tools

Contains AutoCAD support tools and
utilities.

Fonts

Contains program fonts. (True Type
fonts are automatically installed with
the program.)

Autodesk Impression
Toolbar

The Impression toolbar allows you to-
export any view for advanced line ef-
fects.

Material Library

Contains over 300 professionally built
materials to apply to a model.

New Features Work-
shop

Contains animated demos, exercises,
and sampile files to help users learn
new features.

Portable License Utility

Contains a tool for moving a stand-
alone license between computers.

Migrate Custom Set-
tings

Allows you to migrate custom settings
and files from previous releases. For
more information, see Migrate Custom
Settings on page 8.

Reference Manager

Allows you to view and edit the paths
of externally referenced files associated
with a drawing.

Samples

Contains various feature sample files.
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Tutorials Contains product lessons.

VBA Support Contains Microsoft Visual Basic for
Applications support files.

Is it possible to change the installation folder when
adding or removing features?

Once your product is installed, you cannot change the installation path from
the Add/Remove Features page. Changing the path while adding features
results in program corruption, so it is not an option.

When should | reinstall the product instead of a
repair?
You should reinstall your product if you accidentally delete or alter files that
are required by the program. Missing or altered files adversely affect the

performance of your product and cause error messages when you try to execute
a command or find a file.

If an attempt to repair an installation fails, reinstalling is the next best option.

Do | need my original disk to reinstall my software?

When performing a reinstall of the product, you do not need to have the
original DVD or CD on hand. Installation data is cached locally on your drive
and that data is reused when reinstalling.

After repairing my installation, is it possible to
recover my settings?

Custom settings can be exported and later re-imported to the same system in
case you have to repair the installation of your program.
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For more detailed information regarding exporting and importing custom
settings, see Export and Import Custom Settings from the Same Release on
page 14.

When | uninstall my software, what files are left on
my system?
If you uninstall the product, some files remain on your system such as files

you created or edited (drawings or custom menus).

Your license file also stays on your workstation when you uninstall your
product. If you reinstall on the same workstation, the license information
remains valid and you do not have to reactivate the product.

58 | Chapter 4 Installation Troubleshooting



Index

3D video cards 31

A

activating programs 4, 36
administrator permission requirements 2
stand-alone installation 2
aliases 8
migrating 8
alternate font mapping files 22
anti-virus software 3
applications 3
anti-virus software 3
closing during installation 3
ARG files 9
AutoCAD 7, 44
product manuals 44
versions of 7
Autodesk Design Review 40
features requiring 40
AutoLISP Compatibility Analyzer 13

browsers 28
bundled products 2

C

CAD Manager Control utility 5
installing S

CFG files 22

computers 28

configuration files (plotters) 22
locating 22

configuration files (pointing devices) 22
locating 22

converting 8
menu files to CUI format 8

CUI (customization) files 8

custom icon files 22

custom settings 3, 7, 13-14, 16-17
exporting to other systems 14, 16
importing migration packages 14,
17

migrating from previous releases 3,
7

restoring default settings 13

customization files (CUI) 8, 22
locating files 22
migrating older menu filesto 8

customizing 7, 13-14, 19, 37
installation 37
locating customized files 19
migrating older customization

files 7
migration packages 14
restoring default settings 13
types of customized files 19

D

data links 19

locating files 19
dataloss 3
DCL files (dialog control language) 22
display adapters 31
displaying 12, 19

hidden files 19

migration log files 12
downloading 7

migration tools 7
drawing templates 25

locating files 25
DWG TrueView migration tool 13
DWT files 25

locating 25

59 | Index



E
exporting 14, 16
custom settings as migration
packages 14, 16
F

faxing registration information 37
files 14, 16-17, 19
custom settings files 14
locations 19
migration packages 14
network locations  16-17
roaming profiles and 19
finding 19
customized files 19
FMP files (font mapping) 22
font mapping files 22

G

graphics cards 31

H

hard disks 28

system requirements 28
hardware 1, 28

installation requirements 1, 28
hatches 8

migrating patterns to new releases 8
Help 22

locating Help files 22
hidden files 19

icons 22
customizations 22
importing 14, 17
custom settings from migration
packages 14,17

60 | Index

installation 1-2, 4-5, 7, 27-28, 32, 36—
39, 41-42, 44, 51-52, 55
adding or removing features 37
CAD Manager Control utility 5
Installation wizard 27
licensing 51
multiple or bundled products 2
networking issues 52
preparing for 1
registration and activation 4, 36
repairing damaged installations 38
serial numbers 2
side-by-side 7
software deployments 44
stand-alone installation 1, 27, 32
starting AutoCAD 4
system requirements 28
troubleshooting 41
typical 42
uninstalling 39, 55
Installation wizard 3, 27
interface 8
migrating custom settings for 8
Internet 36
program registration and
activation 36
Internet Explorer (Microsoft) 28

L

legacy menu files 8
licenses 51

issues 51
limited user rights 4
LIN files (linetype library) 8, 22
linetypes 8

migrating to new releases 8
log files 12

migration log files 12

M

mailing registration information 37
memory (RAM) 28
system requirements 28



menus 8
migrating to new releases 8

Microsoft Internet Explorer 28

Microsoft Windows operating

systems 28

migrating 3,7, 12-14

custom settings from previous
releases 3,7

migration log files 12
migration packages 14
migration tools 13
restoring default settings after 13

migration log file 12

migration packages 14

migration tools 13

MLN files 22

MNS files (source menu) 8
migrating 8

MNU files (menu template) 8
migrating 8

monitors 28

multi-product bundles 2

multi-seat stand-alone installations 1

N

network adapters 31
network installations 52
issues 52
networks 16-17
custom files located on 16-17

o

OpenGL driver 28
operating systems 28
system requirements 28

P

PAT files 8, 22

PC3 files (plotter configuration) 9
migrating 9

PGP files (program parameters) 8, 22

plot styles 20
locating files 20
plotter configuration files 21
locating files 21
PMP files (plot model parameter) 21
pointing devices 28
system requirements 28
previous releases 3, 7, 13
migrating custom settings from 3,
7
user profile default settings and 13
processors 28
Product Activation wizard 4, 36
profiles (user) 8,13, 18
importing custom settings 18
migrating custom settings 8
restoring default settings 13
PSF files 22

R

RAM 28

system requirements 28
reinstalling programs 38
removing 39

uninstalling programs 39
repairing 38

damaged installations 38

S

ScriptPro migration tool 13
serial numbers 2
stand-alone installation 2
service packs 28
shortcuts 4
creating 4
side-by-side installation 7
software deployments 44
software installation requirements 28
stand-alone installations 1, 31, 36
process 31
program registration and
activation 36
Quick Start 1

Index | 61



starting 4 UNT files 22

AutoCAD 4 upgrading 3
support files 22 installing newer AutoCAD releases 3
locations 22 user interface 8
system requirements 1, 28 migrating custom settings for 8
stand-alone installations 1, 28
Vv
T
video cards 28
templates 25 video monitors 28
locating files 25 virus software 3
textures 26
locating files 26
tools 7,13 w
migration tools 7, 13 web browsers 28

troubleshooting installation 41 Windows operating systems 28

system requirements 28

§)

uninstalling programs 55

62 | Index



	Contents
	Quick Start to Stand-Alone Installation
	How to Prepare for Installation
	How to Review System Requirements
	How to Understand Administrative Permission Requirements
	How to Install Multiple or Bundled Products
	How to Locate Your AutoCAD 2009 Serial Number
	How to Avoid Data Loss During Installation
	How to Migrate Custom Settings from Previous Versions

	How to Install and Run AutoCAD
	How to Install AutoCAD
	How to Register and Activate AutoCAD
	How to Launch AutoCAD 2009

	How to Install and Start the CAD Manager Control Utility
	How to install the CAD Manager Control utility


	Move to AutoCAD 2009 from a Previous or Same Release
	Migrate Custom Settings and Files from Previous Releases
	Migrate Custom Settings
	View the Migration Log File
	Restore AutoCAD 2009 Profiles After Migrating Files from an Earlier Release

	Use Migration Tools

	Export and Import Custom Settings from the Same Release
	Export Custom Settings
	Import Custom Settings

	Locate Customized Files
	Locate Data Link Files
	Locate Plot Style Files
	Locate Plotter Files
	Locate the PMP File
	Locate Support Files
	Locate Drawing Template Files
	Locate Texture Files


	Install Autodesk Products for an Individual User
	The AutoCAD 2009 Installation Wizard
	System Requirements
	Install AutoCAD
	Register and Activate AutoCAD
	Add or Remove Features
	Reinstall or Repair AutoCAD
	Uninstall AutoCAD
	Features that Require Design Review

	Installation Troubleshooting
	General Installation Issues
	How can I check my graphics card driver to see if it needs to be updated?
	What is the text editor used for?
	When performing a Typical installation, what gets installed?
	Why should I install the Materials Library?
	Where are my product manuals?

	Deployment Issues
	Is there a checklist I can refer to when performing a deployment?
	Where should deployments be located?
	What are the default search paths and file location settings?
	Along with defining search paths and file location, can files be added?
	Where can I check if service packs are available for my software?
	How do I extract an MSP file?
	Can Online Resource settings be modified later?
	Where can I learn about InfoCenter?
	What are information channels?
	What are the benefits to enabling CAD Manager Channels?
	What are RSS feeds and how do they benefit my installation?
	Where can I learn about InfoCenter search locations?
	How do I set or customize search locations?

	Licensing Issues
	What is the difference between a stand-alone license and a network license?
	What is the benefit to using a network licensed version of the software?
	What is Internet Explorer used for?

	Networking Issues
	When installing tools and utilities, which selections are applicable for a multi-seat stand-alone installation?
	When installing tools and utilities, which selections are applicable for a stand-alone installation?
	Where do I find my server name?
	If I choose to create a log file, what kind of information does the log file contain?
	When specifying user workstation settings, I’m given the option to specify a profile. What are profiles?
	Can I create custom desktop shortcuts?
	What happens when you choose to append or merge service packs?
	What is an administrative image (MSI) file?
	What is the impact of selecting all products to be included in the administrative image?

	Uninstall and Maintenance Issues
	When adding or removing features, how can I tell what features get installed by default?
	Is it possible to change the installation folder when adding or removing features?
	When should I reinstall the product instead of a repair?
	Do I need my original disk to reinstall my software?
	After repairing my installation, is it possible to recover my settings?
	When I uninstall my software, what files are left on my system?


	Index

