AutoCAD 2009 Developer Help

Welcome to AutoCAD 2009 Developer Help

AutoCAD Developer Help provides complete information for customizing and extending AutoCAD. Click the links on the right or use the Contents tab to browse Help topics.

General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

My Help
Resources on the Web


AutoCAD 2009 Help

Customization Guide

The Customization Guide tells experienced users how to customize AutoCAD. To browse the Customization Guide, use the Contents tab on the left side of the Help window.

  • Basic Customization
  • Custom Linetypes
  • Custom Hatch Patterns
  • Customize the User Interface
  • DIESEL
  • Slides and Command Scripts
  • Introduction to Programming Interfaces
  • Shapes and Shape Fonts
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference


AutoLISP Reference

The AutoLISP Reference provides a comprehensive reference for AutoLISP®, a full-featured, interpretive programming language that you can use to call AutoCAD commands, system variables, and dialog boxes. The following topics are included in the AutoLISP Reference:

  • AutoLISP Functions: Operators, A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z.
  • Externally Defined Commands
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


AutoLISP Developer's Guide

The AutoLISP Developer's Guide provides information for using the Visual LISP® interactive development environment to develop and test AutoLISP® programs. The guide also describes how to use the extensions provided with Visual LISP to create ActiveX® automation. The following topics are included in the AutoLISP Developer's Guide:

  • Introduction
  • Using the Visual LISP Environment
  • Using the AutoLISP Language
  • Working with Programmable Dialog Boxes
  • Appendixes
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


AutoLISP Tutorial

The AutoLISP Tutorial provides step-by-step lessons that teach you how to use Visual LISP™ to develop an AutoLISP® application. The following topics are included in the AutoLISP Tutorial:

  • Introduction
  • Designing and Beginning the Program
  • Using Visual LISP Debugging Tools
  • Drawing the Path Boundary
  • Creating a Project and Adding the Interface
  • Drawing the Tiles
  • Acting with Reactors
  • Putting It All Together
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


DXF Reference

The DXF Reference provides a comprehensive reference to the DXF™ file format. The following topics are included in the DXF Reference:

  • DXF Format
  • HEADER Section
  • CLASSES Section
  • TABLES Section
  • BLOCKS Section
  • ENTITIES Section
  • OBJECTS Section
  • THUMBNAILIMAGE Section
  • Drawing Interexchange File Formats
  • Advanced DXF Issues
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


ActiveX and VBA Developer's Guide

The ActiveX and VBA Developer's Guide explains how to use ActiveX and VBA to develop an application to customize AutoCAD. The guide also includes sample code and step-by-step procedures. The following topics are included in the ActiveX and VBA Developer's Guide:

  • Introduction
  • Getting Started with VBA
  • ActiveX Automation Basics
  • Control the AutoCAD Environment
  • Create and Edit AutoCAD Entities
  • Dimensions and Tolerances
  • Customize Toolbars and Menus
  • Use Events
  • Work in Three-Dimensional Space
  • Define Layouts and Plot
  • Advanced Drawing and Organizational Techniques
  • Develop Applications with VBA
  • Interact with Other Applications and Windows APIs
  • ActiveX/VBA Tutorial: Design the Garden Path
  • Visual LISP and ActiveX/VBA Comparison
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


ActiveX and VBA Reference

The ActiveX and VBA Reference provides a reference to the ActiveX object model and its associated interface components. The following topics are included in the ActiveX and VBA Reference:

  • Object Model
  • Events
  • Methods
  • Properties
  • Objects
  • Code Examples
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


Sheet Set Objects Reference

The Sheet Set Objects Reference provides a reference to the objects for Sheet Set Manager. The following topics are included in the Sheet Set Objects Reference:

  • Overview of Sheet Set Manager Objects
  • Objects
  • Methods
  • Properties
  • Enums
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


Connectivity Automation Reference

The Connectivity Automation Reference provides a reference to the Connectivity Automation object model and its associated interface components. The following topics are included in the Connectivity Automation Reference:

  • Connectivity Automation Objects
  • Object Model
  • Objects
  • Methods
  • Properties
  • Events
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


ObjectARX

ObjectARX®, the AutoCAD® Runtime Extension programming environment, includes C++ libraries that are the building blocks you can use to develop AutoCAD applications, extend AutoCAD classes and protocol, and create new commands that operate in the same manner as built-in AutoCAD commands.

If this Help item displays as a page icon ( [image]) on the Contents tab, the ObjectARX documentation is not yet available in your Help system.

The AutoCAD ObjectARX documentation can be downloaded from the Developer Center section of the Autodesk Web site. To integrate the ObjectARX documentation with your AutoCAD documentation, copy the ObjectARX Help files into your AutoCAD \HELP\ folder.
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


My Help

You can create your own group of Help topics called My Help. Once you add the My Help topics to AutoCAD Help, they are available from the Contents tab, the Index tab (if you add index entries), and the Search tab in the left pane of the Help window. Click this My Help topic on the Contents tab to access the Help topics you add to AutoCAD Help.

For information about setting up My Help, see Set Up My Help.
General Information

Help Files

Customization Guide

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF Reference


Comments?

Using this form sends your comments to the Autodesk Technical Publications group responsible for this documentation.

Topic title and location (do not edit):
Name (optional):
         Email (optional):
Comments:

Note: This form is not intended as a way for you to receive feedback or technical support. The information you provide will be used to enhance future updates to the documentation. Thanks!


Copyrights and Trademarks

© 2008 Autodesk, Inc. All rights reserved. Except as otherwise permitted by Autodesk, Inc., this publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose.

Certain materials included in this publication are reprinted with the permission of the copyright holder.

Trademarks

The following are registered trademarks or trademarks of Autodesk, Inc., in the USA and other countries: 3DEC (design/logo), 3December, 3December.com, 3ds Max, ActiveShapes, Actrix, ADI, Alias, Alias (swirl design/logo), AliasStudio, Alias|Wavefront (design/logo), ATC, AUGI, AutoCAD, AutoCAD Learning Assistance, AutoCAD LT, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, Autodesk, Autodesk Envision, Autodesk Insight, Autodesk Intent, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, AutoLISP, AutoSnap, AutoSketch, AutoTrack, Backdraft, Built with ObjectARX (logo), Burn, Buzzsaw, CAiCE, Can You Imagine, Character Studio, Cinestream, Civil 3D, Cleaner, Cleaner Central, ClearScale, Colour Warper, Combustion, Communication Specification, Constructware, Content Explorer, Create>what’s>Next> (design/logo), Dancing Baby (image), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, DesignStudio, Design|Studio (design/logo), Design Your World, Design Your World (design/logo), DWF, DWG, DWG (logo), DWG TrueConvert, DWG TrueView, DXF, EditDV, Education by Design, Extending the Design Team, FBX, Filmbox, FMDesktop, Freewheel, GDX Driver, Gmax, Heads-up Design, Heidi, HOOPS, HumanIK, i-drop, iMOUT, Incinerator, IntroDV, Inventor, Inventor LT, Kaydara, Kaydara (design/logo), LocationLogic, Lustre, Maya, Mechanical Desktop, MotionBuilder, ObjectARX, ObjectDBX, Open Reality, PolarSnap, PortfolioWall, Powered with Autodesk Technology, Productstream, ProjectPoint, Reactor, RealDWG, Real-time Roto, Render Queue, Revit, Showcase, SketchBook, StudioTools, Topobase, Toxik, Visual, Visual Bridge, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Syllabus, Visual Toolbox, Visual Tugboat, Visual LISP, Voice Reality, Volo, and Wiretap.

The following are registered trademarks or trademarks of Autodesk Canada Co. in the USA and/or Canada and other countries: Backburner, Discreet, Fire, Flame, Flint, Frost, Inferno, Multi-Master Editing, River, Smoke, Sparks, Stone, Wire.

All other brand names, product names or trademarks belong to their respective holders.

Disclaimer

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY AUTODESK, INC. “AS IS.” AUTODESK, INC., DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.


Set Up My Help

If you want to set up My Help, you must create your Help topics in HTML, and then compile them with Microsoft HTML Help Workshop to create a compiled Help file named myhelp.chm. Copy this file to the AutoCAD\Help folder.

To display hyperlinked topic titles in the main My Help topic

  • Include a file that lists those topic titles in the CHM file. Name this included file myhelp_toc.html.

To display the topic titles on the Contents tab

  • Include an HHC (Help Contents) file that lists those topic titles in the CHM file.

To display any index entries you add to your Help topics

  • Include an HHK (Help Index) file in the CHM file.

Even if you haven't included the myhelp_toc.html file or the HHC or HHK files, the content in your CHM file is available on the Search tab.