Overview of Sheet Set Manager Objects

Guidelines for Modifying a Sheet Set
Overview of Sheet Set Manager Objects

The Sheet Set Manager API is based on a set of COM objects. You can use the COM objects of the Sheet Set Manager to develop macros and applications that create sheet sets and perform related tasks.

AcSmSheetSetMgr allows you to open and create sheet set databases (AcSmDatabase) well as determine which databases are already open.

AcSmDatabase contains a hierachy of objects that includes subsets and sheet objects. The sheet set database also contains various properties including version information and the main sheet set object. You can call the GetSheetSet method to retrieve a pointer to the main sheet set object (AcSmSheetSet).

AcSmSheet contains a collection of subsets and sheets (AcSmSubset and AcSmSheet, respectively). AcSmSubset is a collection that can contain sheets and/or other subsets. AcSmSheet is an object that references a specific layout within a specific drawing file. A sheet object contains information about the associated drawing file name, layout name, and handle, as well as other information such as sheet number, description, and so on.

You can view the Sheet Set Manager objects in the AutoCAD VBA integrated development environment (VBA IDE) and in Microsoft Visual Studio. To view the objects using the Object Browser in the VBA IDE, add a reference to the AcSmComponents17 1.0 type library. The file, AcSmComponents17.tlb, is in the following folder: C:\Program Files\Common Files\Autodesk Shared.

A sample project that shows how to use the Sheet Set Manager objects is in the following folder: C:\Program Files\AutoCAD 2009\Sample\ActiveX\SheetSetVBA.

Topics in this section

  • Guidelines for Modifying a Sheet Set
  • Create or Open a Sheet Set Database
  • Add a Sheet Set to a Database
  • Reliably Access Sheet Set Components
  • Create a Subset
  • Add Custom Data
Please send us your comment about this page


Guidelines for Modifying a Sheet Set

Overview of Sheet Set Manager Objects
Overview of Sheet Set Manager Objects
Create or Open a Sheet Set Database
Guidelines for Modifying a Sheet Set

The sheet set API is a multiclient API. This means that multiple clients may be viewing and interacting with a given AcSmDatabase at any given time. This requires special attention as to how objects are referenced or modified in the database.

In order to make modifications to any object within the AcSmDatabase, you must lock it and then unlock it when you are finished making changes. You should only lock the database when you are ready to make changes, and you should unlock it as soon as possible. For performance reasons, you should also lock and unlock the database as few times as possible. If you need to make several modifications, lock the database, make all your changes, and then unlock it.

Because the database has multiple clients, it will be automatically reloaded from time to time as other clients make changes. When the database gets reloaded, all contained object instances are discarded and new instances are created as the database is read in.

For this reason, it is important to adhere to the following basic rule when referencing objects that reside within a sheet set database:

  • Never cache direct pointers to objects within a sheet set database. If you must cache a reference to an object within a sheet set database, store the associated IAcSmObjectId instead. With an object ID, you can safely retrieve a pointer to the associated object instance; the current instance is always retrieved.

After a database is reloaded, a pointer to a database-resident object will be invalid. However, if you store the object ID instead, you can use it to safely retrieve a pointer to the current object instance.

The only exception to this rule is the database. You can store a pointer to the AcSmDatabaseAcSmDatabase because the database object is not destroyed and recreated during a reload operation.

You can retrieve the object ID of any database-resident object by calling the GetObjectIdGetObjectId method on the object. Conversely, you can get the associated object instance from an ID by calling the GetPeristentObjectGetPeristentObject method. This returns a general IAcSmPersistIAcSmPersist interface pointer, which can be queried for the desired interface.

NoteDST files should only be modified using Sheet Set Manager objects.


Create or Open a Sheet Set Database

Guidelines for Modifying a Sheet Set
Overview of Sheet Set Manager Objects
Add a Sheet Set to a Database
Create or Open a Sheet Set Database

To use Sheet Set Manager objects, you must use an AcSmSheetSetMgr object and one or more AcSmDatabase objects (DST files).

After you create an AcSmSheetSetMgr object, you can use the CreateDatabase method to create an AcSmDatabaseAcSmDatabase object. Specify a file name with a DST extension. Alternatively, you can use the OpenDatabase method to open an existing database. You can also access databases that are currently open. Use the GetDatabaseEnumerator method to obtain an enumerator that provides access to the list of open databases. You can retrieve a specific open database using the FindOpenDatabase method.

In order to make changes to a database, it must be locked using the LockDb method. Any changes you make can be saved or rolled back using the UnlockDb method. UnLockDbUnLockDb has a Boolean commitcommit parameter that controls this behavior. If the value of the commitcommit parameter is true, then the changes will be written to the file. If you pass in false for the commitcommit parameter, the changes will be rolled back or undone by reloading the database from disk.

WarningWhen you unlock without commiting changes, the database is reloaded, all object instances in the database are cleared, and new objects are created as the database is read in. This means that any pointers to database-resident objects are invalid after the database has been reloaded. If you need to access database-resident objects across lock and unlock boundaries, you should store the object ID instead of a direct pointer to the object. The object ID (IAcSmObjectId) provides a means of safely referencing an object within the sheet set database. You can retrieve the object ID of any database resident object by calling the GetObjectId method on the object. Con-versely, you can get the associated object instance from an ID by calling the GetPeristentObject method.


Add a Sheet Set to a Database

Create or Open a Sheet Set Database
Overview of Sheet Set Manager Objects
Reliably Access Sheet Set Components
Add a Sheet Set to a Database

To add a sheet set to a sheet set database, you use a locked AcSmDatabase object and the GetSheetSet method to get an AcSmSheetSet object. With the AcSmSheetSet object, you can perform operations such as adding a name and description to the sheet set.

To add a sheet to an AcSmSheetSet object, you use the AddNewSheet method or the ImportSheet method. If you use the ImportSheet method, you create an AcSmNamedAcDbObjectReference object with the appropriate file name and layout name. After calling the ImportSheet method, you must call the InsertComponent method to finish the import.


Reliably Access Sheet Set Components

Add a Sheet Set to a Database
Overview of Sheet Set Manager Objects
Create a Subset
Reliably Access Sheet Set Components

You can use the Do While structure in VBA for reliable access to sheet set components. The Microsoft Help for VBA contains examples of the Do While structure. The Microsoft Help for VBA is available from the Help menu in the VBA IDE.

To use the Do While structure to access sheet set components, you use a statement similar to Do While Not obj Is Nothing to determine if an object is available. For example, to use a Do While Not obj Is Nothing statement to iterate through objects in a collection, you could use the following code:

Public Function FindAllComponents(comps As Collection) As Boolean
 On Local Error GoTo etrap
 If comps Is Nothing Then Set comps = New Collection
 Dim iter As IAcSmEnumPersist
 Set iter = m_db.GetEnumerator
 Dim obj As IAcSmPersist
 Set obj = iter.Next
 Do While Not obj Is Nothing
 If TypeOf obj Is IAcSmComponent Then
 Dim comp As IAcSmComponent
 Set comp = obj
 comps.Add comp
 End If
 Set obj = iter.Next
 Loop
 FindAllComponents = True
 Exit Function
etrap:
 MsgBox CStr(Err.Number) & " - " & Err.Description
End Function

For an additional example of using the Do While structure in VBA to access sheet set components, see the sample VBA project in the Sample\ActiveX\SheetSetVBA directory of your AutoCAD installation.


Create a Subset

Reliably Access Sheet Set Components
Overview of Sheet Set Manager Objects
Add Custom Data
Create a Subset

You can create a subset (or nested subset) in a sheet set.

To create a subset, you use the CreateSubset method of the AcSmSheetSet object. The CreateSubset method creates an AcSmSubset object.

After an AcSmSubset object is created, you can add sheets to it. Create an AcSmSheetSet object and use the AddNewSheet method or the ImportSheet method. If you use the ImportSheet method, you create an AcSmNamedAcDbObjectReference object with the appropriate file name and layout name. After calling the ImportSheet method, you must call the InsertComponent method to finish the import.


Add Custom Data

Create a Subset
Overview of Sheet Set Manager Objects
Objects
Add Custom Data

To add a custom property to a sheet set, you use the GetCustomPropertyBag method of the AcSmSheet object to create an AcSmCustomPropertyBag object. Then use the SetProperty method to set a custom property value. If you add a custom property to a sheet set and set the property flag to CUSTOM_SHEET_PROP, sheets that are within subsets of the sheet set inherit the property.


Objects

Add Custom Data
A Objects
Objects

Topics in this section

  • A Objects
  • I Objects
  • P Objects


A Objects

Objects
Objects
AcSmAcDbBlockRecordReference
A Objects

Topics in this section

  • AcSmAcDbBlockRecordReference
  • AcSmAcDbDatabase
  • AcSmAcDbLayoutReference
  • AcSmAcDbObjectReference
  • AcSmAcDbViewReference
  • AcSmCalloutBlockReferences
  • AcSmCalloutBlocks
  • AcSmCustomPropertyBag
  • AcSmCustomPropertyValue
  • AcSmDatabase
  • AcSmDSTFiler
  • AcSmEvent
  • AcSmFileReference
  • AcSmNamedAcDbObjectReference
  • AcSmObjectReference
  • AcSmPersistProxy
  • AcSmPublishOptions
  • AcSmResources
  • AcSmSheet
  • AcSmSheetSelSet
  • AcSmSheetSelSets
  • AcSmSheetSet
  • AcSmSheetSetMgr
  • AcSmSheetView
  • AcSmSheetViews
  • AcSmSubset
  • AcSmViewCategories
  • AcSmViewCategory


AcSmAcDbBlockRecordReference

A Objects
A Objects
AcSmAcDbDatabase
AcSmAcDbBlockRecordReference

Refers to a block record in a drawing file.

Methods, Properties and Events

Methods

AcSmAcDbBlockRecordReference.Clear Method

AcSmAcDbBlockRecordReference.GetAcSmAcDbDatabase Method

AcSmAcDbBlockRecordReference.GetDatabase Method

AcSmAcDbBlockRecordReference.GetDirectlyOwnedObjects Method

AcSmAcDbBlockRecordReference.GetFileName Method

AcSmAcDbBlockRecordReference.GetIsDirty Method

AcSmAcDbBlockRecordReference.GetName Method

AcSmAcDbBlockRecordReference.GetObjectId Method

AcSmAcDbBlockRecordReference.GetOwner Method

AcSmAcDbBlockRecordReference.GetOwnerAcDbHandle Method

AcSmAcDbBlockRecordReference.GetTypeName Method

AcSmAcDbBlockRecordReference.InitNew Method

AcSmAcDbBlockRecordReference.Load Method

AcSmAcDbBlockRecordReference.ResolveAcDbObject Method

AcSmAcDbBlockRecordReference.ResolveFileName Method

AcSmAcDbBlockRecordReference.Save Method

AcSmAcDbBlockRecordReference.SetAcDbHandle Method

AcSmAcDbBlockRecordReference.SetAcDbObject Method

AcSmAcDbBlockRecordReference.SetFileName Method

AcSmAcDbBlockRecordReference.SetName Method

AcSmAcDbBlockRecordReference.SetOwner Method

AcSmAcDbBlockRecordReference.SetOwnerAcDbHandle Method


AcSmAcDbDatabase

AcSmAcDbBlockRecordReference
A Objects
AcSmAcDbLayoutReference
AcSmAcDbDatabase

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods

AcSmAcDbDatabase.GetAcDbDatabase Method

AcSmAcDbDatabase.GetIAcadDatabase Method


AcSmAcDbLayoutReference

AcSmAcDbDatabase
A Objects
AcSmAcDbObjectReference
AcSmAcDbLayoutReference

Refers to a layout in a drawing file.

Methods, Properties and Events

Methods

AcSmAcDbLayoutReference.Clear Method

AcSmAcDbLayoutReference.GetAcDbHandle Method

AcSmAcDbLayoutReference.GetAcSmAcDbDatabase Method

AcSmAcDbLayoutReference.GetDatabase Method

AcSmAcDbLayoutReference.GetDirectlyOwnedObjects Method

AcSmAcDbLayoutReference.GetFileName Method

AcSmAcDbLayoutReference.GetIsDirty Method

AcSmAcDbLayoutReference.GetName Method

AcSmAcDbLayoutReference.GetObjectId Method

AcSmAcDbLayoutReference.GetOwner Method

AcSmAcDbLayoutReference.GetOwnerAcDbHandle Method

AcSmAcDbLayoutReference.GetTypeName Method

AcSmAcDbLayoutReference.InitNew Method

AcSmAcDbLayoutReference.Load Method

AcSmAcDbLayoutReference.ResolveAcDbObject Method

AcSmAcDbLayoutReference.ResolveFileName Method

AcSmAcDbLayoutReference.Save Method

AcSmAcDbLayoutReference.SetAcDbHandle Method

AcSmAcDbLayoutReference.SetAcDbObject Method

AcSmAcDbLayoutReference.SetFileName Method

AcSmAcDbLayoutReference.SetName Method

AcSmAcDbLayoutReference.SetOwner Method

AcSmAcDbLayoutReference.SetOwnerAcDbHandle Method


AcSmAcDbObjectReference

AcSmAcDbLayoutReference
A Objects
AcSmAcDbViewReference
AcSmAcDbObjectReference

The AcDbObject reference component.

To properly initialize an IAcSmAcDbObjectReference in order to reference a stored AcDbObject, use the SetAcDbObject method. This method initializes the NamedAcDbObjectReference, so there is no need to use the SetAcDbHandle method, SetFileName method, or SetName method.

To find a referenced object in an AcDbDatabase, use the ResolveAcDbObject method. For example, to find a layout in order to retrieve its properties, use the ResolveAcDbObject method.

Methods, Properties and Events

Methods

AcSmAcDbObjectReference.Clear Method

AcSmAcDbObjectReference.GetAcDbHandle Method

AcSmAcDbObjectReference.GetAcSmAcDbDatabase Method

AcSmAcDbObjectReference.GetDatabase Method

AcSmAcDbObjectReference.GetDirectlyOwnedObjects Method

AcSmAcDbObjectReference.GetFileName Method

AcSmAcDbObjectReference.GetIsDirty Method

AcSmAcDbObjectReference.GetObjectId Method

AcSmAcDbObjectReference.GetOwner Method

AcSmAcDbObjectReference.GetTypeName Method

AcSmAcDbObjectReference.InitNew Method

AcSmAcDbObjectReference.Load Method

AcSmAcDbObjectReference.ResolveAcDbObject Method

AcSmAcDbObjectReference.ResolveFileName Method

AcSmAcDbObjectReference.Save Method

AcSmAcDbObjectReference.SetAcDbHandle Method

AcSmAcDbObjectReference.SetAcDbObject Method

AcSmAcDbObjectReference.SetFileName Method

AcSmAcDbObjectReference.SetOwner Method


AcSmAcDbViewReference

AcSmAcDbObjectReference
A Objects
AcSmCalloutBlockReferences
AcSmAcDbViewReference

Refers to a view in a drawing file.

Methods, Properties and Events

Methods

AcSmAcDbViewReference.Clear Method

AcSmAcDbViewReference.GetAcDbHandle Method

AcSmAcDbViewReference.GetAcSmAcDbDatabase Method

AcSmAcDbViewReference.GetDatabase Method

AcSmAcDbViewReference.GetDirectlyOwnedObjects Method

AcSmAcDbViewReference.GetFileName Method

AcSmAcDbViewReference.GetIsDirty Method

AcSmAcDbViewReference.GetName Method

AcSmAcDbViewReference.GetObjectId Method

AcSmAcDbViewReference.GetOwner Method

AcSmAcDbViewReference.GetOwnerAcDbHandle Method

AcSmAcDbViewReference.GetTypeName Method

AcSmAcDbViewReference.InitNew Method

AcSmAcDbViewReference.Load Method

AcSmAcDbViewReference.ResolveAcDbObject Method

AcSmAcDbViewReference.ResolveFileName Method

AcSmAcDbViewReference.Save Method

AcSmAcDbViewReference.SetAcDbHandle Method

AcSmAcDbViewReference.SetAcDbObject Method

AcSmAcDbViewReference.SetFileName Method

AcSmAcDbViewReference.SetName Method

AcSmAcDbViewReference.SetOwner Method

AcSmAcDbViewReference.SetOwnerAcDbHandle Method


AcSmCalloutBlockReferences

AcSmAcDbViewReference
A Objects
AcSmCalloutBlocks
AcSmCalloutBlockReferences

Callout block references collection.

Methods, Properties and Events

Methods

AcSmCalloutBlockReferences.Add Method

AcSmCalloutBlockReferences.Clear Method

AcSmCalloutBlockReferences.GetCustomPropertyBag Method

AcSmCalloutBlockReferences.GetDatabase Method

AcSmCalloutBlockReferences.GetDesc Method

AcSmCalloutBlockReferences.GetDirectlyOwnedObjects Method

AcSmCalloutBlockReferences.GetEnumerator Method

AcSmCalloutBlockReferences.GetIsDirty Method

AcSmCalloutBlockReferences.GetName Method

AcSmCalloutBlockReferences.GetObjectId Method

AcSmCalloutBlockReferences.GetOwner Method

AcSmCalloutBlockReferences.GetTypeName Method

AcSmCalloutBlockReferences.InitNew Method

AcSmCalloutBlockReferences.Load Method

AcSmCalloutBlockReferences.Remove Method

AcSmCalloutBlockReferences.Save Method

AcSmCalloutBlockReferences.SetDesc Method

AcSmCalloutBlockReferences.SetName Method

AcSmCalloutBlockReferences.SetOwner Method


AcSmCalloutBlocks

AcSmCalloutBlockReferences
A Objects
AcSmCustomPropertyBag
AcSmCalloutBlocks

Callout blocks collection that contains IAcSmNamedAcDbObjectReference objects.

Methods, Properties and Events

Methods

AcSmCalloutBlocks.Clear Method

AcSmCalloutBlocks.GetCustomPropertyBag Method

AcSmCalloutBlocks.GetDatabase Method

AcSmCalloutBlocks.GetDesc Method

AcSmCalloutBlocks.GetDirectlyOwnedObjects Method

AcSmCalloutBlocks.GetEnumerator Method

AcSmCalloutBlocks.GetIsDirty Method

AcSmCalloutBlocks.GetName Method

AcSmCalloutBlocks.GetObjectId Method

AcSmCalloutBlocks.GetOwner Method

AcSmCalloutBlocks.GetTypeName Method

AcSmCalloutBlocks.InitNew Method

AcSmCalloutBlocks.Load Method

AcSmCalloutBlocks.Remove Method

AcSmCalloutBlocks.Save Method

AcSmCalloutBlocks.SetDesc Method

AcSmCalloutBlocks.SetName Method

AcSmCalloutBlocks.SetOwner Method


AcSmCustomPropertyBag

AcSmCalloutBlocks
A Objects
AcSmCustomPropertyValue
AcSmCustomPropertyBag

Custom property bag component, which stores custom properties. Every component that derives from IAcSmComponent has a GetCustomPropertyBag method. This method returns the property bag of the component.

Methods, Properties and Events

Methods

AcSmCustomPropertyBag.Clear Method

AcSmCustomPropertyBag.GetDatabase Method

AcSmCustomPropertyBag.GetDirectlyOwnedObjects Method

AcSmCustomPropertyBag.GetIsDirty Method

AcSmCustomPropertyBag.GetObjectId Method

AcSmCustomPropertyBag.GetOwner Method

AcSmCustomPropertyBag.GetProperty Method

AcSmCustomPropertyBag.GetPropertyEnumerator Method

AcSmCustomPropertyBag.GetTypeName Method

AcSmCustomPropertyBag.InitNew Method

AcSmCustomPropertyBag.Load Method

AcSmCustomPropertyBag.Save Method

AcSmCustomPropertyBag.SetOwner Method

AcSmCustomPropertyBag.SetProperty Method


AcSmCustomPropertyValue

AcSmCustomPropertyBag
A Objects
AcSmDatabase
AcSmCustomPropertyValue

Custom property value object.

Methods, Properties and Events

Methods

AcSmCustomPropertyValue.Clear Method

AcSmCustomPropertyValue.GetDatabase Method

AcSmCustomPropertyValue.GetDirectlyOwnedObjects Method

AcSmCustomPropertyValue.GetFlags Method

AcSmCustomPropertyValue.GetIsDirty Method

AcSmCustomPropertyValue.GetObjectId Method

AcSmCustomPropertyValue.GetOwner Method

AcSmCustomPropertyValue.GetTypeName Method

AcSmCustomPropertyValue.GetValue Method

AcSmCustomPropertyValue.InitNew Method

AcSmCustomPropertyValue.Load Method

AcSmCustomPropertyValue.Save Method

AcSmCustomPropertyValue.SetFlags Method

AcSmCustomPropertyValue.SetOwner Method

AcSmCustomPropertyValue.SetValue Method


AcSmDatabase

AcSmCustomPropertyValue
A Objects
AcSmDSTFiler
AcSmDatabase

Database component.

Methods, Properties and Events

Methods

AcSmDatabase.Clear Method

AcSmDatabase.FindObject Method

AcSmDatabase.GetCustomPropertyBag Method

AcSmDatabase.GetDatabase Method

AcSmDatabase.GetDbVersion Method

AcSmDatabase.GetDesc Method

AcSmDatabase.GetDirectlyOwnedObjects Method

AcSmDatabase.GetEnumerator Method

AcSmDatabase.GetFileName Method

AcSmDatabase.GetIsDirty Method

AcSmDatabase.GetIsTemporary Method

AcSmDatabase.GetLockOwnerInfo Method

AcSmDatabase.GetLockStatus Method

AcSmDatabase.GetName Method

AcSmDatabase.GetNewObjectId Method

AcSmDatabase.GetObjectId Method

AcSmDatabase.GetOwner Method

AcSmDatabase.GetSheetSet Method

AcSmDatabase.GetTemplateDstFileName Method

AcSmDatabase.GetTypeName Method

AcSmDatabase.InitNew Method

AcSmDatabase.Load Method

AcSmDatabase.LoadFromFile Method

AcSmDatabase.LockDb Method

AcSmDatabase.NotifyRegisteredEventHandlers Method

AcSmDatabase.Register Method

AcSmDatabase.RegisterOwner Method

AcSmDatabase.Save Method

AcSmDatabase.SetDesc Method

AcSmDatabase.SetFileName Method

AcSmDatabase.SetIsTemporary Method

AcSmDatabase.SetName Method

AcSmDatabase.SetOwner Method

AcSmDatabase.UnlockDb Method

AcSmDatabase.Unregister Method

AcSmDatabase.UpdateInMemoryDwgHints Method


AcSmDSTFiler

AcSmDatabase
A Objects
AcSmEvent
AcSmDSTFiler

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods

AcSmDSTFiler.Close Method

AcSmDSTFiler.GetCurrentObject Method

AcSmDSTFiler.GetCurrentObjectHeaderInfo Method

AcSmDSTFiler.GetDatabase Method

AcSmDSTFiler.GetRevisionNumber Method

AcSmDSTFiler.Init Method

AcSmDSTFiler.PopCurrentReadObject Method

AcSmDSTFiler.PopCurrentWriteObject Method

AcSmDSTFiler.PushCurrentReadObject Method

AcSmDSTFiler.PushCurrentWriteObject Method

AcSmDSTFiler.ReadObject Method

AcSmDSTFiler.ReadProperty Method

AcSmDSTFiler.ReadRawData Method

AcSmDSTFiler.WriteObject Method

AcSmDSTFiler.WriteProperty Method

AcSmDSTFiler.WriteRawData Method


AcSmEvent

AcSmDSTFiler
A Objects
AcSmFileReference
AcSmEvent

Contains events in Sheet Set Manager objects.

Methods, Properties and Events

Properties

AcSmEvent.ACSM_DATABASE_CHANGED Property

AcSmEvent.ACSM_DATABASE_CREATED Property

AcSmEvent.ACSM_DATABASE_IS_CLOSING Property

AcSmEvent.ACSM_DATABASE_LOAD_BEGIN Property

AcSmEvent.ACSM_DATABASE_LOAD_COMPLETE Property

AcSmEvent.ACSM_DATABASE_LOAD_FAILED Property

AcSmEvent.ACSM_DATABASE_LOCKED Property

AcSmEvent.ACSM_DATABASE_OPENED Property

AcSmEvent.ACSM_DATABASE_UNLOCKED Property

AcSmEvent.CALLOUT_BLOCK_ADDED Property

AcSmEvent.CALLOUT_BLOCK_DELETED Property

AcSmEvent.MODEL_RESOURCE_ADDED Property

AcSmEvent.MODEL_RESOURCE_DELETED Property

AcSmEvent.SHEET_ADDED Property

AcSmEvent.SHEET_DELETED Property

AcSmEvent.SHEET_SELECTION_SET_CREATED Property

AcSmEvent.SHEET_SELECTION_SET_DELETED Property

AcSmEvent.SHEET_SUBSET_CREATED Property

AcSmEvent.SHEET_SUBSET_DELETED Property

AcSmEvent.SHEET_VIEW_CATEGORY_CREATED Property

AcSmEvent.SHEET_VIEW_CATEGORY_DELETED Property

AcSmEvent.SHEET_VIEW_CREATED Property

AcSmEvent.SHEET_VIEW_DELETED Property

AcSmEvent.SHEETS_RENUMBERED Property


AcSmFileReference

AcSmEvent
A Objects
AcSmNamedAcDbObjectReference
AcSmFileReference

File reference component.

Use the ResolveFileName method to retrieve the fully qualified path to a resolved file name.

Methods, Properties and Events

Methods

AcSmFileReference.Clear Method

AcSmFileReference.GetDatabase Method

AcSmFileReference.GetDirectlyOwnedObjects Method

AcSmFileReference.GetFileName Method

AcSmFileReference.GetIsDirty Method

AcSmFileReference.GetObjectId Method

AcSmFileReference.GetOwner Method

AcSmFileReference.GetTypeName Method

AcSmFileReference.InitNew Method

AcSmFileReference.Load Method

AcSmFileReference.ResolveFileName Method

AcSmFileReference.Save Method

AcSmFileReference.SetFileName Method

AcSmFileReference.SetOwner Method


AcSmNamedAcDbObjectReference

AcSmFileReference
A Objects
AcSmObjectReference
AcSmNamedAcDbObjectReference

Stores a named AcDbObject, such as a symbol table record or a dictionary entry. The name and handle of the object are stored, so either one can be used to locate the object.

To reference a stored AcDbObject, use the SetAcDbObject . This method initializes the NamedAcDbObjectReference, so there is no need to use the SetAcDbHandle method, SetFileName method, or SetName method.

To find the referenced object in an AcDbDatabase, use the ResolveAcDbObject method.

Methods, Properties and Events

Methods

AcSmNamedAcDbObjectReference.Clear Method

AcSmNamedAcDbObjectReference.GetAcDbHandle Method

AcSmNamedAcDbObjectReference.GetAcSmAcDbDatabase Method

AcSmNamedAcDbObjectReference.GetDatabase Method

AcSmNamedAcDbObjectReference.GetDirectlyOwnedObjects Method

AcSmNamedAcDbObjectReference.GetFileName Method

AcSmNamedAcDbObjectReference.GetIsDirty Method

AcSmNamedAcDbObjectReference.GetName Method

AcSmNamedAcDbObjectReference.GetObjectId Method

AcSmNamedAcDbObjectReference.GetOwner Method

AcSmNamedAcDbObjectReference.GetOwnerAcDbHandle Method

AcSmNamedAcDbObjectReference.GetTypeName Method

AcSmNamedAcDbObjectReference.InitNew Method

AcSmNamedAcDbObjectReference.Load Method

AcSmNamedAcDbObjectReference.ResolveAcDbObject Method

AcSmNamedAcDbObjectReference.ResolveFileName Method

AcSmNamedAcDbObjectReference.Save Method

AcSmNamedAcDbObjectReference.SetAcDbHandle Method

AcSmNamedAcDbObjectReference.SetAcDbObject Method

AcSmNamedAcDbObjectReference.SetFileName Method

AcSmNamedAcDbObjectReference.SetName Method

AcSmNamedAcDbObjectReference.SetOwner Method

AcSmNamedAcDbObjectReference.SetOwnerAcDbHandle Method


AcSmObjectReference

AcSmNamedAcDbObjectReference
A Objects
AcSmPersistProxy
AcSmObjectReference

Object reference component.

Methods, Properties and Events

Methods

AcSmObjectReference.Clear Method

AcSmObjectReference.GetDatabase Method

AcSmObjectReference.GetDirectlyOwnedObjects Method

AcSmObjectReference.GetIsDirty Method

AcSmObjectReference.GetObjectId Method

AcSmObjectReference.GetOwner Method

AcSmObjectReference.GetReferencedObject Method

AcSmObjectReference.GetReferenceFlags Method

AcSmObjectReference.GetTypeName Method

AcSmObjectReference.InitNew Method

AcSmObjectReference.Load Method

AcSmObjectReference.Save Method

AcSmObjectReference.SetOwner Method

AcSmObjectReference.SetReferencedObject Method

AcSmObjectReference.SetReferenceFlags Method


AcSmPersistProxy

AcSmObjectReference
A Objects
AcSmPublishOptions
AcSmPersistProxy

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods

AcSmPersistProxy.Clear Method

AcSmPersistProxy.GetDatabase Method

AcSmPersistProxy.GetDirectlyOwnedObjects Method

AcSmPersistProxy.GetIsDirty Method

AcSmPersistProxy.GetObjectId Method

AcSmPersistProxy.GetOwner Method

AcSmPersistProxy.GetTypeName Method

AcSmPersistProxy.InitNew Method

AcSmPersistProxy.Load Method

AcSmPersistProxy.Save Method

AcSmPersistProxy.SetOwner Method

AcSmPersistProxy.SetTypeName Method


AcSmPublishOptions

AcSmPersistProxy
A Objects
AcSmResources
AcSmPublishOptions

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods

AcSmPublishOptions.Clear Method

AcSmPublishOptions.GetDatabase Method

AcSmPublishOptions.GetDefaultOutputdir Method

AcSmPublishOptions.GetDirectlyOwnedObjects Method

AcSmPublishOptions.GetDwfType Method

AcSmPublishOptions.GetIncludePlotStamp Method

AcSmPublishOptions.GetIsDirty Method

AcSmPublishOptions.GetLayerInfo Method

AcSmPublishOptions.GetObjectId Method

AcSmPublishOptions.GetOutputFileName Method

AcSmPublishOptions.GetOwner Method

AcSmPublishOptions.GetPassword Method

AcSmPublishOptions.GetPromptForName Method

AcSmPublishOptions.GetPromptForPassword Method

AcSmPublishOptions.GetTypeName Method

AcSmPublishOptions.GetUnrecognizedData Method

AcSmPublishOptions.GetUnrecognizedSections Method

AcSmPublishOptions.GetUsePassword Method

AcSmPublishOptions.InitNew Method

AcSmPublishOptions.Load Method

AcSmPublishOptions.Save Method

AcSmPublishOptions.SetDefaultOutputdir Method

AcSmPublishOptions.SetDwfType Method

AcSmPublishOptions.SetIncludePlotStamp Method

AcSmPublishOptions.SetLayerInfo Method

AcSmPublishOptions.SetOutputFileName Method

AcSmPublishOptions.SetOwner Method

AcSmPublishOptions.SetPassword Method

AcSmPublishOptions.SetPromptForName Method

AcSmPublishOptions.SetPromptForPassword Method

AcSmPublishOptions.SetUnrecognizedData Method

AcSmPublishOptions.SetUnrecognizedSections Method

AcSmPublishOptions.SetUsePassword Method


AcSmResources

AcSmPublishOptions
A Objects
AcSmSheet
AcSmResources

Resources collection that contains IAcSmFileReference objects.

Methods, Properties and Events

Methods

AcSmResources.Add Method

AcSmResources.Clear Method

AcSmResources.GetCustomPropertyBag Method

AcSmResources.GetDatabase Method

AcSmResources.GetDesc Method

AcSmResources.GetDirectlyOwnedObjects Method

AcSmResources.GetEnumerator Method

AcSmResources.GetIsDirty Method

AcSmResources.GetName Method

AcSmResources.GetObjectId Method

AcSmResources.GetOwner Method

AcSmResources.GetTypeName Method

AcSmResources.InitNew Method

AcSmResources.Load Method

AcSmResources.Remove Method

AcSmResources.Save Method

AcSmResources.SetDesc Method

AcSmResources.SetName Method

AcSmResources.SetOwner Method


AcSmSheet

AcSmResources
A Objects
AcSmSheetSelSet
AcSmSheet

Sheet component.

Methods, Properties and Events

Methods

AcSmSheet.Clear Method

AcSmSheet.GetCategory Method

AcSmSheet.GetCustomPropertyBag Method

AcSmSheet.GetDatabase Method

AcSmSheet.GetDesc Method

AcSmSheet.GetDirectlyOwnedObjects Method

AcSmSheet.GetDoNotPlot Method

AcSmSheet.GetIsDirty Method

AcSmSheet.GetIssuePurpose Method

AcSmSheet.GetLayout Method

AcSmSheet.GetName Method

AcSmSheet.GetNumber Method

AcSmSheet.GetObjectId Method

AcSmSheet.GetOwner Method

AcSmSheet.GetRevisionDate Method

AcSmSheet.GetRevisionNumber Method

AcSmSheet.GetSheetViews Method

AcSmSheet.GetTitle Method

AcSmSheet.GetTypeName Method

AcSmSheet.InitNew Method

AcSmSheet.Load Method

AcSmSheet.Save Method

AcSmSheet.SetCategory Method

AcSmSheet.SetDesc Method

AcSmSheet.SetDoNotPlot Method

AcSmSheet.SetIssuePurpose Method

AcSmSheet.SetLayout Method

AcSmSheet.SetName Method

AcSmSheet.SetNumber Method

AcSmSheet.SetOwner Method

AcSmSheet.SetRevisionDate Method

AcSmSheet.SetRevisionNumber Method

AcSmSheet.SetTitle Method


AcSmSheetSelSet

AcSmSheet
A Objects
AcSmSheetSelSets
AcSmSheetSelSet

Selection set component.

Methods, Properties and Events

Methods

AcSmSheetSelSet.Add Method

AcSmSheetSelSet.Clear Method

AcSmSheetSelSet.GetCustomPropertyBag Method

AcSmSheetSelSet.GetDatabase Method

AcSmSheetSelSet.GetDesc Method

AcSmSheetSelSet.GetDirectlyOwnedObjects Method

AcSmSheetSelSet.GetEnumerator Method

AcSmSheetSelSet.GetIsDirty Method

AcSmSheetSelSet.GetName Method

AcSmSheetSelSet.GetObjectId Method

AcSmSheetSelSet.GetOwner Method

AcSmSheetSelSet.GetTypeName Method

AcSmSheetSelSet.InitNew Method

AcSmSheetSelSet.Load Method

AcSmSheetSelSet.Remove Method

AcSmSheetSelSet.Save Method

AcSmSheetSelSet.SetDesc Method

AcSmSheetSelSet.SetName Method

AcSmSheetSelSet.SetOwner Method


AcSmSheetSelSets

AcSmSheetSelSet
A Objects
AcSmSheetSet
AcSmSheetSelSets

Selection sets collection.

Methods, Properties and Events

Methods

AcSmSheetSelSets.Add Method

AcSmSheetSelSets.Clear Method

AcSmSheetSelSets.GetCustomPropertyBag Method

AcSmSheetSelSets.GetDatabase Method

AcSmSheetSelSets.GetDesc Method

AcSmSheetSelSets.GetDirectlyOwnedObjects Method

AcSmSheetSelSets.GetEnumerator Method

AcSmSheetSelSets.GetIsDirty Method

AcSmSheetSelSets.GetName Method

AcSmSheetSelSets.GetObjectId Method

AcSmSheetSelSets.GetOwner Method

AcSmSheetSelSets.GetTypeName Method

AcSmSheetSelSets.InitNew Method

AcSmSheetSelSets.Load Method

AcSmSheetSelSets.Remove Method

AcSmSheetSelSets.Save Method

AcSmSheetSelSets.SetDesc Method

AcSmSheetSelSets.SetName Method

AcSmSheetSelSets.SetOwner Method


AcSmSheetSet

AcSmSheetSelSets
A Objects
AcSmSheetSetMgr
AcSmSheetSet

Sheet set component.

Methods, Properties and Events

Methods

AcSmSheetSet.AddNewSheet Method

AcSmSheetSet.Clear Method

AcSmSheetSet.CreateSubset Method

AcSmSheetSet.GetAltPageSetups Method

AcSmSheetSet.GetCalloutBlocks Method

AcSmSheetSet.GetCustomPropertyBag Method

AcSmSheetSet.GetDatabase Method

AcSmSheetSet.GetDefAltPageSetup Method

AcSmSheetSet.GetDefDwtLayout Method

AcSmSheetSet.GetDefLabelBlk Method

AcSmSheetSet.GetDesc Method

AcSmSheetSet.GetDirectlyOwnedObjects Method

AcSmSheetSet.GetIsDirty Method

AcSmSheetSet.GetName Method

AcSmSheetSet.GetNewSheetLocation Method

AcSmSheetSet.GetObjectId Method

AcSmSheetSet.GetOwner Method

AcSmSheetSet.GetProjectMilestone Method

AcSmSheetSet.GetProjectName Method

AcSmSheetSet.GetProjectNumber Method

AcSmSheetSet.GetProjectPhase Method

AcSmSheetSet.GetPromptForDwgName Method

AcSmSheetSet.GetPromptForDwt Method

AcSmSheetSet.GetPublishOptions Method

AcSmSheetSet.GetResources Method

AcSmSheetSet.GetSheetEnumerator Method

AcSmSheetSet.GetSheetSelSets Method

AcSmSheetSet.GetTypeName Method

AcSmSheetSet.GetViewCategories Method

AcSmSheetSet.ImportSheet Method

AcSmSheetSet.InitNew Method

AcSmSheetSet.InsertComponent Method

AcSmSheetSet.InsertComponentAfter Method

AcSmSheetSet.Load Method

AcSmSheetSet.NotifyRegisteredEventHandlers Method

AcSmSheetSet.Register Method

AcSmSheetSet.RemoveSheet Method

AcSmSheetSet.RemoveSubset Method

AcSmSheetSet.Save Method

AcSmSheetSet.SetAltPageSetups Method

AcSmSheetSet.SetDefAltPageSetup Method

AcSmSheetSet.SetDefDwtLayout Method

AcSmSheetSet.SetDefLabelBlk Method

AcSmSheetSet.SetDesc Method

AcSmSheetSet.SetName Method

AcSmSheetSet.SetNewSheetLocation Method

AcSmSheetSet.SetOwner Method

AcSmSheetSet.SetProjectMilestone Method

AcSmSheetSet.SetProjectName Method

AcSmSheetSet.SetProjectNumber Method

AcSmSheetSet.SetProjectPhase Method

AcSmSheetSet.SetPromptForDwgName Method

AcSmSheetSet.SetPromptForDwt Method

AcSmSheetSet.Sync Method

AcSmSheetSet.Unregister Method

AcSmSheetSet.UpdateInMemoryDwgHints Method


AcSmSheetSetMgr

AcSmSheetSet
A Objects
AcSmSheetView
AcSmSheetSetMgr

Sheet Set Manager object.

Methods, Properties and Events

Methods

AcSmSheetSetMgr.Close Method

AcSmSheetSetMgr.CloseAll Method

AcSmSheetSetMgr.CreateDatabase Method

AcSmSheetSetMgr.FindOpenDatabase Method

AcSmSheetSetMgr.GetDatabaseEnumerator Method

AcSmSheetSetMgr.GetParentSheetSet Method

AcSmSheetSetMgr.OpenDatabase Method

AcSmSheetSetMgr.Register Method

AcSmSheetSetMgr.Unregister Method


AcSmSheetView

AcSmSheetSetMgr
A Objects
AcSmSheetViews
AcSmSheetView

Sheet view component.

Methods, Properties and Events

Methods

AcSmSheetView.Clear Method

AcSmSheetView.GetCategory Method

AcSmSheetView.GetCustomPropertyBag Method

AcSmSheetView.GetDatabase Method

AcSmSheetView.GetDesc Method

AcSmSheetView.GetDirectlyOwnedObjects Method

AcSmSheetView.GetIsDirty Method

AcSmSheetView.GetName Method

AcSmSheetView.GetNamedView Method

AcSmSheetView.GetNumber Method

AcSmSheetView.GetObjectId Method

AcSmSheetView.GetOwner Method

AcSmSheetView.GetTitle Method

AcSmSheetView.GetTypeName Method

AcSmSheetView.InitNew Method

AcSmSheetView.Load Method

AcSmSheetView.Save Method

AcSmSheetView.SetCategory Method

AcSmSheetView.SetDesc Method

AcSmSheetView.SetName Method

AcSmSheetView.SetNamedView Method

AcSmSheetView.SetNumber Method

AcSmSheetView.SetOwner Method

AcSmSheetView.SetTitle Method


AcSmSheetViews

AcSmSheetView
A Objects
AcSmSubset
AcSmSheetViews

Sheet views collection.

Methods, Properties and Events

Methods

AcSmSheetViews.Clear Method

AcSmSheetViews.GetCustomPropertyBag Method

AcSmSheetViews.GetDatabase Method

AcSmSheetViews.GetDesc Method

AcSmSheetViews.GetDirectlyOwnedObjects Method

AcSmSheetViews.GetEnumerator Method

AcSmSheetViews.GetIsDirty Method

AcSmSheetViews.GetName Method

AcSmSheetViews.GetObjectId Method

AcSmSheetViews.GetOwner Method

AcSmSheetViews.GetTypeName Method

AcSmSheetViews.InitNew Method

AcSmSheetViews.Load Method

AcSmSheetViews.Save Method

AcSmSheetViews.SetDesc Method

AcSmSheetViews.SetName Method

AcSmSheetViews.SetOwner Method

AcSmSheetViews.Sync Method


AcSmSubset

AcSmSheetViews
A Objects
AcSmViewCategories
AcSmSubset

Subset component.

Methods, Properties and Events

Methods

AcSmSubset.AddNewSheet Method

AcSmSubset.Clear Method

AcSmSubset.CreateSubset Method

AcSmSubset.GetCustomPropertyBag Method

AcSmSubset.GetDatabase Method

AcSmSubset.GetDefDwtLayout Method

AcSmSubset.GetDesc Method

AcSmSubset.GetDirectlyOwnedObjects Method

AcSmSubset.GetIsDirty Method

AcSmSubset.GetName Method

AcSmSubset.GetNewSheetLocation Method

AcSmSubset.GetObjectId Method

AcSmSubset.GetOwner Method

AcSmSubset.GetPromptForDwt Method

AcSmSubset.GetSheetEnumerator Method

AcSmSubset.GetTypeName Method

AcSmSubset.ImportSheet Method

AcSmSubset.InitNew Method

AcSmSubset.InsertComponent Method

AcSmSubset.InsertComponentAfter Method

AcSmSubset.Load Method

AcSmSubset.NotifyRegisteredEventHandlers Method

AcSmSubset.RemoveSheet Method

AcSmSubset.RemoveSubset Method

AcSmSubset.Save Method

AcSmSubset.SetDefDwtLayout Method

AcSmSubset.SetDesc Method

AcSmSubset.SetName Method

AcSmSubset.SetNewSheetLocation Method

AcSmSubset.SetOwner Method

AcSmSubset.SetPromptForDwt Method

AcSmSubset.UpdateInMemoryDwgHints Method


AcSmViewCategories

AcSmSubset
A Objects
AcSmViewCategory
AcSmViewCategories

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods

AcSmViewCategories.Clear Method

AcSmViewCategories.CreateViewCategory Method

AcSmViewCategories.GetCustomPropertyBag Method

AcSmViewCategories.GetDatabase Method

AcSmViewCategories.GetDefaultViewCategory Method

AcSmViewCategories.GetDesc Method

AcSmViewCategories.GetDirectlyOwnedObjects Method

AcSmViewCategories.GetEnumerator Method

AcSmViewCategories.GetIsDirty Method

AcSmViewCategories.GetName Method

AcSmViewCategories.GetObjectId Method

AcSmViewCategories.GetOwner Method

AcSmViewCategories.GetTypeName Method

AcSmViewCategories.InitNew Method

AcSmViewCategories.Load Method

AcSmViewCategories.RemoveViewCategory Method

AcSmViewCategories.Save Method

AcSmViewCategories.SetDesc Method

AcSmViewCategories.SetName Method

AcSmViewCategories.SetOwner Method


AcSmViewCategory

AcSmViewCategories
A Objects
I Objects
AcSmViewCategory

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods

AcSmViewCategory.Clear Method

AcSmViewCategory.GetCalloutBlocks Method

AcSmViewCategory.GetCustomPropertyBag Method

AcSmViewCategory.GetDatabase Method

AcSmViewCategory.GetDesc Method

AcSmViewCategory.GetDirectlyOwnedObjects Method

AcSmViewCategory.GetIsDirty Method

AcSmViewCategory.GetName Method

AcSmViewCategory.GetObjectId Method

AcSmViewCategory.GetOwner Method

AcSmViewCategory.GetSheetViewEnumerator Method

AcSmViewCategory.GetTypeName Method

AcSmViewCategory.InitNew Method

AcSmViewCategory.Load Method

AcSmViewCategory.Save Method

AcSmViewCategory.SetDesc Method

AcSmViewCategory.SetName Method

AcSmViewCategory.SetOwner Method


I Objects

AcSmViewCategory
Objects
IAcSmComponent Object
I Objects

Topics in this section

  • IAcSmComponent Object
  • IAcSmEnumAcDbBlockRecordReference
  • IAcSmEnumComponent
  • IAcSmEnumDatabase
  • IAcSmEnumFileReference
  • IAcSmEnumPersist
  • IAcSmEnumProperty
  • IAcSmEnumSheetSelSet
  • IAcSmEnumSheetView
  • IAcSmEnumViewCategory
  • IAcSmEvents
  • IAcSmObjectId
  • IAcSmPersist


IAcSmComponent Object

I Objects
I Objects
IAcSmEnumAcDbBlockRecordReference
IAcSmComponent Object

The IAcSmComponent interface defines the basic behavior of most Sheet Set Manager objects. The IAcSmComponent derives from the IAcSmPersist interface and includes all IAcSmPersist methods.

Methods, Properties and Events

Methods

Clear

GetCustomPropertyBag

GetDatabase

GetDesc

GetDirectlyOwnedObjects

GetIsDirty

GetName

GetObjectId

GetOwner

GetTypeName

InitNew

Load

Save

SetDesc

SetName

SetOwner


IAcSmEnumAcDbBlockRecordReference

IAcSmComponent Object
I Objects
IAcSmEnumComponent
IAcSmEnumAcDbBlockRecordReference

Object enumerator for AcSmAcDbBlockRecordReference.

Methods, Properties and Events

Methods

IAcSmEnumAcDbBlockRecordReference.Next Method

IAcSmEnumAcDbBlockRecordReference.Reset Method


IAcSmEnumComponent

IAcSmEnumAcDbBlockRecordReference
I Objects
IAcSmEnumDatabase
IAcSmEnumComponent

Object enumerator for IAcSmComponent.

Methods, Properties and Events

Methods

IAcSmEnumComponent.Next Method


IAcSmEnumDatabase

IAcSmEnumComponent
I Objects
IAcSmEnumFileReference
IAcSmEnumDatabase

Object enumerator for IAcSmDatabase. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components

Methods, Properties and Events

Methods

IAcSmEnumDatabase.Next Method

IAcSmEnumDatabase.Reset Method


IAcSmEnumFileReference

IAcSmEnumDatabase
I Objects
IAcSmEnumPersist
IAcSmEnumFileReference

Object enumerator for IAcSmEnumFileReference.

Methods, Properties and Events

Methods

IAcSmEnumFileReference.Next Method

IAcSmEnumFileReference.Reset Method


IAcSmEnumPersist

IAcSmEnumFileReference
I Objects
IAcSmEnumProperty
IAcSmEnumPersist

Object enumerator for IAcSmEnumPersist.

Methods, Properties and Events

Methods

IAcSmEnumPersist.Next Method

IAcSmEnumPersist.Reset Method


IAcSmEnumProperty

IAcSmEnumPersist
I Objects
IAcSmEnumSheetSelSet
IAcSmEnumProperty

Custom property enumerator interface.

Methods, Properties and Events

Methods

IAcSmEnumProperty.Next Method

IAcSmEnumProperty.Reset Method


IAcSmEnumSheetSelSet

IAcSmEnumProperty
I Objects
IAcSmEnumSheetView
IAcSmEnumSheetSelSet

Object enumerator for IAcSmEnumSheetSelSet. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components

Methods, Properties and Events

Methods

IAcSmEnumSheetSelSet.Next Method

IAcSmEnumSheetSelSet.Reset Method


IAcSmEnumSheetView

IAcSmEnumSheetSelSet
I Objects
IAcSmEnumViewCategory
IAcSmEnumSheetView

Object enumerator for IAcSmEnumSheetView. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components

Methods, Properties and Events

Methods

IAcSmEnumSheetView.Next Method

IAcSmEnumSheetView.Reset Method


IAcSmEnumViewCategory

IAcSmEnumSheetView
I Objects
IAcSmEvents
IAcSmEnumViewCategory

This API was designed for internal use and has not been thoroughly tested.

Methods, Properties and Events

Methods

IAcSmEnumViewCategory.Next Method

IAcSmEnumViewCategory.Reset Method


IAcSmEvents

IAcSmEnumViewCategory
I Objects
IAcSmObjectId
IAcSmEvents

The callback interface used for event notifications.

Methods, Properties and Events

Methods

IAcSmEvents.OnChanged Method


IAcSmObjectId

IAcSmEvents
I Objects
IAcSmPersist
IAcSmObjectId

Unique identifier for each component.

Methods, Properties and Events

Methods

IAcSmObjectId.GetDatabase Method

IAcSmObjectId.GetHandle Method

IAcSmObjectId.GetOwner Method

IAcSmObjectId.GetPersistObject Method

IAcSmObjectId.IsEqual Method

IAcSmObjectId.IsValid Method


IAcSmPersist

IAcSmObjectId
I Objects
P Objects
IAcSmPersist

The base persistence interface used by an AcSmDatabase database.

Methods, Properties and Events

Methods

IAcSmPersist.Clear Method

IAcSmPersist.GetDatabase Method

IAcSmPersist.GetDirectlyOwnedObjects Method

IAcSmPersist.GetIsDirty Method

IAcSmPersist.GetObjectId Method

IAcSmPersist.GetOwner Method

IAcSmPersist.GetTypeName Method

IAcSmPersist.InitNew Method

IAcSmPersist.Load Method

IAcSmPersist.Save Method

IAcSmPersist.SetOwner Method


P Objects

IAcSmPersist
Objects
PropertyFlags
P Objects

Topics in this section

  • PropertyFlags


PropertyFlags

P Objects
P Objects
Methods
PropertyFlags

Custom property flags. The flags are used with the GetFlags and SetFlags methods of the AcSmCustomPropertyValue object.

Methods, Properties and Events

Properties

CUSTOM_SHEET_PROP

PropertyFlags.EMPTY Property


Methods

PropertyFlags
A Methods
Methods

Topics in this section

  • A Methods
  • C Methods
  • F Methods
  • G Methods
  • I Methods
  • L Methods
  • N Methods
  • O Methods
  • P Methods
  • R Methods
  • S Methods
  • U Methods
  • W Methods


A Methods

Methods
Methods
AcSmSheetSet.AddNewSheet Method
A Methods

Topics in this section

  • AcSmSheetSet.AddNewSheet Method
  • AcSmSubset.AddNewSheet Method
  • AcSmCalloutBlockReferences.Add Method
  • AcSmCalloutBlocks.Add Method
  • AcSmResources.Add Method
  • AcSmSheetSelSet.Add Method
  • AcSmSheetSelSets.Add Method


AcSmSheetSet.AddNewSheet Method

A Methods
A Methods
AcSmSubset.AddNewSheet Method
AcSmSheetSet.AddNewSheet Method

Constructs a new sheet component. The new sheet is not automatically inserted into the collection.

Syntax

AddNewSheet(
 name As String,
 desc As String) As IAcSmSheet
name | Input string containing NameName value
desc | Input string containing the text to set as the description


AcSmSubset.AddNewSheet Method

AcSmSheetSet.AddNewSheet Method
A Methods
AcSmCalloutBlockReferences.Add Method
AcSmSubset.AddNewSheet Method

Adds a new sheet component without adding it to the subset.

To add the new sheet component to the subset, use the InsertComponent method.

Syntax

AddNewSheet(
 name As String,
 desc As String) As IAcSmSheet
name | Input string containing NameName value of the new sheet
desc | Input string containing the text to set as the description


AcSmCalloutBlockReferences.Add Method

AcSmSubset.AddNewSheet Method
A Methods
AcSmCalloutBlocks.Add Method
AcSmCalloutBlockReferences.Add Method

Appends the provided AcSmAcDbBlockRecordReference component to the collection.

Syntax

Add(
 pBlkRef As IAcSmAcDbBlockRecordReference) As Object
pBlkRef Input block reference


AcSmCalloutBlocks.Add Method

AcSmCalloutBlockReferences.Add Method
A Methods
AcSmResources.Add Method
AcSmCalloutBlocks.Add Method

Appends an IAcSmAcDbBlockRecordReference component to the collection.

Syntax

Add(
 pBlkRef As IAcSmAcDbBlockRecordReference) As Object
pBlkRef Input pointer to an IAcSmAcDbBlockRecordReference component to add to the collection


AcSmResources.Add Method

AcSmCalloutBlocks.Add Method
A Methods
AcSmSheetSelSet.Add Method
AcSmResources.Add Method

Appends an IAcSmFileReference component to the collection.

Syntax

Add(
 pResource As IAcSmFileReference) As Object
pResource Input IAcSmFileReferenceIAcSmFileReference component to add to the collection


AcSmSheetSelSet.Add Method

AcSmResources.Add Method
A Methods
AcSmSheetSelSets.Add Method
AcSmSheetSelSet.Add Method

Adds a component to the selection set.

Syntax

Add(
 comp As IAcSmComponent) As Object
comp Input sheet or subset to be added to the selection set


AcSmSheetSelSets.Add Method

AcSmSheetSelSet.Add Method
A Methods
C Methods
AcSmSheetSelSets.Add Method

Adds a new selection set component and adds the component to the sheet set.

The caller must release the interface when the operation is complete.

Syntax

Add(
 name As String,
 desc As String,
 selset As IAcSmSheetSelSet) As Object
name | Input string containing the name of the selection set component to be added
desc | Input string containing the text to set as the description of the selection set component
selset | Output pointer to an IAcSmSheetSelSetIAcSmSheetSelSet interface


C Methods

AcSmSheetSelSets.Add Method
Methods
AcSmAcDbBlockRecordReference.Clear Method
C Methods

Topics in this section

  • AcSmAcDbBlockRecordReference.Clear Method
  • AcSmAcDbLayoutReference.Clear Method
  • AcSmAcDbObjectReference.Clear Method
  • AcSmAcDbViewReference.Clear Method
  • AcSmCalloutBlockReferences.Clear Method
  • AcSmCalloutBlocks.Clear Method
  • AcSmCustomPropertyBag.Clear Method
  • AcSmCustomPropertyValue.Clear Method
  • AcSmDatabase.Clear Method
  • AcSmFileReference.Clear Method
  • AcSmNamedAcDbObjectReference.Clear Method
  • AcSmObjectReference.Clear Method
  • AcSmPersistProxy.Clear Method
  • AcSmPublishOptions.Clear Method
  • AcSmPublishOptions.Clear Method
  • AcSmResources.Clear Method
  • AcSmSheet.Clear Method
  • AcSmSheetSelSet.Clear Method
  • AcSmSheetSelSets.Clear Method
  • AcSmSheetSet.Clear Method
  • AcSmSheetView.Clear Method
  • AcSmSheetViews.Clear Method
  • AcSmSubset.Clear Method
  • AcSmViewCategories.Clear Method
  • AcSmViewCategory.Clear Method
  • IAcSmComponent.Clear Method
  • IAcSmPersist.Clear Method
  • AcSmSheetSetMgr.CloseAll Method
  • AcSmDSTFiler.Close Method
  • AcSmSheetSetMgr.Close Method
  • AcSmSheetSetMgr.CreateDatabase Method
  • AcSmSheetSet.CreateSubset Method
  • AcSmSubset.CreateSubset Method
  • AcSmViewCategories.CreateViewCategory Method


AcSmAcDbBlockRecordReference.Clear Method

C Methods
C Methods
AcSmAcDbLayoutReference.Clear Method
AcSmAcDbBlockRecordReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmAcDbLayoutReference.Clear Method

AcSmAcDbBlockRecordReference.Clear Method
C Methods
AcSmAcDbObjectReference.Clear Method
AcSmAcDbLayoutReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmAcDbObjectReference.Clear Method

AcSmAcDbLayoutReference.Clear Method
C Methods
AcSmAcDbViewReference.Clear Method
AcSmAcDbObjectReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmAcDbViewReference.Clear Method

AcSmAcDbObjectReference.Clear Method
C Methods
AcSmCalloutBlockReferences.Clear Method
AcSmAcDbViewReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmCalloutBlockReferences.Clear Method

AcSmAcDbViewReference.Clear Method
C Methods
AcSmCalloutBlocks.Clear Method
AcSmCalloutBlockReferences.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmCalloutBlocks.Clear Method

AcSmCalloutBlockReferences.Clear Method
C Methods
AcSmCustomPropertyBag.Clear Method
AcSmCalloutBlocks.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmCustomPropertyBag.Clear Method

AcSmCalloutBlocks.Clear Method
C Methods
AcSmCustomPropertyValue.Clear Method
AcSmCustomPropertyBag.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmCustomPropertyValue.Clear Method

AcSmCustomPropertyBag.Clear Method
C Methods
AcSmDatabase.Clear Method
AcSmCustomPropertyValue.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmDatabase.Clear Method

AcSmCustomPropertyValue.Clear Method
C Methods
AcSmFileReference.Clear Method
AcSmDatabase.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmFileReference.Clear Method

AcSmDatabase.Clear Method
C Methods
AcSmNamedAcDbObjectReference.Clear Method
AcSmFileReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmNamedAcDbObjectReference.Clear Method

AcSmFileReference.Clear Method
C Methods
AcSmObjectReference.Clear Method
AcSmNamedAcDbObjectReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmObjectReference.Clear Method

AcSmNamedAcDbObjectReference.Clear Method
C Methods
AcSmPersistProxy.Clear Method
AcSmObjectReference.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmPersistProxy.Clear Method

AcSmObjectReference.Clear Method
C Methods
AcSmPublishOptions.Clear Method
AcSmPersistProxy.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


AcSmPublishOptions.Clear Method

AcSmPersistProxy.Clear Method
C Methods
AcSmPublishOptions.Clear Method
AcSmPublishOptions.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


AcSmPublishOptions.Clear Method
C Methods
AcSmResources.Clear Method
AcSmPublishOptions.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


AcSmResources.Clear Method

AcSmPublishOptions.Clear Method
C Methods
AcSmSheet.Clear Method
AcSmResources.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheet.Clear Method

AcSmResources.Clear Method
C Methods
AcSmSheetSelSet.Clear Method
AcSmSheet.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetSelSet.Clear Method

AcSmSheet.Clear Method
C Methods
AcSmSheetSelSets.Clear Method
AcSmSheetSelSet.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetSelSets.Clear Method

AcSmSheetSelSet.Clear Method
C Methods
AcSmSheetSet.Clear Method
AcSmSheetSelSets.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetSet.Clear Method

AcSmSheetSelSets.Clear Method
C Methods
AcSmSheetView.Clear Method
AcSmSheetSet.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetView.Clear Method

AcSmSheetSet.Clear Method
C Methods
AcSmSheetViews.Clear Method
AcSmSheetView.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSheetViews.Clear Method

AcSmSheetView.Clear Method
C Methods
AcSmSubset.Clear Method
AcSmSheetViews.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmSubset.Clear Method

AcSmSheetViews.Clear Method
C Methods
AcSmViewCategories.Clear Method
AcSmSubset.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


AcSmViewCategories.Clear Method

AcSmSubset.Clear Method
C Methods
AcSmViewCategory.Clear Method
AcSmViewCategories.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


AcSmViewCategory.Clear Method

AcSmViewCategories.Clear Method
C Methods
IAcSmComponent.Clear Method
AcSmViewCategory.Clear Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Clear() As Object


IAcSmComponent.Clear Method

AcSmViewCategory.Clear Method
C Methods
IAcSmPersist.Clear Method
IAcSmComponent.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

Syntax

Clear() As Object


IAcSmPersist.Clear Method

IAcSmComponent.Clear Method
C Methods
AcSmSheetSetMgr.CloseAll Method
IAcSmPersist.Clear Method

Resets and cleans up the object, leaving the object uninitialized.

If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

Clear() As Object


AcSmSheetSetMgr.CloseAll Method

IAcSmPersist.Clear Method
C Methods
AcSmDSTFiler.Close Method
AcSmSheetSetMgr.CloseAll Method

Closes all open databases.

Syntax

CloseAll() As Object


AcSmDSTFiler.Close Method

AcSmSheetSetMgr.CloseAll Method
C Methods
AcSmSheetSetMgr.Close Method
AcSmDSTFiler.Close Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Close(
 bSuccess As Boolean) As Object
bSuccess Input Boolean


AcSmSheetSetMgr.Close Method

AcSmDSTFiler.Close Method
C Methods
AcSmSheetSetMgr.CreateDatabase Method
AcSmSheetSetMgr.Close Method

Closes a database.

Syntax

Close(
 db As IAcSmDatabase) As Object
db Input IAcSmDatabase to close


AcSmSheetSetMgr.CreateDatabase Method

AcSmSheetSetMgr.Close Method
C Methods
AcSmSheetSet.CreateSubset Method
AcSmSheetSetMgr.CreateDatabase Method

Creates a new database (DST file) and returns the IAcSmDatabase component for the database.

The method fails if the database file exists. If the templatefileName parameter is null or is an empty ("") string, then a database file is created without a template. If the templatefileName parameter specifies a file that is not found or read, E_FAIL is returned.

The caller must release the interface when the operation is complete.

Syntax

CreateDatabase(
 filename As String,
 templatefilename As String = 0,
 bAlwaysCreate As Boolean = True) As IAcSmDatabase
filename | Input file name of the database to be created
templatefilename | Input file name of the template for the database
bAlwaysCreate | Input Boolean indicating whether to create a new DST file even when there is an existing DST file with the same name


AcSmSheetSet.CreateSubset Method

AcSmSheetSetMgr.CreateDatabase Method
C Methods
AcSmSubset.CreateSubset Method
AcSmSheetSet.CreateSubset Method

Constructs a new subset component. The new subset is not inserted automatically into the collection.

Syntax

CreateSubset(
 name As String,
 desc As String) As IAcSmSubset
name | Input string containing Name value
desc | Input string containing the text to set as the description


AcSmSubset.CreateSubset Method

AcSmSheetSet.CreateSubset Method
C Methods
AcSmViewCategories.CreateViewCategory Method
AcSmSubset.CreateSubset Method

Adds a new subset component without adding it to the current subset.

The caller must release the interface when the operation is complete.

Syntax

CreateSubset(
 name As String,
 desc As String) As IAcSmSubset
name | Input string containing the Name value of the new subset component
desc | Input string containing the text to set as the description of the new subset


AcSmViewCategories.CreateViewCategory Method

AcSmSubset.CreateSubset Method
C Methods
F Methods
AcSmViewCategories.CreateViewCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

CreateViewCategory(
 name As String,
 desc As String,
 id As String) As IAcSmViewCategory
name | Input string containing NameName value
desc | Input string containing the text to set as the description
id | Input ID


F Methods

AcSmViewCategories.CreateViewCategory Method
Methods
AcSmDatabase.FindObject Method
F Methods

Topics in this section

  • AcSmDatabase.FindObject Method
  • AcSmSheetSetMgr.FindOpenDatabase Method


AcSmDatabase.FindObject Method

F Methods
F Methods
AcSmSheetSetMgr.FindOpenDatabase Method
AcSmDatabase.FindObject Method

Finds an IAcSmPersist object based on the persisted handle of the object instance.

The caller must release the interface when the operation is complete.

Syntax

FindObject(
 hand As String) As IAcSmPersist
hand Input object handle, or null if a new ID is requested


AcSmSheetSetMgr.FindOpenDatabase Method

AcSmDatabase.FindObject Method
F Methods
G Methods
AcSmSheetSetMgr.FindOpenDatabase Method

Checks the open databases for a specific database.

The caller must release the interface when the operation is complete.

Syntax

FindOpenDatabase(
 filename As String) As IAcSmDatabase
filename Input file name of the open database to find


G Methods

AcSmSheetSetMgr.FindOpenDatabase Method
Methods
AcSmAcDbDatabase.GetAcDbDatabase Method
G Methods

Topics in this section

  • AcSmAcDbDatabase.GetAcDbDatabase Method
  • AcSmAcDbBlockRecordReference.GetAcDbHandle Method
  • AcSmAcDbLayoutReference.GetAcDbHandle Method
  • AcSmAcDbObjectReference.GetAcDbHandle Method
  • AcSmAcDbViewReference.GetAcDbHandle Method
  • AcSmNamedAcDbObjectReference.GetAcDbHandle Method
  • AcSmAcDbBlockRecordReference.GetAcSmAcDbDatabase Method
  • AcSmAcDbLayoutReference.GetAcSmAcDbDatabase Method
  • AcSmAcDbObjectReference.GetAcSmAcDbDatabase Method
  • AcSmAcDbViewReference.GetAcSmAcDbDatabase Method
  • AcSmNamedAcDbObjectReference.GetAcSmAcDbDatabase Method
  • AcSmSheetSet.GetAltPageSetups Method
  • AcSmSheetSet.GetCalloutBlocks Method
  • AcSmViewCategory.GetCalloutBlocks Method
  • AcSmSheet.GetCategory Method
  • AcSmSheetView.GetCategory Method
  • AcSmDSTFiler.GetCurrentObjectHeaderInfo Method
  • AcSmDSTFiler.GetCurrentObject Method
  • AcSmCalloutBlockReferences.GetCustomPropertyBag Method
  • AcSmCalloutBlocks.GetCustomPropertyBag Method
  • AcSmDatabase.GetCustomPropertyBag Method
  • AcSmResources.GetCustomPropertyBag Method
  • AcSmSheet.GetCustomPropertyBag Method
  • AcSmSheetSelSet.GetCustomPropertyBag Method
  • AcSmSheetSelSets.GetCustomPropertyBag Method
  • AcSmSheetSet.GetCustomPropertyBag Method
  • AcSmSheetView.GetCustomPropertyBag Method
  • AcSmSheetViews.GetCustomPropertyBag Method
  • AcSmSubset.GetCustomPropertyBag Method
  • AcSmViewCategories.GetCustomPropertyBag Method
  • AcSmViewCategory.GetCustomPropertyBag Method
  • IAcSmComponent.GetCustomPropertyBag Method
  • AcSmSheetSetMgr.GetDatabaseEnumerator Method
  • AcSmAcDbBlockRecordReference.GetDatabase Method
  • AcSmAcDbLayoutReference.GetDatabase Method
  • AcSmAcDbObjectReference.GetDatabase Method
  • AcSmAcDbViewReference.GetDatabase Method
  • AcSmCalloutBlockReferences.GetDatabase Method
  • AcSmCalloutBlocks.GetDatabase Method
  • AcSmCustomPropertyBag.GetDatabase Method
  • AcSmCustomPropertyValue.GetDatabase Method
  • AcSmDSTFiler.GetDatabase Method
  • AcSmDatabase.GetDatabase Method
  • AcSmFileReference.GetDatabase Method
  • AcSmNamedAcDbObjectReference.GetDatabase Method
  • AcSmObjectReference.GetDatabase Method
  • AcSmPersistProxy.GetDatabase Method
  • AcSmPublishOptions.GetDatabase Method
  • AcSmResources.GetDatabase Method
  • AcSmSheet.GetDatabase Method
  • AcSmSheetSelSet.GetDatabase Method
  • AcSmSheetSelSets.GetDatabase Method
  • AcSmSheetSet.GetDatabase Method
  • AcSmSheetView.GetDatabase Method
  • AcSmSheetViews.GetDatabase Method
  • AcSmSubset.GetDatabase Method
  • AcSmViewCategories.GetDatabase Method
  • AcSmViewCategory.GetDatabase Method
  • IAcSmComponent.GetDatabase Method
  • IAcSmObjectId.GetDatabase Method
  • IAcSmPersist.GetDatabase Method
  • AcSmDatabase.GetDbVersion Method
  • AcSmSheetSet.GetDefAltPageSetup Method
  • AcSmSheetSet.GetDefDwtLayout Method
  • AcSmSubset.GetDefDwtLayout Method
  • AcSmSheetSet.GetDefLabelBlk Method
  • AcSmPublishOptions.GetDefaultOutputdir Method
  • AcSmViewCategories.GetDefaultViewCategory Method
  • AcSmCalloutBlockReferences.GetDesc Method
  • AcSmCalloutBlocks.GetDesc Method
  • AcSmDatabase.GetDesc Method
  • AcSmResources.GetDesc Method
  • AcSmSheet.GetDesc Method
  • AcSmSheetSelSet.GetDesc Method
  • AcSmSheetSelSets.GetDesc Method
  • AcSmSheetSet.GetDesc Method
  • AcSmSheetView.GetDesc Method
  • AcSmSheetViews.GetDesc Method
  • AcSmSubset.GetDesc Method
  • AcSmViewCategories.GetDesc Method
  • AcSmViewCategory.GetDesc Method
  • IAcSmComponent.GetDesc Method
  • AcSmAcDbBlockRecordReference.GetDirectlyOwnedObjects Method
  • AcSmAcDbLayoutReference.GetDirectlyOwnedObjects Method
  • AcSmAcDbObjectReference.GetDirectlyOwnedObjects Method
  • AcSmAcDbViewReference.GetDirectlyOwnedObjects Method
  • AcSmCalloutBlockReferences.GetDirectlyOwnedObjects Method
  • AcSmCalloutBlocks.GetDirectlyOwnedObjects Method
  • AcSmCustomPropertyBag.GetDirectlyOwnedObjects Method
  • AcSmCustomPropertyValue.GetDirectlyOwnedObjects Method
  • AcSmDatabase.GetDirectlyOwnedObjects Method
  • AcSmFileReference.GetDirectlyOwnedObjects Method
  • AcSmNamedAcDbObjectReference.GetDirectlyOwnedObjects Method
  • AcSmObjectReference.GetDirectlyOwnedObjects Method
  • AcSmPersistProxy.GetDirectlyOwnedObjects Method
  • AcSmPublishOptions.GetDirectlyOwnedObjects Method
  • AcSmResources.GetDirectlyOwnedObjects Method
  • AcSmSheet.GetDirectlyOwnedObjects Method
  • AcSmSheetSelSet.GetDirectlyOwnedObjects Method
  • AcSmSheetSelSets.GetDirectlyOwnedObjects Method
  • AcSmSheetSet.GetDirectlyOwnedObjects Method
  • AcSmSheetView.GetDirectlyOwnedObjects Method
  • AcSmSheetViews.GetDirectlyOwnedObjects Method
  • AcSmSubset.GetDirectlyOwnedObjects Method
  • AcSmViewCategories.GetDirectlyOwnedObjects Method
  • AcSmViewCategory.GetDirectlyOwnedObjects Method
  • IAcSmComponent.GetDirectlyOwnedObjects Method
  • IAcSmPersist.GetDirectlyOwnedObjects Method
  • AcSmSheet.GetDoNotPlot Method
  • AcSmPublishOptions.GetDwfType Method
  • AcSmCalloutBlockReferences.GetEnumerator Method
  • AcSmCalloutBlocks.GetEnumerator Method
  • AcSmDatabase.GetEnumerator Method
  • AcSmResources.GetEnumerator Method
  • AcSmSheetSelSet.GetEnumerator Method
  • AcSmSheetSelSets.GetEnumerator Method
  • AcSmSheetViews.GetEnumerator Method
  • AcSmViewCategories.GetEnumerator Method
  • AcSmAcDbBlockRecordReference.GetFileName Method
  • AcSmAcDbLayoutReference.GetFileName Method
  • AcSmAcDbObjectReference.GetFileName Method
  • AcSmAcDbViewReference.GetFileName Method
  • AcSmDatabase.GetFileName Method
  • AcSmFileReference.GetFileName Method
  • AcSmNamedAcDbObjectReference.GetFileName Method
  • AcSmCustomPropertyValue.GetFlags Method
  • IAcSmObjectId.GetHandle Method
  • AcSmAcDbDatabase.GetIAcadDatabase Method
  • AcSmPublishOptions.GetIncludePlotStamp Method
  • AcSmAcDbBlockRecordReference.GetIsDirty Method
  • AcSmAcDbLayoutReference.GetIsDirty Method
  • AcSmAcDbObjectReference.GetIsDirty Method
  • AcSmAcDbViewReference.GetIsDirty Method
  • AcSmCalloutBlockReferences.GetIsDirty Method
  • AcSmCalloutBlocks.GetIsDirty Method
  • AcSmCustomPropertyBag.GetIsDirty Method
  • AcSmCustomPropertyValue.GetIsDirty Method
  • AcSmDatabase.GetIsDirty Method
  • AcSmFileReference.GetIsDirty Method
  • AcSmNamedAcDbObjectReference.GetIsDirty Method
  • AcSmObjectReference.GetIsDirty Method
  • AcSmPersistProxy.GetIsDirty Method
  • AcSmPublishOptions.GetIsDirty Method
  • AcSmResources.GetIsDirty Method
  • AcSmSheet.GetIsDirty Method
  • AcSmSheetSelSet.GetIsDirty Method
  • AcSmSheetSelSets.GetIsDirty Method
  • AcSmSheetSet.GetIsDirty Method
  • AcSmSheetView.GetIsDirty Method
  • AcSmSheetViews.GetIsDirty Method
  • AcSmSubset.GetIsDirty Method
  • AcSmViewCategories.GetIsDirty Method
  • AcSmViewCategory.GetIsDirty Method
  • IAcSmComponent.GetIsDirty Method
  • IAcSmPersist.GetIsDirty Method
  • AcSmDatabase.GetIsTemporary Method
  • AcSmSheet.GetIssuePurpose Method
  • AcSmPublishOptions.GetLayerInfo Method
  • AcSmSheet.GetLayout Method
  • AcSmDatabase.GetLockOwnerInfo Method
  • AcSmDatabase.GetLockStatus Method
  • AcSmAcDbBlockRecordReference.GetName Method
  • AcSmAcDbLayoutReference.GetName Method
  • AcSmAcDbViewReference.GetName Method
  • AcSmCalloutBlockReferences.GetName Method
  • AcSmCalloutBlocks.GetName Method
  • AcSmDatabase.GetName Method
  • AcSmNamedAcDbObjectReference.GetName Method
  • AcSmResources.GetName Method
  • AcSmSheet.GetName Method
  • AcSmSheetSelSet.GetName Method
  • AcSmSheetSelSets.GetName Method
  • AcSmSheetSet.GetName Method
  • AcSmSheetView.GetName Method
  • AcSmSheetViews.GetName Method
  • AcSmSubset.GetName Method
  • AcSmViewCategories.GetName Method
  • AcSmViewCategory.GetName Method
  • IAcSmComponent.GetName Method
  • AcSmSheetView.GetNamedView Method
  • AcSmDatabase.GetNewObjectId Method
  • AcSmSheetSet.GetNewSheetLocation Method
  • AcSmSubset.GetNewSheetLocation Method
  • AcSmSheet.GetNumber Method
  • AcSmSheetView.GetNumber Method
  • AcSmAcDbBlockRecordReference.GetObjectId Method
  • AcSmAcDbLayoutReference.GetObjectId Method
  • AcSmAcDbObjectReference.GetObjectId Method
  • AcSmAcDbViewReference.GetObjectId Method
  • AcSmCalloutBlockReferences.GetObjectId Method
  • AcSmCalloutBlocks.GetObjectId Method
  • AcSmCustomPropertyBag.GetObjectId Method
  • AcSmCustomPropertyValue.GetObjectId Method
  • AcSmDatabase.GetObjectId Method
  • AcSmFileReference.GetObjectId Method
  • AcSmNamedAcDbObjectReference.GetObjectId Method
  • AcSmObjectReference.GetObjectId Method
  • AcSmPersistProxy.GetObjectId Method
  • AcSmPublishOptions.GetObjectId Method
  • AcSmResources.GetObjectId Method
  • AcSmSheet.GetObjectId Method
  • AcSmSheetSelSet.GetObjectId Method
  • AcSmSheetSelSets.GetObjectId Method
  • AcSmSheetSet.GetObjectId Method
  • AcSmSheetView.GetObjectId Method
  • AcSmSheetViews.GetObjectId Method
  • AcSmSubset.GetObjectId Method
  • AcSmViewCategories.GetObjectId Method
  • AcSmViewCategory.GetObjectId Method
  • IAcSmComponent.GetObjectId Method
  • IAcSmPersist.GetObjectId Method
  • AcSmPublishOptions.GetOutputFileName Method
  • AcSmAcDbBlockRecordReference.GetOwnerAcDbHandle Method
  • AcSmAcDbLayoutReference.GetOwnerAcDbHandle Method
  • AcSmAcDbViewReference.GetOwnerAcDbHandle Method
  • AcSmNamedAcDbObjectReference.GetOwnerAcDbHandle Method
  • AcSmAcDbBlockRecordReference.GetOwner Method
  • AcSmAcDbLayoutReference.GetOwner Method
  • AcSmAcDbObjectReference.GetOwner Method
  • AcSmAcDbViewReference.GetOwner Method
  • AcSmCalloutBlockReferences.GetOwner Method
  • AcSmCalloutBlocks.GetOwner Method
  • AcSmCustomPropertyBag.GetOwner Method
  • AcSmCustomPropertyValue.GetOwner Method
  • AcSmDatabase.GetOwner Method
  • AcSmFileReference.GetOwner Method
  • AcSmNamedAcDbObjectReference.GetOwner Method
  • AcSmObjectReference.GetOwner Method
  • AcSmPersistProxy.GetOwner Method
  • AcSmPublishOptions.GetOwner Method
  • AcSmResources.GetOwner Method
  • AcSmSheet.GetOwner Method
  • AcSmSheetSelSet.GetOwner Method
  • AcSmSheetSelSets.GetOwner Method
  • AcSmSheetSet.GetOwner Method
  • AcSmSheetView.GetOwner Method
  • AcSmSheetViews.GetOwner Method
  • AcSmSubset.GetOwner Method
  • AcSmViewCategories.GetOwner Method
  • AcSmViewCategory.GetOwner Method
  • IAcSmComponent.GetOwner Method
  • IAcSmObjectId.GetOwner Method
  • IAcSmPersist.GetOwner Method
  • AcSmSheetSetMgr.GetParentSheetSet Method
  • AcSmPublishOptions.GetPassword Method
  • IAcSmObjectId.GetPersistObject Method
  • AcSmSheetSet.GetProjectMilestone Method
  • AcSmSheetSet.GetProjectName Method
  • AcSmSheetSet.GetProjectNumber Method
  • AcSmSheetSet.GetProjectPhase Method
  • AcSmSheetSet.GetPromptForDwgName Method
  • AcSmSheetSet.GetPromptForDwt Method
  • AcSmSubset.GetPromptForDwt Method
  • AcSmPublishOptions.GetPromptForName Method
  • AcSmPublishOptions.GetPromptForPassword Method
  • AcSmCustomPropertyBag.GetPropertyEnumerator Method
  • AcSmCustomPropertyBag.GetProperty Method
  • AcSmSheetSet.GetPublishOptions Method
  • AcSmObjectReference.GetReferenceFlags Method
  • AcSmObjectReference.GetReferencedObject Method
  • AcSmSheetSet.GetResources Method
  • AcSmSheet.GetRevisionDate Method
  • AcSmDSTFiler.GetRevisionNumber Method
  • AcSmSheet.GetRevisionNumber Method
  • AcSmSheetSet.GetSheetEnumerator Method
  • AcSmSubset.GetSheetEnumerator Method
  • AcSmSheetSet.GetSheetSelSets Method
  • AcSmDatabase.GetSheetSet Method
  • AcSmViewCategory.GetSheetViewEnumerator Method
  • AcSmSheet.GetSheetViews Method
  • AcSmDatabase.GetTemplateDstFileName Method
  • AcSmSheet.GetTitle Method
  • AcSmSheetView.GetTitle Method
  • AcSmAcDbBlockRecordReference.GetTypeName Method
  • AcSmAcDbLayoutReference.GetTypeName Method
  • AcSmAcDbObjectReference.GetTypeName Method
  • AcSmAcDbViewReference.GetTypeName Method
  • AcSmCalloutBlockReferences.GetTypeName Method
  • AcSmCalloutBlocks.GetTypeName Method
  • AcSmCustomPropertyBag.GetTypeName Method
  • AcSmCustomPropertyValue.GetTypeName Method
  • AcSmDatabase.GetTypeName Method
  • AcSmFileReference.GetTypeName Method
  • AcSmNamedAcDbObjectReference.GetTypeName Method
  • AcSmObjectReference.GetTypeName Method
  • AcSmPersistProxy.GetTypeName Method
  • AcSmPublishOptions.GetTypeName Method
  • AcSmResources.GetTypeName Method
  • AcSmSheet.GetTypeName Method
  • AcSmSheetSelSet.GetTypeName Method
  • AcSmSheetSelSets.GetTypeName Method
  • AcSmSheetSet.GetTypeName Method
  • AcSmSheetView.GetTypeName Method
  • AcSmSheetViews.GetTypeName Method
  • AcSmSubset.GetTypeName Method
  • AcSmViewCategories.GetTypeName Method
  • AcSmViewCategory.GetTypeName Method
  • IAcSmComponent.GetTypeName Method
  • IAcSmPersist.GetTypeName Method
  • AcSmPublishOptions.GetUnrecognizedData Method
  • AcSmPublishOptions.GetUnrecognizedSections Method
  • AcSmPublishOptions.GetUsePassword Method
  • AcSmCustomPropertyValue.GetValue Method
  • AcSmSheetSet.GetViewCategories Method


AcSmAcDbDatabase.GetAcDbDatabase Method

G Methods
G Methods
AcSmAcDbBlockRecordReference.GetAcDbHandle Method
AcSmAcDbDatabase.GetAcDbDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetAcDbDatabase() As Object


AcSmAcDbBlockRecordReference.GetAcDbHandle Method

AcSmAcDbDatabase.GetAcDbDatabase Method
G Methods
AcSmAcDbLayoutReference.GetAcDbHandle Method
AcSmAcDbBlockRecordReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmAcDbLayoutReference.GetAcDbHandle Method

AcSmAcDbBlockRecordReference.GetAcDbHandle Method
G Methods
AcSmAcDbObjectReference.GetAcDbHandle Method
AcSmAcDbLayoutReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmAcDbObjectReference.GetAcDbHandle Method

AcSmAcDbLayoutReference.GetAcDbHandle Method
G Methods
AcSmAcDbViewReference.GetAcDbHandle Method
AcSmAcDbObjectReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmAcDbViewReference.GetAcDbHandle Method

AcSmAcDbObjectReference.GetAcDbHandle Method
G Methods
AcSmNamedAcDbObjectReference.GetAcDbHandle Method
AcSmAcDbViewReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmNamedAcDbObjectReference.GetAcDbHandle Method

AcSmAcDbViewReference.GetAcDbHandle Method
G Methods
AcSmAcDbBlockRecordReference.GetAcSmAcDbDatabase Method
AcSmNamedAcDbObjectReference.GetAcDbHandle Method

Retrieves the AcDbHandle of the referenced AcDbObject. The name of the referenced object may not be the current name of the object.

Syntax

GetAcDbHandle() As String


AcSmAcDbBlockRecordReference.GetAcSmAcDbDatabase Method

AcSmNamedAcDbObjectReference.GetAcDbHandle Method
G Methods
AcSmAcDbLayoutReference.GetAcSmAcDbDatabase Method
AcSmAcDbBlockRecordReference.GetAcSmAcDbDatabase Method

Returns the open AcSmAcDbDatabase containing the referenced AcDbObject.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmAcDbLayoutReference.GetAcSmAcDbDatabase Method

AcSmAcDbBlockRecordReference.GetAcSmAcDbDatabase Method
G Methods
AcSmAcDbObjectReference.GetAcSmAcDbDatabase Method
AcSmAcDbLayoutReference.GetAcSmAcDbDatabase Method

Returns the open AcSmAcDbDatabase containing the referenced AcDbObject.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmAcDbObjectReference.GetAcSmAcDbDatabase Method

AcSmAcDbLayoutReference.GetAcSmAcDbDatabase Method
G Methods
AcSmAcDbViewReference.GetAcSmAcDbDatabase Method
AcSmAcDbObjectReference.GetAcSmAcDbDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmAcDbViewReference.GetAcSmAcDbDatabase Method

AcSmAcDbObjectReference.GetAcSmAcDbDatabase Method
G Methods
AcSmNamedAcDbObjectReference.GetAcSmAcDbDatabase Method
AcSmAcDbViewReference.GetAcSmAcDbDatabase Method

Returns the open AcSmAcDbDatabase containing the referenced AcDbObject.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmNamedAcDbObjectReference.GetAcSmAcDbDatabase Method

AcSmAcDbViewReference.GetAcSmAcDbDatabase Method
G Methods
AcSmSheetSet.GetAltPageSetups Method
AcSmNamedAcDbObjectReference.GetAcSmAcDbDatabase Method

Returns the open AcSmAcDbDatabase containing the referenced AcDbObject.

Syntax

GetAcSmAcDbDatabase() As AcSmAcDbDatabase


AcSmSheetSet.GetAltPageSetups Method

AcSmNamedAcDbObjectReference.GetAcSmAcDbDatabase Method
G Methods
AcSmSheetSet.GetCalloutBlocks Method
AcSmSheetSet.GetAltPageSetups Method

Retrieves the IAcSmFileReference component that references the template containing alternative page setups.

The caller must release the allocated memory when the operation is complete.

Syntax

GetAltPageSetups() As IAcSmFileReference


AcSmSheetSet.GetCalloutBlocks Method

AcSmSheetSet.GetAltPageSetups Method
G Methods
AcSmViewCategory.GetCalloutBlocks Method
AcSmSheetSet.GetCalloutBlocks Method

Returns a collection of callout block references that are associated with the sheet set.

The caller must release the interface when the operation is complete.

Syntax

GetCalloutBlocks() As IAcSmCalloutBlocks


AcSmViewCategory.GetCalloutBlocks Method

AcSmSheetSet.GetCalloutBlocks Method
G Methods
AcSmSheet.GetCategory Method
AcSmViewCategory.GetCalloutBlocks Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCalloutBlocks() As IAcSmCalloutBlocks


AcSmSheet.GetCategory Method

AcSmViewCategory.GetCalloutBlocks Method
G Methods
AcSmSheetView.GetCategory Method
AcSmSheet.GetCategory Method

Retrieves the CategoryCategory property. Returns S_OK if successful.

Syntax

GetCategory(
 pVal As BSTR*) As HRESULT
pVal Output pointer to a string containing the value of the CategoryCategory property


AcSmSheetView.GetCategory Method

AcSmSheet.GetCategory Method
G Methods
AcSmDSTFiler.GetCurrentObjectHeaderInfo Method
AcSmSheetView.GetCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCategory() As IAcSmViewCategory


AcSmDSTFiler.GetCurrentObjectHeaderInfo Method

AcSmSheetView.GetCategory Method
G Methods
AcSmDSTFiler.GetCurrentObject Method
AcSmDSTFiler.GetCurrentObjectHeaderInfo Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCurrentObjectHeaderInfo(
 names As String(),
 values As String()) As Object
names | Output pointer to a SAFEARRAY of strings containing the names of the header entries of the object
values | Output pointer to a SAFEARRAY of strings containing the values of the header entries of the object


AcSmDSTFiler.GetCurrentObject Method

AcSmDSTFiler.GetCurrentObjectHeaderInfo Method
G Methods
AcSmCalloutBlockReferences.GetCustomPropertyBag Method
AcSmDSTFiler.GetCurrentObject Method

This API was designed for internal use and has not been thoroughly tested.

The caller must release the IAcSmPersist object when the operation is completed.

Syntax

GetCurrentObject() As IAcSmPersist


AcSmCalloutBlockReferences.GetCustomPropertyBag Method

AcSmDSTFiler.GetCurrentObject Method
G Methods
AcSmCalloutBlocks.GetCustomPropertyBag Method
AcSmCalloutBlockReferences.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmCalloutBlocks.GetCustomPropertyBag Method

AcSmCalloutBlockReferences.GetCustomPropertyBag Method
G Methods
AcSmDatabase.GetCustomPropertyBag Method
AcSmCalloutBlocks.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmDatabase.GetCustomPropertyBag Method

AcSmCalloutBlocks.GetCustomPropertyBag Method
G Methods
AcSmResources.GetCustomPropertyBag Method
AcSmDatabase.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmResources.GetCustomPropertyBag Method

AcSmDatabase.GetCustomPropertyBag Method
G Methods
AcSmSheet.GetCustomPropertyBag Method
AcSmResources.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheet.GetCustomPropertyBag Method

AcSmResources.GetCustomPropertyBag Method
G Methods
AcSmSheetSelSet.GetCustomPropertyBag Method
AcSmSheet.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetSelSet.GetCustomPropertyBag Method

AcSmSheet.GetCustomPropertyBag Method
G Methods
AcSmSheetSelSets.GetCustomPropertyBag Method
AcSmSheetSelSet.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetSelSets.GetCustomPropertyBag Method

AcSmSheetSelSet.GetCustomPropertyBag Method
G Methods
AcSmSheetSet.GetCustomPropertyBag Method
AcSmSheetSelSets.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetSet.GetCustomPropertyBag Method

AcSmSheetSelSets.GetCustomPropertyBag Method
G Methods
AcSmSheetView.GetCustomPropertyBag Method
AcSmSheetSet.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetView.GetCustomPropertyBag Method

AcSmSheetSet.GetCustomPropertyBag Method
G Methods
AcSmSheetViews.GetCustomPropertyBag Method
AcSmSheetView.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetViews.GetCustomPropertyBag Method

AcSmSheetView.GetCustomPropertyBag Method
G Methods
AcSmSubset.GetCustomPropertyBag Method
AcSmSheetViews.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSubset.GetCustomPropertyBag Method

AcSmSheetViews.GetCustomPropertyBag Method
G Methods
AcSmViewCategories.GetCustomPropertyBag Method
AcSmSubset.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmViewCategories.GetCustomPropertyBag Method

AcSmSubset.GetCustomPropertyBag Method
G Methods
AcSmViewCategory.GetCustomPropertyBag Method
AcSmViewCategories.GetCustomPropertyBag Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmViewCategory.GetCustomPropertyBag Method

AcSmViewCategories.GetCustomPropertyBag Method
G Methods
IAcSmComponent.GetCustomPropertyBag Method
AcSmViewCategory.GetCustomPropertyBag Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


IAcSmComponent.GetCustomPropertyBag Method

AcSmViewCategory.GetCustomPropertyBag Method
G Methods
AcSmSheetSetMgr.GetDatabaseEnumerator Method
IAcSmComponent.GetCustomPropertyBag Method

Retrieves the custom property bag of the component.

The caller must release the IAcSmPropertyBag object when the operation is completed.

Syntax

GetCustomPropertyBag() As IAcSmCustomPropertyBag


AcSmSheetSetMgr.GetDatabaseEnumerator Method

IAcSmComponent.GetCustomPropertyBag Method
G Methods
AcSmAcDbBlockRecordReference.GetDatabase Method
AcSmSheetSetMgr.GetDatabaseEnumerator Method

Returns an enumerator of the currently open IAcSmDatabase components handled by the manager.

The caller must release the interface when the operation is complete.

Syntax

GetDatabaseEnumerator() As IAcSmEnumDatabase


AcSmAcDbBlockRecordReference.GetDatabase Method

AcSmSheetSetMgr.GetDatabaseEnumerator Method
G Methods
AcSmAcDbLayoutReference.GetDatabase Method
AcSmAcDbBlockRecordReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmAcDbLayoutReference.GetDatabase Method

AcSmAcDbBlockRecordReference.GetDatabase Method
G Methods
AcSmAcDbObjectReference.GetDatabase Method
AcSmAcDbLayoutReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmAcDbObjectReference.GetDatabase Method

AcSmAcDbLayoutReference.GetDatabase Method
G Methods
AcSmAcDbViewReference.GetDatabase Method
AcSmAcDbObjectReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmAcDbViewReference.GetDatabase Method

AcSmAcDbObjectReference.GetDatabase Method
G Methods
AcSmCalloutBlockReferences.GetDatabase Method
AcSmAcDbViewReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmCalloutBlockReferences.GetDatabase Method

AcSmAcDbViewReference.GetDatabase Method
G Methods
AcSmCalloutBlocks.GetDatabase Method
AcSmCalloutBlockReferences.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmCalloutBlocks.GetDatabase Method

AcSmCalloutBlockReferences.GetDatabase Method
G Methods
AcSmCustomPropertyBag.GetDatabase Method
AcSmCalloutBlocks.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmCustomPropertyBag.GetDatabase Method

AcSmCalloutBlocks.GetDatabase Method
G Methods
AcSmCustomPropertyValue.GetDatabase Method
AcSmCustomPropertyBag.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmCustomPropertyValue.GetDatabase Method

AcSmCustomPropertyBag.GetDatabase Method
G Methods
AcSmDSTFiler.GetDatabase Method
AcSmCustomPropertyValue.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmDSTFiler.GetDatabase Method

AcSmCustomPropertyValue.GetDatabase Method
G Methods
AcSmDatabase.GetDatabase Method
AcSmDSTFiler.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

The caller must release the IAcSmDatabase object when the operation is completed.

Syntax

GetDatabase() As IAcSmDatabase


AcSmDatabase.GetDatabase Method

AcSmDSTFiler.GetDatabase Method
G Methods
AcSmFileReference.GetDatabase Method
AcSmDatabase.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmFileReference.GetDatabase Method

AcSmDatabase.GetDatabase Method
G Methods
AcSmNamedAcDbObjectReference.GetDatabase Method
AcSmFileReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmNamedAcDbObjectReference.GetDatabase Method

AcSmFileReference.GetDatabase Method
G Methods
AcSmObjectReference.GetDatabase Method
AcSmNamedAcDbObjectReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmObjectReference.GetDatabase Method

AcSmNamedAcDbObjectReference.GetDatabase Method
G Methods
AcSmPersistProxy.GetDatabase Method
AcSmObjectReference.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmPersistProxy.GetDatabase Method

AcSmObjectReference.GetDatabase Method
G Methods
AcSmPublishOptions.GetDatabase Method
AcSmPersistProxy.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDatabase() As IAcSmDatabase


AcSmPublishOptions.GetDatabase Method

AcSmPersistProxy.GetDatabase Method
G Methods
AcSmResources.GetDatabase Method
AcSmPublishOptions.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDatabase() As IAcSmDatabase


AcSmResources.GetDatabase Method

AcSmPublishOptions.GetDatabase Method
G Methods
AcSmSheet.GetDatabase Method
AcSmResources.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheet.GetDatabase Method

AcSmResources.GetDatabase Method
G Methods
AcSmSheetSelSet.GetDatabase Method
AcSmSheet.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetSelSet.GetDatabase Method

AcSmSheet.GetDatabase Method
G Methods
AcSmSheetSelSets.GetDatabase Method
AcSmSheetSelSet.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetSelSets.GetDatabase Method

AcSmSheetSelSet.GetDatabase Method
G Methods
AcSmSheetSet.GetDatabase Method
AcSmSheetSelSets.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetSet.GetDatabase Method

AcSmSheetSelSets.GetDatabase Method
G Methods
AcSmSheetView.GetDatabase Method
AcSmSheetSet.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetView.GetDatabase Method

AcSmSheetSet.GetDatabase Method
G Methods
AcSmSheetViews.GetDatabase Method
AcSmSheetView.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSheetViews.GetDatabase Method

AcSmSheetView.GetDatabase Method
G Methods
AcSmSubset.GetDatabase Method
AcSmSheetViews.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmSubset.GetDatabase Method

AcSmSheetViews.GetDatabase Method
G Methods
AcSmViewCategories.GetDatabase Method
AcSmSubset.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


AcSmViewCategories.GetDatabase Method

AcSmSubset.GetDatabase Method
G Methods
AcSmViewCategory.GetDatabase Method
AcSmViewCategories.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDatabase() As IAcSmDatabase


AcSmViewCategory.GetDatabase Method

AcSmViewCategories.GetDatabase Method
G Methods
IAcSmComponent.GetDatabase Method
AcSmViewCategory.GetDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDatabase() As IAcSmDatabase


IAcSmComponent.GetDatabase Method

AcSmViewCategory.GetDatabase Method
G Methods
IAcSmObjectId.GetDatabase Method
IAcSmComponent.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDatabase() As IAcSmDatabase


IAcSmObjectId.GetDatabase Method

IAcSmComponent.GetDatabase Method
G Methods
IAcSmPersist.GetDatabase Method
IAcSmObjectId.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the interface when the operation is complete.

Syntax

GetDatabase() As IAcSmDatabase


IAcSmPersist.GetDatabase Method

IAcSmObjectId.GetDatabase Method
G Methods
AcSmDatabase.GetDbVersion Method
IAcSmPersist.GetDatabase Method

Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmDatabase object when the operation is completed.

Syntax

GetDatabase() As IAcSmDatabase


AcSmDatabase.GetDbVersion Method

IAcSmPersist.GetDatabase Method
G Methods
AcSmSheetSet.GetDefAltPageSetup Method
AcSmDatabase.GetDbVersion Method

Gets the version number of an AcSmDatabase.

Syntax

GetDbVersion() As String


AcSmSheetSet.GetDefAltPageSetup Method

AcSmDatabase.GetDbVersion Method
G Methods
AcSmSheetSet.GetDefDwtLayout Method
AcSmSheetSet.GetDefAltPageSetup Method

Retrieves the IAcSmNamedAcDbObjectReference component that references the default page setup within the template containing alternative page setups.

Syntax

GetDefAltPageSetup() As IAcSmNamedAcDbObjectReference


AcSmSheetSet.GetDefDwtLayout Method

AcSmSheetSet.GetDefAltPageSetup Method
G Methods
AcSmSubset.GetDefDwtLayout Method
AcSmSheetSet.GetDefDwtLayout Method

Returns the IAcSmNamedAcDbObjectReference that points to the AcDbLayout to be used as a template for new sheet creation.

Syntax

GetDefDwtLayout() As IAcSmNamedAcDbObjectReference


AcSmSubset.GetDefDwtLayout Method

AcSmSheetSet.GetDefDwtLayout Method
G Methods
AcSmSheetSet.GetDefLabelBlk Method
AcSmSubset.GetDefDwtLayout Method

Returns the IAcSmNamedAcDbObjectReference that points to the layout used as a template for new sheets.

The caller must release the interface when operations are complete.

Syntax

GetDefDwtLayout() As IAcSmNamedAcDbObjectReference


AcSmSheetSet.GetDefLabelBlk Method

AcSmSubset.GetDefDwtLayout Method
G Methods
AcSmPublishOptions.GetDefaultOutputdir Method
AcSmSheetSet.GetDefLabelBlk Method

Returns the IAcSmNamedAcDbObjectReference component that references the label block definition for the sheet set.

The caller must release the interface when the operation is complete.

Syntax

GetDefLabelBlk() As IAcSmNamedAcDbObjectReference


AcSmPublishOptions.GetDefaultOutputdir Method

AcSmSheetSet.GetDefLabelBlk Method
G Methods
AcSmViewCategories.GetDefaultViewCategory Method
AcSmPublishOptions.GetDefaultOutputdir Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDefaultOutputdir() As String


AcSmViewCategories.GetDefaultViewCategory Method

AcSmPublishOptions.GetDefaultOutputdir Method
G Methods
AcSmCalloutBlockReferences.GetDesc Method
AcSmViewCategories.GetDefaultViewCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDefaultViewCategory() As IAcSmViewCategory


AcSmCalloutBlockReferences.GetDesc Method

AcSmViewCategories.GetDefaultViewCategory Method
G Methods
AcSmCalloutBlocks.GetDesc Method
AcSmCalloutBlockReferences.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmCalloutBlocks.GetDesc Method

AcSmCalloutBlockReferences.GetDesc Method
G Methods
AcSmDatabase.GetDesc Method
AcSmCalloutBlocks.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmDatabase.GetDesc Method

AcSmCalloutBlocks.GetDesc Method
G Methods
AcSmResources.GetDesc Method
AcSmDatabase.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmResources.GetDesc Method

AcSmDatabase.GetDesc Method
G Methods
AcSmSheet.GetDesc Method
AcSmResources.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheet.GetDesc Method

AcSmResources.GetDesc Method
G Methods
AcSmSheetSelSet.GetDesc Method
AcSmSheet.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetSelSet.GetDesc Method

AcSmSheet.GetDesc Method
G Methods
AcSmSheetSelSets.GetDesc Method
AcSmSheetSelSet.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetSelSets.GetDesc Method

AcSmSheetSelSet.GetDesc Method
G Methods
AcSmSheetSet.GetDesc Method
AcSmSheetSelSets.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetSet.GetDesc Method

AcSmSheetSelSets.GetDesc Method
G Methods
AcSmSheetView.GetDesc Method
AcSmSheetSet.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetView.GetDesc Method

AcSmSheetSet.GetDesc Method
G Methods
AcSmSheetViews.GetDesc Method
AcSmSheetView.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSheetViews.GetDesc Method

AcSmSheetView.GetDesc Method
G Methods
AcSmSubset.GetDesc Method
AcSmSheetViews.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmSubset.GetDesc Method

AcSmSheetViews.GetDesc Method
G Methods
AcSmViewCategories.GetDesc Method
AcSmSubset.GetDesc Method

Retrieves the description of the component.

Syntax

GetDesc() As String


AcSmViewCategories.GetDesc Method

AcSmSubset.GetDesc Method
G Methods
AcSmViewCategory.GetDesc Method
AcSmViewCategories.GetDesc Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDesc() As String


AcSmViewCategory.GetDesc Method

AcSmViewCategories.GetDesc Method
G Methods
IAcSmComponent.GetDesc Method
AcSmViewCategory.GetDesc Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDesc() As String


IAcSmComponent.GetDesc Method

AcSmViewCategory.GetDesc Method
G Methods
AcSmAcDbBlockRecordReference.GetDirectlyOwnedObjects Method
IAcSmComponent.GetDesc Method

Retrieves the description of the component.

The caller must release the allocated memory when the operation is complete.

Syntax

GetDesc() As String


AcSmAcDbBlockRecordReference.GetDirectlyOwnedObjects Method

IAcSmComponent.GetDesc Method
G Methods
AcSmAcDbLayoutReference.GetDirectlyOwnedObjects Method
AcSmAcDbBlockRecordReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmAcDbLayoutReference.GetDirectlyOwnedObjects Method

AcSmAcDbBlockRecordReference.GetDirectlyOwnedObjects Method
G Methods
AcSmAcDbObjectReference.GetDirectlyOwnedObjects Method
AcSmAcDbLayoutReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object) As Object
objects Output SAFEARRAY of the IUnknownIUnknown pointers of the directly owned objects


AcSmAcDbObjectReference.GetDirectlyOwnedObjects Method

AcSmAcDbLayoutReference.GetDirectlyOwnedObjects Method
G Methods
AcSmAcDbViewReference.GetDirectlyOwnedObjects Method
AcSmAcDbObjectReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknownIUnknown pointers of the directly owned objects


AcSmAcDbViewReference.GetDirectlyOwnedObjects Method

AcSmAcDbObjectReference.GetDirectlyOwnedObjects Method
G Methods
AcSmCalloutBlockReferences.GetDirectlyOwnedObjects Method
AcSmAcDbViewReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmCalloutBlockReferences.GetDirectlyOwnedObjects Method

AcSmAcDbViewReference.GetDirectlyOwnedObjects Method
G Methods
AcSmCalloutBlocks.GetDirectlyOwnedObjects Method
AcSmCalloutBlockReferences.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknownIUnknown pointers of the directly owned objects


AcSmCalloutBlocks.GetDirectlyOwnedObjects Method

AcSmCalloutBlockReferences.GetDirectlyOwnedObjects Method
G Methods
AcSmCustomPropertyBag.GetDirectlyOwnedObjects Method
AcSmCalloutBlocks.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknownIUnknown pointers of the directly owned objects


AcSmCustomPropertyBag.GetDirectlyOwnedObjects Method

AcSmCalloutBlocks.GetDirectlyOwnedObjects Method
G Methods
AcSmCustomPropertyValue.GetDirectlyOwnedObjects Method
AcSmCustomPropertyBag.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmCustomPropertyValue.GetDirectlyOwnedObjects Method

AcSmCustomPropertyBag.GetDirectlyOwnedObjects Method
G Methods
AcSmDatabase.GetDirectlyOwnedObjects Method
AcSmCustomPropertyValue.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmDatabase.GetDirectlyOwnedObjects Method

AcSmCustomPropertyValue.GetDirectlyOwnedObjects Method
G Methods
AcSmFileReference.GetDirectlyOwnedObjects Method
AcSmDatabase.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmFileReference.GetDirectlyOwnedObjects Method

AcSmDatabase.GetDirectlyOwnedObjects Method
G Methods
AcSmNamedAcDbObjectReference.GetDirectlyOwnedObjects Method
AcSmFileReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmNamedAcDbObjectReference.GetDirectlyOwnedObjects Method

AcSmFileReference.GetDirectlyOwnedObjects Method
G Methods
AcSmObjectReference.GetDirectlyOwnedObjects Method
AcSmNamedAcDbObjectReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmObjectReference.GetDirectlyOwnedObjects Method

AcSmNamedAcDbObjectReference.GetDirectlyOwnedObjects Method
G Methods
AcSmPersistProxy.GetDirectlyOwnedObjects Method
AcSmObjectReference.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmPersistProxy.GetDirectlyOwnedObjects Method

AcSmObjectReference.GetDirectlyOwnedObjects Method
G Methods
AcSmPublishOptions.GetDirectlyOwnedObjects Method
AcSmPersistProxy.GetDirectlyOwnedObjects Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmPublishOptions.GetDirectlyOwnedObjects Method

AcSmPersistProxy.GetDirectlyOwnedObjects Method
G Methods
AcSmResources.GetDirectlyOwnedObjects Method
AcSmPublishOptions.GetDirectlyOwnedObjects Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDirectlyOwnedObjects(
 objects As Unknown) As Object
objects Output array of directly owned objects


AcSmResources.GetDirectlyOwnedObjects Method

AcSmPublishOptions.GetDirectlyOwnedObjects Method
G Methods
AcSmSheet.GetDirectlyOwnedObjects Method
AcSmResources.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheet.GetDirectlyOwnedObjects Method

AcSmResources.GetDirectlyOwnedObjects Method
G Methods
AcSmSheetSelSet.GetDirectlyOwnedObjects Method
AcSmSheet.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetSelSet.GetDirectlyOwnedObjects Method

AcSmSheet.GetDirectlyOwnedObjects Method
G Methods
AcSmSheetSelSets.GetDirectlyOwnedObjects Method
AcSmSheetSelSet.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetSelSets.GetDirectlyOwnedObjects Method

AcSmSheetSelSet.GetDirectlyOwnedObjects Method
G Methods
AcSmSheetSet.GetDirectlyOwnedObjects Method
AcSmSheetSelSets.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetSet.GetDirectlyOwnedObjects Method

AcSmSheetSelSets.GetDirectlyOwnedObjects Method
G Methods
AcSmSheetView.GetDirectlyOwnedObjects Method
AcSmSheetSet.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OKS_OK. If the parent database cannot be found, S_FALSES_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetView.GetDirectlyOwnedObjects Method

AcSmSheetSet.GetDirectlyOwnedObjects Method
G Methods
AcSmSheetViews.GetDirectlyOwnedObjects Method
AcSmSheetView.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheetViews.GetDirectlyOwnedObjects Method

AcSmSheetView.GetDirectlyOwnedObjects Method
G Methods
AcSmSubset.GetDirectlyOwnedObjects Method
AcSmSheetViews.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSubset.GetDirectlyOwnedObjects Method

AcSmSheetViews.GetDirectlyOwnedObjects Method
G Methods
AcSmViewCategories.GetDirectlyOwnedObjects Method
AcSmSubset.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmViewCategories.GetDirectlyOwnedObjects Method

AcSmSubset.GetDirectlyOwnedObjects Method
G Methods
AcSmViewCategory.GetDirectlyOwnedObjects Method
AcSmViewCategories.GetDirectlyOwnedObjects Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmViewCategory.GetDirectlyOwnedObjects Method

AcSmViewCategories.GetDirectlyOwnedObjects Method
G Methods
IAcSmComponent.GetDirectlyOwnedObjects Method
AcSmViewCategory.GetDirectlyOwnedObjects Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


IAcSmComponent.GetDirectlyOwnedObjects Method

AcSmViewCategory.GetDirectlyOwnedObjects Method
G Methods
IAcSmPersist.GetDirectlyOwnedObjects Method
IAcSmComponent.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


IAcSmPersist.GetDirectlyOwnedObjects Method

IAcSmComponent.GetDirectlyOwnedObjects Method
G Methods
AcSmSheet.GetDoNotPlot Method
IAcSmPersist.GetDirectlyOwnedObjects Method

Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetDirectlyOwnedObjects(
 objects As Object()) As Object
objects Output SAFEARRAY of the IUnknown pointers of the directly owned objects


AcSmSheet.GetDoNotPlot Method

IAcSmPersist.GetDirectlyOwnedObjects Method
G Methods
AcSmPublishOptions.GetDwfType Method
AcSmSheet.GetDoNotPlot Method

Retreives a flag indicating whether a sheet should be skipped during plotting and publishing.

Syntax

GetDoNotPlot() As Boolean


AcSmPublishOptions.GetDwfType Method

AcSmSheet.GetDoNotPlot Method
G Methods
AcSmCalloutBlockReferences.GetEnumerator Method
AcSmPublishOptions.GetDwfType Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetDwfType() As Boolean


AcSmCalloutBlockReferences.GetEnumerator Method

AcSmPublishOptions.GetDwfType Method
G Methods
AcSmCalloutBlocks.GetEnumerator Method
AcSmCalloutBlockReferences.GetEnumerator Method

Returns an enumerator of the contained IAcSmNamedAcDbObjectReference components in the collection.

Syntax

GetEnumerator() As IAcSmEnumNamedAcDbObjectReference


AcSmCalloutBlocks.GetEnumerator Method

AcSmCalloutBlockReferences.GetEnumerator Method
G Methods
AcSmDatabase.GetEnumerator Method
AcSmCalloutBlocks.GetEnumerator Method

Returns an enumerator of the contained IAcSmNamedAcDbObjectReference components in the collection.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumNamedAcDbObjectReference


AcSmDatabase.GetEnumerator Method

AcSmCalloutBlocks.GetEnumerator Method
G Methods
AcSmResources.GetEnumerator Method
AcSmDatabase.GetEnumerator Method

Returns an enumerator of all objects in the database.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumPersist


AcSmResources.GetEnumerator Method

AcSmDatabase.GetEnumerator Method
G Methods
AcSmSheetSelSet.GetEnumerator Method
AcSmResources.GetEnumerator Method

Returns an enumerator of the contained IAcSmFileReference components in the collection.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumFileReference


AcSmSheetSelSet.GetEnumerator Method

AcSmResources.GetEnumerator Method
G Methods
AcSmSheetSelSets.GetEnumerator Method
AcSmSheetSelSet.GetEnumerator Method

Returns an enumerator of the components in the selection set.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumComponent


AcSmSheetSelSets.GetEnumerator Method

AcSmSheetSelSet.GetEnumerator Method
G Methods
AcSmSheetViews.GetEnumerator Method
AcSmSheetSelSets.GetEnumerator Method

Returns an enumerator of the selection sets in the collection.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumSheetSelSet


AcSmSheetViews.GetEnumerator Method

AcSmSheetSelSets.GetEnumerator Method
G Methods
AcSmViewCategories.GetEnumerator Method
AcSmSheetViews.GetEnumerator Method

Returns an enumerator of the contained sheet views in the collection.

The caller must release the interface when the operation is complete.

Syntax

GetEnumerator() As IAcSmEnumSheetView


AcSmViewCategories.GetEnumerator Method

AcSmSheetViews.GetEnumerator Method
G Methods
AcSmAcDbBlockRecordReference.GetFileName Method
AcSmViewCategories.GetEnumerator Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetEnumerator() As IAcSmEnumViewCategory


AcSmAcDbBlockRecordReference.GetFileName Method

AcSmViewCategories.GetEnumerator Method
G Methods
AcSmAcDbLayoutReference.GetFileName Method
AcSmAcDbBlockRecordReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmAcDbLayoutReference.GetFileName Method

AcSmAcDbBlockRecordReference.GetFileName Method
G Methods
AcSmAcDbObjectReference.GetFileName Method
AcSmAcDbLayoutReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmAcDbObjectReference.GetFileName Method

AcSmAcDbLayoutReference.GetFileName Method
G Methods
AcSmAcDbViewReference.GetFileName Method
AcSmAcDbObjectReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmAcDbViewReference.GetFileName Method

AcSmAcDbObjectReference.GetFileName Method
G Methods
AcSmDatabase.GetFileName Method
AcSmAcDbViewReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmDatabase.GetFileName Method

AcSmAcDbViewReference.GetFileName Method
G Methods
AcSmFileReference.GetFileName Method
AcSmDatabase.GetFileName Method

Retrieves the file name of the database.

Syntax

GetFileName() As String


AcSmFileReference.GetFileName Method

AcSmDatabase.GetFileName Method
G Methods
AcSmNamedAcDbObjectReference.GetFileName Method
AcSmFileReference.GetFileName Method

Retrieves the file name that this object references.

Syntax

GetFileName() As String


AcSmNamedAcDbObjectReference.GetFileName Method

AcSmFileReference.GetFileName Method
G Methods
AcSmCustomPropertyValue.GetFlags Method
AcSmNamedAcDbObjectReference.GetFileName Method

Retrieves the file name property of this file reference.

Syntax

GetFileName() As String


AcSmCustomPropertyValue.GetFlags Method

AcSmNamedAcDbObjectReference.GetFileName Method
G Methods
IAcSmObjectId.GetHandle Method
AcSmCustomPropertyValue.GetFlags Method

Retrieves a combination of PropertyFlags enum values associated with the custom property.

Syntax

GetFlags() As __MIDL___MIDL_itf_AcSmComponents_0264_0001


IAcSmObjectId.GetHandle Method

AcSmCustomPropertyValue.GetFlags Method
G Methods
AcSmAcDbDatabase.GetIAcadDatabase Method
IAcSmObjectId.GetHandle Method

Retrieves the persisted, unique handle.

Syntax

GetHandle() As String


AcSmAcDbDatabase.GetIAcadDatabase Method

IAcSmObjectId.GetHandle Method
G Methods
AcSmPublishOptions.GetIncludePlotStamp Method
AcSmAcDbDatabase.GetIAcadDatabase Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIAcadDatabase() As AcadDatabase


AcSmPublishOptions.GetIncludePlotStamp Method

AcSmAcDbDatabase.GetIAcadDatabase Method
G Methods
AcSmAcDbBlockRecordReference.GetIsDirty Method
AcSmPublishOptions.GetIncludePlotStamp Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIncludePlotStamp() As Boolean


AcSmAcDbBlockRecordReference.GetIsDirty Method

AcSmPublishOptions.GetIncludePlotStamp Method
G Methods
AcSmAcDbLayoutReference.GetIsDirty Method
AcSmAcDbBlockRecordReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmAcDbLayoutReference.GetIsDirty Method

AcSmAcDbBlockRecordReference.GetIsDirty Method
G Methods
AcSmAcDbObjectReference.GetIsDirty Method
AcSmAcDbLayoutReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmAcDbObjectReference.GetIsDirty Method

AcSmAcDbLayoutReference.GetIsDirty Method
G Methods
AcSmAcDbViewReference.GetIsDirty Method
AcSmAcDbObjectReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmAcDbViewReference.GetIsDirty Method

AcSmAcDbObjectReference.GetIsDirty Method
G Methods
AcSmCalloutBlockReferences.GetIsDirty Method
AcSmAcDbViewReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabaseAcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmCalloutBlockReferences.GetIsDirty Method

AcSmAcDbViewReference.GetIsDirty Method
G Methods
AcSmCalloutBlocks.GetIsDirty Method
AcSmCalloutBlockReferences.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmCalloutBlocks.GetIsDirty Method

AcSmCalloutBlockReferences.GetIsDirty Method
G Methods
AcSmCustomPropertyBag.GetIsDirty Method
AcSmCalloutBlocks.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmCustomPropertyBag.GetIsDirty Method

AcSmCalloutBlocks.GetIsDirty Method
G Methods
AcSmCustomPropertyValue.GetIsDirty Method
AcSmCustomPropertyBag.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmCustomPropertyValue.GetIsDirty Method

AcSmCustomPropertyBag.GetIsDirty Method
G Methods
AcSmDatabase.GetIsDirty Method
AcSmCustomPropertyValue.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmDatabase.GetIsDirty Method

AcSmCustomPropertyValue.GetIsDirty Method
G Methods
AcSmFileReference.GetIsDirty Method
AcSmDatabase.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabaseAcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmFileReference.GetIsDirty Method

AcSmDatabase.GetIsDirty Method
G Methods
AcSmNamedAcDbObjectReference.GetIsDirty Method
AcSmFileReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmNamedAcDbObjectReference.GetIsDirty Method

AcSmFileReference.GetIsDirty Method
G Methods
AcSmObjectReference.GetIsDirty Method
AcSmNamedAcDbObjectReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmObjectReference.GetIsDirty Method

AcSmNamedAcDbObjectReference.GetIsDirty Method
G Methods
AcSmPersistProxy.GetIsDirty Method
AcSmObjectReference.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmPersistProxy.GetIsDirty Method

AcSmObjectReference.GetIsDirty Method
G Methods
AcSmPublishOptions.GetIsDirty Method
AcSmPersistProxy.GetIsDirty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIsDirty() As Boolean


AcSmPublishOptions.GetIsDirty Method

AcSmPersistProxy.GetIsDirty Method
G Methods
AcSmResources.GetIsDirty Method
AcSmPublishOptions.GetIsDirty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIsDirty() As Boolean


AcSmResources.GetIsDirty Method

AcSmPublishOptions.GetIsDirty Method
G Methods
AcSmSheet.GetIsDirty Method
AcSmResources.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheet.GetIsDirty Method

AcSmResources.GetIsDirty Method
G Methods
AcSmSheetSelSet.GetIsDirty Method
AcSmSheet.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetSelSet.GetIsDirty Method

AcSmSheet.GetIsDirty Method
G Methods
AcSmSheetSelSets.GetIsDirty Method
AcSmSheetSelSet.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetSelSets.GetIsDirty Method

AcSmSheetSelSet.GetIsDirty Method
G Methods
AcSmSheetSet.GetIsDirty Method
AcSmSheetSelSets.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetSet.GetIsDirty Method

AcSmSheetSelSets.GetIsDirty Method
G Methods
AcSmSheetView.GetIsDirty Method
AcSmSheetSet.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetView.GetIsDirty Method

AcSmSheetSet.GetIsDirty Method
G Methods
AcSmSheetViews.GetIsDirty Method
AcSmSheetView.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSheetViews.GetIsDirty Method

AcSmSheetView.GetIsDirty Method
G Methods
AcSmSubset.GetIsDirty Method
AcSmSheetViews.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmSubset.GetIsDirty Method

AcSmSheetViews.GetIsDirty Method
G Methods
AcSmViewCategories.GetIsDirty Method
AcSmSubset.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmViewCategories.GetIsDirty Method

AcSmSubset.GetIsDirty Method
G Methods
AcSmViewCategory.GetIsDirty Method
AcSmViewCategories.GetIsDirty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIsDirty() As Boolean


AcSmViewCategory.GetIsDirty Method

AcSmViewCategories.GetIsDirty Method
G Methods
IAcSmComponent.GetIsDirty Method
AcSmViewCategory.GetIsDirty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetIsDirty() As Boolean


IAcSmComponent.GetIsDirty Method

AcSmViewCategory.GetIsDirty Method
G Methods
IAcSmPersist.GetIsDirty Method
IAcSmComponent.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


IAcSmPersist.GetIsDirty Method

IAcSmComponent.GetIsDirty Method
G Methods
AcSmDatabase.GetIsTemporary Method
IAcSmPersist.GetIsDirty Method

If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.

Syntax

GetIsDirty() As Boolean


AcSmDatabase.GetIsTemporary Method

IAcSmPersist.GetIsDirty Method
G Methods
AcSmSheet.GetIssuePurpose Method
AcSmDatabase.GetIsTemporary Method

Retrieves a flag indicating a non-persisted database.

Syntax

GetIsTemporary() As Boolean


AcSmSheet.GetIssuePurpose Method

AcSmDatabase.GetIsTemporary Method
G Methods
AcSmPublishOptions.GetLayerInfo Method
AcSmSheet.GetIssuePurpose Method

Retrieves the IssuePurpose property. Returns S_OK if successful.

Syntax

GetIssuePurpose(
 pVal As BSTR*) As HRESULT
pVal Output pointer to a string containing the value of the IssuePurpose property


AcSmPublishOptions.GetLayerInfo Method

AcSmSheet.GetIssuePurpose Method
G Methods
AcSmSheet.GetLayout Method
AcSmPublishOptions.GetLayerInfo Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetLayerInfo() As Boolean


AcSmSheet.GetLayout Method

AcSmPublishOptions.GetLayerInfo Method
G Methods
AcSmDatabase.GetLockOwnerInfo Method
AcSmSheet.GetLayout Method

Returns the IAcSmNamedAcDbObjectReference object, which references the drawing and layout associated with the sheet component.

The caller must release the interface when the operation is completed.

Syntax

GetLayout() As IAcSmNamedAcDbObjectReference


AcSmDatabase.GetLockOwnerInfo Method

AcSmSheet.GetLayout Method
G Methods
AcSmDatabase.GetLockStatus Method
AcSmDatabase.GetLockOwnerInfo Method

Returns the user name and machine name of the lock owner.

Syntax

GetLockOwnerInfo(
 pstrUserName As String,
 pstrMachineName As String) As Object
pstrUserName | Output user name of the user who locked the database
pstrMachineName | Output machine name of the user who locked the database


AcSmDatabase.GetLockStatus Method

AcSmDatabase.GetLockOwnerInfo Method
G Methods
AcSmAcDbBlockRecordReference.GetName Method
AcSmDatabase.GetLockStatus Method

Retrieves the lock status of the database.

Syntax

GetLockStatus() As AcSmLockStatus


AcSmAcDbBlockRecordReference.GetName Method

AcSmDatabase.GetLockStatus Method
G Methods
AcSmAcDbLayoutReference.GetName Method
AcSmAcDbBlockRecordReference.GetName Method

Retrieves the name of the referenced object. The name of the referenced object might not be the current name of the object.

Syntax

GetName() As String


AcSmAcDbLayoutReference.GetName Method

AcSmAcDbBlockRecordReference.GetName Method
G Methods
AcSmAcDbViewReference.GetName Method
AcSmAcDbLayoutReference.GetName Method

Retrieves the name of the referenced object. The name of the referenced object might not be the current name of the object.

Syntax

GetName() As String


AcSmAcDbViewReference.GetName Method

AcSmAcDbLayoutReference.GetName Method
G Methods
AcSmCalloutBlockReferences.GetName Method
AcSmAcDbViewReference.GetName Method

Retrieves the name of the referenced object. The name of the referenced object might not be the current name of the object.

Syntax

GetName() As String


AcSmCalloutBlockReferences.GetName Method

AcSmAcDbViewReference.GetName Method
G Methods
AcSmCalloutBlocks.GetName Method
AcSmCalloutBlockReferences.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmCalloutBlocks.GetName Method

AcSmCalloutBlockReferences.GetName Method
G Methods
AcSmDatabase.GetName Method
AcSmCalloutBlocks.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmDatabase.GetName Method

AcSmCalloutBlocks.GetName Method
G Methods
AcSmNamedAcDbObjectReference.GetName Method
AcSmDatabase.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmNamedAcDbObjectReference.GetName Method

AcSmDatabase.GetName Method
G Methods
AcSmResources.GetName Method
AcSmNamedAcDbObjectReference.GetName Method

Retrieves the name of the referenced object. The name of the referenced object might not be the current name of the object.

Syntax

GetName() As String


AcSmResources.GetName Method

AcSmNamedAcDbObjectReference.GetName Method
G Methods
AcSmSheet.GetName Method
AcSmResources.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheet.GetName Method

AcSmResources.GetName Method
G Methods
AcSmSheetSelSet.GetName Method
AcSmSheet.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetSelSet.GetName Method

AcSmSheet.GetName Method
G Methods
AcSmSheetSelSets.GetName Method
AcSmSheetSelSet.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetSelSets.GetName Method

AcSmSheetSelSet.GetName Method
G Methods
AcSmSheetSet.GetName Method
AcSmSheetSelSets.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetSet.GetName Method

AcSmSheetSelSets.GetName Method
G Methods
AcSmSheetView.GetName Method
AcSmSheetSet.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetView.GetName Method

AcSmSheetSet.GetName Method
G Methods
AcSmSheetViews.GetName Method
AcSmSheetView.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmSheetViews.GetName Method

AcSmSheetView.GetName Method
G Methods
AcSmSubset.GetName Method
AcSmSheetViews.GetName Method

Retrieves the NameName property of the component.

Syntax

GetName() As String


AcSmSubset.GetName Method

AcSmSheetViews.GetName Method
G Methods
AcSmViewCategories.GetName Method
AcSmSubset.GetName Method

Retrieves the Name property of the component.

Syntax

GetName() As String


AcSmViewCategories.GetName Method

AcSmSubset.GetName Method
G Methods
AcSmViewCategory.GetName Method
AcSmViewCategories.GetName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetName() As String


AcSmViewCategory.GetName Method

AcSmViewCategories.GetName Method
G Methods
IAcSmComponent.GetName Method
AcSmViewCategory.GetName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetName() As String


IAcSmComponent.GetName Method

AcSmViewCategory.GetName Method
G Methods
AcSmSheetView.GetNamedView Method
IAcSmComponent.GetName Method

Retrieves the Name property of the component.

The caller must release the allocated memory when the operation is complete.

Syntax

GetName() As String


AcSmSheetView.GetNamedView Method

IAcSmComponent.GetName Method
G Methods
AcSmDatabase.GetNewObjectId Method
AcSmSheetView.GetNamedView Method

Returns an IAcSmNamedAcDbObjectReference that points to the named AcDbView object on the sheet referenced by the sheet view component.

The caller must release the returned interface when the operation is complete.

Syntax

GetNamedView() As IAcSmNamedAcDbObjectReference


AcSmDatabase.GetNewObjectId Method

AcSmSheetView.GetNamedView Method
G Methods
AcSmSheetSet.GetNewSheetLocation Method
AcSmDatabase.GetNewObjectId Method

Retrieves the IAcSmObjectId for a handle or generates a new ID.

The caller must release the interface when the operation is complete.

Syntax

GetNewObjectId(
 hand As String,
 idcookie As Long) As IAcSmObjectId
hand | Input object handle, or null if a new ID is requested
idcookie | Output returned cookie from the database to use as a security key for changing ownership and for other access to the object ID properties


AcSmSheetSet.GetNewSheetLocation Method

AcSmDatabase.GetNewObjectId Method
G Methods
AcSmSubset.GetNewSheetLocation Method
AcSmSheetSet.GetNewSheetLocation Method

Returns the IAcSmFileReference that points to the file system location where new sheets will be created.

Syntax

GetNewSheetLocation() As IAcSmFileReference


AcSmSubset.GetNewSheetLocation Method

AcSmSheetSet.GetNewSheetLocation Method
G Methods
AcSmSheet.GetNumber Method
AcSmSubset.GetNewSheetLocation Method

Returns the IAcSmFileReference that points to the location in the file system where new sheets are created.

The caller must release the interface when operations are complete.

Syntax

GetNewSheetLocation() As IAcSmFileReference


AcSmSheet.GetNumber Method

AcSmSubset.GetNewSheetLocation Method
G Methods
AcSmSheetView.GetNumber Method
AcSmSheet.GetNumber Method

Retrieves the Number property of the sheet.

Syntax

GetNumber() As String


AcSmSheetView.GetNumber Method

AcSmSheet.GetNumber Method
G Methods
AcSmAcDbBlockRecordReference.GetObjectId Method
AcSmSheetView.GetNumber Method

Retrieves the Number property of the sheet view.

Syntax

GetNumber() As String


AcSmAcDbBlockRecordReference.GetObjectId Method

AcSmSheetView.GetNumber Method
G Methods
AcSmAcDbLayoutReference.GetObjectId Method
AcSmAcDbBlockRecordReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmAcDbLayoutReference.GetObjectId Method

AcSmAcDbBlockRecordReference.GetObjectId Method
G Methods
AcSmAcDbObjectReference.GetObjectId Method
AcSmAcDbLayoutReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmAcDbObjectReference.GetObjectId Method

AcSmAcDbLayoutReference.GetObjectId Method
G Methods
AcSmAcDbViewReference.GetObjectId Method
AcSmAcDbObjectReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmAcDbViewReference.GetObjectId Method

AcSmAcDbObjectReference.GetObjectId Method
G Methods
AcSmCalloutBlockReferences.GetObjectId Method
AcSmAcDbViewReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmCalloutBlockReferences.GetObjectId Method

AcSmAcDbViewReference.GetObjectId Method
G Methods
AcSmCalloutBlocks.GetObjectId Method
AcSmCalloutBlockReferences.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmCalloutBlocks.GetObjectId Method

AcSmCalloutBlockReferences.GetObjectId Method
G Methods
AcSmCustomPropertyBag.GetObjectId Method
AcSmCalloutBlocks.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmCustomPropertyBag.GetObjectId Method

AcSmCalloutBlocks.GetObjectId Method
G Methods
AcSmCustomPropertyValue.GetObjectId Method
AcSmCustomPropertyBag.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmCustomPropertyValue.GetObjectId Method

AcSmCustomPropertyBag.GetObjectId Method
G Methods
AcSmDatabase.GetObjectId Method
AcSmCustomPropertyValue.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmDatabase.GetObjectId Method

AcSmCustomPropertyValue.GetObjectId Method
G Methods
AcSmFileReference.GetObjectId Method
AcSmDatabase.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmFileReference.GetObjectId Method

AcSmDatabase.GetObjectId Method
G Methods
AcSmNamedAcDbObjectReference.GetObjectId Method
AcSmFileReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmNamedAcDbObjectReference.GetObjectId Method

AcSmFileReference.GetObjectId Method
G Methods
AcSmObjectReference.GetObjectId Method
AcSmNamedAcDbObjectReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmObjectReference.GetObjectId Method

AcSmNamedAcDbObjectReference.GetObjectId Method
G Methods
AcSmPersistProxy.GetObjectId Method
AcSmObjectReference.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmPersistProxy.GetObjectId Method

AcSmObjectReference.GetObjectId Method
G Methods
AcSmPublishOptions.GetObjectId Method
AcSmPersistProxy.GetObjectId Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetObjectId() As IAcSmObjectId


AcSmPublishOptions.GetObjectId Method

AcSmPersistProxy.GetObjectId Method
G Methods
AcSmResources.GetObjectId Method
AcSmPublishOptions.GetObjectId Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetObjectId() As IAcSmObjectId


AcSmResources.GetObjectId Method

AcSmPublishOptions.GetObjectId Method
G Methods
AcSmSheet.GetObjectId Method
AcSmResources.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheet.GetObjectId Method

AcSmResources.GetObjectId Method
G Methods
AcSmSheetSelSet.GetObjectId Method
AcSmSheet.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetSelSet.GetObjectId Method

AcSmSheet.GetObjectId Method
G Methods
AcSmSheetSelSets.GetObjectId Method
AcSmSheetSelSet.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetSelSets.GetObjectId Method

AcSmSheetSelSet.GetObjectId Method
G Methods
AcSmSheetSet.GetObjectId Method
AcSmSheetSelSets.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetSet.GetObjectId Method

AcSmSheetSelSets.GetObjectId Method
G Methods
AcSmSheetView.GetObjectId Method
AcSmSheetSet.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectIdIAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetView.GetObjectId Method

AcSmSheetSet.GetObjectId Method
G Methods
AcSmSheetViews.GetObjectId Method
AcSmSheetView.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSheetViews.GetObjectId Method

AcSmSheetView.GetObjectId Method
G Methods
AcSmSubset.GetObjectId Method
AcSmSheetViews.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmSubset.GetObjectId Method

AcSmSheetViews.GetObjectId Method
G Methods
AcSmViewCategories.GetObjectId Method
AcSmSubset.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmViewCategories.GetObjectId Method

AcSmSubset.GetObjectId Method
G Methods
AcSmViewCategory.GetObjectId Method
AcSmViewCategories.GetObjectId Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetObjectId() As IAcSmObjectId


AcSmViewCategory.GetObjectId Method

AcSmViewCategories.GetObjectId Method
G Methods
IAcSmComponent.GetObjectId Method
AcSmViewCategory.GetObjectId Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetObjectId() As IAcSmObjectId


IAcSmComponent.GetObjectId Method

AcSmViewCategory.GetObjectId Method
G Methods
IAcSmPersist.GetObjectId Method
IAcSmComponent.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


IAcSmPersist.GetObjectId Method

IAcSmComponent.GetObjectId Method
G Methods
AcSmPublishOptions.GetOutputFileName Method
IAcSmPersist.GetObjectId Method

Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmObjectId object when the operation is completed.

Syntax

GetObjectId() As IAcSmObjectId


AcSmPublishOptions.GetOutputFileName Method

IAcSmPersist.GetObjectId Method
G Methods
AcSmAcDbBlockRecordReference.GetOwnerAcDbHandle Method
AcSmPublishOptions.GetOutputFileName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOutputFileName() As IAcSmFileReference


AcSmAcDbBlockRecordReference.GetOwnerAcDbHandle Method

AcSmPublishOptions.GetOutputFileName Method
G Methods
AcSmAcDbLayoutReference.GetOwnerAcDbHandle Method
AcSmAcDbBlockRecordReference.GetOwnerAcDbHandle Method

Retrieves the AcDbHandle of the parent AcDbObject of the referenced object.

Syntax

GetOwnerAcDbHandle() As String


AcSmAcDbLayoutReference.GetOwnerAcDbHandle Method

AcSmAcDbBlockRecordReference.GetOwnerAcDbHandle Method
G Methods
AcSmAcDbViewReference.GetOwnerAcDbHandle Method
AcSmAcDbLayoutReference.GetOwnerAcDbHandle Method

Retrieves the AcDbHandle of the parent AcDbObject of the referenced object.

Syntax

GetOwnerAcDbHandle() As String


AcSmAcDbViewReference.GetOwnerAcDbHandle Method

AcSmAcDbLayoutReference.GetOwnerAcDbHandle Method
G Methods
AcSmNamedAcDbObjectReference.GetOwnerAcDbHandle Method
AcSmAcDbViewReference.GetOwnerAcDbHandle Method

Retrieves the AcDbHandle of the parent AcDbObject of the referenced object.

Syntax

GetOwnerAcDbHandle() As String


AcSmNamedAcDbObjectReference.GetOwnerAcDbHandle Method

AcSmAcDbViewReference.GetOwnerAcDbHandle Method
G Methods
AcSmAcDbBlockRecordReference.GetOwner Method
AcSmNamedAcDbObjectReference.GetOwnerAcDbHandle Method

Retrieves the AcDbHandle of the parent AcDbObject of the referenced object.

Syntax

GetOwnerAcDbHandle() As String


AcSmAcDbBlockRecordReference.GetOwner Method

AcSmNamedAcDbObjectReference.GetOwnerAcDbHandle Method
G Methods
AcSmAcDbLayoutReference.GetOwner Method
AcSmAcDbBlockRecordReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmAcDbLayoutReference.GetOwner Method

AcSmAcDbBlockRecordReference.GetOwner Method
G Methods
AcSmAcDbObjectReference.GetOwner Method
AcSmAcDbLayoutReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmAcDbObjectReference.GetOwner Method

AcSmAcDbLayoutReference.GetOwner Method
G Methods
AcSmAcDbViewReference.GetOwner Method
AcSmAcDbObjectReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmAcDbViewReference.GetOwner Method

AcSmAcDbObjectReference.GetOwner Method
G Methods
AcSmCalloutBlockReferences.GetOwner Method
AcSmAcDbViewReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmCalloutBlockReferences.GetOwner Method

AcSmAcDbViewReference.GetOwner Method
G Methods
AcSmCalloutBlocks.GetOwner Method
AcSmCalloutBlockReferences.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmCalloutBlocks.GetOwner Method

AcSmCalloutBlockReferences.GetOwner Method
G Methods
AcSmCustomPropertyBag.GetOwner Method
AcSmCalloutBlocks.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmCustomPropertyBag.GetOwner Method

AcSmCalloutBlocks.GetOwner Method
G Methods
AcSmCustomPropertyValue.GetOwner Method
AcSmCustomPropertyBag.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmCustomPropertyValue.GetOwner Method

AcSmCustomPropertyBag.GetOwner Method
G Methods
AcSmDatabase.GetOwner Method
AcSmCustomPropertyValue.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmDatabase.GetOwner Method

AcSmCustomPropertyValue.GetOwner Method
G Methods
AcSmFileReference.GetOwner Method
AcSmDatabase.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmFileReference.GetOwner Method

AcSmDatabase.GetOwner Method
G Methods
AcSmNamedAcDbObjectReference.GetOwner Method
AcSmFileReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmNamedAcDbObjectReference.GetOwner Method

AcSmFileReference.GetOwner Method
G Methods
AcSmObjectReference.GetOwner Method
AcSmNamedAcDbObjectReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmObjectReference.GetOwner Method

AcSmNamedAcDbObjectReference.GetOwner Method
G Methods
AcSmPersistProxy.GetOwner Method
AcSmObjectReference.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmPersistProxy.GetOwner Method

AcSmObjectReference.GetOwner Method
G Methods
AcSmPublishOptions.GetOwner Method
AcSmPersistProxy.GetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOwner() As IAcSmPersist


AcSmPublishOptions.GetOwner Method

AcSmPersistProxy.GetOwner Method
G Methods
AcSmResources.GetOwner Method
AcSmPublishOptions.GetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOwner() As IAcSmPersist


AcSmResources.GetOwner Method

AcSmPublishOptions.GetOwner Method
G Methods
AcSmSheet.GetOwner Method
AcSmResources.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheet.GetOwner Method

AcSmResources.GetOwner Method
G Methods
AcSmSheetSelSet.GetOwner Method
AcSmSheet.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetSelSet.GetOwner Method

AcSmSheet.GetOwner Method
G Methods
AcSmSheetSelSets.GetOwner Method
AcSmSheetSelSet.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetSelSets.GetOwner Method

AcSmSheetSelSet.GetOwner Method
G Methods
AcSmSheetSet.GetOwner Method
AcSmSheetSelSets.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetSet.GetOwner Method

AcSmSheetSelSets.GetOwner Method
G Methods
AcSmSheetView.GetOwner Method
AcSmSheetSet.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetView.GetOwner Method

AcSmSheetSet.GetOwner Method
G Methods
AcSmSheetViews.GetOwner Method
AcSmSheetView.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetViews.GetOwner Method

AcSmSheetView.GetOwner Method
G Methods
AcSmSubset.GetOwner Method
AcSmSheetViews.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmSubset.GetOwner Method

AcSmSheetViews.GetOwner Method
G Methods
AcSmViewCategories.GetOwner Method
AcSmSubset.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


AcSmViewCategories.GetOwner Method

AcSmSubset.GetOwner Method
G Methods
AcSmViewCategory.GetOwner Method
AcSmViewCategories.GetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOwner() As IAcSmPersist


AcSmViewCategory.GetOwner Method

AcSmViewCategories.GetOwner Method
G Methods
IAcSmComponent.GetOwner Method
AcSmViewCategory.GetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetOwner() As IAcSmPersist


IAcSmComponent.GetOwner Method

AcSmViewCategory.GetOwner Method
G Methods
IAcSmObjectId.GetOwner Method
IAcSmComponent.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

Syntax

GetOwner() As IAcSmPersist


IAcSmObjectId.GetOwner Method

IAcSmComponent.GetOwner Method
G Methods
IAcSmPersist.GetOwner Method
IAcSmObjectId.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

The caller must release the interface when the operation is complete.

Syntax

GetOwner() As IAcSmPersist


IAcSmPersist.GetOwner Method

IAcSmObjectId.GetOwner Method
G Methods
AcSmSheetSetMgr.GetParentSheetSet Method
IAcSmPersist.GetOwner Method

Retrieves a pointer to the owning IAcSmPersist parent object.

If the method succeeds, the return value is S_OK. If the pointer to the owning IAcSmPersist parent object cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

Syntax

GetOwner() As IAcSmPersist


AcSmSheetSetMgr.GetParentSheetSet Method

IAcSmPersist.GetOwner Method
G Methods
AcSmPublishOptions.GetPassword Method
AcSmSheetSetMgr.GetParentSheetSet Method

Attempts to find a sheet set that references a file name and layout. Any hints saved in the drawing are used.

The caller must release the interface when the operation is complete.

Syntax

GetParentSheetSet(
 dwg As String,
 layout As String,
 sheetSet As AcSmSheetSet) As IAcSmSheetSet
dwg | Input file name of the drawing that contains the layout
layout | Input name of the layout
sheetSet | Output sheet set that references the file name and layout


AcSmPublishOptions.GetPassword Method

AcSmSheetSetMgr.GetParentSheetSet Method
G Methods
IAcSmObjectId.GetPersistObject Method
AcSmPublishOptions.GetPassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetPassword() As String


IAcSmObjectId.GetPersistObject Method

AcSmPublishOptions.GetPassword Method
G Methods
AcSmSheetSet.GetProjectMilestone Method
IAcSmObjectId.GetPersistObject Method

Returns a pointer to the instance of the IAcSmPersist component identified by the IAcSmObjectId.

The caller must release the interface when the operation is complete.

Syntax

GetPersistObject() As IAcSmPersist


AcSmSheetSet.GetProjectMilestone Method

IAcSmObjectId.GetPersistObject Method
G Methods
AcSmSheetSet.GetProjectName Method
AcSmSheetSet.GetProjectMilestone Method

Retrieves the ProjectMilestone property. Returns S_OK if successful.

Syntax

GetProjectMilestone(
 pVal As BSTR*) As HRESULT
pVal Output pointer to a string containing the value of the ProjectMilestoneProjectMilestone property


AcSmSheetSet.GetProjectName Method

AcSmSheetSet.GetProjectMilestone Method
G Methods
AcSmSheetSet.GetProjectNumber Method
AcSmSheetSet.GetProjectName Method

Retrieves the project name associated with this sheet set. Returns S_OK if successful.

Syntax

GetProjectName(
 pVal As BSTR*) As HRESULT
pVal Output pointer to a string containing the value of the ProjectNameProjectName property


AcSmSheetSet.GetProjectNumber Method

AcSmSheetSet.GetProjectName Method
G Methods
AcSmSheetSet.GetProjectPhase Method
AcSmSheetSet.GetProjectNumber Method

Retrieves the project number associated with this sheet set. Returns S_OK if successful.

Syntax

GetProjectNumber(
 pVal As BSTR*) As HRESULT
pVal Output pointer to a string containing the value of the ProjectNumberProjectNumber property


AcSmSheetSet.GetProjectPhase Method

AcSmSheetSet.GetProjectNumber Method
G Methods
AcSmSheetSet.GetPromptForDwgName Method
AcSmSheetSet.GetProjectPhase Method

Retrieves the ProjectPhase property. Returns S_OK if successful.

Syntax

GetProjectPhase(
 pVal As BSTR*) As HRESULT
pVal Output pointer to a string containing the value of the ProjectPhaseProjectPhase property


AcSmSheetSet.GetPromptForDwgName Method

AcSmSheetSet.GetProjectPhase Method
G Methods
AcSmSheetSet.GetPromptForDwt Method
AcSmSheetSet.GetPromptForDwgName Method

Retrieves the flag indicating whether the user interface should prompt for the name of a new drawing.

Syntax

GetPromptForDwgName() As Boolean


AcSmSheetSet.GetPromptForDwt Method

AcSmSheetSet.GetPromptForDwgName Method
G Methods
AcSmSubset.GetPromptForDwt Method
AcSmSheetSet.GetPromptForDwt Method

Returns the Boolean flag that indicates if the application should prompt for DWT file.

Syntax

GetPromptForDwt() As Boolean


AcSmSubset.GetPromptForDwt Method

AcSmSheetSet.GetPromptForDwt Method
G Methods
AcSmPublishOptions.GetPromptForName Method
AcSmSubset.GetPromptForDwt Method

Returns a Boolean flag indicating if the application should prompt for a DWT file.

Syntax

GetPromptForDwt() As Boolean


AcSmPublishOptions.GetPromptForName Method

AcSmSubset.GetPromptForDwt Method
G Methods
AcSmPublishOptions.GetPromptForPassword Method
AcSmPublishOptions.GetPromptForName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetPromptForName() As Boolean


AcSmPublishOptions.GetPromptForPassword Method

AcSmPublishOptions.GetPromptForName Method
G Methods
AcSmCustomPropertyBag.GetPropertyEnumerator Method
AcSmPublishOptions.GetPromptForPassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetPromptForPassword() As Boolean


AcSmCustomPropertyBag.GetPropertyEnumerator Method

AcSmPublishOptions.GetPromptForPassword Method
G Methods
AcSmCustomPropertyBag.GetProperty Method
AcSmCustomPropertyBag.GetPropertyEnumerator Method

Returns an enumerator of all the contained properties. After an element is returned using the Next method, you can perform operations on it.

The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

The caller must release the allocated memory when the operation is complete.

Syntax

GetPropertyEnumerator() As IAcSmEnumProperty


AcSmCustomPropertyBag.GetProperty Method

AcSmCustomPropertyBag.GetPropertyEnumerator Method
G Methods
AcSmSheetSet.GetPublishOptions Method
AcSmCustomPropertyBag.GetProperty Method

Retrieves the IAcSmCustomPropertyValue specified with the Name parameter. If the method succeeds, the return value is S_OK. If the custom property value cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.

The caller must release the IAcSmCustomPropertyValue interface when the operation is completed.

Syntax

GetProperty(
 name As String) As IAcSmCustomPropertyValue
name Input string containing Name value of a property


AcSmSheetSet.GetPublishOptions Method

AcSmCustomPropertyBag.GetProperty Method
G Methods
AcSmObjectReference.GetReferenceFlags Method
AcSmSheetSet.GetPublishOptions Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetPublishOptions() As IAcSmPublishOptions


AcSmObjectReference.GetReferenceFlags Method

AcSmSheetSet.GetPublishOptions Method
G Methods
AcSmObjectReference.GetReferencedObject Method
AcSmObjectReference.GetReferenceFlags Method

Retrieves the reference flags to determine the type of referencing used, hard referencing or soft referencing.

Syntax

GetReferenceFlags() As AcSmObjectReferenceFlags


AcSmObjectReference.GetReferencedObject Method

AcSmObjectReference.GetReferenceFlags Method
G Methods
AcSmSheetSet.GetResources Method
AcSmObjectReference.GetReferencedObject Method

Retrieves the referenced IAcSmPersist object.

The caller must release the interface when the operation is complete.

Syntax

GetReferencedObject() As IAcSmPersist


AcSmSheetSet.GetResources Method

AcSmObjectReference.GetReferencedObject Method
G Methods
AcSmSheet.GetRevisionDate Method
AcSmSheetSet.GetResources Method

Returns a collection of the resources associated with the sheet set.

The caller must release the interface when the operation is complete.

Syntax

GetResources() As IAcSmResources


AcSmSheet.GetRevisionDate Method

AcSmSheetSet.GetResources Method
G Methods
AcSmDSTFiler.GetRevisionNumber Method
AcSmSheet.GetRevisionDate Method

Retrieves the RevisionDate property. Returns S_OK if successful.

Syntax

GetRevisionDate(
 pVal As BSTR*) As HRESULT
pVal Output pointer to a string containing the value of the RevisionDateRevisionDate property


AcSmDSTFiler.GetRevisionNumber Method

AcSmSheet.GetRevisionDate Method
G Methods
AcSmSheet.GetRevisionNumber Method
AcSmDSTFiler.GetRevisionNumber Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetRevisionNumber() As Long


AcSmSheet.GetRevisionNumber Method

AcSmDSTFiler.GetRevisionNumber Method
G Methods
AcSmSheetSet.GetSheetEnumerator Method
AcSmSheet.GetRevisionNumber Method

Retrieves the RevisionNumber property. Returns S_OK if successful.

Syntax

GetRevisionNumber(
 pVal As BSTR*) As HRESULT
pVal Output pointer to a string containing the value of the RevisionNumber property


AcSmSheetSet.GetSheetEnumerator Method

AcSmSheet.GetRevisionNumber Method
G Methods
AcSmSubset.GetSheetEnumerator Method
AcSmSheetSet.GetSheetEnumerator Method

Returns an enumerator of all components contained in this subset (ordered).

Syntax

GetSheetEnumerator() As IAcSmEnumComponent


AcSmSubset.GetSheetEnumerator Method

AcSmSheetSet.GetSheetEnumerator Method
G Methods
AcSmSheetSet.GetSheetSelSets Method
AcSmSubset.GetSheetEnumerator Method

Returns an enumerator of all components in this subset.

The caller must release the interface when the operation is complete.

Syntax

GetSheetEnumerator() As IAcSmEnumComponent


AcSmSheetSet.GetSheetSelSets Method

AcSmSubset.GetSheetEnumerator Method
G Methods
AcSmDatabase.GetSheetSet Method
AcSmSheetSet.GetSheetSelSets Method

Returns a collection of the sheet selection sets associated with the sheet set.

The caller must release the interface when the operation is complete.

Syntax

GetSheetSelSets() As IAcSmSheetSelSets


AcSmDatabase.GetSheetSet Method

AcSmSheetSet.GetSheetSelSets Method
G Methods
AcSmViewCategory.GetSheetViewEnumerator Method
AcSmDatabase.GetSheetSet Method

Retrieves the IAcSmSheetSet component contained in the database.

The caller must release the interface when the operation is complete.

Syntax

GetSheetSet() As IAcSmSheetSet


AcSmViewCategory.GetSheetViewEnumerator Method

AcSmDatabase.GetSheetSet Method
G Methods
AcSmSheet.GetSheetViews Method
AcSmViewCategory.GetSheetViewEnumerator Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetSheetViewEnumerator() As IAcSmEnumSheetView


AcSmSheet.GetSheetViews Method

AcSmViewCategory.GetSheetViewEnumerator Method
G Methods
AcSmDatabase.GetTemplateDstFileName Method
AcSmSheet.GetSheetViews Method

Retreives the sheet views collection of the sheet.

The caller must release the interface when the operation is complete.

Syntax

GetSheetViews() As IAcSmSheetViews


AcSmDatabase.GetTemplateDstFileName Method

AcSmSheet.GetSheetViews Method
G Methods
AcSmSheet.GetTitle Method
AcSmDatabase.GetTemplateDstFileName Method

Gets the file name of the template DST file specified with the LoadFromFile method when the database object was created.

This is a read-only value that is set only when a database object is initially loaded from a template.

Syntax

GetTemplateDstFileName() As String


AcSmSheet.GetTitle Method

AcSmDatabase.GetTemplateDstFileName Method
G Methods
AcSmSheetView.GetTitle Method
AcSmSheet.GetTitle Method

Retrieves the title of the sheet.

Syntax

GetTitle() As String


AcSmSheetView.GetTitle Method

AcSmSheet.GetTitle Method
G Methods
AcSmAcDbBlockRecordReference.GetTypeName Method
AcSmSheetView.GetTitle Method

Retrieves the Title property of the sheet view.

Syntax

GetTitle() As String


AcSmAcDbBlockRecordReference.GetTypeName Method

AcSmSheetView.GetTitle Method
G Methods
AcSmAcDbLayoutReference.GetTypeName Method
AcSmAcDbBlockRecordReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmAcDbLayoutReference.GetTypeName Method

AcSmAcDbBlockRecordReference.GetTypeName Method
G Methods
AcSmAcDbObjectReference.GetTypeName Method
AcSmAcDbLayoutReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmAcDbObjectReference.GetTypeName Method

AcSmAcDbLayoutReference.GetTypeName Method
G Methods
AcSmAcDbViewReference.GetTypeName Method
AcSmAcDbObjectReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmAcDbViewReference.GetTypeName Method

AcSmAcDbObjectReference.GetTypeName Method
G Methods
AcSmCalloutBlockReferences.GetTypeName Method
AcSmAcDbViewReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmCalloutBlockReferences.GetTypeName Method

AcSmAcDbViewReference.GetTypeName Method
G Methods
AcSmCalloutBlocks.GetTypeName Method
AcSmCalloutBlockReferences.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmCalloutBlocks.GetTypeName Method

AcSmCalloutBlockReferences.GetTypeName Method
G Methods
AcSmCustomPropertyBag.GetTypeName Method
AcSmCalloutBlocks.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmCustomPropertyBag.GetTypeName Method

AcSmCalloutBlocks.GetTypeName Method
G Methods
AcSmCustomPropertyValue.GetTypeName Method
AcSmCustomPropertyBag.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmCustomPropertyValue.GetTypeName Method

AcSmCustomPropertyBag.GetTypeName Method
G Methods
AcSmDatabase.GetTypeName Method
AcSmCustomPropertyValue.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmDatabase.GetTypeName Method

AcSmCustomPropertyValue.GetTypeName Method
G Methods
AcSmFileReference.GetTypeName Method
AcSmDatabase.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmFileReference.GetTypeName Method

AcSmDatabase.GetTypeName Method
G Methods
AcSmNamedAcDbObjectReference.GetTypeName Method
AcSmFileReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmNamedAcDbObjectReference.GetTypeName Method

AcSmFileReference.GetTypeName Method
G Methods
AcSmObjectReference.GetTypeName Method
AcSmNamedAcDbObjectReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmObjectReference.GetTypeName Method

AcSmNamedAcDbObjectReference.GetTypeName Method
G Methods
AcSmPersistProxy.GetTypeName Method
AcSmObjectReference.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmPersistProxy.GetTypeName Method

AcSmObjectReference.GetTypeName Method
G Methods
AcSmPublishOptions.GetTypeName Method
AcSmPersistProxy.GetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetTypeName() As String


AcSmPublishOptions.GetTypeName Method

AcSmPersistProxy.GetTypeName Method
G Methods
AcSmResources.GetTypeName Method
AcSmPublishOptions.GetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetTypeName() As String


AcSmResources.GetTypeName Method

AcSmPublishOptions.GetTypeName Method
G Methods
AcSmSheet.GetTypeName Method
AcSmResources.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheet.GetTypeName Method

AcSmResources.GetTypeName Method
G Methods
AcSmSheetSelSet.GetTypeName Method
AcSmSheet.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetSelSet.GetTypeName Method

AcSmSheet.GetTypeName Method
G Methods
AcSmSheetSelSets.GetTypeName Method
AcSmSheetSelSet.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetSelSets.GetTypeName Method

AcSmSheetSelSet.GetTypeName Method
G Methods
AcSmSheetSet.GetTypeName Method
AcSmSheetSelSets.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetSet.GetTypeName Method

AcSmSheetSelSets.GetTypeName Method
G Methods
AcSmSheetView.GetTypeName Method
AcSmSheetSet.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetView.GetTypeName Method

AcSmSheetSet.GetTypeName Method
G Methods
AcSmSheetViews.GetTypeName Method
AcSmSheetView.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSheetViews.GetTypeName Method

AcSmSheetView.GetTypeName Method
G Methods
AcSmSubset.GetTypeName Method
AcSmSheetViews.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmSubset.GetTypeName Method

AcSmSheetViews.GetTypeName Method
G Methods
AcSmViewCategories.GetTypeName Method
AcSmSubset.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmViewCategories.GetTypeName Method

AcSmSubset.GetTypeName Method
G Methods
AcSmViewCategory.GetTypeName Method
AcSmViewCategories.GetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetTypeName() As String


AcSmViewCategory.GetTypeName Method

AcSmViewCategories.GetTypeName Method
G Methods
IAcSmComponent.GetTypeName Method
AcSmViewCategory.GetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetTypeName() As String


IAcSmComponent.GetTypeName Method

AcSmViewCategory.GetTypeName Method
G Methods
IAcSmPersist.GetTypeName Method
IAcSmComponent.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


IAcSmPersist.GetTypeName Method

IAcSmComponent.GetTypeName Method
G Methods
AcSmPublishOptions.GetUnrecognizedData Method
IAcSmPersist.GetTypeName Method

Retrieves the descriptive name representing the coclass. This method is used mainly by the filer.

Syntax

GetTypeName() As String


AcSmPublishOptions.GetUnrecognizedData Method

IAcSmPersist.GetTypeName Method
G Methods
AcSmPublishOptions.GetUnrecognizedSections Method
AcSmPublishOptions.GetUnrecognizedData Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetUnrecognizedData() As Object


AcSmPublishOptions.GetUnrecognizedSections Method

AcSmPublishOptions.GetUnrecognizedData Method
G Methods
AcSmPublishOptions.GetUsePassword Method
AcSmPublishOptions.GetUnrecognizedSections Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetUnrecognizedSections() As Object


AcSmPublishOptions.GetUsePassword Method

AcSmPublishOptions.GetUnrecognizedSections Method
G Methods
AcSmCustomPropertyValue.GetValue Method
AcSmPublishOptions.GetUsePassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetUsePassword() As Boolean


AcSmCustomPropertyValue.GetValue Method

AcSmPublishOptions.GetUsePassword Method
G Methods
AcSmSheetSet.GetViewCategories Method
AcSmCustomPropertyValue.GetValue Method

Retrieves the variant value associated with the custom property.

Syntax

GetValue() As Variant


AcSmSheetSet.GetViewCategories Method

AcSmCustomPropertyValue.GetValue Method
G Methods
I Methods
AcSmSheetSet.GetViewCategories Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

GetViewCategories() As IAcSmViewCategories


I Methods

AcSmSheetSet.GetViewCategories Method
Methods
AcSmSheetSet.ImportSheet Method
I Methods

Topics in this section

  • AcSmSheetSet.ImportSheet Method
  • AcSmSubset.ImportSheet Method
  • AcSmAcDbBlockRecordReference.InitNew Method
  • AcSmAcDbLayoutReference.InitNew Method
  • AcSmAcDbObjectReference.InitNew Method
  • AcSmAcDbViewReference.InitNew Method
  • AcSmCalloutBlockReferences.InitNew Method
  • AcSmCalloutBlocks.InitNew Method
  • AcSmCustomPropertyBag.InitNew Method
  • AcSmCustomPropertyValue.InitNew Method
  • AcSmDatabase.InitNew Method
  • AcSmFileReference.InitNew Method
  • AcSmNamedAcDbObjectReference.InitNew Method
  • AcSmObjectReference.InitNew Method
  • AcSmPersistProxy.InitNew Method
  • AcSmPublishOptions.InitNew Method
  • AcSmResources.InitNew Method
  • AcSmSheet.InitNew Method
  • AcSmSheetSelSet.InitNew Method
  • AcSmSheetSelSets.InitNew Method
  • AcSmSheetSet.InitNew Method
  • AcSmSheetView.InitNew Method
  • AcSmSheetViews.InitNew Method
  • AcSmSubset.InitNew Method
  • AcSmViewCategories.InitNew Method
  • AcSmViewCategory.InitNew Method
  • IAcSmComponent.InitNew Method
  • IAcSmPersist.InitNew Method
  • AcSmDSTFiler.Init Method
  • AcSmSheetSet.InsertComponentAfter Method
  • AcSmSubset.InsertComponentAfter Method
  • AcSmSheetSet.InsertComponent Method
  • AcSmSubset.InsertComponent Method
  • IAcSmObjectId.IsEqual Method
  • IAcSmObjectId.IsValid Method


AcSmSheetSet.ImportSheet Method

I Methods
I Methods
AcSmSubset.ImportSheet Method
AcSmSheetSet.ImportSheet Method

Constructs a new sheet component that references the existing layout pointed to by the provided AcSmAcDbLayoutReference.

Syntax

ImportSheet(
 pLayoutRef As IAcSmAcDbLayoutReference) As IAcSmAcDbLayoutReference
pLayoutRef Input layout reference


AcSmSubset.ImportSheet Method

AcSmSheetSet.ImportSheet Method
I Methods
AcSmAcDbBlockRecordReference.InitNew Method
AcSmSubset.ImportSheet Method

Adds a new sheet component that references the layout of AcSmAcDbLayoutReference. The new component is not added to the subset.

To add the new sheet component to the subset, use the InsertComponent method.

Syntax

ImportSheet(
 pLayoutRef As IAcSmAcDbLayoutReference) As IAcSmSheet
pLayoutRef Input drawing and layout to be imported


AcSmAcDbBlockRecordReference.InitNew Method

AcSmSubset.ImportSheet Method
I Methods
AcSmAcDbLayoutReference.InitNew Method
AcSmAcDbBlockRecordReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmAcDbLayoutReference.InitNew Method

AcSmAcDbBlockRecordReference.InitNew Method
I Methods
AcSmAcDbObjectReference.InitNew Method
AcSmAcDbLayoutReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmAcDbObjectReference.InitNew Method

AcSmAcDbLayoutReference.InitNew Method
I Methods
AcSmAcDbViewReference.InitNew Method
AcSmAcDbObjectReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmAcDbViewReference.InitNew Method

AcSmAcDbObjectReference.InitNew Method
I Methods
AcSmCalloutBlockReferences.InitNew Method
AcSmAcDbViewReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmCalloutBlockReferences.InitNew Method

AcSmAcDbViewReference.InitNew Method
I Methods
AcSmCalloutBlocks.InitNew Method
AcSmCalloutBlockReferences.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmCalloutBlocks.InitNew Method

AcSmCalloutBlockReferences.InitNew Method
I Methods
AcSmCustomPropertyBag.InitNew Method
AcSmCalloutBlocks.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmCustomPropertyBag.InitNew Method

AcSmCalloutBlocks.InitNew Method
I Methods
AcSmCustomPropertyValue.InitNew Method
AcSmCustomPropertyBag.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmCustomPropertyValue.InitNew Method

AcSmCustomPropertyBag.InitNew Method
I Methods
AcSmDatabase.InitNew Method
AcSmCustomPropertyValue.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmDatabase.InitNew Method

AcSmCustomPropertyValue.InitNew Method
I Methods
AcSmFileReference.InitNew Method
AcSmDatabase.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmFileReference.InitNew Method

AcSmDatabase.InitNew Method
I Methods
AcSmNamedAcDbObjectReference.InitNew Method
AcSmFileReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmNamedAcDbObjectReference.InitNew Method

AcSmFileReference.InitNew Method
I Methods
AcSmObjectReference.InitNew Method
AcSmNamedAcDbObjectReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmObjectReference.InitNew Method

AcSmNamedAcDbObjectReference.InitNew Method
I Methods
AcSmPersistProxy.InitNew Method
AcSmObjectReference.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmPersistProxy.InitNew Method

AcSmObjectReference.InitNew Method
I Methods
AcSmPublishOptions.InitNew Method
AcSmPersistProxy.InitNew Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmPublishOptions.InitNew Method

AcSmPersistProxy.InitNew Method
I Methods
AcSmResources.InitNew Method
AcSmPublishOptions.InitNew Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmResources.InitNew Method

AcSmPublishOptions.InitNew Method
I Methods
AcSmSheet.InitNew Method
AcSmResources.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheet.InitNew Method

AcSmResources.InitNew Method
I Methods
AcSmSheetSelSet.InitNew Method
AcSmSheet.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetSelSet.InitNew Method

AcSmSheet.InitNew Method
I Methods
AcSmSheetSelSets.InitNew Method
AcSmSheetSelSet.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetSelSets.InitNew Method

AcSmSheetSelSet.InitNew Method
I Methods
AcSmSheetSet.InitNew Method
AcSmSheetSelSets.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetSet.InitNew Method

AcSmSheetSelSets.InitNew Method
I Methods
AcSmSheetView.InitNew Method
AcSmSheetSet.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetView.InitNew Method

AcSmSheetSet.InitNew Method
I Methods
AcSmSheetViews.InitNew Method
AcSmSheetView.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetViews.InitNew Method

AcSmSheetView.InitNew Method
I Methods
AcSmSubset.InitNew Method
AcSmSheetViews.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSubset.InitNew Method

AcSmSheetViews.InitNew Method
I Methods
AcSmViewCategories.InitNew Method
AcSmSubset.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmViewCategories.InitNew Method

AcSmSubset.InitNew Method
I Methods
AcSmViewCategory.InitNew Method
AcSmViewCategories.InitNew Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmViewCategory.InitNew Method

AcSmViewCategories.InitNew Method
I Methods
IAcSmComponent.InitNew Method
AcSmViewCategory.InitNew Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


IAcSmComponent.InitNew Method

AcSmViewCategory.InitNew Method
I Methods
IAcSmPersist.InitNew Method
IAcSmComponent.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


IAcSmPersist.InitNew Method

IAcSmComponent.InitNew Method
I Methods
AcSmDSTFiler.Init Method
IAcSmPersist.InitNew Method

Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.

Syntax

InitNew(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmDSTFiler.Init Method

IAcSmPersist.InitNew Method
I Methods
AcSmSheetSet.InsertComponentAfter Method
AcSmDSTFiler.Init Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Init(
 pUnk As Object,
 pDb As IAcSmDatabase,
 bForWrite As Boolean) As Object
pUnk | Input IUnknown pointer representing the data container construct object
pDb | Input IAcSmDatabase that the filer will act on
bForWrite | Input Boolean to indicate if the filer will perform read operations or write operations


AcSmSheetSet.InsertComponentAfter Method

AcSmDSTFiler.Init Method
I Methods
AcSmSubset.InsertComponentAfter Method
AcSmSheetSet.InsertComponentAfter Method

Inserts a sheet at the position specified.

Syntax

InsertComponentAfter(
 newSheet As IAcSmComponent,
 afterComp As IAcSmComponent) As Object
newSheet | Input IAcSmComponent to be inserted
afterComp | Input component after which to insert the sheet


AcSmSubset.InsertComponentAfter Method

AcSmSheetSet.InsertComponentAfter Method
I Methods
AcSmSheetSet.InsertComponent Method
AcSmSubset.InsertComponentAfter Method

Inserts a sheet at the position specified.

Syntax

InsertComponentAfter(
 newSheet As IAcSmComponent,
 afterComp As IAcSmComponent) As Object
newSheet | Input IAcSmComponent to be inserted
afterComp | Input location of the new sheet, or null to insert the sheet at the beginning of the subset


AcSmSheetSet.InsertComponent Method

AcSmSubset.InsertComponentAfter Method
I Methods
AcSmSubset.InsertComponent Method
AcSmSheetSet.InsertComponent Method

Inserts a sheet at the position specified.

Syntax

InsertComponent(
 newSheet As IAcSmComponent,
 beforeComp As IAcSmComponent) As Object
newSheet | Input IAcSmComponent to be inserted
beforeComp | Input IAcSmComponent before which the component will be inserted, or specify null if the component should be inserted at the end of the subset


AcSmSubset.InsertComponent Method

AcSmSheetSet.InsertComponent Method
I Methods
IAcSmObjectId.IsEqual Method
AcSmSubset.InsertComponent Method

Inserts a sheet at the position specified.

Syntax

InsertComponent(
 newSheet As IAcSmComponent,
 beforeComp As IAcSmComponent) As Object
newSheet | Input IAcSmComponent to be inserted
beforeComp | Input location of the new sheet, or null to insert the sheet at the end of the subset


IAcSmObjectId.IsEqual Method

AcSmSubset.InsertComponent Method
I Methods
IAcSmObjectId.IsValid Method
IAcSmObjectId.IsEqual Method

Compares one IAcSmObjectId with another IAcSmObjectId object, and returns True if both objects reference the same component.

Syntax

IsEqual(
 pId As IAcSmObjectId) As Boolean
pId Input IAcSmObjectId for comparison


IAcSmObjectId.IsValid Method

IAcSmObjectId.IsEqual Method
I Methods
L Methods
IAcSmObjectId.IsValid Method

Determines whether an IAcSmObjectId points to a valid object.

Syntax

IsValid() As Boolean


L Methods

IAcSmObjectId.IsValid Method
Methods
AcSmDatabase.LoadFromFile Method
L Methods

Topics in this section

  • AcSmDatabase.LoadFromFile Method
  • AcSmAcDbBlockRecordReference.Load Method
  • AcSmAcDbLayoutReference.Load Method
  • AcSmAcDbObjectReference.Load Method
  • AcSmAcDbViewReference.Load Method
  • AcSmCalloutBlockReferences.Load Method
  • AcSmCalloutBlocks.Load Method
  • AcSmCustomPropertyBag.Load Method
  • AcSmCustomPropertyValue.Load Method
  • AcSmDatabase.Load Method
  • AcSmFileReference.Load Method
  • AcSmNamedAcDbObjectReference.Load Method
  • AcSmObjectReference.Load Method
  • AcSmPersistProxy.Load Method
  • AcSmPublishOptions.Load Method
  • AcSmResources.Load Method
  • AcSmSheet.Load Method
  • AcSmSheetSelSet.Load Method
  • AcSmSheetSelSets.Load Method
  • AcSmSheetSet.Load Method
  • AcSmSheetView.Load Method
  • AcSmSheetViews.Load Method
  • AcSmSubset.Load Method
  • AcSmViewCategories.Load Method
  • AcSmViewCategory.Load Method
  • IAcSmComponent.Load Method
  • IAcSmPersist.Load Method
  • AcSmDatabase.LockDb Method


AcSmDatabase.LoadFromFile Method

L Methods
L Methods
AcSmAcDbBlockRecordReference.Load Method
AcSmDatabase.LoadFromFile Method

Clears the contents of the database and loads data from a file. The file name property of the database is unchanged; the original file name is used by the GetFileName method and the original file name is used when data is written to the disk.

The file name can be null if you want to load or reload data from the current file name.

Syntax

LoadFromFile(
 templateDstFileName As String = 0) As Object
templateDstFileName Input name of the file from which to load data


AcSmAcDbBlockRecordReference.Load Method

AcSmDatabase.LoadFromFile Method
L Methods
AcSmAcDbLayoutReference.Load Method
AcSmAcDbBlockRecordReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load() As Object


AcSmAcDbLayoutReference.Load Method

AcSmAcDbBlockRecordReference.Load Method
L Methods
AcSmAcDbObjectReference.Load Method
AcSmAcDbLayoutReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load() As Object


AcSmAcDbObjectReference.Load Method

AcSmAcDbLayoutReference.Load Method
L Methods
AcSmAcDbViewReference.Load Method
AcSmAcDbObjectReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmAcDbViewReference.Load Method

AcSmAcDbObjectReference.Load Method
L Methods
AcSmCalloutBlockReferences.Load Method
AcSmAcDbViewReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load() As Object


AcSmCalloutBlockReferences.Load Method

AcSmAcDbViewReference.Load Method
L Methods
AcSmCalloutBlocks.Load Method
AcSmCalloutBlockReferences.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmCalloutBlocks.Load Method

AcSmCalloutBlockReferences.Load Method
L Methods
AcSmCustomPropertyBag.Load Method
AcSmCalloutBlocks.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmCustomPropertyBag.Load Method

AcSmCalloutBlocks.Load Method
L Methods
AcSmCustomPropertyValue.Load Method
AcSmCustomPropertyBag.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmCustomPropertyValue.Load Method

AcSmCustomPropertyBag.Load Method
L Methods
AcSmDatabase.Load Method
AcSmCustomPropertyValue.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmDatabase.Load Method

AcSmCustomPropertyValue.Load Method
L Methods
AcSmFileReference.Load Method
AcSmDatabase.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmFileReference.Load Method

AcSmDatabase.Load Method
L Methods
AcSmNamedAcDbObjectReference.Load Method
AcSmFileReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmNamedAcDbObjectReference.Load Method

AcSmFileReference.Load Method
L Methods
AcSmObjectReference.Load Method
AcSmNamedAcDbObjectReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmObjectReference.Load Method

AcSmNamedAcDbObjectReference.Load Method
L Methods
AcSmPersistProxy.Load Method
AcSmObjectReference.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmPersistProxy.Load Method

AcSmObjectReference.Load Method
L Methods
AcSmPublishOptions.Load Method
AcSmPersistProxy.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmPublishOptions.Load Method

AcSmPersistProxy.Load Method
L Methods
AcSmResources.Load Method
AcSmPublishOptions.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmResources.Load Method

AcSmPublishOptions.Load Method
L Methods
AcSmSheet.Load Method
AcSmResources.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheet.Load Method

AcSmResources.Load Method
L Methods
AcSmSheetSelSet.Load Method
AcSmSheet.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetSelSet.Load Method

AcSmSheet.Load Method
L Methods
AcSmSheetSelSets.Load Method
AcSmSheetSelSet.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetSelSets.Load Method

AcSmSheetSelSet.Load Method
L Methods
AcSmSheetSet.Load Method
AcSmSheetSelSets.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetSet.Load Method

AcSmSheetSelSets.Load Method
L Methods
AcSmSheetView.Load Method
AcSmSheetSet.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetView.Load Method

AcSmSheetSet.Load Method
L Methods
AcSmSheetViews.Load Method
AcSmSheetView.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetViews.Load Method

AcSmSheetView.Load Method
L Methods
AcSmSubset.Load Method
AcSmSheetViews.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSubset.Load Method

AcSmSheetViews.Load Method
L Methods
AcSmViewCategories.Load Method
AcSmSubset.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmViewCategories.Load Method

AcSmSubset.Load Method
L Methods
AcSmViewCategory.Load Method
AcSmViewCategories.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmViewCategory.Load Method

AcSmViewCategories.Load Method
L Methods
IAcSmComponent.Load Method
AcSmViewCategory.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


IAcSmComponent.Load Method

AcSmViewCategory.Load Method
L Methods
IAcSmPersist.Load Method
IAcSmComponent.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


IAcSmPersist.Load Method

IAcSmComponent.Load Method
L Methods
AcSmDatabase.LockDb Method
IAcSmPersist.Load Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Load(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmDatabase.LockDb Method

IAcSmPersist.Load Method
L Methods
N Methods
AcSmDatabase.LockDb Method

Locks the database so it can be modified.

Syntax

LockDb(
 pObject As Object) As Object
pObject Input any valid IUnknown pointer as the owner of the requested lock


N Methods

AcSmDatabase.LockDb Method
Methods
IAcSmEnumAcDbBlockRecordReference.Next Method
N Methods

Topics in this section

  • IAcSmEnumAcDbBlockRecordReference.Next Method
  • IAcSmEnumComponent.Next Method
  • IAcSmEnumDatabase.Next Method
  • IAcSmEnumFileReference.Next Method
  • IAcSmEnumPersist.Next Method
  • IAcSmEnumProperty.Next Method
  • IAcSmEnumSheetSelSet.Next Method
  • IAcSmEnumSheetView.Next Method
  • IAcSmEnumViewCategory.Next Method
  • AcSmDatabase.NotifyRegisteredEventHandlers Method
  • AcSmSheetSet.NotifyRegisteredEventHandlers Method
  • AcSmSubset.NotifyRegisteredEventHandlers Method


IAcSmEnumAcDbBlockRecordReference.Next Method

N Methods
N Methods
IAcSmEnumComponent.Next Method
IAcSmEnumAcDbBlockRecordReference.Next Method

Iterates to the next component and retrieves it. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

Syntax

Next() As AcSmAcDbBlockRecordReference


IAcSmEnumComponent.Next Method

IAcSmEnumAcDbBlockRecordReference.Next Method
N Methods
IAcSmEnumDatabase.Next Method
IAcSmEnumComponent.Next Method

Iterates to the next component and retrieves it. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

If the return value is S_OK, iteration can continue. If the return value is S_FALSE, iteration must stop. Do not use the macro SUCCEEDED to determine success or failure.

The caller must release the interface when the operation is complete.

Syntax

Next() As IAcSmComponent


IAcSmEnumDatabase.Next Method

IAcSmEnumComponent.Next Method
N Methods
IAcSmEnumFileReference.Next Method
IAcSmEnumDatabase.Next Method

Iterates to the next component and retrieves it.

Syntax

Next() As IAcSmDatabase


IAcSmEnumFileReference.Next Method

IAcSmEnumDatabase.Next Method
N Methods
IAcSmEnumPersist.Next Method
IAcSmEnumFileReference.Next Method

Iterates to the next component and retrieves it. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

If the return value is S_OK, iteration can continue. If the return value is S_FALSE, iteration must stop. The macro SUCCEEDED should not be used to determine success or failure.

The caller must release the interface when the operation is complete.

Syntax

Next() As IAcSmFileReference


IAcSmEnumPersist.Next Method

IAcSmEnumFileReference.Next Method
N Methods
IAcSmEnumProperty.Next Method
IAcSmEnumPersist.Next Method

Iterates through a collection and returns an element. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

After an element is returned, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

The caller must release the interface when the operation is complete.

If the return value is S_OK, then iteration should continue. If the return value is S_FALSE, then iteration should stop.

Syntax

Next() As IAcSmPersist


IAcSmEnumProperty.Next Method

IAcSmEnumPersist.Next Method
N Methods
IAcSmEnumSheetSelSet.Next Method
IAcSmEnumProperty.Next Method

Iterates to the next component and retrieves it. For an example of how to use the Next method in VBA, see Reliably Access Sheet Set Components.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

The caller must release the allocated data and the interface when the operation is complete.

Syntax

Next(
 propname As String,
 ppValue As IAcSmCustomPropertyValue) As Object
propname | Output pointer to the name of the property
ppValue | Output pointer to an appropriately allocated and initialized IAcSmCustomPropertyValue object


IAcSmEnumSheetSelSet.Next Method

IAcSmEnumProperty.Next Method
N Methods
IAcSmEnumSheetView.Next Method
IAcSmEnumSheetSelSet.Next Method

Iterates to the next component and retrieves it.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

If the return value is S_OK, iteration can continue. If the return value is S_FALSE, iteration must stop. The macro SUCCEEDED should not be used to determine success or failure.

The caller must release the interface when the operation is complete.

Syntax

Next() As IAcSmSheetSelSet


IAcSmEnumSheetView.Next Method

IAcSmEnumSheetSelSet.Next Method
N Methods
IAcSmEnumViewCategory.Next Method
IAcSmEnumSheetView.Next Method

Iterates to the next component and retrieves it.

After an element is returned using the Next method, you can perform operations on it. The collection should be treated as read-only. Elements should not be removed during iteration because removing elements can result in inconsistencies.

If the return value is S_OK, iteration can continue. If the return value is S_FALSE, iteration must stop. The macro SUCCEEDED should not be used to determine success or failure.

The caller must release the interface when the operation is complete.

Syntax

Next() As IAcSmSheetView


IAcSmEnumViewCategory.Next Method

IAcSmEnumSheetView.Next Method
N Methods
AcSmDatabase.NotifyRegisteredEventHandlers Method
IAcSmEnumViewCategory.Next Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Next() As IAcSmViewCategory


AcSmDatabase.NotifyRegisteredEventHandlers Method

IAcSmEnumViewCategory.Next Method
N Methods
AcSmSheetSet.NotifyRegisteredEventHandlers Method
AcSmDatabase.NotifyRegisteredEventHandlers Method

Forces a notification to all registered notification handlers.

Syntax

NotifyRegisteredEventHandlers(
 eventcode As __MIDL___MIDL_itf_AcSmComponents_0265_0001,
 comp As IAcSmPersist) As Object
eventcode | Input event code
comp | Input component affected by the event


AcSmSheetSet.NotifyRegisteredEventHandlers Method

AcSmDatabase.NotifyRegisteredEventHandlers Method
N Methods
AcSmSubset.NotifyRegisteredEventHandlers Method
AcSmSheetSet.NotifyRegisteredEventHandlers Method

Forces a given notification to all registered notification handlers.

Syntax

NotifyRegisteredEventHandlers(
 eventcode As __MIDL___MIDL_itf_AcSmComponents_0265_0001,
 comp As IAcSmPersist) As Object
eventcode | Input event code
comp | Input component


AcSmSubset.NotifyRegisteredEventHandlers Method

AcSmSheetSet.NotifyRegisteredEventHandlers Method
N Methods
O Methods
AcSmSubset.NotifyRegisteredEventHandlers Method

Forces a notification to all registered notification handlers.

Syntax

NotifyRegisteredEventHandlers(
 eventcode As __MIDL___MIDL_itf_AcSmComponents_0265_0001,
 comp As IAcSmPersist) As Object
eventcode | Input event code
comp | Input component affected by the event


O Methods

AcSmSubset.NotifyRegisteredEventHandlers Method
Methods
IAcSmEvents.OnChanged Method
O Methods

Topics in this section

  • IAcSmEvents.OnChanged Method
  • AcSmSheetSetMgr.OpenDatabase Method


IAcSmEvents.OnChanged Method

O Methods
O Methods
AcSmSheetSetMgr.OpenDatabase Method
IAcSmEvents.OnChanged Method

Notification of an event.

Syntax

OnChanged(
 eventcode As __MIDL___MIDL_itf_AcSmComponents_0265_0001,
 comp As IAcSmPersist) As Object
eventcode | Input event code
comp | Input component affected by the event


AcSmSheetSetMgr.OpenDatabase Method

IAcSmEvents.OnChanged Method
O Methods
P Methods
AcSmSheetSetMgr.OpenDatabase Method

Opens an existing database and returns the new IAcSmDatabase component for it.

The caller must release the interface when the operation is complete.

Syntax

OpenDatabase(
 filename As String,
 bFailIfAlreadyOpen As Boolean = True) As IAcSmDatabase
filename | Input name of the file to open
bFailIfAlreadyOpen | Input Boolean indicating whether the method should fail if the file is already open


P Methods

AcSmSheetSetMgr.OpenDatabase Method
Methods
AcSmDSTFiler.PopCurrentReadObject Method
P Methods

Topics in this section

  • AcSmDSTFiler.PopCurrentReadObject Method
  • AcSmDSTFiler.PopCurrentWriteObject Method
  • AcSmDSTFiler.PushCurrentReadObject Method
  • AcSmDSTFiler.PushCurrentWriteObject Method


AcSmDSTFiler.PopCurrentReadObject Method

P Methods
P Methods
AcSmDSTFiler.PopCurrentWriteObject Method
AcSmDSTFiler.PopCurrentReadObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

PopCurrentReadObject(
 bSuccess As Long) As Object
bSuccess Input long; if the input value is zero, then the object read should not be added to the in-memory graph


AcSmDSTFiler.PopCurrentWriteObject Method

AcSmDSTFiler.PopCurrentReadObject Method
P Methods
AcSmDSTFiler.PushCurrentReadObject Method
AcSmDSTFiler.PopCurrentWriteObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

PopCurrentWriteObject(
 bSuccess As Long) As Object
bSuccess Input long; if the input value is not zero, then the pushed write object should be written out


AcSmDSTFiler.PushCurrentReadObject Method

AcSmDSTFiler.PopCurrentWriteObject Method
P Methods
AcSmDSTFiler.PushCurrentWriteObject Method
AcSmDSTFiler.PushCurrentReadObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

PushCurrentReadObject(
 pObj As IAcSmPersist) As Object
pObj Input pointer to the IAcSmPersistIAcSmPersist object that is being read


AcSmDSTFiler.PushCurrentWriteObject Method

AcSmDSTFiler.PushCurrentReadObject Method
P Methods
R Methods
AcSmDSTFiler.PushCurrentWriteObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

PushCurrentWriteObject(
 pObj As IAcSmPersist) As Object
pObj Input pointer to an IAcSmPersistIAcSmPersist object to push onto the stack


R Methods

AcSmDSTFiler.PushCurrentWriteObject Method
Methods
AcSmDSTFiler.ReadObject Method
R Methods

Topics in this section

  • AcSmDSTFiler.ReadObject Method
  • AcSmDSTFiler.ReadProperty Method
  • AcSmDSTFiler.ReadRawData Method
  • AcSmDatabase.RegisterOwner Method
  • AcSmDatabase.Register Method
  • AcSmSheetSet.Register Method
  • AcSmSheetSetMgr.Register Method
  • AcSmSheetSet.RemoveSheet Method
  • AcSmSubset.RemoveSheet Method
  • AcSmSheetSet.RemoveSubset Method
  • AcSmSubset.RemoveSubset Method
  • AcSmViewCategories.RemoveViewCategory Method
  • AcSmCalloutBlockReferences.Remove Method
  • AcSmCalloutBlocks.Remove Method
  • AcSmResources.Remove Method
  • AcSmSheetSelSet.Remove Method
  • AcSmSheetSelSets.Remove Method
  • IAcSmEnumAcDbBlockRecordReference.Reset Method
  • IAcSmEnumComponent.Reset Method
  • IAcSmEnumDatabase.Reset Method
  • IAcSmEnumFileReference.Reset Method
  • IAcSmEnumPersist.Reset Method
  • IAcSmEnumProperty.Reset Method
  • IAcSmEnumSheetSelSet.Reset Method
  • IAcSmEnumSheetView.Reset Method
  • IAcSmEnumViewCategory.Reset Method
  • AcSmAcDbBlockRecordReference.ResolveAcDbObject Method
  • AcSmAcDbLayoutReference.ResolveAcDbObject Method
  • AcSmAcDbObjectReference.ResolveAcDbObject Method
  • AcSmAcDbViewReference.ResolveAcDbObject Method
  • AcSmNamedAcDbObjectReference.ResolveAcDbObject Method
  • AcSmAcDbBlockRecordReference.ResolveFileName Method
  • AcSmAcDbLayoutReference.ResolveFileName Method
  • AcSmAcDbObjectReference.ResolveFileName Method
  • AcSmAcDbViewReference.ResolveFileName Method
  • AcSmFileReference.ResolveFileName Method
  • AcSmNamedAcDbObjectReference.ResolveFileName Method


AcSmDSTFiler.ReadObject Method

R Methods
R Methods
AcSmDSTFiler.ReadProperty Method
AcSmDSTFiler.ReadObject Method

This API was designed for internal use and has not been thoroughly tested.

The caller must release the IAcSmPersist object when the operation is completed.

Syntax

ReadObject() As IAcSmPersist


AcSmDSTFiler.ReadProperty Method

AcSmDSTFiler.ReadObject Method
R Methods
AcSmDSTFiler.ReadRawData Method
AcSmDSTFiler.ReadProperty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

ReadProperty(
 ppPropname As String,
 pVal As Variant) As Object
ppPropname | Output pointer to a string indicating the name of the property that is being read
pVal | Output pointer to a variant indicating the value of the property that is being read


AcSmDSTFiler.ReadRawData Method

AcSmDSTFiler.ReadProperty Method
R Methods
AcSmDatabase.RegisterOwner Method
AcSmDSTFiler.ReadRawData Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

ReadRawData(
 p As Byte,
 count As Long) As Object
p | Output pointer to the raw data buffer
count | Output pointer to the size of the raw data buffer


AcSmDatabase.RegisterOwner Method

AcSmDSTFiler.ReadRawData Method
R Methods
AcSmDatabase.Register Method
AcSmDatabase.RegisterOwner Method

Provides a way to construct component graphs using the idCookie parameter as a security key.

Syntax

RegisterOwner(
 idcookie As Long,
 pObject As IAcSmPersist,
 pOwner As IAcSmPersist) As Object
idcookie | Input security key
pObject | Input object
pOwner | Input pointer to the owner of the object


AcSmDatabase.Register Method

AcSmDatabase.RegisterOwner Method
R Methods
AcSmSheetSet.Register Method
AcSmDatabase.Register Method

Registers a callback notification handler and returns a unique cookie for the handler.

Syntax

Register(
 eventHandler As IAcSmEvents) As Long
eventHandler Input pointer to an IAcSmEvents interface


AcSmSheetSet.Register Method

AcSmDatabase.Register Method
R Methods
AcSmSheetSetMgr.Register Method
AcSmSheetSet.Register Method

Registers a callback notification handler and returns a unique cookie identifier for the handler.

Syntax

Register(
 eventHandler As IAcSmEvents) As Long
eventHandler Input IAcSmEvents interface


AcSmSheetSetMgr.Register Method

AcSmSheetSet.Register Method
R Methods
AcSmSheetSet.RemoveSheet Method
AcSmSheetSetMgr.Register Method

Registers a handler for callback notification. Returns a unique cookie for the handler.

Syntax

Register(
 eventHandler As IAcSmEvents) As Long
eventHandler Input pointer to an event handler


AcSmSheetSet.RemoveSheet Method

AcSmSheetSetMgr.Register Method
R Methods
AcSmSubset.RemoveSheet Method
AcSmSheetSet.RemoveSheet Method

Removes the specified sheet component from the collection.

Syntax

RemoveSheet(
 sheet As IAcSmSheet) As Object
sheet Input IAcSmSheet to be removed


AcSmSubset.RemoveSheet Method

AcSmSheetSet.RemoveSheet Method
R Methods
AcSmSheetSet.RemoveSubset Method
AcSmSubset.RemoveSheet Method

Removes the specified sheet component from the subset.

Syntax

RemoveSheet(
 sheet As IAcSmSheet) As Object
sheet Input sheet to be removed from the subset


AcSmSheetSet.RemoveSubset Method

AcSmSubset.RemoveSheet Method
R Methods
AcSmSubset.RemoveSubset Method
AcSmSheetSet.RemoveSubset Method

Removes the specified subset component from the collection.

Syntax

RemoveSubset(
 subset As IAcSmSubset) As Object
subset Input subset component to be removed


AcSmSubset.RemoveSubset Method

AcSmSheetSet.RemoveSubset Method
R Methods
AcSmViewCategories.RemoveViewCategory Method
AcSmSubset.RemoveSubset Method

Removes the specified subset component from the collection.

Syntax

RemoveSubset(
 subset As IAcSmSubset) As Object
subset Input subset to be removed


AcSmViewCategories.RemoveViewCategory Method

AcSmSubset.RemoveSubset Method
R Methods
AcSmCalloutBlockReferences.Remove Method
AcSmViewCategories.RemoveViewCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

RemoveViewCategory(
 viewCat As IAcSmViewCategory) As Object
viewCat View category


AcSmCalloutBlockReferences.Remove Method

AcSmViewCategories.RemoveViewCategory Method
R Methods
AcSmCalloutBlocks.Remove Method
AcSmCalloutBlockReferences.Remove Method

Removes the specified AcSmAcDbBlockRecordReference component from the collection.

Syntax

Remove(
 pBlkRef As IAcSmAcDbBlockRecordReference) As Object
pBlkRef Input component to be removed


AcSmCalloutBlocks.Remove Method

AcSmCalloutBlockReferences.Remove Method
R Methods
AcSmResources.Remove Method
AcSmCalloutBlocks.Remove Method

Removes an IAcSmAcDbBlockRecordReferenceIAcSmAcDbBlockRecordReference component from the collection.

Syntax

Remove(
 pBlkRef As IAcSmAcDbBlockRecordReference) As Object
pBlkRef Input AcSmAcDbBlockRecordReference component to remove from the collection


AcSmResources.Remove Method

AcSmCalloutBlocks.Remove Method
R Methods
AcSmSheetSelSet.Remove Method
AcSmResources.Remove Method

Removes an IAcSmFileReference component from the collection.

Syntax

Remove(
 pResource As IAcSmFileReference) As Object
pResource Input IAcSmFileReference component to remove from the collection


AcSmSheetSelSet.Remove Method

AcSmResources.Remove Method
R Methods
AcSmSheetSelSets.Remove Method
AcSmSheetSelSet.Remove Method

Removes a component from the selection set.

Syntax

Remove(
 comp As IAcSmComponent) As Object
comp Input sheet or subset to be removed from the selection set


AcSmSheetSelSets.Remove Method

AcSmSheetSelSet.Remove Method
R Methods
IAcSmEnumAcDbBlockRecordReference.Reset Method
AcSmSheetSelSets.Remove Method

Removes a selection set component from the collection.

Syntax

Remove(
 selset As IAcSmSheetSelSet) As Object
selset Input selection set component to remove from the collection


IAcSmEnumAcDbBlockRecordReference.Reset Method

AcSmSheetSelSets.Remove Method
R Methods
IAcSmEnumComponent.Reset Method
IAcSmEnumAcDbBlockRecordReference.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumComponent.Reset Method

IAcSmEnumAcDbBlockRecordReference.Reset Method
R Methods
IAcSmEnumDatabase.Reset Method
IAcSmEnumComponent.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumDatabase.Reset Method

IAcSmEnumComponent.Reset Method
R Methods
IAcSmEnumFileReference.Reset Method
IAcSmEnumDatabase.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumFileReference.Reset Method

IAcSmEnumDatabase.Reset Method
R Methods
IAcSmEnumPersist.Reset Method
IAcSmEnumFileReference.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumPersist.Reset Method

IAcSmEnumFileReference.Reset Method
R Methods
IAcSmEnumProperty.Reset Method
IAcSmEnumPersist.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumProperty.Reset Method

IAcSmEnumPersist.Reset Method
R Methods
IAcSmEnumSheetSelSet.Reset Method
IAcSmEnumProperty.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumSheetSelSet.Reset Method

IAcSmEnumProperty.Reset Method
R Methods
IAcSmEnumSheetView.Reset Method
IAcSmEnumSheetSelSet.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumSheetView.Reset Method

IAcSmEnumSheetSelSet.Reset Method
R Methods
IAcSmEnumViewCategory.Reset Method
IAcSmEnumSheetView.Reset Method

Resets the iterator to the position before the first element.

Syntax

Reset() As Object


IAcSmEnumViewCategory.Reset Method

IAcSmEnumSheetView.Reset Method
R Methods
AcSmAcDbBlockRecordReference.ResolveAcDbObject Method
IAcSmEnumViewCategory.Reset Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Reset() As Object


AcSmAcDbBlockRecordReference.ResolveAcDbObject Method

IAcSmEnumViewCategory.Reset Method
R Methods
AcSmAcDbLayoutReference.ResolveAcDbObject Method
AcSmAcDbBlockRecordReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(
 pAcDbDatabase As AcadDatabase) As String
pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmAcDbLayoutReference.ResolveAcDbObject Method

AcSmAcDbBlockRecordReference.ResolveAcDbObject Method
R Methods
AcSmAcDbObjectReference.ResolveAcDbObject Method
AcSmAcDbLayoutReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(
 pAcDbDatabase As AcadDatabase) As String
pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmAcDbObjectReference.ResolveAcDbObject Method

AcSmAcDbLayoutReference.ResolveAcDbObject Method
R Methods
AcSmAcDbViewReference.ResolveAcDbObject Method
AcSmAcDbObjectReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(
 pAcDbDatabase As AcadDatabase) As String
pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmAcDbViewReference.ResolveAcDbObject Method

AcSmAcDbObjectReference.ResolveAcDbObject Method
R Methods
AcSmNamedAcDbObjectReference.ResolveAcDbObject Method
AcSmAcDbViewReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(
 pAcDbDatabase As AcadDatabase) As String
pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObject


AcSmNamedAcDbObjectReference.ResolveAcDbObject Method

AcSmAcDbViewReference.ResolveAcDbObject Method
R Methods
AcSmAcDbBlockRecordReference.ResolveFileName Method
AcSmNamedAcDbObjectReference.ResolveAcDbObject Method

Attempts to find the referenced AcDbObject in the specified AcDbDatabase.

Syntax

ResolveAcDbObject(
 pAcDbDatabase As AcadDatabase) As String
pAcDbDatabase Input string that indicates the AcadDatabase in which to find the referenced AcDbObjectAcDbObject


AcSmAcDbBlockRecordReference.ResolveFileName Method

AcSmNamedAcDbObjectReference.ResolveAcDbObject Method
R Methods
AcSmAcDbLayoutReference.ResolveFileName Method
AcSmAcDbBlockRecordReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmAcDbLayoutReference.ResolveFileName Method

AcSmAcDbBlockRecordReference.ResolveFileName Method
R Methods
AcSmAcDbObjectReference.ResolveFileName Method
AcSmAcDbLayoutReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmAcDbObjectReference.ResolveFileName Method

AcSmAcDbLayoutReference.ResolveFileName Method
R Methods
AcSmAcDbViewReference.ResolveFileName Method
AcSmAcDbObjectReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmAcDbViewReference.ResolveFileName Method

AcSmAcDbObjectReference.ResolveFileName Method
R Methods
AcSmFileReference.ResolveFileName Method
AcSmAcDbViewReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


AcSmFileReference.ResolveFileName Method

AcSmAcDbViewReference.ResolveFileName Method
R Methods
AcSmNamedAcDbObjectReference.ResolveFileName Method
AcSmFileReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. If the file is not found, the GetReference method can be used to get the stored file name and path.

Syntax

ResolveFileName() As String


AcSmNamedAcDbObjectReference.ResolveFileName Method

AcSmFileReference.ResolveFileName Method
R Methods
S Methods
AcSmNamedAcDbObjectReference.ResolveFileName Method

Retrieves the fully qualified path to the resolved file name. S_FALSE is returned if the file is not found.

Syntax

ResolveFileName() As String


S Methods

AcSmNamedAcDbObjectReference.ResolveFileName Method
Methods
AcSmAcDbBlockRecordReference.Save Method
S Methods

Topics in this section

  • AcSmAcDbBlockRecordReference.Save Method
  • AcSmAcDbLayoutReference.Save Method
  • AcSmAcDbObjectReference.Save Method
  • AcSmAcDbViewReference.Save Method
  • AcSmCalloutBlockReferences.Save Method
  • AcSmCalloutBlocks.Save Method
  • AcSmCustomPropertyBag.Save Method
  • AcSmCustomPropertyValue.Save Method
  • AcSmDatabase.Save Method
  • AcSmFileReference.Save Method
  • AcSmNamedAcDbObjectReference.Save Method
  • AcSmObjectReference.Save Method
  • AcSmPersistProxy.Save Method
  • AcSmPublishOptions.Save Method
  • AcSmResources.Save Method
  • AcSmSheet.Save Method
  • AcSmSheetSelSet.Save Method
  • AcSmSheetSelSets.Save Method
  • AcSmSheetSet.Save Method
  • AcSmSheetView.Save Method
  • AcSmSheetViews.Save Method
  • AcSmSubset.Save Method
  • AcSmViewCategories.Save Method
  • AcSmViewCategory.Save Method
  • IAcSmComponent.Save Method
  • IAcSmPersist.Save Method
  • AcSmAcDbBlockRecordReference.SetAcDbHandle Method
  • AcSmAcDbLayoutReference.SetAcDbHandle Method
  • AcSmAcDbObjectReference.SetAcDbHandle Method
  • AcSmAcDbViewReference.SetAcDbHandle Method
  • AcSmNamedAcDbObjectReference.SetAcDbHandle Method
  • AcSmAcDbBlockRecordReference.SetAcDbObject Method
  • AcSmAcDbLayoutReference.SetAcDbObject Method
  • AcSmAcDbObjectReference.SetAcDbObject Method
  • AcSmAcDbViewReference.SetAcDbObject Method
  • AcSmNamedAcDbObjectReference.SetAcDbObject Method
  • AcSmSheetSet.SetAltPageSetups Method
  • AcSmSheet.SetCategory Method
  • AcSmSheetView.SetCategory Method
  • AcSmSheetSet.SetDefAltPageSetup Method
  • AcSmSheetSet.SetDefDwtLayout Method
  • AcSmSubset.SetDefDwtLayout Method
  • AcSmSheetSet.SetDefLabelBlk Method
  • AcSmPublishOptions.SetDefaultOutputdir Method
  • AcSmCalloutBlockReferences.SetDesc Method
  • AcSmCalloutBlocks.SetDesc Method
  • AcSmDatabase.SetDesc Method
  • AcSmResources.SetDesc Method
  • AcSmSheet.SetDesc Method
  • AcSmSheetSelSet.SetDesc Method
  • AcSmSheetSelSets.SetDesc Method
  • AcSmSheetSet.SetDesc Method
  • AcSmSheetView.SetDesc Method
  • AcSmSheetViews.SetDesc Method
  • AcSmSubset.SetDesc Method
  • AcSmViewCategories.SetDesc Method
  • AcSmViewCategory.SetDesc Method
  • IAcSmComponent.SetDesc Method
  • AcSmSheet.SetDoNotPlot Method
  • AcSmPublishOptions.SetDwfType Method
  • AcSmAcDbBlockRecordReference.SetFileName Method
  • AcSmAcDbLayoutReference.SetFileName Method
  • AcSmAcDbObjectReference.SetFileName Method
  • AcSmAcDbViewReference.SetFileName Method
  • AcSmDatabase.SetFileName Method
  • AcSmFileReference.SetFileName Method
  • AcSmNamedAcDbObjectReference.SetFileName Method
  • AcSmCustomPropertyValue.SetFlags Method
  • AcSmPublishOptions.SetIncludePlotStamp Method
  • AcSmDatabase.SetIsTemporary Method
  • AcSmSheet.SetIssuePurpose Method
  • AcSmPublishOptions.SetLayerInfo Method
  • AcSmSheet.SetLayout Method
  • AcSmAcDbBlockRecordReference.SetName Method
  • AcSmAcDbLayoutReference.SetName Method
  • AcSmAcDbViewReference.SetName Method
  • AcSmCalloutBlockReferences.SetName Method
  • AcSmCalloutBlocks.SetName Method
  • AcSmDatabase.SetName Method
  • AcSmNamedAcDbObjectReference.SetName Method
  • AcSmResources.SetName Method
  • AcSmSheet.SetName Method
  • AcSmSheetSelSet.SetName Method
  • AcSmSheetSelSets.SetName Method
  • AcSmSheetSet.SetName Method
  • AcSmSheetView.SetName Method
  • AcSmSheetViews.SetName Method
  • AcSmSubset.SetName Method
  • AcSmViewCategories.SetName Method
  • AcSmViewCategory.SetName Method
  • IAcSmComponent.SetName Method
  • AcSmSheetView.SetNamedView Method
  • AcSmSheetSet.SetNewSheetLocation Method
  • AcSmSubset.SetNewSheetLocation Method
  • AcSmSheet.SetNumber Method
  • AcSmSheetView.SetNumber Method
  • AcSmPublishOptions.SetOutputFileName Method
  • AcSmAcDbBlockRecordReference.SetOwnerAcDbHandle Method
  • AcSmAcDbLayoutReference.SetOwnerAcDbHandle Method
  • AcSmAcDbViewReference.SetOwnerAcDbHandle Method
  • AcSmNamedAcDbObjectReference.SetOwnerAcDbHandle Method
  • AcSmAcDbBlockRecordReference.SetOwner Method
  • AcSmAcDbLayoutReference.SetOwner Method
  • AcSmAcDbObjectReference.SetOwner Method
  • AcSmAcDbViewReference.SetOwner Method
  • AcSmCalloutBlockReferences.SetOwner Method
  • AcSmCalloutBlocks.SetOwner Method
  • AcSmCustomPropertyBag.SetOwner Method
  • AcSmCustomPropertyValue.SetOwner Method
  • AcSmDatabase.SetOwner Method
  • AcSmFileReference.SetOwner Method
  • AcSmNamedAcDbObjectReference.SetOwner Method
  • AcSmObjectReference.SetOwner Method
  • AcSmPersistProxy.SetOwner Method
  • AcSmPublishOptions.SetOwner Method
  • AcSmResources.SetOwner Method
  • AcSmSheet.SetOwner Method
  • AcSmSheetSelSet.SetOwner Method
  • AcSmSheetSelSets.SetOwner Method
  • AcSmSheetSet.SetOwner Method
  • AcSmSheetView.SetOwner Method
  • AcSmSheetViews.SetOwner Method
  • AcSmSubset.SetOwner Method
  • AcSmViewCategories.SetOwner Method
  • AcSmViewCategory.SetOwner Method
  • IAcSmComponent.SetOwner Method
  • IAcSmPersist.SetOwner Method
  • AcSmPublishOptions.SetPassword Method
  • AcSmSheetSet.SetProjectMilestone Method
  • AcSmSheetSet.SetProjectName Method
  • AcSmSheetSet.SetProjectNumber Method
  • AcSmSheetSet.SetProjectPhase Method
  • AcSmSheetSet.SetPromptForDwgName Method
  • AcSmSheetSet.SetPromptForDwt Method
  • AcSmSubset.SetPromptForDwt Method
  • AcSmPublishOptions.SetPromptForName Method
  • AcSmPublishOptions.SetPromptForPassword Method
  • AcSmCustomPropertyBag.SetProperty Method
  • AcSmObjectReference.SetReferenceFlags Method
  • AcSmObjectReference.SetReferencedObject Method
  • AcSmSheet.SetRevisionDate Method
  • AcSmSheet.SetRevisionNumber Method
  • AcSmSheet.SetTitle Method
  • AcSmSheetView.SetTitle Method
  • AcSmPersistProxy.SetTypeName Method
  • AcSmPublishOptions.SetUnrecognizedData Method
  • AcSmPublishOptions.SetUnrecognizedSections Method
  • AcSmPublishOptions.SetUsePassword Method
  • AcSmCustomPropertyValue.SetValue Method
  • AcSmSheetSet.Sync Method
  • AcSmSheetViews.Sync Method


AcSmAcDbBlockRecordReference.Save Method

S Methods
S Methods
AcSmAcDbLayoutReference.Save Method
AcSmAcDbBlockRecordReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save() As Object


AcSmAcDbLayoutReference.Save Method

AcSmAcDbBlockRecordReference.Save Method
S Methods
AcSmAcDbObjectReference.Save Method
AcSmAcDbLayoutReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save() As Object


AcSmAcDbObjectReference.Save Method

AcSmAcDbLayoutReference.Save Method
S Methods
AcSmAcDbViewReference.Save Method
AcSmAcDbObjectReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmAcDbViewReference.Save Method

AcSmAcDbObjectReference.Save Method
S Methods
AcSmCalloutBlockReferences.Save Method
AcSmAcDbViewReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save() As Object


AcSmCalloutBlockReferences.Save Method

AcSmAcDbViewReference.Save Method
S Methods
AcSmCalloutBlocks.Save Method
AcSmCalloutBlockReferences.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmCalloutBlocks.Save Method

AcSmCalloutBlockReferences.Save Method
S Methods
AcSmCustomPropertyBag.Save Method
AcSmCalloutBlocks.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmCustomPropertyBag.Save Method

AcSmCalloutBlocks.Save Method
S Methods
AcSmCustomPropertyValue.Save Method
AcSmCustomPropertyBag.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmCustomPropertyValue.Save Method

AcSmCustomPropertyBag.Save Method
S Methods
AcSmDatabase.Save Method
AcSmCustomPropertyValue.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmDatabase.Save Method

AcSmCustomPropertyValue.Save Method
S Methods
AcSmFileReference.Save Method
AcSmDatabase.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmFileReference.Save Method

AcSmDatabase.Save Method
S Methods
AcSmNamedAcDbObjectReference.Save Method
AcSmFileReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmNamedAcDbObjectReference.Save Method

AcSmFileReference.Save Method
S Methods
AcSmObjectReference.Save Method
AcSmNamedAcDbObjectReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmObjectReference.Save Method

AcSmNamedAcDbObjectReference.Save Method
S Methods
AcSmPersistProxy.Save Method
AcSmObjectReference.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmPersistProxy.Save Method

AcSmObjectReference.Save Method
S Methods
AcSmPublishOptions.Save Method
AcSmPersistProxy.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmPublishOptions.Save Method

AcSmPersistProxy.Save Method
S Methods
AcSmResources.Save Method
AcSmPublishOptions.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmResources.Save Method

AcSmPublishOptions.Save Method
S Methods
AcSmSheet.Save Method
AcSmResources.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheet.Save Method

AcSmResources.Save Method
S Methods
AcSmSheetSelSet.Save Method
AcSmSheet.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetSelSet.Save Method

AcSmSheet.Save Method
S Methods
AcSmSheetSelSets.Save Method
AcSmSheetSelSet.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetSelSets.Save Method

AcSmSheetSelSet.Save Method
S Methods
AcSmSheetSet.Save Method
AcSmSheetSelSets.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetSet.Save Method

AcSmSheetSelSets.Save Method
S Methods
AcSmSheetView.Save Method
AcSmSheetSet.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetView.Save Method

AcSmSheetSet.Save Method
S Methods
AcSmSheetViews.Save Method
AcSmSheetView.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSheetViews.Save Method

AcSmSheetView.Save Method
S Methods
AcSmSubset.Save Method
AcSmSheetViews.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmSubset.Save Method

AcSmSheetViews.Save Method
S Methods
AcSmViewCategories.Save Method
AcSmSubset.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmViewCategories.Save Method

AcSmSubset.Save Method
S Methods
AcSmViewCategory.Save Method
AcSmViewCategories.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmViewCategory.Save Method

AcSmViewCategories.Save Method
S Methods
IAcSmComponent.Save Method
AcSmViewCategory.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


IAcSmComponent.Save Method

AcSmViewCategory.Save Method
S Methods
IAcSmPersist.Save Method
IAcSmComponent.Save Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


IAcSmPersist.Save Method

IAcSmComponent.Save Method
S Methods
AcSmAcDbBlockRecordReference.SetAcDbHandle Method
IAcSmPersist.Save Method

Saves the object to the provided filer. This method is called when the component needs to be serialized using an IAcSmFilerIAcSmFiler object.

Syntax

Save(
 pFiler As IAcSmFiler) As Object
pFiler Input filer


AcSmAcDbBlockRecordReference.SetAcDbHandle Method

IAcSmPersist.Save Method
S Methods
AcSmAcDbLayoutReference.SetAcDbHandle Method
AcSmAcDbBlockRecordReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference. The name, without the handle, provides insufficient information about the referenced AcDbObject.

Syntax

SetAcDbHandle(
 handle As String) As Object
handle Input string that indicates the AcDbHandle to set


AcSmAcDbLayoutReference.SetAcDbHandle Method

AcSmAcDbBlockRecordReference.SetAcDbHandle Method
S Methods
AcSmAcDbObjectReference.SetAcDbHandle Method
AcSmAcDbLayoutReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference. The name, without the handle, provides insufficient information about the referenced AcDbObject.

Syntax

SetAcDbHandle(
 handle As Object) As Object
handle Input string that indicates the AcDbHandle to set


AcSmAcDbObjectReference.SetAcDbHandle Method

AcSmAcDbLayoutReference.SetAcDbHandle Method
S Methods
AcSmAcDbViewReference.SetAcDbHandle Method
AcSmAcDbObjectReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference.

Syntax

SetAcDbHandle(
 handle As String) As Object
handle Input string that indicates the AcDbHandle to set


AcSmAcDbViewReference.SetAcDbHandle Method

AcSmAcDbObjectReference.SetAcDbHandle Method
S Methods
AcSmNamedAcDbObjectReference.SetAcDbHandle Method
AcSmAcDbViewReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference. The name, without the handle, provides insufficient information about the referenced AcDbObject.

Syntax

SetAcDbHandle(
 handle As String) As Object
handle Input string that indicates the AcDbHandle to set


AcSmNamedAcDbObjectReference.SetAcDbHandle Method

AcSmAcDbViewReference.SetAcDbHandle Method
S Methods
AcSmAcDbBlockRecordReference.SetAcDbObject Method
AcSmNamedAcDbObjectReference.SetAcDbHandle Method

Sets the AcDbHandle that the object will reference. The name, without the handle, provides insufficient information about the referenced AcDbObject.

Syntax

SetAcDbHandle(
 handle As String) As Object
handle Input string that indicates the AcDbHandle to set


AcSmAcDbBlockRecordReference.SetAcDbObject Method

AcSmNamedAcDbObjectReference.SetAcDbHandle Method
S Methods
AcSmAcDbLayoutReference.SetAcDbObject Method
AcSmAcDbBlockRecordReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an AcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmAcDbLayoutReference.SetAcDbObject Method

AcSmAcDbBlockRecordReference.SetAcDbObject Method
S Methods
AcSmAcDbObjectReference.SetAcDbObject Method
AcSmAcDbLayoutReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an AcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmAcDbObjectReference.SetAcDbObject Method

AcSmAcDbLayoutReference.SetAcDbObject Method
S Methods
AcSmAcDbViewReference.SetAcDbObject Method
AcSmAcDbObjectReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an IAcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmAcDbViewReference.SetAcDbObject Method

AcSmAcDbObjectReference.SetAcDbObject Method
S Methods
AcSmNamedAcDbObjectReference.SetAcDbObject Method
AcSmAcDbViewReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an AcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmNamedAcDbObjectReference.SetAcDbObject Method

AcSmAcDbViewReference.SetAcDbObject Method
S Methods
AcSmSheetSet.SetAltPageSetups Method
AcSmNamedAcDbObjectReference.SetAcDbObject Method

Sets and modifies all properties of the object reference specified by the AcDbObject pointer.

This method is recommended for initializing an AcSmAcDbObjectReference object.

Syntax

SetAcDbObject() As Object


AcSmSheetSet.SetAltPageSetups Method

AcSmNamedAcDbObjectReference.SetAcDbObject Method
S Methods
AcSmSheet.SetCategory Method
AcSmSheetSet.SetAltPageSetups Method

Sets the IAcSmFileReference component that references the template containing alternative page setups.

Syntax

SetAltPageSetups(
 pDwtRef As IAcSmFileReference) As Object
pDwtRef Sets the IAcSmFileReference component that references a file containing alternative page setups


AcSmSheet.SetCategory Method

AcSmSheetSet.SetAltPageSetups Method
S Methods
AcSmSheetView.SetCategory Method
AcSmSheet.SetCategory Method

Sets the CategoryCategory property. Returns S_OK if successful.

Syntax

SetCategory(
 newVal As BSTR) As HRESULT
newVal Input string to set the Category property


AcSmSheetView.SetCategory Method

AcSmSheet.SetCategory Method
S Methods
AcSmSheetSet.SetDefAltPageSetup Method
AcSmSheetView.SetCategory Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetCategory(
 pViewCat As IAcSmViewCategory) As Object
pViewCat View category


AcSmSheetSet.SetDefAltPageSetup Method

AcSmSheetView.SetCategory Method
S Methods
AcSmSheetSet.SetDefDwtLayout Method
AcSmSheetSet.SetDefAltPageSetup Method

Sets the IAcSmNamedAcDbObjectReference component that references the default page setup within the template containing the alternative page setups.

Syntax

SetDefAltPageSetup(
 pAltPageSetup As IAcSmNamedAcDbObjectReference) As Object
pAltPageSetup Input object that references the default page setup within the template containing the alternative page setups


AcSmSheetSet.SetDefDwtLayout Method

AcSmSheetSet.SetDefAltPageSetup Method
S Methods
AcSmSubset.SetDefDwtLayout Method
AcSmSheetSet.SetDefDwtLayout Method

Sets the AcSmAcDbLayoutReference that points to the AcDbLayout to be used as a template for new sheet creation.

Syntax

SetDefDwtLayout(
 pLayoutRef As IAcSmAcDbLayoutReference) As Object
pLayoutRef Input reference to layout


AcSmSubset.SetDefDwtLayout Method

AcSmSheetSet.SetDefDwtLayout Method
S Methods
AcSmSheetSet.SetDefLabelBlk Method
AcSmSubset.SetDefDwtLayout Method

Sets the AcSmAcDbLayoutReference that points to the layout used as a template for new sheets.

Syntax

SetDefDwtLayout(
 pLayoutRef As IAcSmAcDbLayoutReference) As Object
pLayoutRef Input AcSmAcDbLayoutReference that points to the layout used as a template for new sheets


AcSmSheetSet.SetDefLabelBlk Method

AcSmSubset.SetDefDwtLayout Method
S Methods
AcSmPublishOptions.SetDefaultOutputdir Method
AcSmSheetSet.SetDefLabelBlk Method

Sets the AcSmAcDbBlockRecordReference component that references the label block definition for the sheet set.

Syntax

SetDefLabelBlk(
 pLabelBlkRef As IAcSmAcDbBlockRecordReference) As Object
pLabelBlkRef Input AcSmAcDbBlockRecordReference component that references the block, as a file or named block, for the sheet set


AcSmPublishOptions.SetDefaultOutputdir Method

AcSmSheetSet.SetDefLabelBlk Method
S Methods
AcSmCalloutBlockReferences.SetDesc Method
AcSmPublishOptions.SetDefaultOutputdir Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetDefaultOutputdir(
 pValue As String) As Object
pValue Input value


AcSmCalloutBlockReferences.SetDesc Method

AcSmPublishOptions.SetDefaultOutputdir Method
S Methods
AcSmCalloutBlocks.SetDesc Method
AcSmCalloutBlockReferences.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmCalloutBlocks.SetDesc Method

AcSmCalloutBlockReferences.SetDesc Method
S Methods
AcSmDatabase.SetDesc Method
AcSmCalloutBlocks.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmDatabase.SetDesc Method

AcSmCalloutBlocks.SetDesc Method
S Methods
AcSmResources.SetDesc Method
AcSmDatabase.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmResources.SetDesc Method

AcSmDatabase.SetDesc Method
S Methods
AcSmSheet.SetDesc Method
AcSmResources.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmSheet.SetDesc Method

AcSmResources.SetDesc Method
S Methods
AcSmSheetSelSet.SetDesc Method
AcSmSheet.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmSheetSelSet.SetDesc Method

AcSmSheet.SetDesc Method
S Methods
AcSmSheetSelSets.SetDesc Method
AcSmSheetSelSet.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmSheetSelSets.SetDesc Method

AcSmSheetSelSet.SetDesc Method
S Methods
AcSmSheetSet.SetDesc Method
AcSmSheetSelSets.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmSheetSet.SetDesc Method

AcSmSheetSelSets.SetDesc Method
S Methods
AcSmSheetView.SetDesc Method
AcSmSheetSet.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmSheetView.SetDesc Method

AcSmSheetSet.SetDesc Method
S Methods
AcSmSheetViews.SetDesc Method
AcSmSheetView.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmSheetViews.SetDesc Method

AcSmSheetView.SetDesc Method
S Methods
AcSmSubset.SetDesc Method
AcSmSheetViews.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmSubset.SetDesc Method

AcSmSheetViews.SetDesc Method
S Methods
AcSmViewCategories.SetDesc Method
AcSmSubset.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmViewCategories.SetDesc Method

AcSmSubset.SetDesc Method
S Methods
AcSmViewCategory.SetDesc Method
AcSmViewCategories.SetDesc Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmViewCategory.SetDesc Method

AcSmViewCategories.SetDesc Method
S Methods
IAcSmComponent.SetDesc Method
AcSmViewCategory.SetDesc Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


IAcSmComponent.SetDesc Method

AcSmViewCategory.SetDesc Method
S Methods
AcSmSheet.SetDoNotPlot Method
IAcSmComponent.SetDesc Method

Sets the description of the component.

Syntax

SetDesc(
 desc As String) As Object
desc Input string containing the text to set as the description


AcSmSheet.SetDoNotPlot Method

IAcSmComponent.SetDesc Method
S Methods
AcSmPublishOptions.SetDwfType Method
AcSmSheet.SetDoNotPlot Method

Sets a flag indicating whether a sheet should be skipped during plotting and publishing.

Syntax

SetDoNotPlot(
 doNotPlot As Boolean) As Object
doNotPlot Input Boolean indicating whether a sheet should be skipped during plotting and publishing


AcSmPublishOptions.SetDwfType Method

AcSmSheet.SetDoNotPlot Method
S Methods
AcSmAcDbBlockRecordReference.SetFileName Method
AcSmPublishOptions.SetDwfType Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetDwfType(
 value As Boolean) As Object
value Input value


AcSmAcDbBlockRecordReference.SetFileName Method

AcSmPublishOptions.SetDwfType Method
S Methods
AcSmAcDbLayoutReference.SetFileName Method
AcSmAcDbBlockRecordReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(
 pValue As String) As Object
pValue Input file name


AcSmAcDbLayoutReference.SetFileName Method

AcSmAcDbBlockRecordReference.SetFileName Method
S Methods
AcSmAcDbObjectReference.SetFileName Method
AcSmAcDbLayoutReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(
 pValue As String) As Object
pValue Input file name


AcSmAcDbObjectReference.SetFileName Method

AcSmAcDbLayoutReference.SetFileName Method
S Methods
AcSmAcDbViewReference.SetFileName Method
AcSmAcDbObjectReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(
 pValue As String) As Object
pValue Input string indicating file name


AcSmAcDbViewReference.SetFileName Method

AcSmAcDbObjectReference.SetFileName Method
S Methods
AcSmDatabase.SetFileName Method
AcSmAcDbViewReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(
 pValue As String) As Object
pValue Input file name


AcSmDatabase.SetFileName Method

AcSmAcDbViewReference.SetFileName Method
S Methods
AcSmFileReference.SetFileName Method
AcSmDatabase.SetFileName Method

Set the file name for this database. You can set the file name only once.

Syntax

SetFileName(
 newVal As String) As Object
newVal Input file name for the database


AcSmFileReference.SetFileName Method

AcSmDatabase.SetFileName Method
S Methods
AcSmNamedAcDbObjectReference.SetFileName Method
AcSmFileReference.SetFileName Method

Sets the file name that this object will reference.

A fully qualified file name should be used.

Syntax

SetFileName(
 pValue As String) As Object
pValue Input string indicating a file name and path to be referenced


AcSmNamedAcDbObjectReference.SetFileName Method

AcSmFileReference.SetFileName Method
S Methods
AcSmCustomPropertyValue.SetFlags Method
AcSmNamedAcDbObjectReference.SetFileName Method

Sets the file name that this object will reference.

Syntax

SetFileName(
 pValue As String) As Object
pValue Input file name


AcSmCustomPropertyValue.SetFlags Method

AcSmNamedAcDbObjectReference.SetFileName Method
S Methods
AcSmPublishOptions.SetIncludePlotStamp Method
AcSmCustomPropertyValue.SetFlags Method

Sets a combination of PropertyFlags enum values associated with the custom property.

Syntax

SetFlags(
 value As __MIDL___MIDL_itf_AcSmComponents_0268_0001) As Object
value Input property flags enumeration associated with the custom property


AcSmPublishOptions.SetIncludePlotStamp Method

AcSmCustomPropertyValue.SetFlags Method
S Methods
AcSmDatabase.SetIsTemporary Method
AcSmPublishOptions.SetIncludePlotStamp Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetIncludePlotStamp() As Boolean


AcSmDatabase.SetIsTemporary Method

AcSmPublishOptions.SetIncludePlotStamp Method
S Methods
AcSmSheet.SetIssuePurpose Method
AcSmDatabase.SetIsTemporary Method

Marks the database as non-persisted.

Syntax

SetIsTemporary() As Object


AcSmSheet.SetIssuePurpose Method

AcSmDatabase.SetIsTemporary Method
S Methods
AcSmPublishOptions.SetLayerInfo Method
AcSmSheet.SetIssuePurpose Method

Sets the IssuePurpose property. Returns S_OK if successful.

Syntax

SetIssuePurpose(
 newVal As BSTR) As HRESULT
newVal Input string to set the IssuePurpose property


AcSmPublishOptions.SetLayerInfo Method

AcSmSheet.SetIssuePurpose Method
S Methods
AcSmSheet.SetLayout Method
AcSmPublishOptions.SetLayerInfo Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetLayerInfo(
 value As Boolean) As Object
value Input value


AcSmSheet.SetLayout Method

AcSmPublishOptions.SetLayerInfo Method
S Methods
AcSmAcDbBlockRecordReference.SetName Method
AcSmSheet.SetLayout Method

Sets the AcSmAcDbLayoutReference object, which references the drawing and layout associated with the sheet component.

Syntax

SetLayout(
 pLayoutRef As IAcSmAcDbLayoutReference) As Object
pLayoutRef Input AcSmAcDbLayoutReference indicating the drawing and layout associated with the sheet component


AcSmAcDbBlockRecordReference.SetName Method

AcSmSheet.SetLayout Method
S Methods
AcSmAcDbLayoutReference.SetName Method
AcSmAcDbBlockRecordReference.SetName Method

Sets the name of the referenced object.

Syntax

SetName(
 name As String) As Object
name Input string containing the name of a symbol table record or dictionary entry


AcSmAcDbLayoutReference.SetName Method

AcSmAcDbBlockRecordReference.SetName Method
S Methods
AcSmAcDbViewReference.SetName Method
AcSmAcDbLayoutReference.SetName Method

Sets the name of the referenced object.

Syntax

SetName(
 name As String) As Object
name Input string containing the name of a symbol table record or dictionary entry


AcSmAcDbViewReference.SetName Method

AcSmAcDbLayoutReference.SetName Method
S Methods
AcSmCalloutBlockReferences.SetName Method
AcSmAcDbViewReference.SetName Method

Sets the name of the referenced object.

Syntax

SetName(
 name As String) As Object
name Input string containing the name of a symbol table record or dictionary entry


AcSmCalloutBlockReferences.SetName Method

AcSmAcDbViewReference.SetName Method
S Methods
AcSmCalloutBlocks.SetName Method
AcSmCalloutBlockReferences.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmCalloutBlocks.SetName Method

AcSmCalloutBlockReferences.SetName Method
S Methods
AcSmDatabase.SetName Method
AcSmCalloutBlocks.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmDatabase.SetName Method

AcSmCalloutBlocks.SetName Method
S Methods
AcSmNamedAcDbObjectReference.SetName Method
AcSmDatabase.SetName Method

Sets the NameName property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmNamedAcDbObjectReference.SetName Method

AcSmDatabase.SetName Method
S Methods
AcSmResources.SetName Method
AcSmNamedAcDbObjectReference.SetName Method

Sets the name of the referenced object.

Syntax

SetName(
 name As String) As Object
name Input string containing the name of a symbol table record or dictionary entry


AcSmResources.SetName Method

AcSmNamedAcDbObjectReference.SetName Method
S Methods
AcSmSheet.SetName Method
AcSmResources.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmSheet.SetName Method

AcSmResources.SetName Method
S Methods
AcSmSheetSelSet.SetName Method
AcSmSheet.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmSheetSelSet.SetName Method

AcSmSheet.SetName Method
S Methods
AcSmSheetSelSets.SetName Method
AcSmSheetSelSet.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmSheetSelSets.SetName Method

AcSmSheetSelSet.SetName Method
S Methods
AcSmSheetSet.SetName Method
AcSmSheetSelSets.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmSheetSet.SetName Method

AcSmSheetSelSets.SetName Method
S Methods
AcSmSheetView.SetName Method
AcSmSheetSet.SetName Method

Returns S_FALSE without setting the Name property of the component. The Name property of the component should be changed at the component level.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmSheetView.SetName Method

AcSmSheetSet.SetName Method
S Methods
AcSmSheetViews.SetName Method
AcSmSheetView.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmSheetViews.SetName Method

AcSmSheetView.SetName Method
S Methods
AcSmSubset.SetName Method
AcSmSheetViews.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmSubset.SetName Method

AcSmSheetViews.SetName Method
S Methods
AcSmViewCategories.SetName Method
AcSmSubset.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmViewCategories.SetName Method

AcSmSubset.SetName Method
S Methods
AcSmViewCategory.SetName Method
AcSmViewCategories.SetName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmViewCategory.SetName Method

AcSmViewCategories.SetName Method
S Methods
IAcSmComponent.SetName Method
AcSmViewCategory.SetName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


IAcSmComponent.SetName Method

AcSmViewCategory.SetName Method
S Methods
AcSmSheetView.SetNamedView Method
IAcSmComponent.SetName Method

Sets the Name property of the component.

Syntax

SetName(
 name As String) As Object
name Input string containing Name value


AcSmSheetView.SetNamedView Method

IAcSmComponent.SetName Method
S Methods
AcSmSheetSet.SetNewSheetLocation Method
AcSmSheetView.SetNamedView Method

Sets the AcSmAcDbViewReference that points to the named AcDbView object on the sheet referenced by this sheet view component.

Syntax

SetNamedView(
 pViewRef As IAcSmAcDbViewReference) As Object
pViewRef Input AcSmAcDbViewReference that provides a drawing name, view name, and handle for a view


AcSmSheetSet.SetNewSheetLocation Method

AcSmSheetView.SetNamedView Method
S Methods
AcSmSubset.SetNewSheetLocation Method
AcSmSheetSet.SetNewSheetLocation Method

Sets the IAcSmFileReference that points to the location in the file system where new sheets are created.

Syntax

SetNewSheetLocation(
 pFileRef As IAcSmFileReference) As Object
pFileRef Input pointer to location to be referenced


AcSmSubset.SetNewSheetLocation Method

AcSmSheetSet.SetNewSheetLocation Method
S Methods
AcSmSheet.SetNumber Method
AcSmSubset.SetNewSheetLocation Method

Sets the IAcSmFileReference that points to the location in the file system where new sheets are created.

Syntax

SetNewSheetLocation(
 pFileRef As IAcSmFileReference) As Object
pFileRef Input IAcSmFileReference pointing to the location in the file system where new sheets are created


AcSmSheet.SetNumber Method

AcSmSubset.SetNewSheetLocation Method
S Methods
AcSmSheetView.SetNumber Method
AcSmSheet.SetNumber Method

Sets the Number property of the sheet.

Syntax

SetNumber(
 num As String) As Object
num Input string indicating the sheet number


AcSmSheetView.SetNumber Method

AcSmSheet.SetNumber Method
S Methods
AcSmPublishOptions.SetOutputFileName Method
AcSmSheetView.SetNumber Method

Sets the Number property of the sheet view.

Syntax

SetNumber(
 num As String) As Object
num Input Number property of the sheet view


AcSmPublishOptions.SetOutputFileName Method

AcSmSheetView.SetNumber Method
S Methods
AcSmAcDbBlockRecordReference.SetOwnerAcDbHandle Method
AcSmPublishOptions.SetOutputFileName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOutputFileName(
 value As IAcSmFileReference) As Object
value Input value


AcSmAcDbBlockRecordReference.SetOwnerAcDbHandle Method

AcSmPublishOptions.SetOutputFileName Method
S Methods
AcSmAcDbLayoutReference.SetOwnerAcDbHandle Method
AcSmAcDbBlockRecordReference.SetOwnerAcDbHandle Method

Sets the AcDbHandle of the owning AcDbObject.

Syntax

SetOwnerAcDbHandle(
 handle As String) As Object
handle Input string that indicates the AcDbHandle to set


AcSmAcDbLayoutReference.SetOwnerAcDbHandle Method

AcSmAcDbBlockRecordReference.SetOwnerAcDbHandle Method
S Methods
AcSmAcDbViewReference.SetOwnerAcDbHandle Method
AcSmAcDbLayoutReference.SetOwnerAcDbHandle Method

Sets the AcDbHandle of the owning AcDbObject.

Syntax

SetOwnerAcDbHandle(
 handle As String) As Object
handle Input string that indicates the AcDbHandle to set


AcSmAcDbViewReference.SetOwnerAcDbHandle Method

AcSmAcDbLayoutReference.SetOwnerAcDbHandle Method
S Methods
AcSmNamedAcDbObjectReference.SetOwnerAcDbHandle Method
AcSmAcDbViewReference.SetOwnerAcDbHandle Method

Sets the AcDbHandle of the owning AcDbObject.

Syntax

SetOwnerAcDbHandle(
 handle As String) As Object
handle Input string that indicates the AcDbHandleAcDbHandle to set


AcSmNamedAcDbObjectReference.SetOwnerAcDbHandle Method

AcSmAcDbViewReference.SetOwnerAcDbHandle Method
S Methods
AcSmAcDbBlockRecordReference.SetOwner Method
AcSmNamedAcDbObjectReference.SetOwnerAcDbHandle Method

Sets the AcDbHandle of the owning AcDbObject.

Syntax

SetOwnerAcDbHandle(
 handle As String) As Object
handle Input string that indicates the AcDbHandle to set


AcSmAcDbBlockRecordReference.SetOwner Method

AcSmNamedAcDbObjectReference.SetOwnerAcDbHandle Method
S Methods
AcSmAcDbLayoutReference.SetOwner Method
AcSmAcDbBlockRecordReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmAcDbLayoutReference.SetOwner Method

AcSmAcDbBlockRecordReference.SetOwner Method
S Methods
AcSmAcDbObjectReference.SetOwner Method
AcSmAcDbLayoutReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmAcDbObjectReference.SetOwner Method

AcSmAcDbLayoutReference.SetOwner Method
S Methods
AcSmAcDbViewReference.SetOwner Method
AcSmAcDbObjectReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmAcDbViewReference.SetOwner Method

AcSmAcDbObjectReference.SetOwner Method
S Methods
AcSmCalloutBlockReferences.SetOwner Method
AcSmAcDbViewReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmCalloutBlockReferences.SetOwner Method

AcSmAcDbViewReference.SetOwner Method
S Methods
AcSmCalloutBlocks.SetOwner Method
AcSmCalloutBlockReferences.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmCalloutBlocks.SetOwner Method

AcSmCalloutBlockReferences.SetOwner Method
S Methods
AcSmCustomPropertyBag.SetOwner Method
AcSmCalloutBlocks.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmCustomPropertyBag.SetOwner Method

AcSmCalloutBlocks.SetOwner Method
S Methods
AcSmCustomPropertyValue.SetOwner Method
AcSmCustomPropertyBag.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmCustomPropertyValue.SetOwner Method

AcSmCustomPropertyBag.SetOwner Method
S Methods
AcSmDatabase.SetOwner Method
AcSmCustomPropertyValue.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmDatabase.SetOwner Method

AcSmCustomPropertyValue.SetOwner Method
S Methods
AcSmFileReference.SetOwner Method
AcSmDatabase.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmFileReference.SetOwner Method

AcSmDatabase.SetOwner Method
S Methods
AcSmNamedAcDbObjectReference.SetOwner Method
AcSmFileReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmNamedAcDbObjectReference.SetOwner Method

AcSmFileReference.SetOwner Method
S Methods
AcSmObjectReference.SetOwner Method
AcSmNamedAcDbObjectReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmObjectReference.SetOwner Method

AcSmNamedAcDbObjectReference.SetOwner Method
S Methods
AcSmPersistProxy.SetOwner Method
AcSmObjectReference.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmPersistProxy.SetOwner Method

AcSmObjectReference.SetOwner Method
S Methods
AcSmPublishOptions.SetOwner Method
AcSmPersistProxy.SetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmPublishOptions.SetOwner Method

AcSmPersistProxy.SetOwner Method
S Methods
AcSmResources.SetOwner Method
AcSmPublishOptions.SetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmResources.SetOwner Method

AcSmPublishOptions.SetOwner Method
S Methods
AcSmSheet.SetOwner Method
AcSmResources.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheet.SetOwner Method

AcSmResources.SetOwner Method
S Methods
AcSmSheetSelSet.SetOwner Method
AcSmSheet.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetSelSet.SetOwner Method

AcSmSheet.SetOwner Method
S Methods
AcSmSheetSelSets.SetOwner Method
AcSmSheetSelSet.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetSelSets.SetOwner Method

AcSmSheetSelSet.SetOwner Method
S Methods
AcSmSheetSet.SetOwner Method
AcSmSheetSelSets.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetSet.SetOwner Method

AcSmSheetSelSets.SetOwner Method
S Methods
AcSmSheetView.SetOwner Method
AcSmSheetSet.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetView.SetOwner Method

AcSmSheetSet.SetOwner Method
S Methods
AcSmSheetViews.SetOwner Method
AcSmSheetView.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSheetViews.SetOwner Method

AcSmSheetView.SetOwner Method
S Methods
AcSmSubset.SetOwner Method
AcSmSheetViews.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmSubset.SetOwner Method

AcSmSheetViews.SetOwner Method
S Methods
AcSmViewCategories.SetOwner Method
AcSmSubset.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmViewCategories.SetOwner Method

AcSmSubset.SetOwner Method
S Methods
AcSmViewCategory.SetOwner Method
AcSmViewCategories.SetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmViewCategory.SetOwner Method

AcSmViewCategories.SetOwner Method
S Methods
IAcSmComponent.SetOwner Method
AcSmViewCategory.SetOwner Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


IAcSmComponent.SetOwner Method

AcSmViewCategory.SetOwner Method
S Methods
IAcSmPersist.SetOwner Method
IAcSmComponent.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


IAcSmPersist.SetOwner Method

IAcSmComponent.SetOwner Method
S Methods
AcSmPublishOptions.SetPassword Method
IAcSmPersist.SetOwner Method

Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.

Syntax

SetOwner(
 pOwner As IAcSmPersist) As Object
pOwner Input pointer to the owner of the object


AcSmPublishOptions.SetPassword Method

IAcSmPersist.SetOwner Method
S Methods
AcSmSheetSet.SetProjectMilestone Method
AcSmPublishOptions.SetPassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetPassword() As Object


AcSmSheetSet.SetProjectMilestone Method

AcSmPublishOptions.SetPassword Method
S Methods
AcSmSheetSet.SetProjectName Method
AcSmSheetSet.SetProjectMilestone Method

Sets the ProjectMilestone property. Returns S_OK if successful.

Syntax

SetProjectMilestone(
 newVal As BSTR) As HRESULT
newVal Input string to set the ProjectMilestone property


AcSmSheetSet.SetProjectName Method

AcSmSheetSet.SetProjectMilestone Method
S Methods
AcSmSheetSet.SetProjectNumber Method
AcSmSheetSet.SetProjectName Method

Sets the project name associated with this sheet set. Returns S_OK if successful.

Syntax

SetProjectName(
 newVal As BSTR) As HRESULT
newVal Input string to set the ProjectNameProjectName property


AcSmSheetSet.SetProjectNumber Method

AcSmSheetSet.SetProjectName Method
S Methods
AcSmSheetSet.SetProjectPhase Method
AcSmSheetSet.SetProjectNumber Method

Sets the project number associated with this sheet set. Returns S_OK if successful.

Syntax

SetProjectNumber(
 newVal As BSTR) As HRESULT
newVal Input string to set the ProjectNumber property


AcSmSheetSet.SetProjectPhase Method

AcSmSheetSet.SetProjectNumber Method
S Methods
AcSmSheetSet.SetPromptForDwgName Method
AcSmSheetSet.SetProjectPhase Method

Sets the ProjectPhase property. Returns S_OK if successful.

Syntax

SetProjectPhase(
 newVal As BSTR) As HRESULT
newVal Input string to set the ProjectPhase property


AcSmSheetSet.SetPromptForDwgName Method

AcSmSheetSet.SetProjectPhase Method
S Methods
AcSmSheetSet.SetPromptForDwt Method
AcSmSheetSet.SetPromptForDwgName Method

Sets the flag indicating whether the user interface should prompt for the name of a new drawing.

Syntax

SetPromptForDwgName(
 askForName As Boolean) As Object
askForName Input Boolean indicating whether the user interface should prompt for the name of a new drawing


AcSmSheetSet.SetPromptForDwt Method

AcSmSheetSet.SetPromptForDwgName Method
S Methods
AcSmSubset.SetPromptForDwt Method
AcSmSheetSet.SetPromptForDwt Method

Sets the Boolean flag that indicates whether the application should prompt for a DWT file.

Syntax

SetPromptForDwt(
 askForDwt As Boolean) As Object
askForDwt Input flag indicating whether the application should prompt for a DWT file


AcSmSubset.SetPromptForDwt Method

AcSmSheetSet.SetPromptForDwt Method
S Methods
AcSmPublishOptions.SetPromptForName Method
AcSmSubset.SetPromptForDwt Method

Sets a Boolean flag indicating if the application should prompt for a DWT file.

Syntax

SetPromptForDwt(
 askForDwt As Boolean) As Object
askForDwt Input Boolean flag indicating if the application should prompt for a DWT file


AcSmPublishOptions.SetPromptForName Method

AcSmSubset.SetPromptForDwt Method
S Methods
AcSmPublishOptions.SetPromptForPassword Method
AcSmPublishOptions.SetPromptForName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetPromptForName(
 value As Boolean) As Object
value Input value


AcSmPublishOptions.SetPromptForPassword Method

AcSmPublishOptions.SetPromptForName Method
S Methods
AcSmCustomPropertyBag.SetProperty Method
AcSmPublishOptions.SetPromptForPassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetPromptForPassword(
 value As Boolean) As Object
value Input Boolean indicating whether to prompt for password


AcSmCustomPropertyBag.SetProperty Method

AcSmPublishOptions.SetPromptForPassword Method
S Methods
AcSmObjectReference.SetReferenceFlags Method
AcSmCustomPropertyBag.SetProperty Method

Sets the IAcSmCustomPropertyValue specified with the Name parameter.

You can remove a property by specifying a null IAcSmCustomPropertyValue value.

Syntax

SetProperty(
 name As String,
 value As IAcSmCustomPropertyValue) As Object
name | Input string containing the Name value of a property
value | Input pointer to a properly initialized IAcSmCustomPropertyValue


AcSmObjectReference.SetReferenceFlags Method

AcSmCustomPropertyBag.SetProperty Method
S Methods
AcSmObjectReference.SetReferencedObject Method
AcSmObjectReference.SetReferenceFlags Method

Sets the reference flags to hard referencing or soft referencing.

Syntax

SetReferenceFlags(
 value As AcSmObjectReferenceFlags) As Object
value Input flag for hard referencing or for soft referencing


AcSmObjectReference.SetReferencedObject Method

AcSmObjectReference.SetReferenceFlags Method
S Methods
AcSmSheet.SetRevisionDate Method
AcSmObjectReference.SetReferencedObject Method

Sets the IAcSmPersist object to reference.

Syntax

SetReferencedObject(
 pObject As IAcSmPersist) As Object
pObject Input pointer to the IAcSmPersist object to reference


AcSmSheet.SetRevisionDate Method

AcSmObjectReference.SetReferencedObject Method
S Methods
AcSmSheet.SetRevisionNumber Method
AcSmSheet.SetRevisionDate Method

Sets the RevisionDate property. Returns S_OK if successful.

Syntax

SetRevisionDate(
 newVal As BSTR) As HRESULT
newVal Input string to set the RevisionDate property


AcSmSheet.SetRevisionNumber Method

AcSmSheet.SetRevisionDate Method
S Methods
AcSmSheet.SetTitle Method
AcSmSheet.SetRevisionNumber Method

Sets the RevisionNumber property. Returns S_OK if successful.

Syntax

SetRevisionNumber(
 newVal As BSTR) As HRESULT
newVal Input string to set the RevisionNumberRevisionNumber property


AcSmSheet.SetTitle Method

AcSmSheet.SetRevisionNumber Method
S Methods
AcSmSheetView.SetTitle Method
AcSmSheet.SetTitle Method

Sets the title of the sheet.

Syntax

SetTitle(
 title As String) As Object
title Input string containing the title of the sheet


AcSmSheetView.SetTitle Method

AcSmSheet.SetTitle Method
S Methods
AcSmPersistProxy.SetTypeName Method
AcSmSheetView.SetTitle Method

Sets the TitleTitle property of the sheet view.

Syntax

SetTitle(
 title As String) As Object
title Input Title property of the sheet view


AcSmPersistProxy.SetTypeName Method

AcSmSheetView.SetTitle Method
S Methods
AcSmPublishOptions.SetUnrecognizedData Method
AcSmPersistProxy.SetTypeName Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetTypeName(
 value As String) As Object
value Input value


AcSmPublishOptions.SetUnrecognizedData Method

AcSmPersistProxy.SetTypeName Method
S Methods
AcSmPublishOptions.SetUnrecognizedSections Method
AcSmPublishOptions.SetUnrecognizedData Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetUnrecognizedData() As Object


AcSmPublishOptions.SetUnrecognizedSections Method

AcSmPublishOptions.SetUnrecognizedData Method
S Methods
AcSmPublishOptions.SetUsePassword Method
AcSmPublishOptions.SetUnrecognizedSections Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetUnrecognizedSections() As Object


AcSmPublishOptions.SetUsePassword Method

AcSmPublishOptions.SetUnrecognizedSections Method
S Methods
AcSmCustomPropertyValue.SetValue Method
AcSmPublishOptions.SetUsePassword Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

SetUsePassword(
 value As Boolean) As Object
value Input value


AcSmCustomPropertyValue.SetValue Method

AcSmPublishOptions.SetUsePassword Method
S Methods
AcSmSheetSet.Sync Method
AcSmCustomPropertyValue.SetValue Method

Sets the variant value associated with the custom property.

Syntax

SetValue(
 value As Variant) As Object
value Input variant value to associate with the custom property


AcSmSheetSet.Sync Method

AcSmCustomPropertyValue.SetValue Method
S Methods
AcSmSheetViews.Sync Method
AcSmSheetSet.Sync Method

Updates the sheet view components in the sheet set of the provided AcadDatabase object.

Syntax

Sync(
 pXDb As IAcadDatabase) As Object
pXDb Input IAcadDatabase object


AcSmSheetViews.Sync Method

AcSmSheetSet.Sync Method
S Methods
U Methods
AcSmSheetViews.Sync Method

Updates the sheet view components in the collection according to the provided AcSmAcDbLayoutReference and IAcadDatabase.

Syntax

Sync(
 pLayout As IAcSmAcDbLayoutReference,
 pXDb As IAcadDatabase) As Object
pLayout | Input AcSmAcDbLayoutReference to update
pXDb | Input IAcadDatabase to use for the update


U Methods

AcSmSheetViews.Sync Method
Methods
AcSmDatabase.UnlockDb Method
U Methods

Topics in this section

  • AcSmDatabase.UnlockDb Method
  • AcSmDatabase.Unregister Method
  • AcSmSheetSet.Unregister Method
  • AcSmSheetSetMgr.Unregister Method
  • AcSmDatabase.UpdateInMemoryDwgHints Method
  • AcSmSheetSet.UpdateInMemoryDwgHints Method
  • AcSmSubset.UpdateInMemoryDwgHints Method


AcSmDatabase.UnlockDb Method

U Methods
U Methods
AcSmDatabase.Unregister Method
AcSmDatabase.UnlockDb Method

Unlocks the database.

Use the bCommit parameter to specify if changes should be saved to disk.

Syntax

UnlockDb(
 pObject As Object,
 bCommit As Boolean = True) As Object
pObject | Input owner of the database lock
bCommit | Input Boolean specifying True if changes should be saved to disk


AcSmDatabase.Unregister Method

AcSmDatabase.UnlockDb Method
U Methods
AcSmSheetSet.Unregister Method
AcSmDatabase.Unregister Method

Unregisters a callback notification handler that was previously registered.

Syntax

Unregister(
 cookie As Long) As Object
cookie Input long indicating the cookie value for the Register call


AcSmSheetSet.Unregister Method

AcSmDatabase.Unregister Method
U Methods
AcSmSheetSetMgr.Unregister Method
AcSmSheetSet.Unregister Method

Unregisters a callback notification handler that was previously registered.

Syntax

Unregister(
 cookie As Long) As Object
cookie Input cookie value received in the registration call


AcSmSheetSetMgr.Unregister Method

AcSmSheetSet.Unregister Method
U Methods
AcSmDatabase.UpdateInMemoryDwgHints Method
AcSmSheetSetMgr.Unregister Method

Unregisters a callback notification handler that was previously registered.

Syntax

Unregister(
 cookie As Long) As Object
cookie Input cookie value received in the RegisterRegister call


AcSmDatabase.UpdateInMemoryDwgHints Method

AcSmSheetSetMgr.Unregister Method
U Methods
AcSmSheetSet.UpdateInMemoryDwgHints Method
AcSmDatabase.UpdateInMemoryDwgHints Method

Updates the hints in the open drawings referenced by this database.

Syntax

UpdateInMemoryDwgHints() As Object


AcSmSheetSet.UpdateInMemoryDwgHints Method

AcSmDatabase.UpdateInMemoryDwgHints Method
U Methods
AcSmSubset.UpdateInMemoryDwgHints Method
AcSmSheetSet.UpdateInMemoryDwgHints Method

Updates the hints in the open drawings referenced in the subset.

Syntax

UpdateInMemoryDwgHints() As Object


AcSmSubset.UpdateInMemoryDwgHints Method

AcSmSheetSet.UpdateInMemoryDwgHints Method
U Methods
W Methods
AcSmSubset.UpdateInMemoryDwgHints Method

Updates the hints in the open drawings referenced in the subset.

Syntax

UpdateInMemoryDwgHints() As Object


W Methods

AcSmSubset.UpdateInMemoryDwgHints Method
Methods
AcSmDSTFiler.WriteObject Method
W Methods

Topics in this section

  • AcSmDSTFiler.WriteObject Method
  • AcSmDSTFiler.WriteProperty Method
  • AcSmDSTFiler.WriteRawData Method


AcSmDSTFiler.WriteObject Method

W Methods
W Methods
AcSmDSTFiler.WriteProperty Method
AcSmDSTFiler.WriteObject Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

WriteObject(
 pObj As IAcSmPersist) As Object
pObj Input pointer to the IAcSmPersist object to write


AcSmDSTFiler.WriteProperty Method

AcSmDSTFiler.WriteObject Method
W Methods
AcSmDSTFiler.WriteRawData Method
AcSmDSTFiler.WriteProperty Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

WriteProperty(
 pPropname As String,
 pVal As Variant) As Object
pPropname | Input string indicating the name of the property to be written
pVal | Input variant indicating the value of the property to be written


AcSmDSTFiler.WriteRawData Method

AcSmDSTFiler.WriteProperty Method
W Methods
Properties
AcSmDSTFiler.WriteRawData Method

This API was designed for internal use and has not been thoroughly tested.

Syntax

WriteRawData(
 p As Byte,
 count As Long) As Object
p | Input pointer to the raw data buffer
count | Input pointer to the size of the raw data buffer


Properties

AcSmDSTFiler.WriteRawData Method
A Properties
Properties

Topics in this section

  • A Properties
  • C Properties
  • E Properties
  • M Properties
  • S Properties


A Properties

Properties
Properties
AcSmEvent.ACSM_DATABASE_CHANGED Property
A Properties

Topics in this section

  • AcSmEvent.ACSM_DATABASE_CHANGED Property
  • AcSmEvent.ACSM_DATABASE_CREATED Property
  • AcSmEvent.ACSM_DATABASE_IS_CLOSING Property
  • AcSmEvent.ACSM_DATABASE_LOAD_BEGIN Property
  • AcSmEvent.ACSM_DATABASE_LOAD_COMPLETE Property
  • AcSmEvent.ACSM_DATABASE_LOAD_FAILED Property
  • AcSmEvent.ACSM_DATABASE_LOCKED Property
  • AcSmEvent.ACSM_DATABASE_OPENED Property
  • AcSmEvent.ACSM_DATABASE_UNLOCKED Property


AcSmEvent.ACSM_DATABASE_CHANGED Property

A Properties
A Properties
AcSmEvent.ACSM_DATABASE_CREATED Property
AcSmEvent.ACSM_DATABASE_CHANGED Property

Event signifying that the database changed on disk. In response to this event, programs usually should use the LoadFromFile method of the AcSmDatabase object. The LoadFromFile method updates the database so it is the same as the database version on disk.

Syntax

ACSM_DATABASE_CHANGED() As Long


AcSmEvent.ACSM_DATABASE_CREATED Property

AcSmEvent.ACSM_DATABASE_CHANGED Property
A Properties
AcSmEvent.ACSM_DATABASE_IS_CLOSING Property
AcSmEvent.ACSM_DATABASE_CREATED Property

Event signifying that a database was created.

Syntax

ACSM_DATABASE_CREATED() As Long


AcSmEvent.ACSM_DATABASE_IS_CLOSING Property

AcSmEvent.ACSM_DATABASE_CREATED Property
A Properties
AcSmEvent.ACSM_DATABASE_LOAD_BEGIN Property
AcSmEvent.ACSM_DATABASE_IS_CLOSING Property

Event signifying that an AcSmDatabase object is closing.

Syntax

ACSM_DATABASE_IS_CLOSING() As Long


AcSmEvent.ACSM_DATABASE_LOAD_BEGIN Property

AcSmEvent.ACSM_DATABASE_IS_CLOSING Property
A Properties
AcSmEvent.ACSM_DATABASE_LOAD_COMPLETE Property
AcSmEvent.ACSM_DATABASE_LOAD_BEGIN Property

Event signifying that a database began loading in memory from disk.

Syntax

ACSM_DATABASE_LOAD_BEGIN() As Long


AcSmEvent.ACSM_DATABASE_LOAD_COMPLETE Property

AcSmEvent.ACSM_DATABASE_LOAD_BEGIN Property
A Properties
AcSmEvent.ACSM_DATABASE_LOAD_FAILED Property
AcSmEvent.ACSM_DATABASE_LOAD_COMPLETE Property

Event signifying that a database completed a load into memory from disk.

Syntax

ACSM_DATABASE_LOAD_COMPLETE() As Long


AcSmEvent.ACSM_DATABASE_LOAD_FAILED Property

AcSmEvent.ACSM_DATABASE_LOAD_COMPLETE Property
A Properties
AcSmEvent.ACSM_DATABASE_LOCKED Property
AcSmEvent.ACSM_DATABASE_LOAD_FAILED Property

Event signifying that a database failed to load in memory from disk.

Syntax

ACSM_DATABASE_LOAD_FAILED() As Long


AcSmEvent.ACSM_DATABASE_LOCKED Property

AcSmEvent.ACSM_DATABASE_LOAD_FAILED Property
A Properties
AcSmEvent.ACSM_DATABASE_OPENED Property
AcSmEvent.ACSM_DATABASE_LOCKED Property

Event signifying that the database is locked.

Syntax

ACSM_DATABASE_LOCKED() As Long


AcSmEvent.ACSM_DATABASE_OPENED Property

AcSmEvent.ACSM_DATABASE_LOCKED Property
A Properties
AcSmEvent.ACSM_DATABASE_UNLOCKED Property
AcSmEvent.ACSM_DATABASE_OPENED Property

Event signifying that the database is opened.

Syntax

ACSM_DATABASE_OPENED() As Long


AcSmEvent.ACSM_DATABASE_UNLOCKED Property

AcSmEvent.ACSM_DATABASE_OPENED Property
A Properties
C Properties
AcSmEvent.ACSM_DATABASE_UNLOCKED Property

Event signifying that the database is unlocked.

Syntax

ACSM_DATABASE_UNLOCKED() As Long


C Properties

AcSmEvent.ACSM_DATABASE_UNLOCKED Property
Properties
AcSmEvent.CALLOUT_BLOCK_ADDED Property
C Properties

Topics in this section

  • AcSmEvent.CALLOUT_BLOCK_ADDED Property
  • AcSmEvent.CALLOUT_BLOCK_DELETED Property
  • AcSmEvent.CUSTOM_SHEET_PROP Property


AcSmEvent.CALLOUT_BLOCK_ADDED Property

C Properties
C Properties
AcSmEvent.CALLOUT_BLOCK_DELETED Property
AcSmEvent.CALLOUT_BLOCK_ADDED Property

Event signifying that a callout block was added.

Syntax

CALLOUT_BLOCK_ADDED() As Long


AcSmEvent.CALLOUT_BLOCK_DELETED Property

AcSmEvent.CALLOUT_BLOCK_ADDED Property
C Properties
AcSmEvent.CUSTOM_SHEET_PROP Property
AcSmEvent.CALLOUT_BLOCK_DELETED Property

Event signifying that a callout block was deleted.

Syntax

CALLOUT_BLOCK_DELETED() As Long


AcSmEvent.CUSTOM_SHEET_PROP Property

AcSmEvent.CALLOUT_BLOCK_DELETED Property
C Properties
E Properties
AcSmEvent.CUSTOM_SHEET_PROP Property

The value specifies that a custom property is automatically inherited from the sheet set to its sheets.

Syntax

CUSTOM_SHEET_PROP() As Long


E Properties

AcSmEvent.CUSTOM_SHEET_PROP Property
Properties
PropertyFlags.EMPTY Property
E Properties

Topics in this section

  • PropertyFlags.EMPTY Property


PropertyFlags.EMPTY Property

E Properties
E Properties
M Properties
PropertyFlags.EMPTY Property

The value is zero.

Syntax

EMPTY() As Long


M Properties

PropertyFlags.EMPTY Property
Properties
AcSmEvent.MODEL_RESOURCE_ADDED Property
M Properties

Topics in this section

  • AcSmEvent.MODEL_RESOURCE_ADDED Property
  • AcSmEvent.MODEL_RESOURCE_DELETED Property


AcSmEvent.MODEL_RESOURCE_ADDED Property

M Properties
M Properties
AcSmEvent.MODEL_RESOURCE_DELETED Property
AcSmEvent.MODEL_RESOURCE_ADDED Property

Event signifying that a model resource was added.

Syntax

MODEL_RESOURCE_ADDED() As Long


AcSmEvent.MODEL_RESOURCE_DELETED Property

AcSmEvent.MODEL_RESOURCE_ADDED Property
M Properties
S Properties
AcSmEvent.MODEL_RESOURCE_DELETED Property

Event signifying that a model resource was deleted.

Syntax

MODEL_RESOURCE_DELETED() As Long


S Properties

AcSmEvent.MODEL_RESOURCE_DELETED Property
Properties
AcSmEvent.SHEETS_RENUMBERED Property
S Properties

Topics in this section

  • AcSmEvent.SHEETS_RENUMBERED Property
  • AcSmEvent.SHEET_ADDED Property
  • AcSmEvent.SHEET_DELETED Property
  • AcSmEvent.SHEET_SELECTION_SET_CREATED Property
  • AcSmEvent.SHEET_SELECTION_SET_DELETED Property
  • AcSmEvent.SHEET_SUBSET_CREATED Property
  • AcSmEvent.SHEET_SUBSET_DELETED Property
  • AcSmEvent.SHEET_VIEW_CATEGORY_CREATED Property
  • AcSmEvent.SHEET_VIEW_CATEGORY_DELETED Property
  • AcSmEvent.SHEET_VIEW_CREATED Property
  • AcSmEvent.SHEET_VIEW_DELETED Property


AcSmEvent.SHEETS_RENUMBERED Property

S Properties
S Properties
AcSmEvent.SHEET_ADDED Property
AcSmEvent.SHEETS_RENUMBERED Property

This API was designed for internal use and has not been thoroughly tested.

Syntax

SHEETS_RENUMBERED() As Long


AcSmEvent.SHEET_ADDED Property

AcSmEvent.SHEETS_RENUMBERED Property
S Properties
AcSmEvent.SHEET_DELETED Property
AcSmEvent.SHEET_ADDED Property

Event signifying that a sheet was added.

Syntax

SHEET_ADDED() As Long


AcSmEvent.SHEET_DELETED Property

AcSmEvent.SHEET_ADDED Property
S Properties
AcSmEvent.SHEET_SELECTION_SET_CREATED Property
AcSmEvent.SHEET_DELETED Property

Event signifying that a sheet was deleted.

Syntax

SHEET_DELETED() As Long


AcSmEvent.SHEET_SELECTION_SET_CREATED Property

AcSmEvent.SHEET_DELETED Property
S Properties
AcSmEvent.SHEET_SELECTION_SET_DELETED Property
AcSmEvent.SHEET_SELECTION_SET_CREATED Property

Event signifying that a sheet selection set was created.

Syntax

SHEET_SELECTION_SET_CREATED() As Long


AcSmEvent.SHEET_SELECTION_SET_DELETED Property

AcSmEvent.SHEET_SELECTION_SET_CREATED Property
S Properties
AcSmEvent.SHEET_SUBSET_CREATED Property
AcSmEvent.SHEET_SELECTION_SET_DELETED Property

Event signifying that a sheet selection set was deleted.

Syntax

SHEET_SELECTION_SET_DELETED() As Long


AcSmEvent.SHEET_SUBSET_CREATED Property

AcSmEvent.SHEET_SELECTION_SET_DELETED Property
S Properties
AcSmEvent.SHEET_SUBSET_DELETED Property
AcSmEvent.SHEET_SUBSET_CREATED Property

Event signifying that a sheet subset was created.

Syntax

SHEET_SUBSET_CREATED() As Long


AcSmEvent.SHEET_SUBSET_DELETED Property

AcSmEvent.SHEET_SUBSET_CREATED Property
S Properties
AcSmEvent.SHEET_VIEW_CATEGORY_CREATED Property
AcSmEvent.SHEET_SUBSET_DELETED Property

Event signifying that a sheet subset was deleted.

Syntax

SHEET_SUBSET_DELETED() As Long


AcSmEvent.SHEET_VIEW_CATEGORY_CREATED Property

AcSmEvent.SHEET_SUBSET_DELETED Property
S Properties
AcSmEvent.SHEET_VIEW_CATEGORY_DELETED Property
AcSmEvent.SHEET_VIEW_CATEGORY_CREATED Property

Event signifying that a sheet view category was deleted.

Syntax

SHEET_VIEW_CATEGORY_DELETED() As Long


AcSmEvent.SHEET_VIEW_CATEGORY_DELETED Property

AcSmEvent.SHEET_VIEW_CATEGORY_CREATED Property
S Properties
AcSmEvent.SHEET_VIEW_CREATED Property
AcSmEvent.SHEET_VIEW_CATEGORY_DELETED Property

Event signifying that a sheet view category was deleted.

Syntax

SHEET_VIEW_CATEGORY_DELETED() As Long


AcSmEvent.SHEET_VIEW_CREATED Property

AcSmEvent.SHEET_VIEW_CATEGORY_DELETED Property
S Properties
AcSmEvent.SHEET_VIEW_DELETED Property
AcSmEvent.SHEET_VIEW_CREATED Property

Event signifying that a sheet view was created.

Syntax

SHEET_VIEW_CREATED() As Long


AcSmEvent.SHEET_VIEW_DELETED Property

AcSmEvent.SHEET_VIEW_CREATED Property
S Properties
Enums
AcSmEvent.SHEET_VIEW_DELETED Property

Event signifying that a sheet view was deleted.

Syntax

SHEET_VIEW_DELETED() As Long


Enums

AcSmEvent.SHEET_VIEW_DELETED Property
A Enums
Enums

Topics in this section

  • A Enums


A Enums

Enums
Enums
AcSmLockStatus
A Enums

Topics in this section

  • AcSmLockStatus
  • AcSmObjectReferenceFlags


AcSmLockStatus

A Enums
A Enums
AcSmObjectReferenceFlags
AcSmLockStatus

Lock status of an IAcSmDatabase, based on bitcode values.

Name | Value | Description
AcSmLockStatus_Locked_Local | 1 | The database is locked and open for write access.
AcSmLockStatus_Locked_ReadOnly | 4 | Write access to the database is denied because it is read-only.
AcSmLockStatus_Locked_Remote | 2 | Write access to the database is denied because it is remote.
AcSmLockStatus_UnLocked | 0 | Write access to the database is denied because it was not locked.
AcSmLockStatus_Locked_AccessDenied | 16 | Access to the database is denied due to lack of rights for access.
AcSmLockStatus_Locked_NotConnected | 8 | Access to the database is denied due to a lost connection to the database.


AcSmObjectReferenceFlags

AcSmLockStatus
A Enums
AcSmObjectReferenceFlags

The kind of referencing provided by an IAcSmObjectReference. An IAcSmObjectReference is used to create an object reference from one component to another.

Name | Value | Description
AcSmObjectReference_HardPointer | 2 | The referenced object is essential to the existence of the object that refers to it.
AcSmObjectReference_SoftPointer | 1 | The referenced object is not essential to the existence of the object that refers to it.


Comments?

Using this form sends your comments to the Autodesk Technical Publications group responsible for this documentation.

Topic title and location (do not edit):
Name (optional):
         Email (optional):
Comments:

Note: This form is not intended as a way for you to receive feedback or technical support. The information you provide will be used to enhance future updates to the documentation. Thanks!