Welcome to AutoCAD Architecture Help

AutoCAD Architecture Developer Help

Welcome to AutoCAD® Architecture Developer Help. Click the following links or use the Contents pane to browse Help topics.

  • Understanding ActiveX Automation in AutoCAD Architecture

    • Describes the Automation object model and provides an overview on customizing the program using ActiveX Automation in Visual Basic for Applications.
  • AEC Base Automation Reference

    • Provides a reference to the components of the AutoCAD Architecture Automation object model that are common to all Autodesk AEC products.
  • AEC AutoCAD Architecture Automation Reference

    • Provides a reference to the components of the AutoCAD Architecture Automation object model that are specific to Autodesk Architectural Desktop.
  • AEC Schedule Automation Reference

    • Provides a reference to the schedule and property set features of AutoCAD Architecture.
  • AEC Structural Automation Reference

    • Provides a reference to the structural member features of AutoCAD Architecture.
  • AEC Details Automation Reference

    • Provides a reference to the Details customization features of AutoCAD Architecture.
  • AutoCAD ActiveX and VBA Developer's Guide

    • Explains how to use ActiveX Automation and VBA to develop an application to customize AutoCAD. Includes sample code and step-by-step procedures.
  • AutoCAD ActiveX and VBA Reference

    • Provides a reference to the AutoCAD ActiveX object model and its associated interface components.


Understanding ActiveX Automation in AutoCAD Architecture

Understanding ActiveX Automation in AutoCAD Architecture describes the AutoCAD® Architecture Automation object model and provides an overview on customizing the program using Visual Basic for Applications (VBA). It also contains examples to help you get started coding Visual Basic (VB) applications to interact with the program. This document assumes that you already know how to use VBA, understand ActiveX Automation concepts, and have some prior knowledge about using VBA with an AutoCAD-based product. The following topics are included in the Understanding ActiveX Automation in AutoCAD Architecture:

  • ACA Automation Concepts
  • Understanding the ACA Object Model
  • Accessing ACA Objects
  • Using Visual Basic to Program ACA
  • Other Sources of Information


AEC Base Automation Reference

The AEC Base Automation Reference provides a reference to the components of the ACA Automation object model that are common to all Autodesk AEC products. The following topics are included in the AEC Base Automation Reference:

  • Object Model
  • Objects
  • Methods
  • Properties
  • Events (Use the Contents tab on the left side of your Help window to browse Events.)
  • Enums (Use the Contents tab on the left side of your Help window to browse Enums.)
  • Code Examples (Use the Contents tab on the left side of your Help window to browse code examples.)


AutoCAD Architecture Desktop Developer Help

AEC Architectural Automation Reference

The AEC Architectural Automation Reference provides a reference to the components of the Architectural Automation object model that are specific to AutoCAD Architecture. The following topics are included in the AEC Architectural Automation Reference:

  • Object Model
  • Objects
  • Methods
  • Properties
  • Events (Use the Contents tab on the left side of your Help window to browse Events.)
  • Enums (Use the Contents tab on the left side of your Help window to browse Enums.)


AEC Schedule Automation Reference

The AEC Schedule Automation Reference provides a reference to the schedule and property set components of the ACA Automation object model. The following topics are included in the AEC Schedule Automation Reference:

  • Object Model
  • Objects
  • Methods
  • Properties
  • Events (Use the Contents tab on the left side of your Help window to browse Events.)


AEC Structural Automation Reference

The AEC Structural Automation Reference provides a reference to the structural member objects in the ACA Automation object model. The following topics are included in the AEC Structural Automation Reference:

  • Object Model
  • Objects
  • Methods
  • Properties
  • Events (Use the Contents tab on the left side of your Help window to browse Events.)


AEC Details Automation Reference

The AEC Details Automation Reference provides a reference to the Details customization features in the ACA Automation object model. The following topics are included in the AEC Details Automation Reference:

  • Object Model
  • Objects
  • Methods
  • Properties
  • Events (Use the Contents tab on the left side of your Help window to browse Events.)