Въведение

HP Driver Deployment Utility (DDU) позволява на администраторите да създават пакет за инсталиране на драйвер за инсталиране от крайните потребители, необходимост от намеса и изпълняване на допълнителни стъпки. Тази помощна програма поддържа добавяне на драйвери за печат към хранилището за драйвери на Windows и създаване на записи в папката за принтери. Driver Deployment Utility поддържа драйвери за печат, създадени за използване със съветника за добавяне на принтер на Microsoft. Важат всички ограничения и уведомления за сертификати на Microsoft.

Потребителският интерфейс е разделен в три раздела:

  1. "Package Source" (Източник на пакета) описва местоположението на драйвера и типа на пакета, които искате да създадете.
  2. "Package Target (Местоназначение на пакета) идентифицира името и местоположението на инсталационния пакет.
  3. "Create Package" (Създаване на пакета) стартира процеса по създаване на пакета.


Източник на пакета

Директория на драйвера

Използвайте бутона "Select Driver…" (Избор на драйвер…), за да изберете inf файл в директорията на драйвера, като отидете там или го въведете. В тази директория би следвало да се намира само един пакет на драйвера, тъй като тази помощна програма ще пакетира в изпълним файл всички файлове в тази директория (и нейните поддиректории). Ако сте изтеглили компресиран пакет на драйвера, трябва да го разкомпресирате, преди да използвате тази помощна програма.

В някои случаи е възможно в директорията да има няколко inf файла (понякога един за цветни принтери и друг за монохромни). В този случай допълнителен диалогов прозорец ще ви помогне да изберете кой драйвер да пакетирате.

Ако директорията е голяма, ще получите предупреждение. Това има за цел да предотврати пакетиране на повече от един драйвер. Може да изберете да продължите, ако в директорията се съдържат всички желани или нужни файлове.

След избора на директория на драйвера и след намирането на драйвер в нея на екрана ще се покаже информация за директорията и драйвера.

За драйвери, поддържащи предварително конфигуриране, ще бъде разрешено квадратчето за отметка по-долу. Поставянето на отметка в него ще доведе до отваряне на диалогов прозорец за конфигуриране след натискане на бутона "Create Package" (Създаване на пакета).

Тип на инсталирането

"Preload the driver" (Предварително зареждане на драйвера) – това е опцията, която трябва да бъде избрана от потребители, които ще използват пряка връзка, например по USB кабел. За инсталиране на драйвера ще бъде необходимо бъдещо събитие от типа "Plug and Play", но всички файлове вече ще са инсталирани от този пакет за бъдеща употреба в хранилището за драйвери на Windows. ЗАБЕЛЕЖКА: Ако за дадено устройство са открити няколко драйвера, операционната система ще определи кой драйвер пасва най-добре на "Plug and Play" събитието или ще изведе пред потребителя диалогов прозорец за избор на драйвер.

По подразбиране изпълнимият файл се изпълнява с диалогов прозорец за хода на процеса. За да изключите диалоговия прозорец за хода на процеса, стартирайте изпълнимия файл с "/q" в командния ред. Ако искате крайният потребител да бъде подканен в края на инсталирането да свърже принтера, отметнете квадратчето "Show a prompt to connect the printer" (Показвай подкана за свързване на принтера).

За принтери, използващи мрежова връзка, изберете опцията "Create network port and install the driver" (Създаване на мрежов порт и инсталиране на драйвера). Бутонът "Network Settings" (Настройки на мрежата) ще бъде разрешен и ще трябва да щракнете върху него, за да направите необходимите мрежови настройки.

Настройки на мрежата

Трябва да идентифицирате мрежовия принтер по един от следните начини. Тази помощна програма не комуникира с устройството, за да определи дали настройките са валидни, но извършва синтактична проверка. (За да разрешите повторното откриване на устройството, проверете дали е зададен хардуерният адрес.)

IP Address (IP адрес):

Въведете IPv4 или IPv6 адреса на принтера

Hardware Address (Хардуерен адрес):

Въведете хардуерния адрес на принтера

Hostname (Име на хост):

Въведете името на хоста на принтера

Следните настройки на мрежата са допълнителни. Може да приемете предлаганите стойности по подразбиране или да ги промените.

Port Name (Име на порт):

Това е името на мрежовия порт, който ще бъде създаден. Ако името вече съществува, то ще бъде направено уникално чрез добавяне на число към него.

Printer Name (Име на принтер):

Това е името на принтера, което ще се показва в папката за принтери. Ако името вече съществува, то ще бъде направено уникално чрез добавяне на число към него.

Set this printer as default (Задай като принтер по подразбиране):

Yes (Да) – Ще зададе принтера като принтер по подразбиране, когато печатате от други приложения.

No (Не) – Ще запази текущо избрания принтер по подразбиране освен ако това е единственият инсталиран принтер.

Share this printer (Споделяне на принтера):

Yes (Да) – Ще позволи на други да използват този принтер.

Share Name (Споделено име):

Името, под което принтерът се споделя. Тази опция е разрешена само ако за опцията "Share this printer" (Споделяне на принтера) е избрано "Yes" (Да). Ако името вече съществува, то ще бъде направено уникално чрез добавяне на число към него.


Местоназначение на пакета

Изберете бутона "Save As…" (Запиши като…), за да въведете името и местоназначението на изходния пакет. Помощната програма ще създаде пакета във временната директория, след което ще го премести в крайното му местоположение. Този пакет ще се състои от 2 файла, които трябва да се доставят заедно: .exe файл и .cab файл.

На същото място ще бъде копиран и съответен описателен xml файл, съдържащ подробни данни за пакета. Xml пакетът е само за информация и той не се използва от DDU по време на изпълнението.


Създаване на пакета

Изберете бутона "Create Package" (Създаване на пакета), когато въведете цялата описана по-горе информация. Този бутон ще остане забранен, докато не въведете необходимата информация. След като веднъж бъде избран, ще бъдат разрешени бутонът "Cancel" (Отказ) и лентата "Progress" (Ход на прогреса).

За да спрете създаването на пакета, натиснете бутона "Cancel" (Отказ).

Изпълнимият файл ще се изпълни с диалогов прозорец за хода на прогреса, както и с подкана към потребителя за директно свързване на принтера (ако е зададена такава подкана). Ако по време на изпълнението възниква грешка, ще се покаже диалогов прозорец за грешка. За да забраните показването на диалогов прозорец за грешка, трябва да отметнете квадратчето "Suppress all end user error messages" (Забрани всички съобщения за грешки за крайния потребител).


Допълнителни забележки:

За да затворите това приложение, използвайте бутона за затваряне на Windows в горния десен ъгъл.


Поддържани операционни системи

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP (64-битово издание)

Microsoft Windows Server 2003 / 2008

Microsoft Windows Server 2003 / 2008 (64-битово издание)

Microsoft Windows Vista

Microsoft Windows Vista (64-битово издание)


Опции за командния ред

Пакетът за крайния потребител може да се модифицира чрез добавяне на команди в командния ред. Командите в командния ред могат да се комбинират заедно с интервал помежду им. В случай че в командния ред има грешка, се показва съобщение за грешка (например, невалиден знак или неправилно форматиране). Грешните команди в командния ред се игнорират. Следното описание на командния ред е налично (на английски език) при изпълнение на пакета за крайния пакет с "/?".

Предварително заредените пакети поддържат следните опции за командния ред:

/? Показване на информация за командния ред (само на английски)

/q Изключване на лентата за хода на прогреса

/p Подканване на потребителя да свърже принтера

/s Забраняване показването на съобщения за грешки за крайния потребител

Пакетите за мрежови принтери поддържат следните опции за командния ред:

/? Показване на информация за командния ред (само на английски)

/q Изключване на лентата за хода на прогреса

/s Забраняване показването на съобщения за грешки за крайния потребител

/ip <ipадрес> Използване на указания IP адрес за идентифициране на принтера, напр. /ip 120.25.5.56

/hw <хардуеренадрес> Използване на указания хардуерен адрес за идентифициране на принтера, напр. /hw 0001E6299128

/hn <именахост> Използване на указаното име на хост за идентифициране на принтера, напр. /hn Myhostname

Името на хоста не може да бъде по-дълго от 255 знака и може да съдържа само следните знаци:A-Z, a-z, 0-9 и тире (-).

/pn <именапорт> Използване на указаното име като име на порта, напр. /pn HPPort

Името на порта не може да съдържа интервали и не може да е по-дълго от 128 знака.

/n "<именапринтер>" Използване на указаното име като име на принтера, напр. /n "HP LaserJet 8150"

Името на принтера трябва да е оградено с кавички, не може да бъде по-дълго от 40 знака и не може да съдържа следните специални знаци: ! # ,

/d Задаване на този принтер като принтер по подразбиране

/sn "<споделеноиме>" Включване на споделянето и използване на указаното име като споделено име за принтера, напр. /sn "Моят споделен принтер HP LaserJet 8150"

Споделеното име трябва да е оградено с кавички, не може да бъде по-дълго от 80 знака и не може да съдържа следните специални знаци: / \ : ; “ ? * + = < > [ ]

© 2007-2008 Hewlett-Packard Development Company, L.P.