Johdanto

HP Driver Deployment Utility (DDU) -apuohjelmalla järjestelmänvalvoja voi luoda ohjaimen asennuspaketin, jonka avulla loppukäyttäjät voivat suorittaa valvomattoman automaattisen asennuksen. Tämä apuohjelma tukee tulostinohjainten lisäämistä Windowsin ohjainsäilöön ja merkintöjen luomista tulostimen kansioon. Driver Deployment Utility -apuohjelma tukee tulostinohjaimia, jotka on suunniteltu toimimaan Microsoftin ohjatulla tulostimen asennustoiminnolla. Asennustoimissa huomioidaan kaikki Microsoftin varmennerajoitukset ja -ilmoitukset.

Käyttöliittymä on jaettu kolmeen osaan:

  1. Pakettilähde-kohdassa kerrotaan luotavan paketin tyyppi ja ohjaimen sijainti
  2. Pakettikohde ilmaisee asennuspaketin nimen ja sijainnin
  3. Luo paketti aloittaa paketin luontitoiminnon


Pakettilähde

Ohjainhakemisto

Valitse ohjain… -painikkeen avulla voit valita inf-tiedoston ohjainhakemistosta selaamalla hakemistoa tai kirjoittamalla tiedoston nimen. Tässä hakemistossa saa olla vain yksi ohjainpaketti, koska apuohjelma pakkaa ohjelmatiedostoon kaikki tästä hakemistosta (ja sen alihakemistoista) löytyneet tiedostot. Jos olet noutanut pakatun ohjainpaketin, sen pakkaus on purettava ennen apuohjelman käyttämistä.

Joissakin tapauksissa hakemistossa voi olla useita ohjaimen inf-tiedostoja (toisinaan yksi on väri- ja toinen mustavalkotulostimia varten). Tässä tapauksessa näkyviin tulee valintaikkuna, jossa voit valita, minkä ohjaimen haluat pakata.

Saat myös varoituksen, jos hakemisto on suuri. Tämä auttaa estämään useamman kuin yhden ohjaimen pakkaamisen. Voit halutessasi jatkaa tästä kohdasta eteenpäin, jos kaikki halutut tai tarvittavat tiedostot ovat tässä kansiossa.

Kun ohjainhakemisto on valittu ja yksi ohjain on löytynyt, hakemisto ja ohjaimen tiedot näkyvät.

Alla oleva valintaruutu näkyy valittuna käsiteltäessä ohjaimia, jotka tukevat esimääritystä. Jos valitset tämän vaihtoehdon, järjestelmä suorittaa kokoonpanovalintaikkunan, kun Luo paketti -painike on valittu.

Asennustyyppi

Ohjaimen asennus on oikea vaihtoehto niille käyttäjille, jotka haluavat käyttää suoraa yhteyttä, kuten USB-kaapelia. Ohjaimen asennus edellyttää myöhemmin tehtävää Plug and Play -asennusta, mutta paketti asentaa kaikki tiedostot Windowsin ohjainsäilöön myöhemmin käytettäviksi. HUOMAUTUS: Jos laitteelle löytyy useita ohjaimia, käyttöjärjestelmä selvittää, mikä ohjain sopii parhaiten Plug and Play -toimintoon, tai käyttäjä saa näkyviin ohjaimen valintaikkunan.

Kun ohjelmatiedosto suoritetaan, edistymistä kuvaava valintaikkuna tulee oletusarvoisesti näkyviin. Jos haluat poistaa edistymistä kuvaavan valintaikkunan käytöstä, käytä komentorivillä valitsinta /q. Jos haluat kehottaa loppukäyttäjää liittämään tulostimen asennuksen lopussa, valitse Näytä tulostimen liittämiskehote -valintaruutu.

Valitse verkkoyhteyttä käyttäville tulostimille vaihtoehto Verkkoportin luominen ja ohjaimen asennus. Verkkoasetukset-painike on käytettävissä. Napsauta sitä, jotta voit antaa tarvittavat verkkoasetukset.

Verkkoasetukset

Verkkotulostin on yksilöitävä käyttämällä vähintään yhtä seuraavista menetelmistä. Tämä apuohjelma ei ole yhteydessä laitteeseen selvittääkseen, ovatko asetukset kelvollisia. Se tekee kuitenkin syntaksitarkistuksen. (Jotta laite löytyisi uudelleen, varmista, että laiteosoite on määritetty.)

IP-osoite:

Kirjoita tulostimen IPv4- tai IPv6-osoite

Laiteosoite:

Kirjoita tulostimen laiteosoite

Isäntänimi:

Kirjoita tulostimen isäntänimi

Seuraavat verkkoasetukset ovat lisäasetuksia. Voit hyväksyä esiasetetut oletusasetukset tai vaihtaa niitä.

Portin nimi:

Tämä on luotavan verkkoportin nimi. Jos nimi on jo käytössä, nimeen lisätään numero, jotta siitä tulisi yksilöllinen.

Tulostimen nimi:

Tämä on tulostimen kansiossa näkyvä tulostimen nimi. Jos nimi on jo käytössä, nimeen lisätään numero, jotta siitä tulisi yksilöllinen.

Aseta tämä oletustulostimeksi:

Kyllä - Tästä tulostimesta tulee oletustulostin tulostettaessa toisista sovelluksista.

Ei - Säilyttää nykyiset oletusasetukset, ellei tämä ole ainoa asennettu tulostin.

Jaetaanko tämä tulostin?:

Kyllä - Toiset käyttäjät voivat käyttää tätä tulostinta.

Jakonimi:

Tulostimen jakonimi. Käytettävissä vain silloin, kun Jaetaanko tämä tulostin? -asetukseksi on valittu Kyllä. Jos nimi on jo käytössä, nimeen lisätään numero, jotta siitä tulisi yksilöllinen.


Pakettikohde

Anna tulostuspaketin nimi ja sijainti valitsemalla Tallenna nimellä… -painike. Apuohjelma luo paketin temp-hakemistoon. Siirrä se sitten lopulliseen sijaintiin. Paketissa on kaksi tiedostoa, jotka on toimitettava yhdessä: .exe- ja .cab-tiedosto.

Vastaava xml-kuvaustiedosto, joka sisältää paketin tiedot, kopioituu myös lopulliseen sijaintiin. Xml-paketissa on vain tiedoksi tarkoitettua sisältöä; DDU-apuohjelma ei käytä sitä ohjelmatiedostoa suorittaessaan.


Luo paketti

Kun olet antanut edellä mainitut tiedot, valitse Luo paketti -painike. Tämä painike on käytettävissä vasta, kun olet antanut tarvittavat tiedot. Kun valitset sen, Peruuta-painike ja Edistyminen-palkki tulevat käyttöön.

Voit keskeyttää paketin luomisen valitsemalla Peruuta-painikkeen.

Kun ohjelmatiedosto suoritetaan, näkyviin tulee edistymistä kuvaava valintaikkuna. Näkyviin tulee myös tulostimen suoraa liittämistä koskeva kehote, jos sellainen on pyydetty. Jos ohjelmatiedoston suorituksen aikana ilmenee virhe, virheloki tulee näkyviin. Voit poistaa virheikkunan näkyvistä valitsemalla Poista kaikki loppukäyttäjän virhesanomat näkyvistä -valintaruudun.


Lisähuomautuksia:

Voit sulkea tämän sovelluksen oikeassa yläkulmassa olevalla Windowsin sulkemispainikkeella.


Tuetut käyttöjärjestelmät

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP, 64-bittinen versio

Microsoft Windows Server 2003/2008

Microsoft Windows Server 2003/2008, 64-bittinen versio

Microsoft Windows Vista

Microsoft Windows Vista (64-bittinen)


Komentorivivalitsimet

Loppukäyttäjän pakettiin voi tehdä muutoksia komentorivivalitsimilla. Jos haluat käyttää useita komentorivivalitsimia, erota ne välilyönneillä. Jos komentorivillä on virhe, näkyviin tulee virheilmoitus. Virheen voi aiheuttaa esimerkiksi väärä merkki tai muoto. Vääriä komentorivivalitsimia ei huomioida. Saat komentorivivalitsimien kuvaukset näkyviin (englanninkielisinä) myös, kun käytät valitsinta /? loppukäyttäjän pakettia suorittaessasi.

Asennuspaketit tukevat seuraavia komentorivivalitsimia:

/? Näyttää komentorivin käyttämistä koskevia tietoja (vain englanninkielisinä).

/q Piilottaa edistymispalkin.

/p Kehottaa käyttäjää yhdistämään tulostimen.

/s Jättää kaikki loppukäyttäjän virheilmoitukset näyttämättä.

Verkkotulostinpaketit tukevat seuraavia komentorivivalitsimia:

/? Näyttää komentorivin käyttämistä koskevia tietoja (vain englanninkielisinä).

/q Piilottaa edistymispalkin.

/s Jättää kaikki loppukäyttäjän virheilmoitukset näyttämättä.

/ip <ip-osoite> Määrittää tulostimelle tietyn IP-osoitteen – esimerkiksi /ip 120.25.5.56.

/hw <laiteosoite> Määrittää tulostimelle tietyn laiteosoitteen – esimerkiksi /hw 0001E6299128.

/hn <isäntänimi> Määrittää tulostimelle tietyn isäntänimen – esimerkiksi /hn OmaIsäntänimi.

Isäntänimessä voi olla enintään 255 merkkiä. Vain seuraavat merkit kelpaavat: A–Z, a–z, 0–9 ja ajatusviiva (-).

/pn <portin_nimi> Käyttää määritettyä nimeä portin nimenä – esimerkiksi /pn HPPort.

Portin nimessä ei voi käyttää välilyöntejä, ja siinä voi olla enintään 128 merkkiä.

/n "<tulostinnimi>" Käyttää määritettyä nimeä tulostimen nimenä – esimerkiksi /n "HP LaserJet 8150".

Tulostimen nimi täytyy sulkea lainausmerkkeihin, ja siinä voi olla enintään 40 merkkiä. Seuraavat erikoismerkit eivät kelpaa: ! # ,

/d Asettaa tämän tulostimen oletustulostimeksi.

/sn "<jaetun resurssin nimi>" Ottaa jakamisen käyttöön ja käyttää määritettyä nimeä jaetun tulostinresurssin nimenä – esimerkiksi /sn "Oma jaettu HP LaserJet 8150".

Jaetun resurssin nimi täytyy sulkea lainausmerkkeihin, ja siinä voi olla enintään 80 merkkiä. Seuraavat erikoismerkit eivät kelpaa: / \ : ; “ ? * + = < > [ ]

© Copyright 2007–2008 Hewlett-Packard Development Company, L.P.