מבוא

תוכנית השירות HP Driver Deployment Utility(DDU) מאפשרת למנהל המערכת ליצור חבילת התקנה של מנהל התקן המיועדת להתקנה ללא השגחה של משתמשי הקצה. תוכנית שירות זו תומכת בהוספת מנהלי התקן הדפסה למאגר מנהלי ההתקן של Windows וביצירת רשומות בתיקיית המדפסת. תוכנית השירות Driver Deployment Utility תומכת במנהלי התקן הדפסה המיועדים לשימוש עם Add Printer Wizard (אשף הוספת מדפסת) של Microsoft. כל המגבלות וההתראות של האישורים של Microsoft חלות.

הממשק למשתמש מחולק לשלושה חלקים:

  1. 'מקור חבילה' מתאר את סוג החבילה ואת מיקום מנהל ההתקן שברצונך ליצור
  2. 'יעד חבילה' מזהה את השם ואת מיקום חבילת ההתקנה
  3. 'יצירת חבילה' מאתחל את תהליך יצירת החבילה


מקור חבילה

ספריית מנהל התקן

השתמש בלחצן 'בחר מנהל התקן...' כדי לבחור קובץ inf בספריית מנהל ההתקן על-ידי עיון או הקלדת שמו. בספריה זו חייבת להימצא חבילת מנהל התקן אחת בלבד משום שתוכנית שירות זו תארוז את כל הקבצים הנמצאים בספריה זו (ובספריות משנה) בקובץ ההפעלה. אם הורדת חבילה דחוסה של מנהל התקן, עליך להרחיב אותה לפני שתשתמש בתוכנית שירות זו.

במקרים מסוימים, ייתכן שיהיו לך קובצי inf מרובים של מנהל התקן בספריה (לפעמים אחד מיועד למדפסת בצבע והשני מיועד למדפסת בשחור-לבן). במקרה זה, תיבת דו-שיח נוספת תאפשר לך לבחור את מנהל ההתקן שיש לארוז.

כמו כן, תקבל אזהרה אם הספריה גדולה. האזהרה מיועדת לסייע במניעת אריזה של יותר ממנהל התקן אחד. באפשרותך לבחור להמשיך בנקודה זו אם הספריה מכילה את כל הקבצים הדרושים או הנחוצים.

כאשר נבחרת ספריית מנהל ההתקן ונמצא מנהל התקן אחד, יוצגו פרטי הספריה ומנהל ההתקן.

עבור מנהלי התקן התומכים בהגדרה מראש, תיבת הסימון להלן תהיה זמינה. בחירה באפשרות זו תפעיל תיבת דו-שיח של הגדרת תצורה לאחר בחירה בלחצן 'יצירת חבילה'.

סוג ההתקנה

'טען מראש את מנהל ההתקן' – זו האפשרות שבה יבחרו משתמשים שישתמשו בחיבור ישיר, כגון כבל USB. אירוע 'הכנס-הפעל' עתידי יהיה הכרחי לצורך התקנת מנהל ההתקן, אבל כל הקבצים יותקנו במאגר מנהלי ההתקנים של Windows על-ידי חבילה זו לצורך שימוש עתידי. הערה: אם נמצאים מנהלי התקן מרובים עבור התקן, מערכת ההפעלה תקבע איזה מנהל התקן מתאים ביותר עבור אירוע 'הכנס-הפעל', או תציג בפני המשתמש תיבת דו-שיח לבחירת מנהל התקן.

כברירת מחדל, קובץ ההפעלה נפתח עם תיבת דו-שיח של התקדמות. לביטול תיבת הדו-שיח של ההתקדמות, פתח את קובץ ההפעלה עם “/q” בשורת הפקודה. אם ברצונך להודיע למשתמש הקצה לחבר את המדפסת בסוף ההתקנה, בחר בתיבת הסימון 'הצג בקשה לחיבור המדפסת'.

עבור מדפסות המשתמשות בחיבור רשת, בחר באפשרות 'צור את יציאת הרשת והתקן את מנהל ההתקן'. הלחצן 'הגדרות רשת' יהפוך לזמין ועליך ללחוץ עליו כדי להזין את הגדרות הרשת הדרושות.

הגדרות רשת

עליך לזהות את מדפסת הרשת לפי שיטה אחת או יותר מהשיטות הבאות. תוכנית השירות לא יוצרת תקשורת עם ההתקן כדי לקבוע אם ההגדרות חוקיות, אולם מבצעת בדיקת תחביר. (כדי לאפשר גילוי מחדש של ההתקן, ודא ש'כתובת חומרה' מצוינת.)

כתובת IP:

הזן את כתובת ה- IPv4או IPv6 של המדפסת

כתובת חומרה:

הזן את כתובת החומרה של המדפסת

שם מארח:

הזן את שם המארח של המדפסת

הגדרות הרשת הבאות הן הגדרות נוספות. באפשרותך לקבל את הערכים המשמשים כברירת מחדל אשר הוזנו מראש, או לשנות כל אחד מהם.

שם יציאה:

זהו שם יציאת הרשת שתיווצר. אם השם כבר קיים, יתווסף לשם מספר כדי להפוך אותו לייחודי.

שם מדפסת:

זה שם המדפסת שיופיע בתיקיית המדפסות. אם השם כבר קיים, יתווסף לשם מספר כדי להפוך אותו לייחודי.

הגדר מדפסת זו כברירת מחדל:

כן – אפשרות זו תהפוך את המדפסת לברירת המחדל בעת הדפסה מיישומים אחרים.

לא – אפשרות זו תשמור על ברירת המחדל הנוכחית, אלא אם כן זו המדפסת היחידה המותקנת.

שתף מדפסת זו:

כן – אפשרות זו תאפשר לאחרים להשתמש במדפסת זו.

שם שיתוף:

שם שיתוף עבור המדפסת. אפשרות זו זמינה רק אם 'שתף מדפסת זו' מוגדר כ'כן'. אם השם כבר קיים, יתווסף לשם מספר כדי להפוך אותו לייחודי.


יעד חבילה

בחר בלחצן 'שמירה בשם...' כדי להזין את השם ואת המיקום עבור חבילת הפלט. תוכנית השירות תיצור את החבילה בספריה הזמנית ולאחר מכן תעביר אותה למיקום הסופי.החבילה תכיל 2 קבצים שיש להעביר יחדיו:קובץ .exe וקובץ .cab

קובץ תיאור xml תואם המכיל את פרטי החבילה יועתק גם הוא למיקום הסופי. חבילת ה-xml הינה למידע בלבד, לא נעשה בה שימוש על-ידי ה-DDU במהלך ההפעלה.


יצירת חבילה

בחר בלחצן 'יצירת חבילה' לאחר שתזין את כל המידע שלעיל. לחצן זה לא יהיה זמין עד להזנת המידע הדרוש.לחצן 'ביטול' ומד 'התקדמות' יהפכו לזמינים עם הבחירה בהם.

כדי לעצור את יצירת החבילה, בחר בלחצן 'ביטול'.

קובץ ההפעלה ייפתח עם תיבת דו-שיח של התקדמות, ובמקרה הצורך תופיע בקשה של משתמש למדפסת בחיבור ישיר. אם אירעה שגיאה במהלך הביצוע, תופיע תיבת דו-שיח של שגיאה. כדי להתעלם מתיבת הדו-שיח של השגיאה, עליך לבחור בתיבת הסימון 'התעלם מכל הודעות השגיאה של משתמשי הקצה'.


הערות נוספות:

כדי לסגור יישום זה, השתמש בלחצן הסגירה של Windows המופיע בקצה הימני העליון.


כות הפעלה נתמכות

מערכות הפעלה נתמכות

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP 64-Bit Edition

Microsoft Windows Server 2003 / 2008

Microsoft Windows Server 2003 / 2008 64-Bit Edition

Microsoft Windows Vista

(Microsoft Windows Vista (64-bit


אפשרויות שורת הפקודה

ניתן לשנות את חבילת משתמש הקצה באמצעות הוספה של מעברים בין שורות פקודה. ניתן לשלב את המעברים בין שורות הפקודה אם הם מופרדים על-ידי רווחים. הודעת שגיאה תוצג אם שורת הפקודה מכילה שגיאה, כגון תו לא חוקי או עיצוב לא מתאים. מעברים לא מתאימים בין שורות הפקודה אינם נלקחים בחשבון. תיאור שורת הפקודה שלהלן זמין (באנגלית) גם על-ידי הפעלת חבילת הקצה של המשתמש עם “/?”.

חבילות שנטענו מראש תומכות באפשרויות שורת הפקודה הבאות:

/? הצג את הפרטים של שורת הפקודה (באנגלית בלבד)

/q העלם את מד ההתקדמות

/p בקש ממשתמש לחבר מדפסת

/s התעלם מהודעות השגיאה של משתמשי הקצה

חבילות של מדפסת רשת תומכות באפשרויות שורת הפקודה הבאות:

/? הצג את הפרטים של שורת הפקודה (באנגלית בלבד)

/q העלם את מד ההתקדמות

/s התעלם מהודעות השגיאה של משתמשי הקצה

<כתובת ip> /ip השתמש בכתובת ה- IP שצוינה כדי לזהות את המדפסת, לדוגמה /ip120.25.5.56

<כתובת חומרה/hw < השתמש בכתובת החומרה שצוינה כדי לזהות את המדפסת, לדוגמה /hw 0001E6299128

<שם מארח/hn < השתמש בשם המארח שצוין כדי לזהות את המדפסת, לדוגמה /hn Myhostname

שם המארח לא יכול להיות ארוך מ-255 תווים ויכול להכיל את התווים הבאים בלבד: A-Z, a-z, 0-9 ומקף (-).

<שם יציאה/pn < השתמש בשם שצוין כשם היציאה, לדוגמה /pn HPPort

שם היציאה אינו יכול להכיל רווחים ולעלות באורכו על 128 תווים.

”<שם מדפסת /n ”<השתמש בשם שצוין בתור שם המדפסת, לדוגמה /n "HP LaserJet 8150"

על שם המדפסת להיות בתוך מרכאות, באורך של עד 40 תווים וללא התווים המיוחדים הבאים: ! # ,

/d הגדר מדפסת זו כברירת מחדל

”<שם שיתוף /sn ”<הפעל את השיתוף והשתמש בשם שצוין בתור שם השיתוף של המדפסת, לדוגמה /sn ”My shared HP LaserJet 8150”

על שם השיתוף להיות בתוך מרכאות, באורך של עד 80 תווים וללא התווים המיוחדים הבאים: / \ : ; “ ? * + = < > [ ]

© Copyright 2007-2008 Hewlett-Packard Development Company, L.P.