Bevezetés

A HP Driver Deployment Utility (DDU) segédprogram lehetővé teszi, hogy a rendszergazdák illesztőprogram-csomagot hozzanak létre azért, hogy a végfelhasználók felügyelet nélküli telepítést végezhessenek.Ez a segédprogram támogatja a nyomtató-illesztőprogramok hozzáadását a Windows illesztőprogram-tárolójához, valamint bejegyzések létrehozását a nyomtató mappájában.A Driver Deployment Utility segédprogram támogatja azokat a nyomtató-illesztőprogramokat, amelyek együtt használhatók a Microsoft Nyomtató hozzáadása varázslójával.Minden, Microsoft-tanúsítványra vonatkozó korlátozás és figyelmeztetés érvényes.

A felhasználói felület 3 részből áll:

  1. a „Csomag forrása” rész a csomag típusát és a létrehozni kívánt illesztőprogram-helyet írja le
  2. a „Csomag célja” a telepítőcsomag nevét és helyét adja meg
  3. a „Csomag létrehozása” rész elindítja a csomaglétrehozó folyamatot


Csomag forrása

Illesztőprogram-könyvtár

Az „Illesztőprogram kiválasztása…” gomb használata után tallózással vagy az útvonal beírásával válasszon egy inf fájlt az illesztőprogram-könyvtárból. Lehetőleg csak egy illesztőprogram-csomag legyen ebben a könyvtárban, mert a segédeszköz a könyvtár (és alkönyvtárai) összes fájlját becsomagolja egy végrehajtható fájlba. Ha egy tömörített illesztőprogram-csomagot töltött le, a segédeszköz használata előtt ki kell tömörítenie.

Előfordulhat, hogy több illesztőprogramot jelképező inf fájl található a könyvtárban (néha az egyik a színes, a másik a fekete-fehér nyomtatókhoz). Ebben az esetben egy további párbeszédpanel segítségével lehet kiválasztani a becsomagolni kívánt illesztőprogramot.

Akkor is figyelmeztet a program, ha túl nagy a könyvtár mérete. Ez segít megelőzni több illesztőprogram becsomagolását. Válassza a folytatást, ha a könyvtár az összes szükséges fájlt tartalmazza.

Az illesztőprogram könyvtárának kiválasztása és az illesztőprogram megkeresése után megjelennek a könyvtár és az illesztőprogram információi.

Előkonfigurálást támogató illesztőprogramok esetén az alábbi jelölőnégyzet engedélyezve lesz. Ennek bejelölése esetén egy konfigurációs ablak fog megjelenni a „Csomag létrehozása” gomb megnyomása után.

Telepítés típusa

„Illesztőprogram előtöltése” – ezt a lehetőséget kell választani a közvetlen kapcsolattal, például USB-kábellel rendelkező felhasználóknak. Egy későbbi Plug and Play esemény szükséges az illesztőprogram telepítéséhez, de a későbbi használathoz ez a csomag telepíti az összes fájlt a Windows illesztőprogram-tárolójába. MEGJEGYZÉS: Ha több illesztőprogram található egy eszközhöz, az operációs rendszer meghatározza, hogy melyik illesztőprogram felel meg leginkább a Plug and Play eseményhez, vagy megjelenít egy párbeszédpanelt, amelyen a felhasználó kiválaszthatja a kívánt illesztőprogramot.

A program alapértelmezés szerint egy folyamatjelző párbeszédpanellel fut. A folyamatjelző párbeszédpanel kikapcsolásához futtassa a futtatható fájlt egy „/q” kapcsolóval a parancssorban. Ha szeretné, hogy a felhasználó a telepítés végén csatlakoztassa a nyomtatóját, akkor jelölje be a „Felkérés a nyomtató csatlakoztatására” jelölőnégyzetet.

Hálózati kapcsolatot használó nyomtatók esetén válassza a „Hálózati port létrehozása és illesztőprogram telepítése” lehetőséget. A „Hálózati beállítások” gomb engedélyezetté válik, és erre kell kattintatni a szükséges hálózati beállítások megadásához.

Hálózati beállítások

Az alábbi módszerek egyikével vagy kombinálásával azonosítsa a hálózati nyomtatót. Ez a segédeszköz a beállítások érvényességének ellenőrzéséhez nem kommunikál az eszközzel, de szintaxisellenőrzést végez. (Az eszköz újbóli megkeresésének engedélyezéséhez győződjön meg róla, hogy a Hardvercím meg van adva.)

IP-cím:

Írja be a nyomtató IPv4- vagy IPv6-címét

Hardvercím:

Írja be a nyomtató hardvercímét

Állomásnév:

Írja be a nyomtató állomásnevét

Az alábbi hálózati beállításokat nem kötelező megadni.Elfogadhatja az előre megadott alapértelmezett értékeket, vagy módosíthatja azokat.

Portnév:

Ez a létrehozandó hálózati port neve.Ha a név már létezik, a program hozzáfűz egy számot, hogy egyedivé tegye.

Nyomtató neve:

Ez az a név, amely megjelenik a nyomtatók mappájában.Ha a név már létezik, a program hozzáfűz egy számot, hogy egyedivé tegye.

A nyomtató alapértelmezetté tétele:

Igen – ez a nyomtató lesz az alapértelmezett, ha más alkalmazásokból nyomtat.

Nem – a jelenlegi nyomtató marad az alapértelmezett, ha van ilyen telepítve.

Nyomtató megosztása:

Igen – engedélyezi, hogy más felhasználók is használják a nyomtatót.

Megosztási név:

A nyomtató megosztási neve.Csak akkor engedélyezett, ha a „Nyomtató megosztása” értéke Igen.Ha a név már létezik, a program hozzáfűz egy számot, hogy egyedivé tegye.


Csomag célja

Nyomja meg a „Mentés másként…” gombot, majd adja meg a kimeneti csomag nevét és helyét.A segédeszköz az ideiglenes könyvtárban hozza létre a csomagot, majd áthelyezi a végső helyére.A csomag 2 fájlból fog állni, melyeket együtt kell szállítani:egy .exe és egy .cab fájlból.

Emellett egy, a csomag részleteit tartalmazó xml leírófájlt is a végső helyre másol.Az xml csomag csak informáló jellegű, a végrehajtás során nem használja a DDU segédeszköz.


Csomag létrehozása

Az összes fenti adat megadása után nyomja meg a „Csomag létrehozása” gombot.Ez a gomb addig nem engedélyezett, amíg nem adott meg minden szükséges adatot.A gomb megnyomása után használhatóvá válik a „Mégse” gomb, és megjelenik a „Folyamat” sáv.

A csomag létrehozásának leállításához nyomja meg a „Mégse” gombot.

Amennyiben igényelt a felhasználót a nyomtató csatlakoztatására figyelmeztető üzenetet, a program folyamatjelző párbeszédpanellel fog futni.Ha a végrehajtás közben hiba lép fel, megjelenik egy hibaüzenet.A hibaüzenet elrejtéséhez jelölje be a „Végfelhasználói hibaüzenetek elrejtése” jelölőnégyzetet.


További megjegyzések:

Az alkalmazás bezárásához használja a jobb felső sarokban lévő Windows bezárás gombot.


Támogatott operációs rendszerek

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP 64-Bit Edition

Microsoft Windows Server 2003 / 2008

Microsoft Windows Server 2003 / 2008 64-Bit Edition

Microsoft Windows Vista

Microsoft Windows Vista (64 bites)


Parancssori kapcsolók

A végfelhasználói csomag parancssori kapcsolók hozzáadásával módosítható.A parancssori kapcsolók kombinálhatók, ha szóközzel választják el őket.Egy hibaüzenet jelenik meg, ha a parancssor hibát, például érvénytelen karaktert, vagy nem megfelelő formázást tartalmaz.A nem megfelelő parancssori kapcsolókat a rendszer nem veszi figyelembe.Az alábbi parancssori leírás is elérhető (angolul), ha a végfelhasználói csomagot a „/?” kapcsolóval futtatja.

Az előre betöltött csomagok az alábbi parancssori kapcsolókat támogatják:

/? megjeleníti a parancssori információkat (csak angolul)

/q elrejti a folyamatsávot

/p felkéri a felhasználót a nyomtató csatlakoztatására

/s elrejti a végfelhasználói hibaüzeneteket

A hálózatinyomtató-csomagok az alábbi parancssori beállításokat támogatják:

/? megjeleníti a parancssori információkat (csak angolul)

/q elrejti a folyamatsávot

/s elrejti a végfelhasználói hibaüzeneteket

/ip <IP-cím> a megadott IP-cím használata a nyomtató azonosítására, pl. /ip 120.25.5.56

/hw <hardvercím> a megadott hardvercím használata a nyomtató azonosítására, pl. /hw 0001E6299128

/hn <állomásnév> a megadott állomásnév használata a nyomtató azonosítására, pl. /hn Állomásnév

Az állomásnév nem lehet hosszabb 255 karakternél, és csak az alábbi karaktereket tartalmazhatja:A-Z, a-z, 0-9 és kötőjel (-).

/pn <portnév> a megadott név használata portnévként, pl. /pn HPPort

Az állomásnév nem tartalmazhat szóközöket, és nem lehet hosszabb 128 karakternél.

/n "<nyomtató neve>" a megadott név használata a nyomtató neveként, pl. /n "HP LaserJet 8150"

A nyomtató nevét idézőjelek közé kell tenni, nem lehet hosszabb 40 karakternél, és nem tartalmazhatja az alábbi speciális karaktereket:! # ,

/d a nyomtató alapértelmezetté tétele

/sn "<megosztási név>" megosztás bekapcsolása, és a megadott név használata a nyomtató megosztási neveként, pl. /sn "Megosztott HP LaserJet 8150"

A nyomtató megosztási nevét idézőjelek közé kell tenni, nem lehet hosszabb 80 karakternél, és nem tartalmazhatja az alábbi speciális karaktereket:/ \ : ; “ ? * + = < > [ ]

© Copyright 2007-2008 Hewlett-Packard Development Company, L.P.