はじめに

HP Driver Deployment Utility (DDU) を使用すると、管理者はドライバインストールパッケージを作成して、エンドユーザーによる無人インストールを実現できます。 このユーティリティでは、Windows ドライバストアへのプリンタドライバの追加およびプリンタフォルダでのエントリの作成がサポートされています。 Driver Deployment Utility は、Microsoft の [プリンタの追加] ウィザードで使用できるように設計されたプリンタドライバをサポートします。 Microsoft の認証に関する制約および警告がすべて適用されます。

UI は、3 つのセクションに分かれています。

  1. 「パッケージソース」では、作成するパッケージのタイプおよびドライバの場所について説明します。
  2. 「パッケージターゲット」では、インストールパッケージの名前および場所を特定します。
  3. 「パッケージの作成」では、パッケージの作成プロセスを開始します。


パッケージターゲット

[名前を付けて保存…] ボタンを選択して、出力パッケージの名前および場所を入力します。 パッケージは、一時ディレクトリに作成されてから、目的の場所に移動されます。パッケージには、一緒に配布する必要のある 2 つのファイル (.exe および .cab) が含まれています。

パッケージの詳細が含まれている、マッチング xml 記述ファイルも目的の場所にコピーされます。 xml パッケージは参照目的でのみ使用されます。実行時に DDU で使用されることはありません。


パッケージの作成

上記のすべての情報を入力したら、[パッケージの作成] を選択します。 必要な情報が入力されないと、このボタンは有効になりません。このボタンを選択すると、[キャンセル] ボタンと [進捗状況] バーが有効になります。

パッケージの作成を停止するには、[キャンセル] ボタンを選択します。

実行ファイルの実行時、進捗状況を示すダイアログが表示されます。ユーザーが要求した場合は、プリンタの直接接続の指示も表示されます。 実行時にエラーが発生すると、エラーダイアログが表示されます。 エラーダイアログが表示されないようにするには、[すべてのエンドユーザーエラーメッセージを表示しない] チェックボックスをオンにします。


その他の注記

このアプリケーションを閉じるには、Windows の画面右上の [閉じる] ボタンを使用します。


対応 OS

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP 64-Bit Edition

Microsoft Windows Server 2003 / 2008

Microsoft Windows Server 2003 / 2008 64-Bit Edition

Microsoft Windows Vista

Microsoft Windows Vista (64 ビット)


コマンドラインのオプション

コマンドラインスイッチを追加して、エンドユーザーパッケージを変更できます。 コマンドラインスイッチを空白で区切ると、それらを組み合わせることができます。 エラー (無効な文字や間違った形式など) がコマンドラインに含まれている場合は、エラーメッセージが表示されます。 間違ったコマンドラインスイッチは無視されます。 エンドユーザーパッケージに「/?」を追加して実行すると、以下のコマンドラインの記述も使用できます (英語)。

プリロードのパッケージは、以下のコマンドラインオプションをサポートします。

/? コマンドライン情報が表示されます (英語のみ)。

/q プログレスバーを表示しません。

/p プリンタの接続指示をユーザーに表示します。

/s エンドユーザーエラーメッセージを表示しません。

ネットワークプリンタパッケージは、以下のコマンドラインオプションをサポートします。

/? コマンドライン情報が表示されます (英語のみ)。

/q プログレスバーを表示しません。

/s エンドユーザーエラーメッセージを表示しません。

/ip <ip アドレス> 指定された IP アドレスを使用してプリンタを識別します。たとえば /ip 120.25.5.56 など。

/hw <ハードウェアアドレス> 指定されたハードウェアアドレスを使用してプリンタを識別します。たとえば /hw 0001E6299128 など。

/hn <ホスト名> 指定されたホスト名を使用してプリンタを識別します。たとえば /hn Myhostname など。

ホスト名は 255 文字以下にします。A ～ Z、a ～ z、0 ～ 9、およびダッシュ (-) 以外の文字は使用できません。

/pn <ポート名> 指定された名前をポート名として使用します。たとえば /pn HPPort など。

ポート名には空白を使用できません。ポート名は 128 文字以下にします。

/n ”<プリンタ名>” 指定された名前をプリンタ名として使用します。たとえば /n "HP LaserJet 8150" など。

プリンタ名は引用符で囲む必要があり、40 文字以内の長さにします。次の特殊文字 (! # ,) は使用できません。

/d デフォルトのプリンタとして設定します。

/sn ”<共有名>” 共有をオンにし、指定された名前をプリンタの共有名として使用します。たとえば /sn ”My shared HP LaserJet 8150” など。

共有名は引用符で囲む必要があり、80 文字以内の長さにします。次の特殊文字 (/ \ : ; “ ? * + = < > [ ] ) は使用できません。

© Copyright 2007-2008 Hewlett-Packard Development Company, L.P.