Кіріспе

HP Driver Deployment Utility (DDU) әкімшінің соңғы пайдаланушылардың қатыспай орнатуына арналған драйверді орнату бумасын жасауына мүмкіндік береді. Бұл утилита Windows драйверлерінің қоймасына баспа драйверлерін қосуды және Принтер қалтасына деректерді енгізуді қолдайды. Драйверді қолдану утилитасы Microsoft компаниясының Принтер қосу шеберімен қолданылуға арналған баспа драйверлерін қолдайды. Барлық Microsoft сертификаттау шектеулері мен ескертулері қолданылады.

Пайдаланушы интерфейсі 3 бөлімнен құралған:

  1. «Бума ресурсы» бума түрін және құрағыңыз келетін драйвердің орналасқан жерін сипаттайды.
  2. «Бума нысанасы» орнату бумасының атын және орналасқан жерін білдіреді.
  3. «Бума жасау» бума жасау үрдісін бастайды.


Бума ресурсы

Драйвер каталогы

«Драйверді таңдау» батырмасын басу арқылы ақпараттық файлды драйвердің каталогынан шолып немесе атын енгізіп таңдаңыз. Бұл каталогта тек бір драйвердің жиынтығы болуы керек. Себебі бұл утилита осы каталогтағы (және ішкі каталогтардағы) барлық файлдарды орындалмалы бумаға айналдырады.

Осындай жағдайларда каталогта драйвердің бірнеше ақпараттық файлдары болуы мүмкін (кейде біреуі түрлі түсті, ал екіншісі моно принтерлерге арналады). Мұндай жағдайда қосымша диалог терезесі бууға арналған драйверді таңдауға мүмкіндік береді.

Сондай-ақ, каталог үлкен болған кезде сіз ескерту аласыз. Бұл бірден аса драйверді бумаға салуға жол бермеуге көмектеседі. Егер каталогта барлық қалаған немесе қажетті файлдар қамтылса, сіз осы жерден жалғастыруды таңдай аласыз.

Драйвер каталогы таңдалып, бір драйвер табылғанда, каталог пен драйвер туралы ақпарат шығады.

Алдын ала конфигурациялаушы драйверлер үшін төмендегі құсбелгі көзі белгіленеді. «Бума жасау» батырмасы басылған соң, мұны таңдау конфигурациялау диалог терезесін іске қосады.

Орнату түрі

«Драйверді алдын ала жүктеу» - USB кабелі тәрізді тікелей байланысты қолданатын пайдаланушыларға берілген таңдау опциясы. Драйверді орнату үшін болашақ Plug and Play оқиғасы қажет болады. Бірақ бұл бума барлық файлдарды Windows сақтау қоймасына болашақта қолдану мақсатымен орнатады. ЕСКЕРТУ: Құрылғының бірнеше драйвері табылатын болса, Операциялық жүйе Plug and Play оқиғасына өте сай келетін драйверді анықтайді немесе пайдаланушыға драйверді таңдау диалог терезесін ұсынады.

Әдепкі мәні бойынша орындалатын үрдіс прогресс диалог терезесімен іске қосылады. Прогресс диалог терезесін өшіру үшін орындалатын үрдісті командалар жолағындағы “/q” белгісімен іске қосыңыз. Егер сіздің орнату үрдісінің соңында соңғы пайдаланушыны принтерді қосу туралы ескерткіңіз келетін болса, онда «Принтерді қосуға нұсқау беру» құсбелгі көзін белгілеңіз.

Желілік байланысты қолданатын принтерлер үшін «Желілік портты жасау және драйверді орнату» параметрін таңдаңыз. «Желілік параметрлер» батырмасы іске қосылып, сіз қажетті желілік параметрлерге енгізу үшін оны басасыз.

Желілік параметрлер

Сіз желілік принтерді төмендегі әдістердің біреуін немесе бірнешеуін пайдалана отырып табуға тиістісіз. Бұл утилита параметрлердің дұрыс екендігін анықтау үшін құрылғымен байланыспайды, бірақ синтаксисін тексереді. (Құрылғыны табуды қосу үшін Аппараттық құрал мекенжайының көрсетілгеніне көз жеткізіңіз.)

IP мекенжайы:

Принтердің IPv4 немесе IPv6 мекенжайын енгізіңіз

Аппараттық құрал мекенжайы:

Принтердің аппараттық құрал мекенжайын енгізіңіз

Хост аты:

Принтердің хост атын енгізіңіз

Төмендегі желілік параметрлер қосымша беріледі. Алдын ала берілген әдепкі мәндерді қабылдауыңызға немесе кез келгенін өзгертуіңізге болады.

Порт аты:

Бұл - құралатын желілік порт аты. Егер бұл атау бар болса, нөмір оны бірегей ету үшіін тіркеледі.

Принтер аты:

Бұл - принтерлердің қалтасында көрсетілетін принтер аты. Егер бұл атау бар болса, нөмір оны бірегей ету үшіін тіркеледі.

Бұл принтерді әдепкі етіп қойыңыз:

Иә – басқа қосымшалардан басып шығаратын кезде осы принтерді әдепкі етіп қояды.

Жоқ – осы жалғыз орнатылған принтер болса, ағымдағыны әдепкі етіп қалдырады.

Бұл принтерді ортақ пайдаланыңыз:

Иә – басқалардың осы принтерді пайдалануына рұқсат береді.

Ортақ атау:

Принтердің ортақ атауы. «Осы принтерді ортақ пайдалану» құсбелгі көзіне Иә жауабы таңдалғанда ғана қосылады. Егер бұл атау бар болса, нөмір оны бірегей ету үшіін тіркеледі.


Бума нысанасы

Шығыс бумасына атау мен орын енгізу үшін «Басқаша сақтау» батырмасын таңдаңыз. Утилита буманы уақытша каталогтың ішіне құрып, оны соңғы орналасатын жеріне көшіреді. Бума бірге жеткізілуге тиісті 2 файлдан тұрады: .exe және .cab.

Ішінде буманың егжей-тегжейлері бар сәйкес келетін xml сипатты файл да соңғы орналасатын жерге көшіріледі. Орындалу барысында DDU арқылы пайдаланылмаған кезде ғана xml бумасы ақпаратты болып табылады.


Бума жасау

Барлық ақпаратты енгізіп болған соң, «Бума жасау» батырмасын басыңыз. Қажетті ақпарат енгізілмейінше, бұл батырма басылмайды. Батырма басылған соң, «Болдырмау» батырмасы мен «Орындалуы» көрсеткіші қосылады.

Бума жасау үрдісін тоқтату үшін «Болдырмау» батырмасын басыңыз.

Орындалу үрдісі прогресс диалог терезесімен, қажет болған жағдайда, тікелей қосылатын принтерге қатысты пайдаланушы нұсқауымен іске қосылады. Егер орындалу барысында қателік пайда болса, қателік туралы диалог терезесі ашылады. Қателік туралы диалог терезелерін шығартпау үшін «Барлық соңғы пайдаланушының қателік туралы хабарларын болдырмау» құсбелгі көзін белгілеуіңіз қажет.


Қосымша ескертулер:

Осы қосымшаны жабу үшін жоғарғы оң жақтағы Windows жүйесінің жабу батырмасын пайдаланыңыз.


Қолдау көрсетілетін операциялық жүйелер

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP 64 биттік шығарылымы

Microsoft Windows Server 2003 / 2008

Microsoft Windows Server 2003 / 2008 64 биттік шығарылымы

Microsoft Windows Vista

Microsoft Windows Vista (64 бит)


Командалар жолағы параметрлері

Соңғы пайдаланушы бумасын командалар жолағының қосқыштарын қосу арқылы өзгертуге болады. Командалар жолағының қосқыштары бос орындармен ажыратылмаса, оларды біріктіруге болады. Командалар жолағында жарамсыз таңба немесе дұрыс емес пішім сияқты қателік болса, қателік туралы хабар шығады. Дұрыс емес командалар жолағының қосқыштары еленбейді. Төмендегі командалар жолағының сипаттамасы да “/?” белгісі бар пайдаланушы бумасын іске қосу арқылы (ағылшын тілінде) қолданылады.

Алдын ала жүктелетін бумалар төмендегі командалар жолағының параметрлерін қолданады:

/? командалар жолағы туралы ақпаратты көрсету (тек ағылшын тілінде)

/q орындалуы барысы жолағын кішірейту

/p пайдаланушының принтерді қосуына нұсқау беру

/s соңғы пайдаланушының қателік туралы хабарларын азайту

Желілік принтер бумалары төмендегі командалар жолағының параметрлерін қолданады:

/? командалар жолағы туралы ақпаратты көрсету (тек ағылшын тілінде)

/q орындалуы барысы жолағын кішірейту

/s соңғы пайдаланушының қателік туралы хабарларын азайту

/ip принтерді анықтауға көрсетілген IP мекенжайын пайдалану, мысалы, /ip 120.25.5.56

/hw <аппараттық құрал мекенжайы> принтерді анықтауға көрсетілген аппараттық құрал мекенжайын пайдалану, мысалы, /hw 0001E6299128

/hn <хост аты> принтерді анықтауға көрсетілген хост атын пайдалану, мысалы, /hn Myhostname

Хост аты 255 таңбадан аспау керек және төмендегі таңбаларды ғана қамти алады: A-Z, a-z, 0-9 және сызықша (-).

/pn <порт аты> көрсетілген атты порт аты ретінде пайдалану, мысалы, /pn HPPort

Порт атының құрамында бос орын болмауға және ол 128 таңбадан аспауға тиісті.

/n ”<принтер аты>” көрсетілген атты принтер аты ретінде пайдалану, мысалы, /n "HP LaserJet 8150"

Принтер аты тырнақшаларға алынуға, құрамы 40 таңбадан аспауға және мынандай арнайы таңбаларды қамтымауға тиісті: ! # ,

/d бұл принтерді әдепкі етіп қою

/sn ”<ортақ атау >” ортақ пайдалануды қосу және көрсетілген атауды принтерге ортақ аиау ретінде пайдалану, мысалы, /sn ”My shared HP LaserJet 8150”

Ортақ атау тырнақшаларға алынуға, құрамы 80 таңбадан аспауға және мынандай арнайы таңбаларды қамтымауға тиісті: / \ : ; “ ? * + = < > [ ]

© Copyright 2007 - 2008 Hewlett-Packard Development Company, L.P.