Introdução

O HP Driver Deployment Utility permite que um administrador crie um pacote de instalação silenciosa e autônoma de drivers a ser usado pelos usuários finais. Este utilitário suporta o acréscimo de drivers de impressão ao armazenamento de drivers do Windows e a criação de entradas na pasta da Impressora. O Driver Deployment Utility suporta drivers de impressão projetados para uso com o Assistente para Adicionar Impressora da Microsoft. Aplicam-se todas as restrições e alertas de certificação da Microsoft.

A IU é dividida em três seções:

  1. A “Origem do Pacote” descreve o tipo de pacote e o local do driver que você deseja criar.
  2. O “Destino do Pacote” identifica o nome e o local do pacote de instalação.
  3. A opção "Criar pacote" inicia o processo de criação do pacote.


Origem do pacote

Diretório de drivers

Utilize o botão “Selecionar driver…” para selecionar um arquivo inf no diretório de drivers procurando-o ou digitando-o. Você só deve ter um pacote de drivers neste diretório porque este utititário vai empacotar todos os arquivos encontrados neste diretório (e subdiretórios) no executável. Se você baixar um pacote de driver compactado, você deve expandi-lo antes de usar este utilitário.

Em alguns casos, você pode ter vários arquivos inf do driver no diretório (às vezes um é para impressoras coloridas e outro para impressoras preto-e-branco). Neste caso, um novo diálogo vai permitir selecionar o driver a ser empacotado.

Você também vai receber uma advertência caso o diretório seja grande. Isso serve para ajudar a impedir o empacotamento de mais de um driver. Talvez você prefira continuar neste ponto se o diretório contiver todos os arquivos desejados ou necessários.

Depois que o diretório de drivers for selecionado, e for encontrado um driver, são exibidas as informações do diretório e do driver.

Para os drivers que suportam a pré-configuração, a caixa de seleção a seguir será habilitada. Com essa seleção, será aberto um diálogo de configuração depois que se seleciona o botão "Criar pacote".

Tipo de instalação

“Pré-carregar o driver” – Esta é a opção que os usuários que vão usar uma conexão direta, como um cabo USB, devem escolher. Será necessário um evento futuro do tipo Plug and Play para instalar o driver, mas todos os arquivos serão instalados por este pacote no armazenamento do driver do Windows para uso futuro. OBSERVAÇÃO: se forem encontrados vários drivers para um dispositivo, o Sistema Operacional vai determinar qual driver combina com o evento Plug and Play ou apresentar ao usuário um diálogo de seleção de driver.

Por padrão, o executável vai funcionar com um diálogo de progresso. Para desativar o diálogo de progresso, abra o executável com um "/q" na linha de comando. Se você quiser solicitar que o usuário final conecte a impressora ao final da instalação, selecione a caixa de marcação "Mostrar uma solicitação de conexão da impressora”.

Para as impressoras que usam uma conexão de rede, selecione a opção "Criar uma porta de rede e instalar o driver”. O botão “Configurações de rede” vai ficar ativado, e você deve clicar nele para inserir as configurações exigidas de rede.

Configurações de rede

Você deve identificar a impressora de rede através de um ou mais dos seguintes métodos. Este utilitário não se comunica com o dispositivo para determinar se as configurações são válidas, mas faz uma verificação de sintaxe. (Para ativar a redescoberta do dispositivo, garante que o Endereço de Hardware seja especificado.)

Endereço IP:

Insira o endereço IPv4 ou IPv6 da impressora

Endereço de hardware:

Insira o endereço de hardware da impressora

Nome de host:

Insira o nome de host da impressora

As seguintes configurações de rede são adicionais. Você pode aceitar os valores padrão pré-inseridos ou alterar qualquer um deles.

Nome da porta:

Este é o nome da porta de rede que será criado. Se o nome já existir, será acrescentado um número para torná-lo exclusivo.

Nome da impressora:

Este é o nome da impressora que vai aparecer na pasta das impressoras. Se o nome já existir, será acrescentado um número para torná-lo exclusivo.

Configure esta impressora como padrão:

Sim – tornará esta impressora a padrão ao imprimir de outros aplicativos.

Não – manterá o padrão atual, a menos que seja a única impressora instalada.

Compartilhe esta impressora:

Sim – vai permitir que outras pessoas usem esta impressora.

Nome de compartilhamento:

Compartilhe o nome da impressora. Está ativado apenas se "Compartilhar esta impressora" for Sim. Se o nome já existir, será acrescentado um número para torná-lo exclusivo.


Destino do pacote

Selecione o botão “Salvar como...” para inserir o nome e o local para o pacote de saída. O utilitário vai criar o pacote no diretório temp e depois movê-lo para o local final. O pacote vai consistir em dois arquivos que precisam ser entregues juntos: um .exe e um .cab.

Também será copiado para o local final um arquivo correspondente de descrição xml contendo os detalhes do pacote. O pacote xml serve apenas para fins informativos, não sendo usado pelo DDU durante a execução.


Criar pacote

Selecione o botão “Criar pacote” ao inserir todas as informações acima. Este botão será desativado até você inserir as informações necessárias. Depois de selecionado, o botão “Cancelar” e a barra de "Progresso" serão habilitados.

Para interromper a criação do pacote, selecione o botão "Cancelar".

O executável será aberto com uma caixa de diálogo de progresso e, se necessário, o usuário vai precisar fornecer uma impressora de conexão direta. Caso seja encontrado um erro durante a execução, vai aparecer um diálogo de erro. Para ignorar o diálogo de erro, você deve selecionar a caixa “Ignorar todas as mensagens de erro de usuário final”.


Observações complementares:

Para fechar este aplicativo, use o botão Fechar do Windows no canto superior direito.


Sistemas operacionais com suporte

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP, versão de 64 bits

Microsoft Windows Server 2003 / 2008

Microsoft Windows Server 2003 / 2008, versão de 64 bits

Microsoft Windows Vista

Microsoft Windows Vista (64 bits)


Opções da linha de comando

O pacote do usuário final pode ser modificado acrescentando-se chaves da linha de comando. As chaves da linha de comando podem ser combinadas caso sejam separadas por espaços. É exibida uma mensagem de erro se a linha de comando contiver erro, como um caractere inválido ou uma formatação inadequada. As chaves inadequadas da linha de comando são ignoradas. A descrição a seguir da linha de comando também está disponível (em inglês) quando se executa o pacote do usuário final com um "/?".

Os pacotes pré-carregados suportam as seguintes opções na linha de comando:

/? exibe as informações da linha de comando (apenas em inglês)

/q ignora a barra de progresso

/p solicita que o usuário conecte uma impressora

/s ignora as mensagens de erro do usuário final

Os pacotes da impressora de rede suportam as seguintes opções na linha de comando:

/? exibe as informações da linha de comando (apenas em inglês)

/q ignora a barra de progresso

/s ignora as mensagens de erro do usuário final

/ip <endereço ip> usa o endereço IP especificado para identificar a impressora, por exemplo, /ip 120.25.5.56

/hw <endereço de hardware> usa o endereço de hardware especificado para identificar a impressora, por exemplo, /hw 0001E6299128

/hn <nome de host> usa o nome de host especificado para identificar a impressora, por exemplo, /hn Meunomedehost

O nome de host não pode ter mais de 225 caracteres e só pode conter os seguintes caracteres: A-Z, a-z, 0-9 e o hífen (-).

/pn <nomedaporta> use o nome especificado como nome de porta, por exemplo, /pn HPPort

O nome de porta não pode conter espaços e não pode ser maior do que 128 caracteres.

/n ”<nomedaimpressora>” use o nome especificado como nome da impressora, por exemplo, /n "HP LaserJet 8150"

O nome da impressora deve estar entre aspas, não pode ter mais de 40 caracteres e não pode conter nenhum dos seguintes caracteres especiais: ! # ,

/d configurar esta impressora como padrão

/sn ”<nomedecompartilhamento>” ativa o compartilhamento e usa o nome especificado como nome de compartilhamento para a impressora, por exemplo, /sn ”Minha HP LaserJet 8150 compartilhada”

O nome de compartilhamento deve estar entre aspas, não pode ter mais de 80 caracteres e não pode conter nenhum dos seguintes caracteres especiais: / \ : ; “ ? * + = < > [ ]

© Copyright 2007-2008 Hewlett-Packard Development Company, L.P.