Uvod

Program HP Driver Deployment Utility (DDU) omogućava administratoru da kreira paket za instaliranje upravljačkih programa za samostalnu instalaciju od strane krajnjih korisnika. Ovaj uslužni program podržava dodavanje upravljačkih programa za štampač u skladište Windows upravljačkih programa i kreira stavke u fascikli za štampač. Program Driver Deployment Utility podržava upravljačke programe koji su kreirani za korišćenje sa Microsoft-ovim Čarobnjakom za dodavanje štampača. Važe sva ograničenja i upozorenja kompanije Microsoft.

Korisnički interfejs je podeljen na 3 dela:

  1. „Izvor paketa“ opisuje tip paketa i lokaciju upravljačkog programa koji želite da kreirate
  2. „Cilj paketa“ prepoznaje ime i lokaciju instalacionog paketa
  3. „Kreiraj paket“ pokreće proces kreiranja paketa


Izvor paketa

Direktorijum upravljačkog programa

Upotrebite dugme „Izaberi upravljački program…“ da biste izabrali inf datoteku u upravljačkom direktorijumu, tražeći je ili unoseći njeno ime. U ovom direktorijumu bi trebalo da imate samo jedan paket upravljačkih programa jer ovaj uslužni program pakuje sve datoteke koje pronađe u ovom direktorijumu (i poddirektorijumima) u jednu izvršnu datoteku. Ukoliko ste preuzeli komprimovan paket upravljačkih programa, morate ga razviti pre korišćenja ovog uslužnog programa.

U nekim slučajevima se možete imati više inf datoteka upravljačkog programa u direktorijumu (nekad je jedna za štampače u boji, a druga za jednobojne štampače). U ovom slučaju, dodatni dijalog će vam omogućiti da izaberete upravljački program koji ćete da pakujete.

Dobićete i upozorenje ukoliko vam je direktorijum obiman. Ovo treba da spreči pakovanje više od jednog upravljačkog programa. Možete odlučiti da nastavite ukoliko direktorijum sadrži sve željene ili potrebne datoteke.

Kada je direktorijum upravljačkog programa izabran i jedan upravljački program pronađen, prikazuju se direktorijum i informacije o upravljačkom programu.

Za upravljačke programe koji podržavaju pretkonfiguraciju, biće omogućeno sledeće polje za potvrdu. Odabiranje ovog polja će pokrenuti konfiguracijski dijalog nakon što je pritisnuto dugme „Kreiraj paket“.

Tip instalacije

„Pripremno preuzimanje upravljačkog programa“ je opcija koju treba da izaberu korisnici koji će upotrebljavati direktnu vezu, kao što je USB kabl. „Plug and Play“ događaj će kasnije biti neophodan za instaliranje upravljačkog programa, ali će ovim paketom sve datoteke biti instalirane u skladište Windows upravljačkih programa za buduću upotrebu. NAPOMENA: Ako se za uređaj pronađe više upravljačkih programa, operativni sistem će odlučiti koji upravljački program najviše odgovara „Plug and Play“ događaju ili će korisniku prikazati dijalog za izbor upravljačkog programa.

Prema podrazumevanim postavkama, izvršna datoteka se izvršava sa progresivnim dijalogom. Da isključite progresivni dijalog, pokrenite izvršnu datoteku koristeći prekidač “/q” u komandnoj liniji. Ukoliko krajnjem korisniku želite da ponudite da poveže štampač na kraju instaliranja, onda izaberite polje za potvrdu „Prikaži ponudu za povezivanje štampača“.

Za štampače koji koriste mrežnu vezu, izaberite opciju „Kreiraj mrežni port i instaliraj upravljački program“. Biće omogućeno dugme „Podešavanje mreže“ i treba da kliknete na njega da biste ušli u potrebna podešavanja mreže.

Mrežne postavke

Morate prepoznati mrežni štampač na jedan ili više sledećih načina. Ovaj uslužni program ne komunicira sa uređajem da bi utvrdio ispravnost postavki, ali proverava sintaksu. (Da biste omogućili ponovno otkrivanje uređaja, obezbedite da hardverska adresa bude navedena.)

IP adresa:

Unesite IPv4 ili IPv6 adresu štampača

Hardverska adresa:

Unesite hardversku adresu štampača

Ime domaćina:

Unesite ime domaćina štampača

Sledeće mrežne postavke su dodatne. Možete prihvatiti prethodno unete podrazumevane vrednosti ili promeniti neku od njih.

Ime porta:

Ovo je ime mrežnog porta koji će biti kreiran. Ako to ime već postoji, biće mu pridodata cifra kako bi postalo jedinstveno.

Ime štampača:

Ovo je ime štampača koje će se pojaviti u fascikli štampača. Ako to ime već postoji, biće mu pridodata cifra kako bi postalo jedinstveno.

Podesi ovaj štampač kao podrazumevani:

Da – učiniće da ovaj štampač bude podrazumevani štampač kada se štampa iz drugih aplikacija.

Ne - zadržaće aktuelni podrazumevani štampač, osim ako je ovo jedini instalirani štampač.

Deli ovaj štampač:

Da – omogućiće drugima da koriste ovaj štampač.

Deli ime:

Deli ime za štampač. Omogućeno je samo ako je za postavku „Deli ovaj štampač“ izabrano Da. Ako to ime već postoji, biće mu pridodata cifra kako bi postalo jedinstveno.


Cilj paketa

Izaberite dugme „Sačuvaj kao…“ da biste uneli ime i lokaciju za izlazni paket. Uslužni program će kreirati paket u privremeno direktorijumu, a onda će ga prebaciti na konačnu lokaciju.Paket će se sastojati od 2 datoteke koje se moraju zajedno isporučiti: .exe i .cab datoteke.

Podudarna xml opisna datoteka sa detaljima o paketu će takođe biti iskopirana na konačnu lokaciju. xml paket je samo informativan, ne koristi se u toku izvršavanja DDU.


Kreiraj paket

Kada unesete sve navedene informacije, izaberite dugme „Kreiraj paket“. Ovo dugme će biti onemogućeno sve dok ne unesete potrebne informacije.Kada ih izaberete, biće omogućeni dugme „Otkaži“ i traka „Tok“

Da zaustavite kreiranje paketa, izaberite dugme „Otkaži“.

Izvršni program će se pokrenuti dijalogom toka i, ako je potrebno, sa ponudom korisniku da direktno poveže štampač. Ukoliko se naiđe na grešku tokom izvršenja, pojaviće se dijalog o grešci. Da biste sprečili pojavljivanje dijaloga o grešci, trebalo bi da izaberete polje za potvrdu „Spreči pojavljivanje svih poruka o greškama krajnjeg korisnika“.


Dodatne napomene:

Da zatvorite ovu aplikaciju, koristite Windows dugme za zatvaranje u gornjem desnom uglu.


Podržani operativni sistemi

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP 64-Bit Edition

Microsoft Windows Server 2003 / 2008

Microsoft Windows Server 2003 / 2008 64-Bit Edition

Microsoft Windows Vista

Microsoft Windows Vista (64-bit)


Opcije komandne linije

Paket za krajnjeg korisnika se može izmeniti dodavanjem prekidača komandne linije. Prekidači komandne linije se mogu kombinovati ako su odvojeni razmacima. Prikazuje se poruka o grešci ako komandna linija sadrži grešku kao što je neispravan znak ili neodgovarajuće formatiranje. Neispravni prekidači komandne linije se ignorišu. Sledeći opis komandne linije je takođe dostupan (na engleskom jeziku) kada se paket krajnjeg korisnika pokrene sa “/?”.

Pripremno preuzeti paketi podržavaju sledeće opcije komandne linije:

/? prikaži informacije komandne linije (samo na engleskom jeziku)

/q spreči traku toka

/p ponudi korisniku da poveže štampač

/s spreči poruke o greškama krajnjeg korisnika

Paketi za mrežne štampače podržavaju sledeće opcije komandne linije:

/? prikaži informacije komandne linije (samo na engleskom jeziku)

/q spreči traku toka

/s spreči poruke o greškama krajnjeg korisnika

/ip <ip adresa> koristi navedenu IP adresu za prepoznavanje štampača, npr. /ip 120.25.5.56

/hw <hardverska adresa> koristi navedenu hardversku adresu za prepoznavanje, npr. /hw 0001E6299128

/hn <ime domaćina> koristi navedeno ime domaćina za prepoznavanje štampača, npr. /hn Myhostname

Ime domaćina ne može biti duže od 255 znakova i može sadržati samo sledeće znakove: A-Z, a-z, 0-9 i crtica (-).

/pn <ime porta> koristi navedeno ime kao ime porta, npr. /pn HPPort

Ime porta ne može sadržati razmake i ne može biti duže od 128 znakova.

/n ”<ime štampača>” koristi navedeno ime kao ime štampača, npr. /n "HP LaserJet 8150"

Ime štampača mora biti pod navodnicima, ne može biti duže od 40 znakova i ne može sadržati sledeće specijalne znakove: ! # ,

/d postavi ovaj štampač kao podrazumevani

/sn ”<ime koje se deli>” uključi deljenje i koristi navedeno ime štampača koje se deli, npr. /sn ”My shared HP LaserJet 8150”

Ime koje se deli mora biti pod navodnicima, ne može biti duže od 80 znakova i ne može sadržati sledeće specijalne znakove: / \ : ; “ ? * + = < > [ ]

© Copyright 2007-2008 Hewlett-Packard Development Company, L.P.