Giới thiệu

HP Driver Deployment Utility (DDU) cho phép người quản trị tạo gói cài đặt trình điều khiển để người dùng cuối có thể cài đặt không cần giám sát. Tiện ích này hỗ trợ việc thêm các trình điều khiển máy in vào hệ thống lưu trữ trình điều khiển của Windows và tạo các mục trong thư mục của Máy in. Tiện ích cài đặt Driver hỗ trợ các driver inấn được thiết kế dùng trong Trình hướng dẫn Cài thêm máy in của Microsoft. Tất cả các cảnh báo và yêu cầu chứng nhận của Microsoft đều được áp dụng..

Giao diện Người dùng chia thành 3 phần:

  1. ‘Gói Nguồn’ mô tả loại gói và vị trí của trình điều khiển mà bạn muốn tạo
  2. ‘Gói Đích’ nhận dạng tên và vị trí của gói cài đặt
  3. ‘Tạo Gói’ bắt đầu quy trình tạo gói


Gói Nguồn

Thư mục Trình điều khiển

Sử dụng nút ‘Chọn Trình điều khiển...’ để chọn một tập tin inf trong thư mục trình điều khiển bằng cách duyệt hoặc nhập tên tập tin đó vào. Bạn chỉ nên có một gói trình điều khiển trong thư mục này vì tiện ích này sẽ đóng gói tất cả các tập tin được tìm thấy trong thư mục này (và các thư mục con) thành một gói có thể thực thi được. Nếu đã tải vềgói trình điều khiển được nén, thì bạn phải giải nén gói đó trước khi sử dụng tiện ích này.

Trong một số trường hợp, bạn sẽ có nhiều tập tin inf trình điều khiển trong thư mục đó (đôi khi chỉ một tập tin là dành cho máy in màu, còn những tập tin khác dành cho máy in trắng đen). Trong trường hợp này, một hộp thoại khác sẽ cho phép bạn chọn trình điều khiển để đóng gói.

Bạn cũng sẽ nhận được một cảnh báo nếu thư mục của bạn quá lớn. Điều này sẽ giúp ngăn chặn việc đóng gói nhiều trình điều khiển. Bạn có thể chọn để tiếp tục tại điểm này nếu thư mục chứa tất cả các tập tin cần thiết hoặc mongmuốn.

Khi thư mục trình điều khiển được chọn, và đã tìm thấy một trình điều khiển, thông tin về thư mục và trình điều khiển sẽ hiển thị.

Đối với các trình điều khiển hỗ trợ cấu hình sẵn, hộp kiểm bên dưới sẽ được bật. Chọn hộp kiểm này sẽ làm chạy một hộp thoại cấu hình sau khi nút ‘Tạo Gói’ được chọn

Loại Cài đặt

‘Nạp trước trình điều khiển – là tùy chọn dành cho người sử dụng chọn kết nối trực tiếp, giống như cáp USB. Cần có chức năng Cắm và Chạy để cài đặt trình điều khiển, nhưng gói này sẽ cài đặt tất cả tập tin vào hệ thống lưu trữ trình điều khiển Windows để sử dụng về sau. LƯU Ý: Nếu tìm thấy nhiều trình điều khiển cho một thiết bị, thì Hệ điều hành sẽ xác định trình điều khiển phù hợp nhất cho việc Cắm và Chạy, hoặc cung cấp cho người dùng một hộp lựa chọn trình điều khiển.

Theo mặc định, tập tin thực thi sẽ tự động chạy cùng với một hộp thoại tiến trình. Để tắt hộp thoại tiến trình, chạy tập tin thực thi với một dòng lệnh ‘/q’. Nếu bạn muốn nhắc người sử dụng cuối kết nối với máy in vào cuối quá trình cài đặt, hãy chọn hộp kiểm “Hiển thị lời nhắc kết nối máy in”.

Đối với những máy in sử dụng kết nối mạng, hãy chọn tùy chọn ‘Tạo cổng mạng và cài đặt trình điều khiển’. Nút 'Càiđặt Mạng’ sẽ bật, và bạn ph̉ i nhấp vào nút này để nhập cài đặt mạng được yêu cầu.

Cài đặt Mạng

Bạn phải nhận dạng máy in mạng bằng một trong các phương pháp sau. Tiện ích này không giao tiếp với thiết bị để xác định tính hợp lệ của cài đặt, nhưng sẽ thực hiện việc kiểm tra cú pháp. (Để bật tính năng tìm kiếm lại của thiết bị, hãy bảo đảm là đã quy định Địa chỉ Phần cứng.)

Địa chỉ IP:

Nhập địa chỉ IPv4 hoặc IPv6 của máy in

Địa chỉ Phần cứng:

Nhập địa chỉ phần cứng của máy in

Tên máy chủ:

Nhập tên máy chủ in

Cài đặt mạng sau là phần bổ sung. Bạn có thể chấp nhận các giá trị mặc định được nhập vào sẵn hoặc thay đổi bất kỳ giá trị nào.

Tên Cổng:

Đây là tên cổng mạng sẽ được tạo. Nếu tên đã có sẵn, số sẽ được gán để tạo một tên riêng.

Tên Máy in:

Đây là tên máy in sẽ xuất hiện trong thư mục của các máy in. Nếu tên đã có sẵn, số sẽ được gán để tạo một tên riêng.

Đặt máy in này làm máy in mặc định:

Có – sẽ đặt máy in này làm mặc định khi in từ các ứng dụng khác.

Không – sẽ giữ lại mặc định hiện tại, trừ khi đây là máy in duy nhất được cài đặt.

Chia sẻ máy in này:

Có – cho phép người khác sử dụng máy in này.

Tên Chia sẻ:

Tên chia sẻ của máy in. Chỉ được bật khi “Chia sẻ máy in này" là Có. Nếu tên đã có sẵn, số sẽ được gán để tạo một tên riêng.


GóiĐích

Chọn nút ‘Lưu dạng...’ để nhập tên và vị trí cho gói xuất. Tiện ích sẽ tạo gói trong thư mục tạm thời và sau đó sẽ chuyển nó đến vị trí cuối cùng. Gói này sẽ chứa 2 tập tin cần được đóng gói cùng nhau: một tập tin ở dạng .exe và một ở dạng .cab

Tập tin mô t̉ xml tương ứng chứa các chi tiết gói cũng sẽ được sao chép vào vị trí cuối cùng. Gói xml chỉ là thôngtin, không được DDU sử dụng trong suốt quá trình thực thi.


Tạo Gói

Chọn nút ‘Tạo Gói’ khi bạn đã nhập vào tất cả các thông tin trên. Nút này sẽ được tắt cho đến khi bạn đã nhập vào các thông tin bắt buộc.Khi được chọn, nút ‘Hủy’ và thanh ‘Tiến trình’ sẽ bật.

Để ngừng tạo gói, hãy chọn nút ‘Hủy’.

Tập tin thực thi sẽ tự động chạy với hộp thoại tiến trình, và nếu có yêu cầu, sẽ có một dấu nhắc người dùng kết nốitrực tiếp với máy in. Nếu gặp phải lỗi trong quá trình thực thi, hộp thoại lỗi sẽ xuất hiện. Để chặn hộp thoại lỗi, bạn nên chọn hộp kiểm ‘Chặn tất cả thông báo lỗi người sử dụng cuối’.


Ghi chú Bổ sung:

Sử dụng nút đóng Windows ở phía trên bên phải để đóng ứng dụng này lại.


Những Hệ điều hành Được Hỗ trợ

Microsoft Windows 2000

Microsoft Windows XP

Microsoft Windows XP 64-Bit Edition

Microsoft Windows Server 2003 / 2008
Microsoft Windows Server 2003 / 2008 64-Bit Edition

Microsoft Windows Vista

Microsoft Windows Vista (64-bit)


Các Tùy chọn Dòng lệnh

Gói người dùng cuối có thể được thêm bằng cách thêm các chuyển mạch dòng lệnh. Dòng lệnh chuyển đổi có thể kếthợp nếu chúng không bị ngăn cách bởi khỏ ng trống. Một thông báo lỗi được hiển thị nếu các dòng lệnh có chứa lỗi, như ký tự sai và hiển thị không đúng. Các chuyển đổi dòng lệnh khônng đúng sẽ bị bỏ qua. Diễn gỉ i dòng lệnh sau cũng có hiệu lực (bằng tiếng Anh) bằng cách chạy gói người dùng cuối với một dấu “/?”.

Gói tải trước hỗ trợ các tùy chọn dòng lệnh sau:

/? hiển thị thông tin dòng lệnh (chỉ bằng tiếng Anh)

/q ngăn chặn thanh tiến trình

/p thông báo người dùng kết nối vào máy in

/s chặn tất cả các thông báo lỗi người dùng cuối

Gói máy in mạng tải trước hỗ trợ các tùy chọn dòng lệnh sau:

/? hiển thị thông tin dòng lệnh (chỉ bằng tiếng Anh)

/q ngăn chặn thanh tiến trình

/s chặn tất cả các thông báo lỗi người sử dụng cuối

/ip <địa chỉ ip> sử dụng địa chỉ IP đã xác định để xác định máy in, ví dụ: /ip 120.25.5.56

/hw <địa chỉ phần cứng> sử dụng địa chỉ Phần cứng đã xác định để xác định máy in, ví dụ: /hw 0001E6299128

/hn <tên máy chủ> sử dụng Tên máy chủ đã xác định để xác định máy in, ví dụ: /hn Myhostname

Tên máy chủ không được dài quá 255 ký tự và chỉ chứa các ký tự sau: A-Z, a-z, 0-9, và dấu gạch ngang (-).

/pn <tên cổng> sử dụng tên đã xác định làm tên cổng, ví dụ: /pn HPPort

Tên cổng không thể chứa khỏ ng trắng và không dài quá 128 ký tự.

/n ”<tên máy in>” sử dụng tên đã xác định làm tên máy in, ví dụ: /n ”HP LaserJet 8150”

Tên của máy in ph̉ i được đặt trong dấu ngoặc kép, không dài quá 40 ký tự và không được chứa bất kỳ các ký tự đặcbiệt sau: ! # ,

/d đặt máy in này làm máy in mặc định:

/sn ”<tên chia sẻ>” bật chức năng chia sẻ và sử dụng tên đã xác định làm tên dùng chung của máy in, ví dụ: /sn ”My shared HP LaserJet 8150”

Tên dùng chung ph̉ i được đặt trong dấu ngoặc kép, không dài quá 80 ký tự và không được chứa bất kỳ các ký tự đặcbiệt sau: / \ : ; “ ? * + = < > [ ]

© Copyright 2007-2008 Hewlett-Packard Development Company, L.P.