Guía de instalación de Microsoft Office Project Server 2003

Guía de instalación de Microsoft Office Project Server 2003

Microsoft Office Project Server 2003 puede utilizarse junto con Microsoft Office Project Edición Professional 2003 para promover una colaboración de equipo eficaz entre jefes de proyectos, integrantes de grupo y otros participantes. Los equipos del proyecto pueden revisar y trabajar con la información de Project Server 2003 mediante la interfaz de usuario basada en Web denominada Microsoft Office Project Web Access 2003.

Los integrantes de grupo del proyecto y otros participantes pueden utilizar Project Web Access 2003, cuya licencia de uso se concede por separado, para ver o trabajar con información del proyecto en un sitio Web. Los jefes de proyecto pueden actualizar los cambios a Project Edición Professional 2003 para que el plan del proyecto esté actualizado. (Consulte el contrato de licencia para el usuario final para obtener información sobre la licencia del producto.)

Para obtener más información sobre las tareas necesarias para instalar Project Server, consulte Opciones de implantación.

Para obtener información más completa sobre la implantación de Project Server, consulte el sitio Web de Microsoft.

Para obtener más información acerca de Project Server, consulte el sitio Web de Microsoft.


Información general sobre Microsoft Office Project Server 2003

Información general sobre Microsoft Office Project Server 2003

Project Server 2003 se ha diseñado para asistir en la colaboración entre jefes de proyectos que utilizan Microsoft Office Project Edición Professional 2003 y los integrantes de grupo que usan Microsoft Office Project Web Access 2003. Las funciones de administración de proyectos de empresa de Microsoft Office Project 2003 se han integrado en Project Edición Professional 2003, Project Web Access 2003 y Microsoft Office Project Server 2003.

Project Server 2003 incluye partes de horas, informes de estado, análisis y modelado de cartera de proyectos, recursos de empresa y plantillas de empresa.

El acceso del usuario a Project Server 2003 se realiza a través de Project Web Access 2003, que es un cliente basado en explorador que permite a los integrantes de grupo, jefes de recursos y ejecutivos indicar y ver la información de parte de horas y ver los informes de cartera de proyectos.

Project Edición Professional 2003 es un cliente de escritorio que permite a los jefes de proyecto crear y modificar planes de proyecto e integrantes del fondo de recursos de empresa. Los planes y recursos de proyectos se pueden guardar en la base de datos de Project Server 2003.

Project Server 2003 se puede integrar con Microsoft Windows SharePoint Services 2.0 para ofrecer funciones de colaboración como seguimiento de problemas y riesgos y administración de documentos.

Project Server 2003 es flexible y se ha diseñado para permitir que los clientes, socios y proveedores de soluciones amplíen su solución de administración de proyectos de empresa. Los clientes pueden comenzar por utilizar un número limitado de funciones y, a continuación, usar funciones adicionales a medida que se necesiten.

Pasar a la administración de proyectos de empresa exige ciertos cambios dentro de la organización. Algunos de los cambios tendrán un impacto considerable, de manera que es importante planear estos cambios antes de proceder con la implantación de Project Server 2003. Durante la fase de planeación, considere estratégicamente los procesos comerciales, los problemas culturales y la tecnología que podrían convertirse en factores importantes al actualizar las posibilidades de administración de proyectos.

Información adicional

Para obtener más información sobre Project Server 2003, consulte el sitio Web de Microsoft.

Para obtener más información sobre la implantación de Project Server 2003 en empresas, consulte el sitio Web de Microsoft.

Para obtener información sobre la administración de Project Server 2003, consulte el sitio Web de Microsoft.

Para obtener información acerca de las copias de seguridad y la restauración de los datos de Project Server 2003, consulte el sitio Web de Microsoft.


Componentes de Microsoft Office Project Server 2003

Componentes de Microsoft Office Project Server 2003

Project Server 2003 consta de los siguientes componentes:

  • Los componentes de cliente de Project Server 2003 gestionan todas las solicitudes de Microsoft Office Project Web Access 2003 y Project Data Service.
  • Procesador de vistas genera vistas de Project Web Access 2003.
  • El Administrador de sesiones gestiona los datos de las sesiones de cada cliente que se conecta a Project Server 2003 desde Project Web Access 2003.

Project Server 2003 requiere los servicios y el soporte de las siguientes aplicaciones de Microsoft:

  • Microsoft SQL Server 2000 es el sistema de administración de bases de datos para los usuarios que desean beneficiarse de todas las funciones de empresa incorporadas a Project Server 2003 en un entorno escalable. Tanto SQL Server 2000 Standard como SQL Server 2000 Enterprise admiten las funciones de empresa de Project Server 2003, pero sólo SQL Server 2000 Enterprise es compatible con las funciones de implantación avanzadas como conmutación por error o compatibilidad con HTTP. SQL Server 2000 deberá instalarse antes de poder instalar Project Server 2003 o configure Windows SharePoint Services para Project Server 2003.
  • Analysis Services de SQL Server 2000 ofrece servicios OLAP (Online Analytical Processing), necesarios para utilizar la función Analizador de la cartera de proyectos de Project Server 2003. La función Analizador de la cartera de proyectos sólo está disponible como función de empresa de Project Server 2003.
  • Windows SharePoint Services proporciona servicios de biblioteca de documentos y seguimiento de problemas y riesgos a nivel de proyecto cuando se configura de forma correcta para Project Server 2003. Windows SharePoint Services puede descargarse desde el sitio Web de Microsoft o se puede configurar una instalación existente de Windows SharePoint Services para Project Server 2003.
  • Microsoft Office Project Edición Professional 2003 proporciona funciones de administración de recursos y proyectos para toda la empresa, funciones de colaboración y herramientas de supuestos para organizaciones que precisan de una solución de administración de proyectos de empresa.
  • El complemento de integración con Outlook de Project Web Access 2003 facilita el seguimiento de las tareas que se han asignado en Microsoft Project. Las tareas pueden controlarse en Outlook 2000 o superior (o en Outlook Web Access con una capacidad limitada). El complemento de integración con Outlook se encuentra disponible en la Página principal de Project Web Access 2003.
  • Es necesario Internet Explorer 5.01 (o superior) para obtener acceso a la interfaz de usuario de Project Web Access 2003. Internet Explorer 5.5 es preciso para utilizar todas las funciones disponibles de Project Web Access 2003 y para tener acceso a Project Server 2003 desde Project Professional.


Arquitectura de Microsoft Office Project Server 2003

Arquitectura de Microsoft Office Project Server 2003

Las funciones de administración de proyectos de empresa de Microsoft Project se basan en una arquitectura de 3 niveles. El nivel de cliente proporcionado por Microsoft Office Project Edición Professional 2003 y Microsoft Office Project Web Access 2003. El nivel medio de la arquitectura suministrado por Microsoft Office Project Server 2003. Project Server 2003 combina aspectos de una aplicación de servidor Web de n niveles con una aplicación de base de datos de cliente servidor de dos niveles. Microsoft SQL Server 2000 proporciona el nivel de base de datos de la solución. Los clientes también pueden elegir utilizar las funciones de biblioteca de documentos, seguimiento de riesgos y seguimiento de problemas gracias a la integración de Project Server 2003 con Microsoft Windows SharePoint Services 2.0.

Para obtener más información sobre Project Server 2003, consulte el sitio Web de Microsoft.

Nivel de cliente

Project Web Access 2003 proporciona acceso al parte de horas, las vistas de proyectos, los informes de estado y ##Team Builder Lite##. Además, permite obtener acceso a la biblioteca de documentos y al seguimiento de riesgos y problemas a través de la integración con Windows SharePoint Services. Project Web Access 2003 está formado por un conjunto de controles Actives (principalmente, un control de tipo cuadrícula) y páginas HTML suministrados en páginas de Active Server. La primera vez que se tiene acceso a Project Web Access 2003 se descargan los controles ActiveX. Project Web Access 2003 precisa Microsoft Internet Explorer 5 o superior.

Project Edición Professional 2003 se ejecuta en Microsoft Windows 2000 y superior. Project Edición Professional 2003 puede publicar información en Project Server 2003 así como actualizar información desde Project Server 2003 a planes de proyecto. Project Professional permite abrir y guardar también proyectos y recursos de empresa desde Project Server 2003.

Con el fin de que los clientes de Project Web Access 2003 obtengan acceso a Project Server 2003, deberá agregar la dirección URL de Project Server 2003 a la lista Sitios de confianza de Internet Explorer en el equipo cliente.

Nivel de servidor de la aplicación

Project Server 2003 incluye características de administración de proyectos empresariales y no empresariales para aplicaciones de cliente. Las funciones no empresariales interactúan fundamentalmente con Project Server 2003 mediante el objeto de comercial de servidor. Project llama a este objeto cuando los planes de proyecto se publican en el servidor. Los clientes se comunican con el objeto comercial al publicar documentos XML en páginas ASP de Project Server. Project Server 2003 se ejecuta en Microsoft Windows 2000 Server o posterior y precisa Servicios de Internet Information Server 5.0 o posterior.

Nivel de base de datos

Microsoft SQL Server 2000 proporciona el nivel de base de datos para Project Server 2003. Project Edición Professional 2003 y Project Web Access 2003 trabajan con tablas de empresa y no de empresa en la base de datos de SQL Server. Project Server 2003 utiliza tablas de vistas que contienen datos de fase temporal para todos los proyectos publicados en el servidor para reducir la carga en SQL Server y permitir una mayor escalabilidad.

Microsoft Windows SharePoint Services 2.0

Windows SharePoint Services ofrece un almacén centralizado para documentos, problemas y riesgos; además de permitir a los usuarios actual de forma interactiva con estos elementos. Project Server 2003 se sirve de Windows SharePoint Services para realizar el seguimiento de problemas y riesgos y para la administración de documentos.

Windows SharePoint Services amplía desde un servidor único hasta una agrupación centralizada con varios servidores Web de cliente y servidores de base de datos de servidor.

Para obtener más información sobre Windows SharePoint Services, consulte el sitio Web de Microsoft.

Servicio de directorios de Active Directory

El conector de Active Directory en Project Server 2003 facilita la sincronización de los usuarios y grupos del servicio de directorios de Active Directory para Project Server 2003. Gracias a este componente nuevo, el servicio de directorio de Active Directory escribe datos en el fondo de recursos de empresa y en las tablas de seguridad de la base de datos de Project Server 2003 basados en la presencia y el estado de los usuarios del servicio de directorio de Active Directory en comparación con la presencia y el estado de los usuarios y grupos asignados a los grupos o usuarios del fondo de recursos de empresa.

Microsoft Outlook

El complemento de integración de Outlook para Project Server 2003 permite ver las asignaciones de Project en el Calendario de Outlook. Se agregará una ficha Project Web Access a cada cita. Los usuarios pueden interactuar con esta información en Outlook de la misma manera que interactúan con esta información en Project Web Access 2003.

Tras conectar Outlook a Project Server, podrá importar las asignaciones y establecer que Outlook aplique los mismos avisos para las asignaciones de proyectos que ya estaba usando en Outlook, o bien aplicar una configuración de avisos personalizada.


Requisitos de Microsoft Office Project Server 2003

Requisitos de Microsoft Office Project Server 2003

A continuación se indican los requisitos de hardware, sistema y funciones para la instalación de Microsoft Office Project Server 2003.

Requisitos de hardware

  • Espacio libre disponible en el disco duro: 130 megabytes (MB) aproximadamente para Project Server 2003. El uso de disco duro variará según las opciones de configuración; es posible que las opciones elegidas en la instalación personalizada precisen de más o menos espacio en el disco duro. Para conocer los requisitos de espacio en el disco para otros productos y componentes necesarios para muchas funciones de Project Server 2003, consulte la documentación de esos productos y componentes.
  • Procesador: Intel Pentium III a 550 megahercios (Mhz) o superior (se recomienda Intel Pentium III a 700 Mhz como mínimo) o un procesador similar.
  • Memoria: 256 MB de RAM o más (se recomienda un mínimo de 512 MB).

Nota Los requisitos de procesador, RAM y disco duro dependen en gran medida del número de servicios instalados en el equipo y de la carga del servidor. Los requisitos mínimos parten de la suposición de un servidor donde todos los componentes de Project Server 2003 y las tecnologías complementarias (Microsoft SQL Server 2000 y Windows SharePoint Services) se encuentran instalados. Para obtener más información acerca de los requisitos de sistema de Project Server 2003, consulte el sitio Web de Microsoft.

Requisitos del sistema

Microsoft Windows 2000 Server Service Pack 3 o superior o Microsoft Windows Server 2003. Además deben estar instalados los siguientes componentes:

  • Microsoft Internet Information Server (IIS).
  • Complemento Microsoft Management Console (MMC) para IIS.

Nota Microsoft Internet Explorer 5.01 o superior es necesario para Microsoft Office Project Web Access 2003.

Requisitos de funciones

Además de los requisitos del sistema descritos anteriormente, varias funciones de Project Server 2003 necesitan la instalación de otros productos y componentes:

  • Microsoft SQL Server 2000 Service Pack 3 o superior, o Microsoft Desktop Engine (MSDE) 2000 o superior.

    Nota Microsoft SQL Server 2000 es necesario para las funciones de empresa de Project Server 2003. Debe instalarse antes de instalar Project Server 2003.

  • Los servicios Analysis Services de Microsoft SQL Server son necesarios para la función Analizador de la cartera de proyectos de Project Server 2003.

    Notas

    • La función Analizador de la cartera de proyectos sólo está disponible junto a Microsoft Office Project Professional.
    • Los servicios Analysis Services están incluidos en Microsoft SQL Server 2000.
  • Windows SharePoint Services es necesario para utilizar las funciones de administración de documentos y seguimiento de problemas y riesgos de Project Server 2003.
  • Los service pack instalados para Analysis Services deben ser de la misma versión que los instalados para Microsoft SQL Server 2000.

Nota Microsoft Office 2000 o posterior es necesario en aquellos equipos que utilicen Project Web Access 2003 para usar páginas de acceso a datos.

Servicios de Terminal Server

Puede utilizar los Servicios de Terminal Server para conectarse a una copia de Microsoft Project Professional instalada en un servidor Terminal Server. MedianteTerminal Server podrá resolver algunos de los problemas de funcionamiento del vínculo WAN y habilitar el acceso a Project Server 2003 para los usuarios que trabajen fuera del dominio. Para obtener más información, consulte el sitio Web de Microsoft.


Información general sobre Microsoft Windows SharePoint Services 2.0

Información general sobre Microsoft Windows SharePoint Services 2.0

Microsoft Office Project Server 2003 puede integrarse con Windows SharePoint Services para ofrecer administración de documentos y seguimiento de problemas y riesgos para los equipos de proyecto. Project Server 2003 trabaja con los sitios de SharePoint proporcionados con la plantilla de Project Workspace (instalada mediante el Asistente de configuración de Windows SharePoint Services). La autenticación de Windows es necesaria para obtener acceso a estas funciones de colaboración.

Existen diversas mejoras fundamentales en la arquitectura de Windows SharePoint Services para la integración de Project Server 2003:

  • Windows SharePoint Services utiliza Microsoft SQL Server 2000 para almacenar todos los datos, incluidos los documentos, grupos y derechos de seguridad de usuario y la configuración administrativa. Esta mejora hace posible tener una fidelidad absoluta al crear copias de seguridad de los datos fundamentales de la misión del proyecto y restaurarlos.
  • Todos los usuarios, los grupos de sitios, las funciones y los derechos se almacenan también en la base de datos de SQL Server. De esta forma, se elimina la dependencia en los grupos de NT locales para la administración de usuarios. En consecuencia, se elimina el límite de grupos de usuario que uno puede crear.
  • Windows SharePoint Services admite varias plantillas para sus sitios. De esta forma se permite que Project Server 2003 utilice su propia plantilla de Project Workspace, que habilita un sitio proporcionado con esta plantilla para que trabaje a la perfección con Project Server 2003.
  • Windows SharePoint Services dispone de una arquitectura de implantación escalable. Se puede crear un sistema de agrupación centralizada de servidores y albergar muchos más sitios Web de los que se pueden albergar con SharePoint Team Services 1.0 de Microsoft.

Project Web Access 2003 se comunica con Windows SharePoint Services a través de los servicios Simple Object Access Protocol (SOAP) proporcionados por Windows SharePoint Services. Los servicios SOAP administrativos permiten que los servidores que ejecutan Project Server 2003 proporcionen remotamente un conjunto de sitios de Windows SharePoint Services para cada proyecto publicado, de manera que los usuarios del proyecto pueden colaborar en los documentos, problemas y riesgos del proyecto. Los servicios SOAP de nivel de usuario permiten que Project Server 2003 solicite un documento, problema o riesgo individual y establecen la vinculación entre el proyecto, las tareas y los elementos de la lista.

Nota El servicio de directorio Active Directory y las funciones Small Business Services de Windows SharePoint Services no son compatibles con Project Server 2003.

Novedades para los usuarios de Project Server

A continuación, se detallan algunas de las funciones nuevas que los usuarios de Project Server 2003 podrán utilizar cuando recurran a Windows SharePoint Services para realizar un seguimiento de los problemas y riesgos y para mantener una biblioteca de documentos de los proyectos:

  • Control sobre las versiones de los documentos y protección y desprotección de documentos Utilice el control sobre las versiones del documento para crear de forma automática una copia de seguridad de un archivo siempre que se guarde en una biblioteca de documentos. Los usuarios también pueden desproteger un archivo para bloquearlo mientras se modifica y así, impiden que otros usuarios puedan sobrescribirlo o modificarlo sin darse cuenta.
  • Mejoras en las listas de problemas y riesgos Existe una lista de riesgos nueva. Utilice la lista de seguimiento de riesgos para administrar activamente los proyectos. Los usuarios pueden asociar riesgos a tareas, problemas y documentos. Las mejoras en las listas de problemas y riesgos son:
    • Historial completo de todas las modificaciones efectuadas al elemento de la lista.
    • Informes gráficos sobre los problemas y riesgos derivados de la instalación de componentes y elementos Web de Microsoft Office en el servidor.
    • Permisos exclusivos en las listas. El jefe de proyecto puede aplicar permisos a una lista, de manera que se permita sólo a determinados usuarios realizar cambios en la lista.
  • Área de trabajo de Project Los usuarios pueden colaborar directamente en el sitio Área de trabajo de Project en Windows SharePoint Services. Además de administrar documentos, problemas y riesgos con sus proyectos y tareas, los usuarios también pueden contribuir al calendario, los anuncios y las discusiones del grupo. El Área de trabajo de Project también contiene seis elementos Web de Project Server 2003 para que los usuarios puedan ver los detalles del proyecto o los informes del proyecto en el área de trabajo.
  • Personalización del Área de trabajo de Project Si desea estandarizar los documentos y el seguimiento de problemas y riesgos o definir un aspecto homogéneo, puede crear una variación del Área de trabajo de Project y aplicarla en toda la organización.
  • Compatibilidad con plantillas de listas y sitios Los usuarios pueden guardar las listas de Windows SharePoint Services como plantillas y volver a utilizarlas o distribuirlas a otros sitios. Los usuarios con derechos de Administradores y Diseñadores Web pueden guardar los sitios como plantillas para capturar las mejores prácticas o definir un aspecto homogéneo para las subweb de proyectos personalizadas.
  • Compatibilidad con elementos Web y páginas de elemento Web Cada lista de un sitio es un elemento Web que permite personalizar de manera sencilla usando el explorador. Los usuarios pueden personalizar los elementos Web o agregar elementos Web nuevos a una página.

Información adicional

Para obtener más información sobre Windows SharePoint Services, consulte el sitio Web de Microsoft.

Para obtener más información sobre la administración de Windows SharePoint Services, consulte el sitio Web de Microsoft.


Requisitos de sistema de Microsoft Windows SharePoint Services 2.0

Requisitos de sistema de Microsoft Windows SharePoint Services 2.0

Antes de poder instalar Windows SharePoint Services, debe asegurarse que el servidor Web cumple ciertos requisitos de software y hardware y es capaz de conectarse al equipo con Microsoft SQL Server 2000. Además, deberá configurar el equipo SQL Server 2000 para que esté preparado para alojar los datos de Windows SharePoint Services.

Para poder configurar Windows SharePoint Services con SQL Server 2000, deberá cumplir los siguientes criterios:

  • Un equipo que ejecute Microsoft Windows Server 2003. Los requisitos de hardware para Windows SharePoint Services son los mismos que los requisitos de hardware de la instalación de Windows Server 2003.
  • El equipo debe configurarse como servidor Web (que ejecuta Servicios de Internet Information Server en el modo de aislamiento de proceso de trabajo de IIS 6.0) y que debe ejecutar ASP.NET.
  • El equipo debe contar con una partición NTFS para Windows SharePoint Services.
  • SQL Server 2000 Service Pack 3 debe estar instalado en el equipo. Puede usar tanto Microsoft SQL Server 2000 como Microsoft SQL Server 2000 Enterprise con Windows SharePoint Services.
  • Los equipos cliente deben ejecutar Microsoft Internet Explorer 5.01 o superior (se obtienen mejores resultados con Microsoft Internet Explorer 5.5 o superior) para utilizar Windows SharePoint Services.
  • En el caso de informes con abundantes problemas y riesgos, los componentes y los elementos Web de Microsoft Office deberán instalarse en el servidor de Windows SharePoint Services.
  • Al instalar Microsoft Office 2003 en el equipo cliente, se permite la modificación de hojas de datos para los sitios de SharePoint y otras funciones de integración de Office.


Opciones de implantación

Opciones de implantación

Microsoft Office Project Server 2003 puede implantarse en una extensa variedad de configuraciones que van desde un único servidor hasta implantaciones distribuidas a través de varios servidores que emplean tecnologías de clústeres o equilibrio de carga. Project Server 2003 proporciona las siguientes opciones de escalabilidad:

  • Base de datos de Project Server 2003 La base de datos de Project Server 2003 puede agregarse a un clúster para aprovechar las funciones del clúster de conmutación por error y contar con mayor disponibilidad. La base de datos también puede distribuirse a través de más de un servidor de la base de datos para permitir un mayor rendimiento y capacidad de ampliación. Consulte las implantaciones de empresa que a continuación se detallan para obtener más información.
  • Analysis Services de Microsoft SQL Server Al trasladar la parte OLAP (Online Analytical Processing) del Analizador de la cartera de proyectos a su propio servidor, se puede incrementar significativamente el rendimiento.
  • Microsoft Windows SharePoint Services La administración de documentos y el seguimiento de problemas y riesgos de Project Server 2003 se gestionan mediante Windows SharePoint Services. Esta función estará disponible para los usuarios de Project Server 2003 a través de la interfaz de usuario de Microsoft Office Project Web Access 2003. Windows SharePoint Services se puede instalar en su propio servidor, en una agrupación centralizada de servidores, para obtener un rendimiento mejorado.
  • Servicio Administrador de sesiones El Administrador de sesiones se encarga de controlar a los usuarios, las acciones que están a su cargo y las áreas de Microsoft Office Project Web Access 2003. Al utilizar un entorno de clúster, se recomienda implantar el servidor propio fuera del clúster. De esta forma, los usuarios pueden dirigirse a cualquiera de los servidores de aplicación de clúster.
  • Administrador de vistas Cada vez que un recurso o un proyecto se protege en Project Server 2003, se actualizan las tablas de vistas. Este proceso puede necesitar mucho procesamiento así que se recomienda trasladar esta función a un servidor aparte para reducir en gran medida la carga de trabajo del equipo con Project Server 2003. Para obtener más información sobre cómo distribuir los servicios en varios servidores, consulte las implantaciones de empresa que se recogen a continuación.

Instalación de un único servidor

Al instalar Project Server 2003 y sus componentes asociados en un único servidor, se obtiene un entorno económico para comprobar las funciones de Project Server 2003 antes de llevar a cabo una implantación a gran escala. Además, al realizar la instalación en un único servidor, tendrá la oportunidad de instalar una base de datos de muestra. Esta base de datos contiene datos de muestra que se pueden utilizar mientras se prueba y evalúa Project Server 2003.

Para instalar Project Server 2003 en una configuración de único servidor, siga las instrucciones de la Guía básica de instalación: configuración de un único servidor.

Instalación en varios servidores

Al instalar Project Server 2003, Windows SharePoint Services, SQL Server y Analysis Services de SQL Server en tres servidores distintos se dispone de un ejemplo a mayor escala de la implantación que con la instalación de un único servidor. Se puede utilizar esta opción para crear un entorno de evaluación de Project Server 2003 más versátil.

Para instalar Project Server 2003, Windows SharePoint Services, SQL Server y Analysis Services de SQL Server en una configuración de tres servidores, siga las instrucciones de la Guía básica de instalación: configuración de varios servidores.

Microsoft Desktop Engine

Puede instalar Project Server 2003 para que utilice Microsoft Desktop Engine (MSDE) en lugar de SQL Server 2000. MSDE posee limitaciones de uso de memoria, tamaño de base de datos y carga de trabajo de lotes y no incluye las herramientas de administración que acompañan a SQL Server 2000. No se recomienda en el caso de implantaciones de Project Server 2003 a gran escala.

Para obtener más información sobre la implantación de Project Server 2003 mediante MSDE, consulte el sitio Web de Microsoft.

Para descargar MSDE, consulte el sitio Web de Microsoft.

Implantaciones de empresa

Las dos situaciones de implantación que se han descrito en este documento son ejemplos de situaciones de implantaciones de prueba. Para obtener más información sobre otras situaciones de implantación, entre las que se incluyen implantaciones de bases de datos de muestra, implantaciones distribuidas y empresariales, consulte el sitio Web de Microsoft.


Guía básica de instalación: configuración de un único servidor

Guía básica de instalación: configuración de un único servidor

La instalación de Microsoft Office Project Server 2003 puede ser un proceso complicado que incluye muchas tareas que deben ser completadas antes, durante o después de instalar el producto en sí. Esta guía, aunque no pretende cubrir todos los posibles métodos de actualización ni instalación, proporciona un resumen de los pasos necesarios para instalar Project Server 2003 en un único servidor. Esto incluye pasos manuales que se deben realizar y programas adicionales que se deben instalar, así como detalles de configuración del servidor y la base de datos.

Esta Guía básica de instalación parte del supuesto de que dispone de un único servidor que ejecuta Microsoft Windows Server 2003, Microsoft SQL Server 2000 y Analysis Services de Microsoft SQL Server.

Nota Puede pasar por alto los pasos enumerados a continuación que ya haya llevado a cabo.

Preparar el servidor

  1. Crear cuentas de usuario
  2. Crear un administrador OLAP
  3. Configurar autenticación de SQL Server
  4. Configurar Servicios de Internet Information Server
  5. Configurar la seguridad mejorada de Internet Explorer

Instalar Windows SharePoint Services

  1. Instalar Windows SharePoint Services
  2. Configurar Servidor virtual de administración
  3. Establecer el servidor de bases de datos de configuraciones
  4. Extender el servidor virtual
  5. Ejecutar el Asistente de configuración de Windows SharePoint Services
  6. Crear un administrador de Windows SharePoint Services

Instalar Project Server

  • Instalar Project Server 2003

Después de la instalación

  • Permitir a los usuarios iniciar la sesión usando una cuenta de usuario de Microsoft Windows diferente
  • Agregar usuarios a las funciones de bases de datos de cubos en Analysis Services
  • Migrar el repositorio de Analysis Services a una base de datos de SQL Server


Crear cuentas de usuario

Crear cuentas de usuario

Para instalar Microsoft Office Project Server 2003, necesitará crear las siguientes cuentas de usuario:

  1. Una cuenta de usuario de dominio de Windows o una cuenta de usuario local en el equipo donde vaya a instalar Project Server 2003. Esta cuenta permitirá que Project Server 2003 tenga acceso a Analysis Services de Microsoft SQL Server 2000 y Windows SharePoint Services.
  2. Una cuenta de SQL Server que pertenezca a las funciones Creadores de la base de datos y Administradores de seguridad.

Nota Estas cuentas sólo se utilizarán en Project Server 2003.

Para crear una cuenta de usuario de Windows

  1. Abra Usuarios y equipos de Active Directory.
  2. En el árbol de la consola, haga clic con el botón secundario en la carpeta en la que desee agregar una cuenta de usuario.
  3. Seleccione Nuevo y haga clic en Usuario.
  4. En el cuadro Nombre, escriba el nombre del usuario.
  5. En Iniciales, escriba las iniciales del usuario.
  6. En el cuadro Apellidos, escriba el apellido del usuario.
  7. En los cuadros Contraseña y Confirmar contraseña, escriba la contraseña de usuario.
  8. Desactive la casilla de verificación El usuario debe cambiar la contraseña en el próximo inicio de sesión.

    Nota Si no desactiva esta casilla de verificación, la cuenta no funcionará correctamente con Project Server 2003.

  9. Haga clic en Crear.

Nota Para llevar a cabo este procedimiento, es preciso ser miembro de los grupos Operadores de cuentas, Administradores del dominio o Administradores empresariales de Active Directory, o bien haber recibido la autoridad apropiada.

Para crear una cuenta de usuario local

  1. En el equipo en el que desee crear la cuenta, abra Administración de equipos.
  2. Expanda la opción Usuarios locales y grupos.
  3. Haga clic con el botón secundario en Usuarios y seleccione Usuario nuevo.
  4. En Nombre de usuario, especifique el nombre del usuario.
  5. En Descripción, describa brevemente la cuenta de usuario.
  6. En los cuadros Contraseña y Confirmar contraseña, escriba la contraseña de usuario.
  7. Desactive la casilla de verificación El usuario debe cambiar la contraseña en el próximo inicio de sesión.

    Nota Si no desactiva esta casilla de verificación, la cuenta no funcionará correctamente con Project Server 2003.

  8. Haga clic en Crear.

Para crear una cuenta de SQL Server 2000

  1. Abra el Administrador corporativo.
  2. Expanda un grupo de servidores y, acto seguido, expanda uno de ellos.
  3. Expanda el elemento Seguridad, haga clic con el botón secundario en Inicios de sesión y, a continuación, seleccione Nuevo inicio de sesión.
  4. En el cuadro Nombre, especifique un nombre para el inicio de sesión de Microsoft SQL Server.
  5. En la sección Autenticación, seleccione Autenticación de SQL Server.
  6. Escriba la contraseña en el cuadro Contraseña.
  7. En la ficha Funciones del servidor, active las casillas de verificación Administradores de seguridad y Creadores de bases de datos.
  8. Haga clic en Aceptar.

Siguiente paso: Crear un administrador OLAP

Guía básica de instalación: configuración de un único servidor


Crear un administrador OLAP

Crear un administrador OLAP

Para posibilitar el acceso de Microsoft Office Project Server 2003 a Analysis Services de Microsoft SQL Server 2000, es preciso crear un administrador OLAP en el equipo en el que se ejecute Analysis Services. Para ello, agregue la cuenta que haya creado para este propósito (cuenta número 1 en la lista de cuentas de usuario) al grupo Administradores OLAP del equipo que ejecute Analysis Services.

  1. En el equipo que ejecute Analysis Services, abra Administración de equipos.
  2. En el árbol de la consola, haga clic en Grupos.
  3. Haga clic con el botón secundario en el grupo Administradores OLAP y, a continuación, haga clic en Propiedades.
  4. Haga clic en Agregar.
  5. En Escriba los nombres de objeto que desea seleccionar, especifique el nombre de la cuenta de Windows que desee agregar al grupo y, a continuación, haga clic en Aceptar.
  6. Haga clic en Aceptar.

Siguiente paso: Configurar autenticación de SQL Server

Guía básica de instalación: configuración de un único servidor


Configurar la autenticación de SQL Server

Configurar la autenticación de SQL Server

La autenticación de modo mixto de Microsoft SQL Server permite a los usuarios conectarse a una instancia de SQL Server utilizando la autenticación de Microsoft Windows o la autenticación de Microsoft SQL Server. Microsoft Office Project Server 2003 precisa del modo mixto. Configure la instancia de SQL Server 2000 que vaya a utilizar con Project Server 2003 para usar el modo mixto.

  1. Abra el Administrador corporativo de SQL Server.
  2. Expanda un grupo de servidores.
  3. Haga clic con el botón secundario en el servidor que vaya a utilizar con Project Server 2003 y, acto seguido, haga clic en Propiedades.
  4. Haga clic en la ficha Seguridad.
  5. En la sección Autenticación, haga clic en SQL Server y Windows.
  6. En la sección Nivel de auditoría, seleccione el nivel de acceso a Microsoft SQL Server otorgado al usuario y almacenado en el registro de errores de SQL Server:

    Ninguno: no se realiza ninguna auditoría.

    Correcto: sólo se realizan auditorías de los intentos de inicio de sesión satisfactorios.

    Error: sólo se realizan auditorías de los intentos de inicio de sesión fallidos.

    Todos: se realizan auditorías de los intentos de inicio de sesión satisfactorios y fallidos.

  7. Haga clic en Aceptar.

Siguiente paso: Configurar Servicios de Internet Information Server

Guía básica de instalación: configuración de un único servidor


Configurar Servicios de Internet Information Server

Configurar Servicios de Internet Information Server

Tanto Microsoft Office Project Server 2003 como Microsoft Windows SharePoint Services precisan de los Servicios de Internet Information Server (IIS). Habilite IIS en el equipo donde vaya a instalar Project Server 2003 y Windows SharePoint Services.

Nota Se recomienda configurar IIS para que use el Nivel de socket seguro (Secure Sockets Layer, SSL) a fin de obtener un mayor grado de seguridad. Para obtener más información sobre la configuración de IIS para que use SSL, consulte la documentación de IIS.

Para activar IIS en Windows Server 2003

  1. Haga clic en Inicio y, acto seguido, seleccione Administre su servidor.
  2. En la página Administre su servidor, haga clic en Agregar o quitar función.
  3. En el panel Pasos preliminares, haga clic en Siguiente.
  4. En el panel Función del servidor, haga clic en Servidor de aplicaciones (IIS, ASP.NET) y, acto seguido, en Siguiente.
  5. En el panel Opciones del Servidor de aplicaciones, acepte la opción predeterminada ASP.NET y haga clic en Siguiente.
  6. Haga clic en Finalizar.
  7. Haga clic en Inicio, elija Herramientas administrativas y haga clic en Servicios de Internet Information Server (IIS).
  8. En el administrador de Servicios de Internet Information Server, haga clic en el signo más (+) ubicado junto al nombre del servidor y, acto seguido, haga clic con el botón secundario en la carpeta Sitios Web y seleccione Propiedades.
  9. En el cuadro de diálogo Propiedades, haga clic en la ficha Servicio.
  10. En la sección Modo de aislamiento, desactive la casilla de verificación Ejecutar el servicio WWW en el Modo aislado de IIS 5.0 y haga clic en Aceptar.

Nota La casilla de verificación Ejecutar el servicio WWW en el Modo aislado de IIS 5.0 sólo aparecerá activada si se ha actualizado a IIS 6.0 en Windows Server 2003 desde IIS 5.0 en Windows Server 2000. Las nuevas instalaciones de IIS 6.0 se establecen de forma predeterminada en el modo aislado del proceso de trabajo de IIS 6.0.

Siguiente paso: Configurar la seguridad mejorada de Internet Explorer

Guía básica de instalación: configuración de un único servidor


Configurar la seguridad mejorada de Internet Explorer

Configurar la seguridad mejorada de Internet Explorer

De forma predeterminada, Microsoft Windows Server 2003 incluye un conjunto de opciones de seguridad denominado Configuración de seguridad mejorada de Internet Explorer. Esta configuración limita los tipos de contenido que un usuario puede ver en el servidor usando Microsoft Internet Explorer, con la excepción de los sitios enumerados en las zonas Intranet local y Sitios de confianza. Por ejemplo, de forma predeterminada, las secuencias de comandos en las páginas de Internet no funcionarán. El objetivo de estas opciones es ayudarle a asegurarse de que un usuario local de un equipo que también se ejecuta como servidor no descargue un virus u otros archivos dañinos desde Internet e infecte el servidor. La Configuración de seguridad mejorada de Internet Explorer no afecta a los usuarios remotos que ven el contenido del servidor, sólo a los usuarios que ejecutan Internet Explorer en el propio equipo servidor.

Al utilizar Configuración de seguridad mejorada de Internet Explorer en un servidor Web que ejecute Microsoft Windows SharePoint Services no es posible ver algunos códigos necesarios para la visualización de las páginas de los sitios o páginas de administración HTML. De nuevo, los usuarios remotos con derechos de acceso adecuados podrán seguir viendo las páginas sin problema, pero un usuario que ejecute Internet Explorer en el servidor no podrá ver o administrar el sitio. El usuario en el servidor tampoco podrá ver ni administrar un sitio de SharePoint remoto, debido a la configuración de seguridad.

Medidas de prevención

Si lo desea, puede hacer uso de las siguientes medidas de prevención que le ayudarán a garantizar el correcto funcionamiento de Windows SharePoint Services en su entorno:

  • Desinstale la función Configuración de seguridad mejorada de Internet Explorer. Si no le preocupa que los usuarios puedan trabajar de forma local en el servidor Web, un administrador puede desinstalar la función Configuración de seguridad mejorada de Internet Explorer mediante la utilidad Agregar o quitar programas del sistema.
  • Agregue sitios de SharePoint a la lista de sitios de Intranet local. Es una solución que implica más tiempo pero es, potencialmente, la más segura. Un administrador del servidor puede agregar las direcciones URL de los servidores virtuales que se están alojando en la zona Intranet local de Internet Explorer.

Para desinstalar la función Configuración de seguridad mejorada de Internet Explorer

  1. En el equipo donde se vaya a instalar Windows SharePoint Services, haga clic en Inicio, seleccione Panel de control y, a continuación, haga clic en Agregar o quitar programas.
  2. Haga clic en Agregar o quitar componentes de Windows.
  3. En la lista Componentes, desactive la casilla de verificación Configuración de seguridad mejorada de Internet Explorer y haga clic en Siguiente.

    Se eliminará el componente Configuración de seguridad mejorada de Internet Explorer.

  4. Haga clic en Finalizar.

Para agregar un sitio de SharePoint a la lista de sitios de Intranet local

  1. En el equipo donde vaya a instalar Windows SharePoint Services, abra Internet Explorer.
  2. En el menú Herramientas, haga clic en Opciones de Internet.
  3. Haga clic en la ficha Seguridad y después, en el icono Intranet local.
  4. Haga clic en Sitios.
  5. Escriba la dirección URL del sitio que desee agregar y, a continuación, haga clic en Agregar.
  6. Cuando haya terminado de agregar sitios, haga clic en Cerrar y después, en Aceptar.

Siguiente paso: Instalar Windows SharePoint Services

Guía básica de instalación: configuración de un único servidor


Instalar Windows SharePoint Services

Instalar Windows SharePoint Services

Si no dispone de Windows SharePoint Services, puede descargarlo desde el sitio Web de Microsoft.

  1. En el equipo donde desee instalar Windows SharePoint Services, introduzca el CD de Windows SharePoint Services en la unidad de CD-ROM del servidor o conéctese a un punto de instalación de red.
  2. Haga clic en Inicio y, acto seguido, en Ejecutar.
  3. En el cuadro Abrir, escriba "d:\setupsts.exe" (siendo d: el punto de instalación de red o la unidad de CD-ROM de su equipo).

    Se iniciará el programa de instalación de Windows SharePoint Services.

  4. En el panel del contrato de licencia para el usuario final, repase las condiciones, active la casilla de verificación Acepto los términos del Contrato de licencia y, a continuación, haga clic en Siguiente.
  5. En el panel Tipo de instalación, haga clic en la opción Agrupación centralizada de servidores y, a continuación, en Siguiente.
  6. En el panel Resumen, compruebe que sólo se instalará Windows SharePoint Services y, acto seguido, haga clic en Instalar.

    El programa de instalación se ejecutará e instalará Windows SharePoint Services.

    Cuando finalice el proceso de instalación, aparecerá una ventana de explorador y la página Configurar el servidor virtual de administración.

Siguiente paso: Configurar Servidor virtual de administración

Guía básica de instalación: configuración de un único servidor


Configurar Servidor virtual de administración

Configurar Servidor virtual de administración

Una vez terminado el proceso de instalación, es posible configurar el servidor virtual de administración, incluyendo la especificación de un fondo de aplicaciones que usar para los procesos del servidor virtual.

  1. En la página Configurar el servidor virtual de administración, seleccione la opción Utilizar un grupo de aplicaciones existente y mantenga el grupo de aplicaciones predeterminado de la lista.
  2. Haga clic en Aceptar.

    Se mostrará la página El grupo de aplicaciones ha cambiado.

  3. En el escritorio de Microsoft Windows, haga clic en Inicio, después, en Ejecutar y en el cuadro Abrir, escriba "CMD" y haga clic en Aceptar.
  4. En el símbolo del sistema, escriba "iisreset" y presione ENTRAR.
  5. Cuando se haya reiniciado Servicios de Internet Information Server (IIS), cierre la ventana de comandos y vuelva al explorador.
  6. En la página El grupo de aplicaciones ha cambiado, haga clic en Aceptar.

Siguiente paso: Establecer el servidor de bases de datos de configuraciones

Guía básica de instalación: configuración de un único servidor


Establecer el servidor de bases de datos de configuración

Establecer el servidor de bases de datos de configuración

Mediante este procedimiento se configurará Windows SharePoint Services para trabajar con Microsoft SQL Server 2000.

  1. En el cuadro Servidor de la base de datos, escriba el nombre de la instancia de SQL Server 2000 a la que desea conectarse.
  2. En el cuadro Nombre de la base de datos de SQL Server, especifique el nombre que desee asignar a la base de datos de configuración que desea crear.
  3. Seleccione la opción Utilizar autenticación de SQL Server.
  4. Escriba un nombre de usuario y una contraseña para la cuenta de SQL Server, que se utilizarán para crear las tablas de configuración de bases de datos (cuenta número 2 de la lista de cuentas de usuario).
  5. En la sección Creación de cuentas de Active Directory, seleccione la opción Los usuarios ya disponen de cuentas de dominio.

    Nota No seleccione la opción Crear automáticamente cuentas de Active Directory para los usuarios de este sitio, ya que no es compatible con Microsoft Office Project Server 2003.

  6. Haga clic en Aceptar.

Paso siguiente: Extender el servidor virtual

Guía básica de instalación: configuración de un único servidor


Extender el servidor virtual

Extender el servidor virtual

Tras configurar la conexión a Microsoft SQL Server 2000, estará listo para extender sus servidores virtuales con Windows SharePoint Services. Al extender un servidor virtual, Windows SharePoint Services se aplica a un servidor virtual y se crea un sitio Web de nivel superior.

  1. En la página Administración central, haga clic en Ampliar o actualizar el servidor virtual.
  2. En la página Lista de servidores virtuales, haga clic en Sitio Web predeterminado.
  3. En la página Ampliar servidor virtual, haga clic en Ampliar y crear una base de datos de contenido.
  4. En la página Ampliar y crear base de datos de contenido, seleccione la opción Crear un nuevo grupo de aplicaciones.
  5. En el cuadro Nombre del grupo de aplicaciones, especifique un nombre para el grupo de aplicaciones.
  6. Seleccione la opción Predefinida y, acto seguido, elija el elemento Servicio de red de la lista.
  7. En el cuadro Nombre de usuario de la sección Propietario del sitio, especifique el nombre cuenta de Windows del propietario de este servidor virtual.

    Este usuario recibirá cualquier aviso de superación de cuota o eliminación automática y dispondrá de privilegios de administración de Windows SharePoint Services.

  8. En el cuadro Correo electrónico, especifique la dirección de correo electrónico del propietario de este servidor virtual.
  9. Haga clic en Aceptar.

Siguiente paso: Ejecutar el Asistente de configuración de Windows SharePoint Services

Guía básica de instalación: configuración de un único servidor


Ejecutar el Asistente de configuración de Windows SharePoint Services

Ejecutar el Asistente de configuración de Windows SharePoint Services

El Asistente de configuración de Windows SharePoint Services instalará una plantilla básica de Microsoft Project Workspace y otros archivos de programa en el servidor que ejecute Windows SharePoint Services. El asistente también proporcionará un sitio denominado MS_ProjectServer_PublicDocuments para la función de biblioteca de documentos pública en Microsoft Office Project Web Access 2003.

  1. Introduzca el CD de Microsoft Office Project Server 2003 en la unidad de CD-ROM.
  2. Si está efectuando la instalación desde el CD de Project Server 2003 con la función de reproducción automática habilitada, haga clic en la opción Instalación del servidor del programa de instalación de Project Server 2003 o, en el CD-ROM de Project Server 2003, localice y ejecute el archivo Setup.exe.

    Comenzará la instalación de Project Server 2003.

  3. Haga clic en Windows SharePoint Services.
  4. En la página siguiente, haga clic en Asistente de configuración de Windows SharePoint Services.
  5. En la página siguiente, haga clic en Siguiente.
  6. En la página siguiente, haga clic en Sitio Web predeterminado o seleccione un sitio anteriormente proporcionado y, acto seguido, haga clic en Siguiente.
  7. En la página siguiente, en la lista Seleccione la ruta URL bajo la que crear sitios de proyectos, haga clic en sitios y, después, en Siguiente.
  8. En la página siguiente, en el cuadro Nombre de cuenta del propietario del sitio, indique el nombre de cuenta de Windows del propietario del sitio.
  9. En el cuadro Correo electrónico del propietario del sitio, escriba la dirección de correo electrónico del propietario del sitio y, a continuación, haga clic en Siguiente.
  10. En la página siguiente, haga clic en Siguiente.
  11. En la página siguiente, anote la información que se proporciona en las secciones URL de administración central de SharePoint y Cree un sitio Web de máximo nivel debajo de este URL. Necesitará estos datos para instalar Project Server 2003.
  12. Haga clic en Finalizar.

Siguiente paso: Crear un administrador de Windows SharePoint Services

Guía básica de instalación: configuración de un único servidor


Crear un administrador de Windows SharePoint Team Services

Crear un administrador de Windows SharePoint Team Services

Para posibilitar el acceso de Microsoft Office Project Server 2003 a Microsoft Windows SharePoint Services, es preciso crear un Administrador de Windows SharePoint Services en el equipo en el que se ejecute Windows SharePoint Services. Para ello, agregue la cuenta que haya creado para este propósito (cuenta número 2 en la lista de cuentas de usuario) al grupo Administradores del equipo que ejecute Windows SharePoint Services.

  1. En el equipo que ejecute Windows SharePoint Services, abra Administración de equipos.
  2. En el árbol de la consola, haga clic en Grupos.
  3. Haga clic con el botón derecho en el grupo Administradores y, acto seguido, haga clic en Propiedades.
  4. Haga clic en Agregar.
  5. En Escriba los nombres de objeto que desea seleccionar, especifique el nombre de la cuenta de Windows que desee agregar al grupo y, a continuación, haga clic en Aceptar.
  6. Haga clic en Aceptar.

Siguiente paso: Instalar Microsoft Office Project Server 2003

Guía básica de instalación: configuración de un único servidor


Instalar Project Server 2003

Instalar Project Server 2003

En este tema se detallan los pasos necesarios para instalar Microsoft Office Project Server 2003 con el programa de instalación. Estas instrucciones se aplican a la configuración de un único servidor.

  1. En el equipo en el que desee instalar Project Server 2003, introduzca el CD de Project Server 2003 en la unidad de CD-ROM o conéctese a un punto de instalación de red.
  2. Si está efectuando la instalación desde el CD de Project Server 2003 con la función de reproducción automática habilitada, haga clic en la opción Instalación del servidor del programa de instalación de Project Server 2003 o, en el CD-ROM de Project Server 2003 (o en el punto de instalación de red), localice y ejecute el archivo Setup.exe.
  3. En la página Información del usuario del programa de instalación, escriba el nombre de usuario, las iniciales, la organización y la clave del producto y, a continuación, haga clic en Siguiente.
  4. Lea y acepte el contrato de licencia y, a continuación, haga clic en Siguiente.
  5. En el cuadro Instalar en, especifique dónde desea instalar Project Server 2003 y, a continuación, haga clic en Siguiente. La ubicación predeterminada es C:\Archivos de programa\Microsoft Project Server 2003.
  6. En la página Seleccione los servicios que desee instalar en este servidor:
    1. Haga clic en la lista Datos de muestra de Microsoft Office Project Server 2003 y, después, haga clic en Ejecutar desde mi PC.
    2. Haga clic en Siguiente.

    Nota Debe seguir configurando la base de datos de muestra una vez que haya finalizado la instalación de Project Server 2003. Para obtener más información, consulte sampledb.htm en la carpeta SUPPORT\SAMPLE\1033 situada en el CD de Project Server 2003.

  7. En la página Especifique la información del servidor de la bases de datos:
    1. Seleccione la opción Crear una base de datos nueva para crear una base de datos nueva para los datos de Project Server 2003.
    2. En el cuadro Servidor de la base de datos, escriba el nombre de la instancia de SQL Server 2000 que desee utilizar con Project Server 2003.
    3. Seleccione la opción Autenticación de SQL Server.
    4. Escriba el nombre de inicio de sesión y la contraseña para la cuenta de SQL Server que se utilizará para crear las tablas de base de datos de Project Server 2003 (cuenta número 2 en la lista de cuentas de usuario).
    5. Haga clic en Siguiente
  8. En la página Especifique la información de conexión de las tablas de vistas, acepte los valores predeterminados y, a continuación, haga clic en Siguiente. De esta forma se instalará la función Tablas vistas de Project Server 2003 en la base de datos principal de Project Server 2003.
  9. En la página Cree la información de la cuenta de la base de datos, escriba las contraseñas que se utilizarán en Project Server 2003 y Microsoft Office Project Edición Professional 2003 para tener acceso a la base de datos de SQL Server 2000; y después, haga clic en Siguiente. Las contraseñas que introduzca se asignarán a las cuentas enumeradas en los cuadros Nombre de inicio de sesión.
  10. En la página Especifique la información de conexión de Analysis Services:
    1. En el cuadro Analysis server, escriba el nombre del servidor de Analysis Services que se utilizará con Project Server 2003.
    2. En el cuadro Nombre de inicio de sesión, escriba el nombre de cuenta de dominio de Windows que Project Server 2003 deberá utilizar para tener acceso al servidor de Analysis Services (cuenta número 1 de la lista de cuentas de usuario).
    3. En el cuadro Contraseña, escriba la contraseña de cuenta de dominio de Windows y, a continuación, haga clic en Siguiente.

    Nota Si opta por proporcionar la información de conexión de Analysis Services en otra ocasión, deberá ejecutar la utilidad pscomplus.exe a fin de establecer la información de cuenta de usuario y contraseña.

  11. En la página Seleccione un sitio Web, haga clic en Sitio Web predeterminado y, a continuación, haga clic en Siguiente.
  12. En la página Especifique la información de la dirección del servidor Web:
    1. En la sección Protocolo de intranet y nombre de servidor para tener acceso a Microsoft Office Project Server, seleccione el protocolo de intranet (http:// o https://) que se utilice en este servidor de entre los que se enumeran en la lista y, acto seguido, escriba el nombre del servidor en el cuadro siguiente.

      Nota No incluya el protocolo http:// o https:// cuando escriba el nombre del servidor.

    2. Opcionalmente, en la sección Protocolo de extranet y nombre de dominio para tener acceso a Microsoft Office Project Server, seleccione el protocolo de extranet (http:// o https://) de la lista y, acto seguido, escriba el nombre del dominio en el cuadro siguiente.

      Nota No incluya el protocolo (http:// o https://) al escribir el nombre del dominio.

    3. Haga clic en Siguiente.
  13. En la página Especifique la información del servidor de correo SMTP:
    1. En el cuadro Servidor de correo SMTP, escriba el nombre del servidor de correo SMTP que va a utilizar para las notificaciones y los avisos de Project Server 2003. Para que Project Server 2003 envíe notificaciones y avisos, escriba SMARTHOST.
    2. En el cuadro Puerto, escriba el número de puerto del servidor de correo. El valor predeterminado es 25.
    3. En el cuadro Dirección de origen, escriba la dirección de correo electrónico que se incluirá en el campo De de los mensajes de correo electrónico enviados por Project Server 2003 y haga clic en Siguiente.
  14. En la página Conectarse a un servidor Web que ejecute Windows SharePoint Services:
    1. En URL de administración de Windows SharePoint Services, seleccione el protocolo (http:// or https://) utilizado en el servidor de SharePoint y, a continuación, escriba el nombre del servidor y el número de puerto en el cuadro siguiente. Se corresponde con el vínculo URL de administración central de SharePoint proporcionado por el Asistente de configuración de Windows SharePoint Services.

      Nota No incluya el protocolo http:// o https:// cuando escriba el nombre del servidor.

    2. En Crear sitios bajo esta URL de Windows SharePoint Services, seleccione el protocolo (http:// o https://) utilizado en el servidor de SharePoint y, a continuación, escriba la URL para los sitios de Project Server 2003. Se corresponde con el vínculo Cree un sitio Web de máximo nivel debajo de este URL proporcionado por el Asistente de configuración de Windows SharePoint Services.

      Nota No incluya el protocolo http:// o https:// cuando escriba el nombre del servidor.

    3. Haga clic en Siguiente.

    Nota Si opta por proporcionar la información de conexión de Windows SharePoint Services en otra ocasión, deberá ejecutar la utilidad pscomplus.exe a fin de establecer la información de cuenta de usuario y contraseña.

  15. En la página Especifique la información de cuenta para Windows SharePoint Services (continuación), escriba el nombre de cuenta y la contraseña de Windows que se utilizarán para administrar Windows SharePoint Services (cuenta número 1 de la lista cuentas de usuario) y a continuación, haga clic en Siguiente.
  16. En la página Conectarse a un servidor Web que ejecute Microsoft SharePoint Portal Server, si lo desea, puede especificar la información de conexión del SharePoint Portal Server de su organización, o bien seleccionar la opción Especificar esta información más tarde y hacer clic en Siguiente.
  17. En la página Elija un entorno de instalación, seleccione la opción que desee utilizar para la implantación y, después, haga clic en Siguiente.
  18. En la página Especifique la contraseña del administrador, escriba una contraseña que se utilizará en la cuenta de administrador y a continuación, haga clic en Siguiente.

    Nota Asegúrese de anotar esta contraseña para consultarla en un futuro. Necesitará utilizar la cuenta de administrador la primera vez que inicie la sesión en Microsoft Office Project Web Access 2003.

  19. En la página Resumen, haga clic en Instalar.

    Se instala Project Server 2003.

  20. En la página Instalación completada, haga clic en Fin.

Siguiente paso: Migrar el repositorio de Analysis Services a una base de datos de SQL Server

Guía básica de instalación: configuración de un único servidor


Guía básica de instalación: configuración de varios servidores

Guía básica de instalación: configuración de varios servidores

La instalación de Microsoft Office Project Server 2003 puede ser un proceso complicado que incluye muchas tareas que deben ser completadas antes, durante o después de instalar el producto en sí. Esta guía, aunque no pretende cubrir todos los posibles métodos de actualización ni instalación, proporciona un resumen de los pasos necesarios para instalar Project Server 2003 en una configuración con varios servidores. Esto incluye pasos manuales que se deben realizar y programas adicionales que se deben instalar, así como detalles de configuración del servidor y la base de datos.

Lista de servidores

La Guía básica de instalación parte del supuesto de que cuenta con tres servidores:

  1. Un servidor que ejecuta Microsoft Windows Server 2003, que se utilizará para alojar Microsoft Windows SharePoint Services.
  2. Un servidor que ejecuta Microsoft Windows 2000 Server o Windows Server 2003, que se utilizará para albergar a Project Server 2003.
  3. Un servidor que ejecuta Microsoft SQL Server 2000 y Analysis Services de Microsoft SQL Server, que se utilizará como repositorio de datos para Project Server 2003 y Windows SharePoint Services.

Nota Puede pasar por alto los pasos enumerados a continuación que ya haya llevado a cabo.

Preparar los servidores

  1. Configurar cuentas de usuario
  2. Crear un administrador OLAP
  3. Configurar autenticación de SQL Server
  4. Instalar Objetos de ayuda para la toma de decisiones de Analysis Services
  5. Configurar Servicios de Internet Information Server
  6. Configurar la seguridad mejorada de Internet Explorer

Instalar Windows SharePoint Services

  1. Instalar Windows SharePoint Services
  2. Configurar Servidor virtual de administración
  3. Establecer el servidor de bases de datos de configuraciones
  4. Extender el servidor virtual
  5. Ejecutar el Asistente de configuración de Windows SharePoint Services
  6. Crear un administrador de Windows SharePoint Services

Instalar Project Server

  • Instalar Project Server 2003

Después de la instalación

  • Permitir a los usuarios iniciar la sesión usando una cuenta de usuario de Microsoft Windows diferente
  • Agregar usuarios a las funciones de bases de datos de cubos en Analysis Services
  • Migrar el repositorio de Analysis Services a una base de datos de SQL Server


Crear cuentas de usuario

Crear cuentas de usuario

Para instalar Microsoft Office Project Server 2003 en una configuración de varios servidores, necesitará crear las siguientes cuentas de usuario:

  1. Una cuenta de usuario de dominio de Windows o una cuenta de usuario local en el servidor de Analysis Services para permitir que Project Server 2003 obtenga acceso a Microsoft SQL Server 2000 Analysis Services.
  2. Una cuenta de usuario de dominio de Windows o una cuenta de usuario local en el servidor de Windows SharePoint Services para permitir que Project Server 2003 tenga acceso a Windows SharePoint Services.
  3. Una cuenta de SQL Server en el equipo donde residirán los datos de Project Server 2003 y Windows SharePoint Services (equipo número 3 de la lista de servidores). Esta cuenta debe pertenecer a las funciones Creadores de bases de datos y Administradores de seguridad.

    Nota Puede utilizar la cuenta de administrador de sistema o una cuenta existente que disfrute de estos privilegios.

Nota Project Server 2003 sólo utilizará estas cuentas para la instalación.

Para crear una cuenta de usuario de Windows

  1. Abra Usuarios y equipos de Active Directory.
  2. En el árbol de la consola, haga clic con el botón secundario en la carpeta a la que desee agregar una cuenta de usuario.
  3. Seleccione Nuevo y haga clic en Usuario.
  4. En el cuadro Nombre, escriba el nombre del usuario.
  5. En Iniciales, escriba las iniciales del usuario.
  6. En el cuadro Apellidos, escriba el apellido del usuario.
  7. En los cuadros Contraseña y Confirmar contraseña, escriba la contraseña de usuario.
  8. Desactive la casilla de verificación El usuario debe cambiar la contraseña en el próximo inicio de sesión.

    Nota Si no desactiva esta casilla de verificación, la cuenta no funcionará correctamente con Project Server 2003.

  9. Haga clic en Crear.

Nota Para llevar a cabo este procedimiento, es preciso ser miembro de los grupos Operadores de cuentas, Administradores del dominio o Administradores empresariales de Active Directory, o bien haber recibido la autoridad apropiada.

Para crear una cuenta de usuario local

  1. En el equipo en el que desee crear la cuenta, abra Administración de equipos.
  2. Expanda la opción Usuarios locales y grupos.
  3. Haga clic con el botón secundario en Usuarios y seleccione Usuario nuevo.
  4. En Nombre de usuario, especifique el nombre del usuario.
  5. En Descripción, describa brevemente la cuenta de usuario.
  6. En los cuadros Contraseña y Confirmar contraseña, escriba la contraseña de usuario.
  7. Desactive la casilla de verificación El usuario debe cambiar la contraseña en el próximo inicio de sesión.

    Nota Si no desactiva esta casilla de verificación, la cuenta no funcionará correctamente con Project Server 2003.

  8. Haga clic en Crear.

Para crear una cuenta de SQL Server 2000

  1. Abra Administrador corporativo.
  2. Expanda un grupo de servidores y, acto seguido, expanda uno de ellos.
  3. Expanda el elemento Seguridad, haga clic con el botón secundario en Inicios de sesión y, a continuación, seleccione Nuevo inicio de sesión.
  4. En el cuadro Nombre, especifique un nombre para el inicio de sesión de Microsoft SQL Server.
  5. En la sección Autenticación, seleccione Autenticación de SQL Server.
  6. Escriba la contraseña en el cuadro Contraseña.
  7. En la ficha Funciones del servidor, active las casillas de verificación Administradores de seguridad y Creadores de bases de datos.
  8. Haga clic en Aceptar.

Siguiente paso: Crear un administrador OLAP

Guía básica de instalación


Crear un administrador OLAP

Crear un administrador OLAP

Para posibilitar el acceso de Microsoft Office Project Server 2003 a Analysis Services de Microsoft SQL Server 2000, es preciso crear un administrador OLAP en el equipo en el que se ejecute Analysis Services. Para ello, agregue la cuenta que haya creado para este propósito (cuenta número 1 en la lista de cuentas de usuario) al grupo Administradores OLAP del equipo que ejecute Analysis Services.

  1. En el equipo que ejecuta Analysis Services, abra Administración de equipos.
  2. En el árbol de la consola, haga clic en Grupos.
  3. Haga clic con el botón secundario en el grupo Administradores OLAP y, a continuación, haga clic en Propiedades.
  4. Haga clic en Agregar.
  5. En Escriba los nombres de objeto que desea seleccionar, especifique el nombre de la cuenta de Windows que desee agregar al grupo y, a continuación, haga clic en Aceptar.
  6. Haga clic en Aceptar.

Siguiente paso: Configurar autenticación de SQL Server

Guía básica de instalación


Configurar la autenticación de SQL Server

Configurar la autenticación de SQL Server

La autenticación de modo mixto de Microsoft SQL Server permite a los usuarios conectarse a una instancia de SQL Server utilizando la autenticación de Microsoft Windows o la autenticación de Microsoft SQL Server. Microsoft Office Project Server 2003 precisa del modo mixto. Configure la instancia de SQL Server 2000 que vaya a utilizar con Project Server 2003 para usar el modo mixto.

  1. Abra el Administrador corporativo de SQL Server.
  2. Expanda un grupo de servidores.
  3. Haga clic con el botón secundario en el servidor que vaya a utilizar con Project Server 2003 y, acto seguido, haga clic en Propiedades.
  4. Haga clic en la ficha Seguridad.
  5. En la sección Autenticación, haga clic en SQL Server y Windows.
  6. En la sección Nivel de auditoría, seleccione el nivel de acceso a Microsoft SQL Server otorgado al usuario y almacenado en el registro de errores de SQL Server:

    Ninguno: no se realiza ninguna auditoría.

    Correcto: sólo se realizan auditorías de los intentos de inicio de sesión satisfactorios.

    Error: sólo se realizan auditorías de los intentos de inicio de sesión fallidos.

    Todos: se realizan auditorías de los intentos de inicio de sesión satisfactorios y fallidos.

  7. Haga clic en Aceptar.

Paso siguiente: Instalar los Objetos de ayuda para la toma de decisiones

Guía básica de instalación


Instalar los Objetos de ayuda para la toma de decisiones

Instalar los Objetos de ayuda para la toma de decisiones

Los servicios Analysis Services de Microsoft SQL Server son necesarios para utilizar la función Analizador de la cartera de proyectos de Microsoft Office Project Server 2003. Al instalar Analysis Services en otro equipo distinto al que ejecuta Project Server 2003, el componente Objetos de ayuda para la toma de decisiones (Decision Support Objects, DSO) de Analysis Services debe instalarse en el equipo con Project Server 2003.

  1. Introduzca el CD de Microsoft SQL Server 2000 en la unidad de CD-ROM del equipo donde vaya a instalar Project Server 2003 o conéctese al punto de instalación de red.
  2. Si está instalando desde el CD de Microsoft SQL Server 2000 con la Reproducción automática habilitada, haga clic en Componentes de SQL Server 2000 en el programa de instalación de Microsoft SQL Server 2000 o, en el CD-ROM de Microsoft SQL Server 2000 (o en el punto de instalación de red), busque y ejecute el archivo Autorun.exe.
  3. En la página Instalar componentes, haga clic en Instalar Analysis Services.
  4. Lea y acepte el contrato de licencia.
  5. En el programa de instalación de Analysis Services, en la página Seleccionar componentes, desactive todos los componentes excepto Objetos de ayuda para la toma de decisiones y Componentes de cliente y, a continuación, siga las instrucciones del asistente para instalar los Objetos de ayuda para la toma de decisiones.
  6. Instale Service Pack 3 para Analysis Services de Microsoft SQL Server 2000.

Nota La instalación de DSO separada de Analysis Services no necesita una licencia adicional. Para obtener más información, consulte los Libros en pantalla de Microsoft SQL Server y la información de la licencia.

Siguiente paso: Configurar Servicios de Internet Information Server (IIS)

Guía básica de instalación


Configurar Servicios de Internet Information Server

Configurar Servicios de Internet Information Server

Tanto Microsoft Office Project Server 2003 como Windows SharePoint Services precisan de Servicios de Internet Information Server (IIS). Habilite IIS en el equipo donde vaya a instalar Project Server 2003 y en el equipo donde vaya a instalar Windows SharePoint Services.

Nota Se recomienda configurar IIS para que use el Nivel de socket seguro (Secure Sockets Layer, SSL) a fin de obtener un mayor grado de seguridad. Para obtener más información sobre la configuración de IIS para que use SSL, consulte la documentación de IIS.

Para habilitar IIS en Windows 2000 Server

  1. Haga clic en Inicio, seleccione Configuración, haga clic en Panel control e inicie la aplicación Agregar o quitar programas.
  2. Seleccione Configurar Windows, haga clic en el botón Componentes y siga las instrucciones que se indiquen en pantalla para instalar, quitar o agregar componentes a IIS.

Para activar IIS en Windows Server 2003

  1. Haga clic en Inicio y, acto seguido, seleccione Administre su servidor.
  2. En la página Administre su servidor, haga clic en Agregar o quitar función.
  3. En el panel Pasos preliminares, haga clic en Siguiente.
  4. En el panel Función de servidor, haga clic en Servidor de aplicaciones (IIS, ASP.NET) y, acto seguido, en Siguiente.
  5. En el panel Opciones del Servidor de aplicaciones, acepte la opción predeterminada ASP.NET y haga clic en Siguiente.
  6. Haga clic en Finalizar.
  7. Haga clic en Inicio, elija Herramientas administrativas y haga clic en Servicios de Internet Information Server (IIS).
  8. En el administrador de IIS, haga clic en el signo más (+) ubicado junto al nombre del servidor y, acto seguido, haga clic con el botón secundario en la carpeta Sitios Web y seleccione Propiedades.
  9. En el cuadro de diálogo Propiedades, haga clic en la ficha Servicio.
  10. En la sección Modo de aislamiento, desactive la casilla de verificación Ejecutar el servicio WWW en el Modo aislado de IIS 5.0 y haga clic en Aceptar.

Nota La casilla de verificación Ejecutar el servicio WWW en el Modo aislado de IIS 5.0 sólo aparecerá activada si ha actualizado a IIS 6.0 en Windows Server 2003 desde IIS 5.0 en Windows Server 2000. Las nuevas instalaciones de IIS 6.0 se establecen de forma predeterminada en el modo aislado para el proceso de trabajo de IIS 6.0.

Siguiente paso: Configurar la seguridad mejorada de Internet Explorer

Guía básica de instalación


Configurar la seguridad mejorada de Internet Explorer

Configurar la seguridad mejorada de Internet Explorer

De forma predeterminada, Microsoft Windows Server 2003 incluye un conjunto de opciones de seguridad denominado Configuración de seguridad mejorada de Internet Explorer. Esta configuración limita los tipos de contenido que un usuario puede ver en el servidor usando Microsoft Internet Explorer, con la excepción de los sitios enumerados en las zonas Intranet local y Sitios de confianza. Por ejemplo, de forma predeterminada, las secuencias de comandos de las páginas de Internet no funcionarán. El objetivo de estas opciones es ayudarle a asegurarse de que un usuario local de un equipo que también se ejecuta como servidor no descargue un virus u otros archivos dañinos desde Internet e infecte el servidor. La Configuración de seguridad mejorada de Internet Explorer no afecta a los usuarios remotos que ven el contenido del servidor, sólo a los usuarios que ejecutan Internet Explorer en el propio equipo servidor.

Al utilizar Configuración de seguridad mejorada de Internet Explorer en un servidor Web que ejecute Microsoft Windows SharePoint Services no es posible ver algunos códigos necesarios para la visualización de las páginas de los sitios o páginas de administración HTML. Si se utiliza Configuración de seguridad mejorada de Internet Explorer en un equipo que ejecuta Microsoft Office Project Server 2003, no se podrán instalar los controles Active X. De nuevo, los usuarios remotos con derechos de acceso adecuados podrán seguir viendo las páginas sin problema, pero un usuario que ejecute Internet Explorer en el servidor no podrá ver o administrar el sitio. El usuario en el servidor tampoco podrá ver ni administrar sitios de Project Server 2003 o de SharePoint remotos, debido a la configuración de seguridad.

Medidas de prevención

Si lo desea, puede hacer uso de las siguientes medidas de prevención que le ayudarán a garantizar el correcto funcionamiento de Windows SharePoint Services en su entorno:

  • Administrar Project Server 2003 y Windows SharePoint Services desde una estación de trabajo de Windows.
  • Desinstale la función Configuración de seguridad mejorada de Internet Explorer. Si no le preocupa que los usuarios puedan trabajar de forma local en el servidor Web, un administrador puede desinstalar la función Configuración de seguridad mejorada de Internet Explorer mediante la utilidad Agregar o quitar programas del sistema.

Para desinstalar la función Configuración de seguridad mejorada de Internet Explorer

  1. En el equipo en el que vaya a instalar Windows SharePoint Services (equipo número 1 en la lista de servidores), haga clic en Inicio, seleccione Panel de control y, a continuación, haga clic en Agregar o quitar programas.
  2. Haga clic en Agregar o quitar componentes de Windows.
  3. En la lista Componentes, desactive la casilla de verificación Configuración de seguridad mejorada de Internet Explorer y después, haga clic en Siguiente.

    Se eliminará el componente Configuración de seguridad mejorada de Internet Explorer

  4. Haga clic en Finalizar.

Siguiente paso: Instalar Windows SharePoint Services

Guía básica de instalación


Instalar Windows SharePoint Services

Instalar Windows SharePoint Services

Si no dispone de Windows SharePoint Services, puede descargarlo desde el sitio Web de Microsoft.

  1. En el equipo donde desee instalar Windows SharePoint Services (equipo número 1 de la lista de servidores), introduzca el CD de Windows SharePoint Services en la unidad de CD-ROM del servidor o conéctese a un punto de instalación de red.
  2. Haga clic en Inicio y, acto seguido, en Ejecutar.
  3. En el cuadro Abrir, escriba "d:\setupsts.exe" (siendo d: el punto de instalación de red o la unidad de CD-ROM de su equipo).

    Se iniciará el programa de instalación de Windows SharePoint Services.

  4. En el panel del contrato de licencia para el usuario final, repase las condiciones, active la casilla de verificación Acepto los términos del Contrato de licencia y, a continuación, haga clic en Siguiente.
  5. En el panel Tipo de instalación, haga clic en la opción Agrupación centralizada de servidores y, a continuación, en Siguiente.
  6. En el panel Resumen, compruebe que sólo se instale Windows SharePoint Services y, acto seguido, haga clic en Instalar.

    El programa de instalación se ejecutará e instalará Windows SharePoint Services.

    Cuando finalice el proceso de instalación, aparecerá una ventana de explorador y la página Configurar el servidor virtual de administración.

Siguiente paso: Configurar Servidor virtual de administración

Guía básica de instalación


Configurar Servidor virtual de administración

Configurar Servidor virtual de administración

Una vez terminado el proceso de instalación, es posible configurar el servidor virtual de administración, incluyendo la especificación de un fondo de aplicaciones que usar para los procesos del servidor virtual.

  1. En la página Configurar el servidor virtual de administración, seleccione la opción Utilizar un grupo de aplicaciones existente y mantenga el grupo de aplicaciones predeterminado de la lista.
  2. Haga clic en Aceptar.

    Se mostrará la página El grupo de aplicaciones ha cambiado.

  3. En el escritorio de Windows, haga clic en Inicio, después, en Ejecutar y en el cuadro Abrir, escriba "CMD" y haga clic en Aceptar.
  4. En el símbolo del sistema, escriba "iisreset" y presione ENTRAR.
  5. Cuando se haya reiniciado Servicios de Internet Information Server (IIS), cierre la ventana de comandos y vuelva al explorador.
  6. En la página El grupo de aplicaciones ha cambiado, haga clic en Aceptar.

Siguiente paso: Establecer el servidor de bases de datos de configuraciones

Guía básica de instalación


Establecer el servidor de bases de datos de configuración

Establecer el servidor de bases de datos de configuración

Mediante este procedimiento se configurará Windows SharePoint Services para trabajar con Microsoft SQL Server 2000.

  1. En el cuadro Servidor de la base de datos, escriba el nombre de la instancia de SQL Server 2000 a la que desea conectarse (equipo número 3 en la lista de servidores).
  2. En el cuadro Nombre de la base de datos de SQL Server, especifique el nombre que desee asignar a la base de datos de configuraciones que desea crear.
  3. Seleccione la opción Utilizar autenticación SQL Server.
  4. Escriba un nombre de usuario y una contraseña para la cuenta de SQL Server, que se utilizarán para crear las tablas de configuración de bases de datos (cuenta número 3 de la lista de cuentas de usuario).
  5. En la sección Creación de cuentas de Active Directory, seleccione la opción Los usuarios ya disponen de cuentas de dominio.

    Nota No seleccione la opción Crear automáticamente cuentas de Active Directory para los usuarios de este sitio, ya que no es compatible con Microsoft Office Project Server 2003.

  6. Haga clic en Aceptar.

Paso siguiente: Extender el servidor virtual

Guía básica de instalación


Extender el servidor virtual

Extender el servidor virtual

Tras configurar la conexión a Microsoft SQL Server 2000, estará listo para extender sus servidores virtuales con Windows SharePoint Services. Al extender un servidor virtual, Windows SharePoint Services se aplica a un servidor virtual y se crea un sitio Web de nivel superior.

  1. En la página Administración central, haga clic en Ampliar o actualizar el servidor virtual.
  2. En la página Lista de servidores virtuales, haga clic en Sitio Web predeterminado.
  3. En la página Ampliar servidor virtual, haga clic en Ampliar y crear una base de datos de contenido.
  4. En la página Ampliar y crear base de datos de contenido, seleccione la opción Crear un nuevo grupo de aplicaciones.
  5. En el cuadro Nombre del grupo de aplicaciones, especifique un nombre para el grupo de aplicaciones.
  6. Seleccione la opción Predefinida y, acto seguido, elija el elemento Servicio de red de la lista.
  7. En el cuadro Nombre de usuario de la sección Propietario del sitio, especifique el nombre cuenta de Windows del propietario de este servidor virtual.

    Este usuario recibirá cualquier aviso de superación de cuota o eliminación automática y dispondrá de privilegios de administración de Windows SharePoint Services.

  8. En el cuadro Correo electrónico, especifique la dirección de correo electrónico del propietario de este servidor virtual.
  9. Haga clic en Aceptar.

Siguiente paso: Ejecutar el Asistente de configuración de Windows SharePoint Services

Guía básica de instalación


Ejecutar el Asistente de configuración de Windows SharePoint Services

Ejecutar el Asistente de configuración de Windows SharePoint Services

El Asistente de configuración de Windows SharePoint Services instalará una plantilla básica de Microsoft Project Workspace y otros archivos de programa en el servidor que ejecute Windows SharePoint Services. El asistente también proporcionará un sitio denominado MS_ProjectServer_PublicDocuments para la función de biblioteca de documentos pública en Microsoft Office Project Web Access 2003.

  1. Introduzca el CD de Microsoft Office Project Server 2003 en la unidad de CD-ROM.
  2. Si está efectuando la instalación desde el CD de Project Server 2003 con la función de reproducción automática habilitada, haga clic en la opción Instalación del servidor del programa de instalación de Project Server 2003 o, en el CD-ROM de Project Server, localice y ejecute el archivo Setup.exe.

    Comenzará la instalación de Project Server 2003.

  3. Haga clic en Windows SharePoint Services.
  4. En la página siguiente, haga clic en Asistente de configuración de Windows SharePoint Services.
  5. En la página siguiente, haga clic en Siguiente.
  6. En la página siguiente, haga clic en Sitio Web predeterminado o seleccione un sitio anteriormente proporcionado y, acto seguido, haga clic en Siguiente.
  7. En la página siguiente, en la lista Seleccione la ruta URL bajo la que crear sitios de proyectos, haga clic en sitios y, después, en Siguiente.
  8. En la página siguiente, en el cuadro Nombre de cuenta del propietario del sitio, indique el nombre de cuenta de Windows del propietario del sitio.
  9. En el cuadro Correo electrónico del propietario del sitio, escriba la dirección de correo electrónico del propietario del sitio y, a continuación, haga clic en Siguiente.
  10. En la página siguiente, haga clic en Siguiente.
  11. En la página siguiente, anote la información que se proporciona en las secciones URL de administración central de SharePoint y Cree un sitio Web de máximo nivel debajo de este URL. Necesitará estos datos para instalar Project Server 2003.
  12. Haga clic en Finalizar.

Siguiente paso: Crear un administrador de Windows SharePoint Services

Guía básica de instalación


Crear un administrador de Windows SharePoint Team Services

Crear un administrador de Windows SharePoint Team Services

Para posibilitar el acceso de Microsoft Office Project Server 2003 a Windows SharePoint Services, es preciso crear un Administrador de Windows SharePoint Services en el equipo donde se ejecute Windows SharePoint Services. Para ello, agregue la cuenta que haya creado para este propósito (cuenta número 2 en la lista de cuentas de usuario) al grupo Administradores del equipo que ejecute Windows SharePoint Services.

  1. En el equipo que ejecuta Windows SharePoint Services, abra Administración de equipos.
  2. En el árbol de la consola, haga clic en Grupos.
  3. Haga clic con el botón derecho en el grupo Administradores y, acto seguido, haga clic en Propiedades.
  4. Haga clic en Agregar.
  5. En Escriba los nombres de objeto que desea seleccionar, especifique el nombre de la cuenta de Windows que desee agregar al grupo y, a continuación, haga clic en Aceptar.
  6. Haga clic en Aceptar.

Siguiente paso: Instalar Project Server 2003

Guía básica de instalación


Instalar Project Server 2003

Instalar Project Server 2003

En este tema se describen los pasos necesarios para instalar Microsoft Office Project Server 2003 con el programa de instalación. Estas instrucciones se ajustan a una configuración para varios servidores.

  1. En el equipo en el que vaya a instalar Project Server 2003 (el equipo número 2 en la lista de servidores), introduzca el CD de Project Server en la unidad de CD-ROM o conéctese al punto de instalación de red.
  2. Si está instalando desde el CD de Project Server con la Reproducción automática habilitada, haga clic en Instalación del servidor en el programa de instalación de Microsoft Project Server 2002 o, en el CD-ROM de Microsoft Project Server (o en el punto de instalación de red), busque y ejecute el archivo Setup.exe.
  3. En la página Información del usuario del programa de instalación, escriba el nombre de usuario, las iniciales, la organización y la clave del producto y, a continuación, haga clic en Siguiente.
  4. Lea y acepte el contrato de licencia y, a continuación, haga clic en Siguiente.
  5. En el cuadro Instalar en, especifique dónde desea instalar Project Server y, a continuación, haga clic en Siguiente. La ubicación predeterminada es C:\Archivos de programa\Microsoft Project Server 2003.
  6. En la página Seleccione los servicios que desee instalar en este servidor, haga clic en Siguiente para instalar todos los servicios en este equipo.
  7. En la página Especificar información del servidor de la base de datos:
    1. Seleccione la opción Crear una base de datos nueva para crear una base de datos nueva para los datos de Project Server.
    2. En el cuadro Servidor de la base de datos, escriba el nombre de la instancia de Microsoft SQL Server 2000 que desee utilizar con Project Server (equipo número 3 en la lista de servidores).
    3. Seleccione la opción Autenticación de SQL Server.
    4. Escriba el nombre de inicio de sesión y la contraseña de la cuenta de SQL Server que se utiliza para crear las tablas de base de datos de Project Server (cuenta número 3 en la lista de cuentas de usuario).
    5. Haga clic en Siguiente.
  8. En la página Especifique la información de conexión de las tablas de vistas, acepte los valores predeterminados y, a continuación, haga clic en Siguiente. De esta forma, se instalará la función Tablas vistas de Project Server en la base de datos principal de Project Server.
  9. En la página Cree la información de la cuenta de la base de datos, escriba las contraseñas que se utilizarán en Project Server y Microsoft Office Project Professional 2003 para obtener acceso a la base de datos de SQL Server 2000 y, después, haga clic en Siguiente. Las contraseñas indicadas se asignarán a las cuentas enumeradas en los cuadros de nombre de inicio de sesión.
  10. En la página Especifique la información de conexión de Analysis Services:
    1. En el cuadro Analysis server, indique el nombre del servidor de Analysis Services que se utilizará con Project Server (equipo número 3 en la lista de servidores).
    2. En el cuadro Nombre de inicio de sesión, escriba el nombre de la cuenta de dominio de Windows que deberá usar Project Server para obtener acceso al servidor de Analysis Services (cuenta número 1 en la lista cuentas de usuario).
    3. En el cuadro Contraseña, escriba la contraseña de cuenta de dominio de Windows y, a continuación, haga clic en Siguiente.

    Nota Si opta por proporcionar la información de conexión de Analysis Services más adelante, deberá ejecutar la utilidad pscomplus.exe a fin de establecer la información de cuenta de usuario y contraseña.

  11. En la página Seleccione un sitio Web, haga clic en Sitio Web predeterminado y, a continuación, haga clic en Siguiente.
  12. En la página Especifique la información de la dirección del servidor Web:
    1. En la sección Protocolo de intranet y nombre de servidor para tener acceso a Microsoft Office Project Server, seleccione el protocolo de intranet (http:// o https://) que se utilice en este servidor de entre los que se enumeran en la lista y, acto seguido, escriba el nombre del servidor en el cuadro siguiente.

      Nota No incluya el protocolo http:// o https:// cuando escriba el nombre del servidor.

    2. O bien en la sección Protocolo de extranet y nombre de dominio para tener acceso a Microsoft Office Project Server, seleccione el protocolo de extranet (http:// o https://) en la lista y, acto seguido, escriba el nombre del dominio en el cuadro siguiente.

      Nota No incluya el protocolo (http:// o https://) al escribir el nombre del dominio.

    3. Haga clic en Siguiente.
  13. En la página Especificar información del servidor de correo SMTP:
    1. En el cuadro Servidor de correo SMTP, escriba el nombre del servidor de correo SMTP que se utilizará para las notificaciones y los avisos de Project Server. Para que Project Server 2003 envíe notificaciones y avisos, escriba SMARTHOST.
    2. En el cuadro Puerto, escriba el número de puerto del servidor de correo. El valor predeterminado es 25.
    3. En el cuadro Dirección de origen, indique la dirección de correo electrónico que desee incluir en el campo De en los mensajes de correo electrónico que envíe Project Server y, después, haga clic en Siguiente.
  14. En la página Conectarse a un servidor Web que ejecute Windows SharePoint Services:
    1. En URL de administración de Windows SharePoint Services, seleccione el protocolo (http:// o https://) utilizado en el servidor de SharePoint y, a continuación, escriba el nombre y el número de puerto del servidor en el cuadro siguiente. Se corresponde con el vínculo URL de administración central de SharePoint proporcionado por el Asistente de configuración de Windows SharePoint Services.

      Nota No incluya el protocolo http:// o https:// cuando escriba el nombre del servidor.

    2. En Crear sitios bajo esta URL de Windows SharePoint Services, seleccione el protocolo (http:// o https://) utilizado en el servidor de SharePoint y, a continuación, escriba la dirección URL de los sitios de Project Server. Se corresponde con el vínculo Cree un sitio Web de máximo nivel debajo de este URL proporcionado por el Asistente de configuración de Windows SharePoint Services.

      Nota No incluya el protocolo http:// o https:// cuando escriba el nombre del servidor.

    3. Haga clic en Siguiente.

    Nota Si opta por proporcionar la información de conexión de Windows SharePoint Services en otra ocasión, deberá ejecutar la utilidad pscomplus.exe a fin de establecer la información de cuenta de usuario y contraseña.

  15. En la página Especifique la información de cuenta para Windows SharePoint Services (continuación), indique el nombre de cuenta y la contraseña de Windows que se utilizarán para administrar Windows SharePoint Services (cuenta número 2 de la lista cuentas de usuario) y, después, haga clic en Siguiente.
  16. En la página Conectarse a un servidor Web que ejecute Microsoft SharePoint Portal Server, si lo desea, puede especificar la información de conexión del SharePoint Portal Server de su organización, o bien seleccionar la opción Especificar esta información más tarde y hacer clic en Siguiente.
  17. En la página Elija un entorno de instalación, seleccione la opción que desea utilizar para su implantación y haga clic en Siguiente.
  18. En la página Especifique la contraseña de administrador, escriba la contraseña que se utilizará en la cuenta de administrador de Project Web Access y, después, haga clic en Siguiente.

    Nota Asegúrese de anotar esta contraseña para consultarla en el futuro. Deberá usar la cuenta de usuario la primera vez que inicie la sesión en Project Web Access

  19. En la página Resumen, haga clic en Instalar.

    Se instalará Project Server.

  20. En la página Instalación completada, haga clic en Fin.

Siguiente paso: Migrar el repositorio de Analysis Services a una base de datos de SQL Server

Guía básica de instalación


Migrar el repositorio de Analysis Services a una base de datos de SQL Server

Migrar el repositorio de Analysis Services a una base de datos de SQL Server

Cada servidor de Analysis Services de Microsoft SQL Server 2000 posee un repositorio para almacenar metadatos de los objetos del servidor de Analysis Services (por ejemplo, cubos y dimensiones). De forma predeterminada, este repositorio es una base de datos de Microsoft Access (.mdb) en el equipo servidor donde se ha instalado Analysis Services. Se recomienda migrar el repositorio a una base de datos de Microsoft SQL Server 2000 (.mdf) para evitar que surjan problemas de permisos con los usuarios que intenten acceder a la base de datos de Access desde otro equipo.

Notas

  • Puede migrar el repositorio en cualquier momento después de instalar Analysis Services, siempre y cuando SQL Server esté instalado y exista una base de datos para el repositorio.
  • Si la base de datos de SQL Server es compatible con la autenticación de Microsoft Windows, el grupo Administradores OLAP deberá tener permiso DB_OWNER (propietario) para el repositorio.
  • Si prefiere no migrar el repositorio, necesitará agregar el grupo Administradores OLAP a la lista de usuarios y grupos que disponen de permiso Control total para la carpeta \Archivos de programa\Microsoft Analysis Services\Bin, de modo que se pueda crear el cubo. (Haga clic con el botón secundario en el nombre de la carpeta, haga clic en Propiedades y, a continuación, en la ficha Seguridad.)
  1. Inicie sesión en el equipo de Analysis Services con una cuenta de usuario que disponga de permisos equivalentes a los de los grupos Administradores o Administradores OLAP e inicie Analysis Manager.
  2. Haga clic con el botón secundario en el nombre del servidor en Analysis Servers y, a continuación, haga clic en Migrar depósito para iniciar el Asistente para migración del depósito.

    Nota Es recomendable elegir el formato original de Analysis Services al migrar el repositorio.

Cuando haya migrado el repositorio a una base de datos de SQL Server, puede eliminar el antiguo repositorio definitivamente. De forma predeterminada, esta base de datos es \Archivos de programa\Microsoft Analysis Services\Bin\msmdrep.mdb.


Agregar usuarios a las funciones de bases de datos de cubos en Analysis Services

Agregar usuarios a las funciones de bases de datos de cubos en Analysis Services

Los servicios Analysis Services de Microsoft SQL Server utilizan la autenticación de Windows para controlar el acceso a los cubos OLAP (Online Analytical Processing), por ejemplo, al utilizar el Analizador de la cartera de proyectos. De forma predeterminada, la base de datos del cubo OLAP creada por Microsoft Office Project Server 2003 no tiene funciones de base de datos definidas, así que sólo obtendrán acceso a los cubos aquellos usuarios o grupos que se hayan agregado específicamente.

Nota Este procedimiento no se puede llevar a cabo hasta que no se haya creado una base de datos del cubo OLAP. Para comprobar el estado de la base de datos del cubo, abra Microsoft Project Web Access 2003 y, a continuación, haga clic en Administración en la barra de vínculos para ir al centro Administración. En el panel lateral, haga clic en Administrar las funciones de empresa y, a continuación, haga clic en Especificar las actualizaciones de los recursos y del cubo OLAP. El estado de la base de datos del cubo OLAP aparecerá en Estado actual del cubo.

  1. Inicie sesión en el equipo de Analysis Services con una cuenta de usuario que disponga de permisos equivalentes a los de los grupos Administradores o Administradores OLAP e inicie Analysis Manager.
  2. Expanda el nombre del servidor en Analysis Server para ver las bases de datos de cubos de ese equipo.
  3. Haga clic con el botón secundario en el nombre de la base de datos (tal y como se muestra en el cuadro Nombre del cubo de la página Actualizaciones de las tablas de recursos y del cubo OLAP de Project Web Access 2003) y, a continuación, haga clic en Administrar funciones.
  4. Haga clic en Nuevo y escriba un nombre para la nueva función de base de datos en el cuadro Nombre de función.
  5. En la ficha Pertenencia, haga clic en el botón Agregar para agregar usuarios y grupos a la función.
  6. Haga clic en Aceptar.
  7. En la ficha Cubos, haga clic en Seleccionar todo para permitir el acceso a los tres cubos de la base de datos.
  8. Haga clic en Aceptar para agregar la función.


Permitir a los usuarios iniciar sesión con una cuenta de usuario de Microsoft Windows distinta

Permitir a los usuarios iniciar sesión con una cuenta de usuario de Microsoft Windows distinta

De forma predeterminada, cuando Microsoft Office Project Server 2003 intenta autenticar a un usuario mediante la autenticación de Windows, asume que éste está utilizando un equipo en el que ya ha iniciado sesión en la red mediante su cuenta de usuario de Windows (Autenticación de Windows integrada). Sin embargo, puede que éste no sea el caso. Por ejemplo, un usuario quizás desee comprobar información de Project Server 2003 desde el equipo de otra persona o en un equipo común compartido por varios usuarios en el que no ha iniciado sesión con su cuenta de usuario de Windows.

En este caso, cuando el usuario va a un sitio de Project Server 2003, se abre la página de inicio de sesión en lugar de la página principal. Entonces, sólo tiene que hacer clic en el vínculo Iniciar la sesión utilizando una cuenta de usuario de Microsoft Windows distinta situado en el lateral izquierdo de la página. Después de escribir la información de su cuenta de usuario de Windows, se autentica mediante Autenticación básica y pasa a la página principal.

No obstante, para permitir que los usuarios utilicen el vínculo Iniciar la sesión utilizando una cuenta de usuario de Microsoft Windows distinta de la página de inicio de sesión, el administrador debe realizar los siguientes pasos en el equipo de Project Server 2003:

  • Habilitar la Autenticación básica para el directorio virtual de Project Server 2003 y para la biblioteca ISAPI (Msadcs.dll) de Remote Data Services mediante el complemento Microsoft Management Console (MMC) para Servicios de Internet Information Server (IIS).
  • Establecer las funciones Nivel de socket seguro (Secure Sockets Layer, SSL) de IIS para aumentar la seguridad.

    Para obtener más información sobre SSL, consulte la documentación de IIS.

Para obtener más información sobre las herramientas de administración de Windows, consulte la documentación de Microsoft Windows 2000 Server o Windows Server 2003.

Para habilitar la Autenticación básica del directorio virtual de Project Server 2003

  1. En el panel de la izquierda de la ventana de Internet Information Services, haga clic con el botón secundario en el directorio virtual y, a continuación, haga clic en Propiedades.
  2. Haga clic en la ficha Seguridad de directorios y haga clic en Modificar de la sección de control de autenticación.
  3. Active la casilla de verificación Autenticación básica y, acto seguido, haga clic en Sí cuando se le pregunte si desea continuar.
  4. Haga clic dos veces en Aceptar para que se apliquen las modificaciones y se cierre el cuadro de diálogo.
  5. Haga clic en Aceptar para cerrar el cuadro de diálogo Omitir herencia sin realizar ningún cambio.

Para habilitar la Autenticación básica para MSADCS.DLL

  1. Seleccione el directorio virtual MSADC en el panel de la izquierda de la ventana de Internet Information Services.
  2. Haga clic con el botón secundario en MSACDS.DLL en el panel de la derecha y, a continuación, seleccione Propiedades.
  3. Haga clic en la ficha Seguridad de archivo y, a continuación, haga clic en Modificar en la sección para acceso anónimo y control de la autenticación.
  4. Active la casilla de verificación Autenticación básica y, acto seguido, haga clic en Sí cuando se le pregunte si desea continuar.
  5. Haga clic dos veces en Aceptar para que se apliquen las modificaciones y se cierre el cuadro de diálogo.


Migrar datos desde Project Central o Project Server 2002

Migrar datos desde Project Central o Project Server 2002

Puede migrar los datos de Microsoft Project Central o Microsoft Project Server 2002 para utilizarlos con Microsoft Office Project Server 2003. Estos pasos de migración deberán completarse antes de proceder con la instalación de Project Server 2003.

Cuando lleve a cabo los pasos de migración indicados a continuación, el esquema de base de datos de SQL Server se actualizará para Project Server 2003. Tras la migración, no podrá volver a utilizar la base de datos con Project Central o Project Server 2002; así que si desea seguir utilizando estos programas, haga una copia de seguridad de la base de datos y restáurela con un nombre nuevo, después, realice los pasos de la migración en la nueva base de datos.

Nota Se recomienda que ejecute las secuencias de comandos de migración en el equipo donde se haya instalado la base de datos que se está migrando.

Preparativos para la actualización

  1. Cree una copia de seguridad completa de la base de datos de Project Central o Project Server 2002 que desee actualizar.
  2. En el Explorador de Windows, desplácese hasta la carpeta SUPPORT del CD de Project Server 2003.
  3. En la carpeta SUPPORT, copie la carpeta DATABASE al disco local.

Actualizar desde Microsoft Project Central

Si va a actualizar desde Project Central, en primer lugar, deberá actualizar la base de datos desde Project Central a Project Server 2002. Una vez actualizada la base de datos a Project Server 2002, podrá ejecutar las secuencias de comandos para actualizar a Project Server 2003.

  1. Inicie una ventana de símbolo del sistema y acceda a la carpeta DATABASE.
  2. Abra la carpeta PC2PS02.
  3. Ejecute UPG09DB.CMD utilizando la siguiente sintaxis:

    UPG09DB.CMD <ServerName> <DatabaseName> <UserName> <Password>

    Por ejemplo:

    UPG09DB.CMD PROJSQL2000 ProjectCentral sa hello

  4. Una vez que la secuencia de comandos haya concluido correctamente, siga el procedimiento de actualización desde Microsoft Project Server 2002.

Actualizar desde Microsoft Project Server 2002

  1. Inicie una ventana de símbolo del sistema y acceda a la carpeta DATABASE.
  2. Ejecute UPG10DB.CMD utilizando la sintaxis siguiente:

    UPG10DB.CMD <ServerName> <DatabaseName> <UserName> <Password>

    Por ejemplo:

    UPG10DB.CMD PROJSQL2002 ProjectServer sa hello

  3. Una vez que la secuencia de comandos haya concluido correctamente, instale Project Server 2003 y conéctese a la base de datos actualizada desde la página Especifique la información del servidor de la base de datos del asistente de instalación.


Actualizar a partir de Project Server 2002 y MSDE 2000

Actualizar a partir de Project Server 2002 y MSDE 2000

Para actualizar a Microsoft Office Project Server 2003 desde una instalación de Project Server 2002 que esté configurada para usar Microsoft Desktop Engine (MSDE) 2000, tendrá que realizar lo siguiente:

  • Desconectar la base de datos de Project Server 2002 de MSDE 2000.
  • Desinstalar Project Server 2002 y MSDE 2000.
  • Instalar de nuevo MSDE 2000.
  • Actualizar la base de datos para Project Server 2003 y, a continuación, instalar Project Server 2003.

Para actualizar desde Project Server 2002 y MSDE 2000

  1. Desasocie la base de datos de Microsoft Project Server 2002 de MSDE 2000:
    1. Haga clic en Inicio, haga clic en Ejecutar, escriba osql -U sa en el cuadro Abrir y, a continuación, haga clic en Aceptar.

      De esta manera se conecta con la instancia local y predeterminada de MSDE 2000 gracias al uso de la cuenta de administrador de sistema.

    2. Cuando se le pida la contraseña, introduzca la del administrador y, a continuación, presione ENTRAR.
    3. Recupere los nombres de los archivos de la base de datos (.MDF) y del registro (.LDF) correspondientes a la base de datos de Microsoft Project Server 2002 escribiendo el texto siguiente en líneas separadas y, por último, presione ENTRAR después de cada línea de texto:

      select a.filename as Filename from sysaltfiles a, sysdatabases b where a.dbid = b.dbid and b.name = N'ProjectServer'
go

      De esta forma se devolverán dos filas, una que termina en .MDF, que indica la ruta completa del archivo de la base de datos y otra que termina en .LDF y que indica la ruta completa del archivo de registro.

    4. Cierre cualquier transacción que esté en ejecución, desasocie la base de datos y los archivos de registro mediante el texto siguiente escrito en líneas diferentes y presione ENTRAR después de cada línea:

      EXEC sp_detach_db N'ProjectServer', N'true'
go

      Nota Podría haber un retraso largo después de ejecutar este comando.

    5. Una vez que se haya desasociado la base de datos, realice una copia de seguridad del archivo .MDF y del archivo .LDF desde los directorios que se hayan identificado en el paso 1.3 copiándolos en un directorio distinto.
  2. Quite Microsoft Project Server 2002:
    1. Haga clic en Inicio, haga clic en Panel de control y, a continuación, haga clic en Agregar o quitar programas.
    2. En el cuadro Agregar o quitar programas haga clic en Microsoft Project Server 2002 y, a continuación, haga clic en Quitar.
    3. Siga las instrucciones que aparezcan en pantalla para quitar Microsoft Project Server 2002.
    4. Reinicie el equipo tanto si se le ha pedido que lo haga como si no.
  3. Instale Microsoft SQL Server Desktop Engine Service Pack 3:
    1. Diríjase al sitio Web de Microsoft.
    2. Seleccione el idioma que coincida con la versión de Microsoft Project Server 2002 en el cuadro Full Download situado en la parte derecha de la ventana y, a continuación, haga clic en Go.
    3. Busque el vínculo de descarga del archivo SQL2KDeskSP3.exe y haga clic en el vínculo de descarga para iniciarla.

      Nota Las versiones que no estén en inglés de la descarga se recogerán como idioma_SQL2KDeskSP3.exe donde idioma representa la versión del idioma de la descarga.

    4. Cuando se le pida, guarde el archivo en el escritorio de Windows.
    5. En el Explorador de Windows, haga doble clic en el archivo que se haya guardado anteriormente en el escritorio.
    6. Haga clic en la opción para aceptar el Contrato de licencia para el usuario final (EULA).
    7. En el cuadro Carpeta de instalación escriba C:\sql2ksp3 y, a continuación, haga clic en Continuar.
    8. Haga clic en Inicio, haga clic en Ejecutar y, a continuación, escriba el siguiente comando en el cuadro Abrir:

      C:\sql2ksp3\msde\setup.exe sapwd=strong_pwd securitymode=sql disablenetworkprotocols=0

      donde strong_pwd corresponde a la contraseña del administrador de sistema (SA).

    9. Haga clic en Aceptar.
  4. Asocie las bases de datos de Microsoft Project Server 2002 a MSDE 2000:
    1. Haga clic en Inicio, haga clic en Ejecutar, escriba osql -U sa en el cuadro Abrir y, a continuación, haga clic en Aceptar.

      De esta manera se conectará a la instancia local y predeterminada de MSDE 2000 mediante la cuenta del administrador de sistema.

    2. Cuando se le pida la contraseña, introduzca la del administrador que se definió en el paso 3.8 y, a continuación, presione ENTRAR.
    3. Asocie los archivos de Project Server .MDF y .LDF escribiendo el siguiente texto en líneas distintas y, a continuación, presione ENTRAR después de cada línea:

      EXEC sp_attach_db @dbname=N'ProjectServer', @filename1=N' mdf_path',@filename2=N'ldf_path’
go

      donde mdf_path y ldf_path son las rutas de acceso al archivo .MDF y al archivo .LDF de los que haya realizado una copia de seguridad anteriormente en una ubicación segura en el paso 1.5.

      Nota Podría haber un retraso largo después de ejecutar este comando.

  5. Cree los inicios de sesión de SQL MSProjectUser y MSProjectServerUser. Para ello, escriba el texto siguiente en líneas distintas y presione ENTRAR después de cada línea

    EXEC sp_addlogin N'MSProjectServerUser', N'newpassword1', N'ProjectServer'
EXEC sp_addlogin N'MSProjectUser', N'newpassword2', N'ProjectServer'
go

    donde newpassword1 es la nueva contraseña para la cuenta MSProjectServerUser y newpassword2 es la nueva contraseña de la cuenta MSProjectUser.

  6. Agregue la cuenta MSProjectServerUser y la cuenta MSProjectUser a la función MSProjectRole y MSProjectServerRole escribiendo el texto siguiente en líneas distintas y presione ENTRAR después de cada línea:

    USE ProjectServer
go
EXEC sp_dropuser N'MSProjectServerUser’
EXEC sp_dropuser N'MSProjectUser’
go
EXEC sp_adduser N'MSProjectServerUser', N'MSProjectServerUser', N'MSProjectServerRole'
EXEC sp_adduser N'MSProjectUser', N'MSProjectUser', N'MSProjectRole'
go
quit

  7. Actualice la base de datos para Project Server 2003 tras seguir los pasos de Migrar datos desde Project Central o Project Server 2002.
  8. Instale Project Server 2003 y conecte la base de datos actualizada de MSDE 2000 desde la página Especifique la información del servidor de la base de datos del asistente de instalación.


Migrar a Windows SharePoint Services desde SharePoint Team Services

Migrar a Windows SharePoint Services desde SharePoint Team Services

SharePoint Team Services 1.0 de Microsoft no funcionará con Microsoft Office Project Server 2003. Si tiene previsto actualizar Microsoft Project Server 2002 a Project Server 2003, deberá migrar SharePoint Team Services a Microsoft Windows SharePoint Services 2.0.

Requisitos

  • El administrador que ejecute PSMIGRAT.EXE deberá ser administrador tanto en el servidor que ejecuta SharePoint Team Services como en el servidor con Windows SharePoint Services.
  • El administrador debe proporcionar una cuenta (Windows o SQL Server) con permisos de lectura y escritura a la base de datos de Project Server 2003.
  • En primer lugar, el administrador ejecutará las secuencias de comandos de actualización de la base de datos de Project Server 2003 para actualizar la base de datos de Project Server 2002 al formato de base de datos de Project Server 2003.
  • WSSWIZ.EXE configura Windows SharePoint Services para Project Server 2003 mediante la aplicación de las plantillas personalizadas que precisa Project Server 2003.

La migración a Windows SharePoint Services puede resultar un proceso muy lento. Para migrar SharePoint Team Services a Windows SharePoint Services, debe utilizarse la herramienta PSMIGRAT.EXE para extraer la información de la subweb desde SharePoint Team Services al archivo FWP. Entonces, la herramienta SMIGRATE.EXE se utilizará para agregar esta información al servidor que ejecute Windows SharePoint Services.

También es preciso que cuente con suficiente espacio en el disco para los directorios de trabajo de PSMIGRAT.EXE, sobre todo, si va a migrar todas las subweb de una vez. Para cada sitio, PSMIGRAT.EXE empaqueta todo el contenido del sitio (incluidos documentos y problemas) en un archivo CAB y expande el archivo para realizar las operaciones adicionales.

Windows SharePoint Services es más estable que SharePoint Team Services, proporciona informes de progreso detallados y registro de errores y resulta más sencillo para los administradores porque la mayor parte de la aplicación se controla automáticamente. El registro de PSMIGRAT.EXE incluye:

  • Una descripción textual de las operaciones principales, incluido el resultado de SMIGRATE.EXE.
  • Opción de modo silencioso; el progreso se escribe en un archivo de registro.

Windows SharePoint Services posee cuenta con un proceso de instalación simplificado y almacena todos los datos relacionados con documentos, problemas y riesgos en la base de datos de Project Server 2003 o en la base de datos de Windows SharePoint Services. El mantenimiento de los datos de Windows SharePoint Services se basará en la misma copia de seguridad y los principios de recuperación que se utilizarían para SQL Server 2000, con lo que se facilita la labor de evitar desastres y la recuperación tras un percance es más fácil de administrar.

También puede elegir actualizar la base de datos desde Microsoft SQL Server 2000 Desktop Engine (MSDE 2000) a Microsoft SQL Server 2000 si observa que necesita las funciones de base de datos adicionales que ofrece SQL Server 2000 o si precisa de mayor capacidad de almacenamiento.


Migrar sitios a Windows SharePoint Services

Migrar sitios a Windows SharePoint Services

Debe ejecutar la versión 1.0 de Microsoft SharePoint Team Services que se incluye como parte de la versión Microsoft Office XP Service Pack 3 para poder migrar un sitio desde SharePoint Team Services a Microsoft Windows SharePoint Services 2.0. El proceso de migración del sitio se ve optimizado al utilizar sitios Web del equipo estándar. Esto significa que muchos tipos de personalizaciones no se migrarán correctamente o no funcionarán en un sitio migrado. Además, debido a que el conjunto de funciones y la arquitectura han cambiado de manera significativa entre SharePoint Team Services y Windows SharePoint Services, muchas funciones que se podían utilizar en estos entornos no funcionarán tras la migración. Las personalizaciones y las características que no se migrarán incluye, pero sin limitarse a ellos, los siguientes elementos:

  • Páginas principales personalizadas. Las páginas principales personalizadas que utilizan un editor de páginas Web compatible con Windows SharePoint Services, como Microsoft FrontPage 2002, restablecerán la página principal del sitio Web de equipo estándar. Las páginas principales personalizadas en el explorador mantendrán sus personalizaciones, incluidas las vistas agregadas y los cambios realizados a la barra de Inicio rápido.
  • Barras de vínculos personalizadas. Las barras de vínculos, como la barra de vínculos situada en la parte superior, que se ha personalizado mediante un editor de páginas Web compatible con Windows SharePoint Services, por ejemplo, FrontPage 2002, volverán a la barra de vínculos estándar.
  • Páginas ASP personalizadas incluidas en el sitio. De forma predeterminada, el filtro ISAPI para Windows SharePoint Services bloquea el uso de cualquier página ASP que no forme parte de la instalación beta de Windows SharePoint Services. Si desea utilizar páginas ASP personalizadas con sitios Web de Windows SharePoint Services actualizados, deberá colocar las páginas ASP en un directorio virtual aparte y crear una ruta excluida para el directorio en Windows SharePoint Services. Así, permitirá que Servicios de Internet Information Server (IIS) controlen el directorio, en vez de Windows SharePoint Services, y permitirá que las páginas ASP se ejecuten.
  • Páginas personalizadas que vinculan a las listas de SharePoint Team Services. La herramienta SMIGRATE.EXE no incluye una herramienta de reparación automática. Tras la migración, cualquier vínculo creado para señalar listas específicas se romperá. Puede actualizar los vínculos para que hagan referencia a la ubicación actual de las listas después de la migración.
  • Subsitios que tienen el mismo nombre que un comodín de inclusión o exclusión. Si ha configurado rutas incluidas y excluidas para el servidor que albergará los sitios migrados, asegúrese de que los nombres de dichas rutas no entren en conflicto con los nombres de los sitios que se van a migrar. Por ejemplo, si uno de los subsitios se denomina http://servername/sitename, y la ruta /sitios en el servidor nuevo es un comodín de inclusión, el subsitio http://servername/sitename no se migrará.
  • Archivos o carpetas con espacios al principio o al final. Windows SharePoint Services no admite espacios al principio o al final (“ archivo.doc”, o “archivo .doc”). Deberá cambiar el nombre del archivo y agregarlo manualmente al sitio.
  • Archivos con extensiones bloqueadas en Windows SharePoint Services. Una función nueva permite a los administradores de servidores controlar si determinados tipos de archivos se pueden cargar o descargar en el servidor. Si un archivo del sitio utiliza una de estas extensiones de archivo (por ejemplo, .exe), el archivo no se migrará al sitio nuevo.
  • Nombres de archivos o carpetas largos (más de 255 caracteres). Los nombres de archivos o carpetas que ocupen más de 255 caracteres no se admiten en Windows SharePoint Services. Puede cambiarle el nombre a estos archivos o carpetas antes de la migración y agregarlos manualmente al sitio nuevo.
  • Vínculos con direcciones URL largas (más de 255 caracteres). Las direcciones URL que ocupen más de 255 caracteres no se admiten en Windows SharePoint Services.
  • Límites de cuentas de usuario. No se admiten límites de cuentas de usuario en Windows SharePoint Services.
  • Cuentas de usuario locales. Las cuentas de usuario locales no son compatibles cuando se ejecuta Windows SharePoint Services con Microsoft Office Project Server 2003.
  • Permisos de seguridad que no se pueden convertir directamente de SharePoint Team Services a Windows SharePoint Services. La herramienta SMIGRATE.EXE proporcionará los mismos permisos o más de los que se encontraban en SharePoint Team Services.
  • Carpetas dentro de la subcarpeta de datos adjuntos de una lista. Si el sitio original contenía una lista con una subcarpeta de datos adjuntos, con archivos y subcarpetas en su interior, la carpeta de datos adjuntos no se migrará. La función de datos adjuntos de Windows SharePoint Services se habilitará para esa lista, de manera que podrá copiar por encima los archivos y las subcarpetas relacionados o agregarlos como datos adjuntos a los elementos de la lista.


Parámetros de línea de comandos de PSMIGRAT.EXE

Parámetros de línea de comandos de PSMIGRAT.EXE

Los siguientes parámetros de línea de comando se pueden utilizar con PSMIGRAT.EXE.

Parámetro | Descripción
*-w | Ruta (URL) administrada de los sitios de proyectos de Microsoft Windows SharePoint Services 2.0. Opcional sólo si se especifica –bo (sólo copia de seguridad).
*-ownerlogin | Cuenta de Windows con permiso para crear un sitio Web de nivel máximo.
*-owneremail | Dirección de correo electrónico del usuario especificado en –ownerlogin.
-i | Números de identificación de las subweb virtuales de Microsoft de SharePoint Team Services 1.0 que se han migrado a Windows SharePoint Services. Puede tratarse de un único identificador de proyecto, un intervalo de identificadores de proyectos o una serie de identificadores de proyectos que estén fuera de servicio. Si no se utiliza este parámetro, TODAS las subweb se migrarán. Utilice -1 para migrar la biblioteca de documentos pública.
*-f | Ruta del archivo de copia de seguridad y de la subcarpeta de trabajo. Necesario para ejecutar PSMIGRAT.EXE.
*-dbserver | Servidor de base de datos de Microsoft Office Project Server 2003.
*-dbname | Nombre de la base de datos de Project Server 2003.
-dblogin | Necesario si se utiliza la autenticación de Microsoft SQL Server.
-dbpassword | Necesario si se utiliza la autenticación de SQL Server.
-c | Cadena de conexión. Puede utilizarse en lugar de los parámetros –db*.
-l | Ruta al archivo de registro. Ambos PSMIGRAT.EXE lo utilizan. Opcional; el valor predeterminado es %temp% si no se especifica.
-s | Indica que PSMIGRAT.EXE se ejecute en modo silencioso. Opcional.
-ro | Restaurar sólo a partir del formato expandido (con manifest.xml y otros archivos enumerados en un directorio) desde el directorio de trabajo (-f). Opcional.
-bo | Crea una copia de seguridad de las subweb de SharePoint Team Services en un archivo .fwp. También mantiene la lista de archivos expandida fuera del archivo .fwp.
*-p | Acepta un prefijo para nombre del sitio, por ejemplo ProjectServer_101.
-un | Nombre de usuario para los equipos que ejecutan Microsoft Windows Server 2003 con la función Configuración de seguridad mejorada de Internet Explorer instalada.
-pwd | Contraseña para equipos que ejecutan Windows Server 2003 con la función Configuración de seguridad mejorada de Internet Explorer instalada.

Nota Los elementos con un asterisco (*) son obligatorios.


Migrar un sitio a Windows SharePoint Services

Migrar un sitio a Windows SharePoint Services
  1. Instale Microsoft Windows SharePoint Services 2.0 y extienda un servidor virtual.
  2. Ejecute WSSWIZ.EXE (el Asistente de configuración de Windows SharePoint Services).
  3. Aplique el parche OWS1002.EXE en SharePoint Team Services 1.0 del servidor de Microsoft. Este parche se puede descargar desde el Centro de descarga de Microsoft. Esto permite que las subweb de SharePoint Team exporten información de esquema adicional sobre las subweb de SharePoint Team Services. Esta información es necesaria para SMIGRATE.EXE durante el proceso de migración a Windows SharePoint Services.
  4. Ejecute PSMIGRAT.EXE. Introduzca el CD de Microsoft Office Project Server 2003 en la unidad de CD-ROM. En el botón Inicio de Windows, haga clic en Ejecutar. Escriba "CMD" y haga clic en Aceptar. Desde la ventana de símbolo del sistema, cambie a la unidad de CD-ROM y vaya a la carpeta \SUPPORT\PSMIGRAT. Esta herramienta precisa la siguiente información:
    • La ruta administrada de Windows SharePoint Services bajo la que se crearán los sitios migrados recientemente.
    • La carpeta donde se almacenarán todos los archivos de copia de seguridad.
    • La información de conexión de la base de datos de Project Server 2003.
    • El intervalo de identificadores de proyecto (opcional).
    • La ubicación del archivo de registro (opcional).

    Por ejemplo, se podría ejecutar lo siguiente:

    PSMIGRAT.EXE –w http://wss_svr/projects
 -f \\<serverName>\<path to server> -dbserver <serverName>
 -dblogin <loginName> -dbpassword <password> -p <prefix>

Para cada subweb, PSMIGRAT.EXE realiza lo siguiente:

  1. Comprueba que el parche de OWS1002.EXE se encuentra instalado en el servidor que ejecuta SharePoint Team Services.
  2. Crea una copia de seguridad de cada subweb en el servidor que ejecuta SharePoint Team Services.
    1. Crea una carpeta de trabajo en el mismo directorio de archivos y extrae el archivo manifest.xml.
    2. Modifica el archivo manifest.xml y realiza lo siguiente:
      • Introduce un identificador de plantilla nuevo (6215).
      • Cambia los tipos de campo Comentarios a campos Nota en los documentos y problemas.
      • Cambia el identificador de lista de problemas a 101 de manera que se puede migrar a una lista personalizada.
    3. Rehace el archivo CAB en 101.fwp.
    4. Elimina el directorio de trabajo (salvo si se especifica –bo).
  3. Ejecuta la herramienta SMIGRATE.EXE para migrar la información de SharePoint Team Services al servidor nuevo que ejecute Windows SharePoint Services.
  4. Actualiza los GUID de lista y las direcciones de sitio nuevas en la base de datos de Project Server 2003.
  5. Migra los problemas del tipo de lista personalizado en SharePoint Team Services al tipo de lista de problemas de Windows SharePoint Services.
  6. Actualiza las propiedades del sitios en el servidor que ejecuta Windows SharePoint Services.
  7. Actualiza la base de datos de Project Server 2003 con la dirección del sitio nuevo y los GUID de lista nuevos.


Desinstalar Microsoft Office Project Server 2003

Desinstalar Microsoft Office Project Server 2003

Los cambios que se producen al desinstalar Project Server 2003:

  • Los archivos de base de datos de Microsoft SQL Server 2000 se conservan.
  • Los archivos del sistema instalados por el programa de instalación (como los archivos de Microsoft XML) se conservan.
  • Las claves del Registro creadas por Project Server 2003 se eliminan.
  • Los productos o componentes adicionales, como Windows SharePoint Services, no se ven afectados por la desinstalación de Project Server 2003.

Notas

  • Puede utilizar el Asistente de configuración de Windows SharePoint Services para desinstalar las plantillas de Project Server 2003 y devolver las plantillas de Windows SharePoint Services a su estado original (los subsitios existentes no se verán afectados). Para desinstalar Windows SharePoint Services por completo, utilice el Asistente de configuración de Windows SharePoint Services para desinstalar las plantillas de Project Server 2003, no extienda el servidor virtual y elimine base de datos de contenido; a continuación, desinstale Windows SharePoint Services mediante Agregar o quitar programas.
  • La desinstalación de Project Server 2003 Server no quitará la base de datos. Por lo tanto, si necesita restablecer la base de datos a su estado original, puede ejecutar las secuencias de comandos de la base de datos. Al volver a ejecutar las secuencias de comandos, los registros de la base de datos se eliminarán automáticamente antes de que se creen nuevos registros predeterminados, con lo que se obtendrán tablas nuevas con registros predeterminados sin eliminar la base de datos. Debido a que todos los registros se eliminan al volver a ejecutar las secuencias de comandos, es posible que desee guardar una copia de seguridad de los datos antes de ejecutar las secuencias de comandos otra vez.


Crear la base de datos de Project Server 2003 manualmente

Crear la base de datos de Project Server 2003 manualmente

Puede crear la base de datos de Microsoft Office Project Server 2003 manualmente mediante las secuencias de comandos de SQL que aparecen en el CD de Project Server 2003. Utilice este procedimiento si no desea que la base de datos la cree el programa de instalación de Project Server 2003.

Nota Se recomienda que ejecute las secuencias de comandos en el equipo donde se haya creado la base de datos.

Para crear la base de datos

  1. En SQL Server 2000 Enterprise Manager, cree una nueva base de datos para su uso con Project Server 2003.
  2. En el Explorador de Windows, desplácese hasta la carpeta SUPPORT del CD de Project Server 2003.
  3. En la carpeta SUPPORT, copie la carpeta DATABASE en el disco local.
  4. Inicie una ventana de símbolo del sistema y acceda a la carpeta DATABASE.
  5. Ejecute SETUPDB.CMD utilizando la siguiente sintaxis:

    SETUPDB.CMD <ServerName> <DatabaseName> <UserName> <Password>

    Por ejemplo,

    SETUPDB.CMD PROJSQL2003 ProjectServer sa hello

  6. Una vez que la secuencia de comandos haya concluido correctamente, instale Project Server 2003 y conéctese a la base de datos nueva desde la página Especifique la información del servidor de la base de datos del asistente de instalación.


Ejecutar la utilidad de configuración de proxy WinHTTP

Ejecutar la utilidad de configuración de proxy WinHTTP

Cuando se ejecuta la instalación de Microsoft Office Project Server 2003, los ajustes de proxy se configuran automáticamente para la instalación de Project Server 2003. Si necesita cambiar o actualizar la configuración del servidor proxy, puede usar la utilidad de configuración de proxy WinHTTP (PROXYCFG.EXE), que se instala en el servidor cuando se ejecuta la instalación.

Para ejecutar proxycfg.exe

  1. En el equipo donde esté instalado Project Server 2003, haga clic en Inicio, haga clic en Ejecutar, escriba cmd y, a continuación, haga clic en Aceptar.
  2. Desplácese hasta la carpeta \Archivos de programa\Microsoft Office Project Server 2003\Bin y, a continuación, ejecute proxycfg.exe con los parámetros que se explican a continuación.
  3. Reinicie Internet Information Services.

    Nota La información nueva o actualizada para la utilidad de configuración de proxy WinHTTP no surtirá efecto hasta que se reinicie Internet Information Services.

Opciones de la utilidad de configuración de proxy WinHTTP

Opción | Descripción
proxycfg | Este comando muestra la configuración actual de proxy WinHTTP.
proxycfg -d | Este comando especifica que a todos los servidores HTTP y HTTPS debería de poder accederse directamente. Utilice este comando si no hay ningún servidor proxy.
proxycfg -p proxy-server-list optional-bypass-list | Este comando especifica uno o varios servidores proxy y una lista opcional de hosts a los que se debería poder obtener acceso directamente. Si un servidor proxy no está especificado para un protocolo dado y ese servidor no está en la lista de omisión, la opción -p quiere decir que al servidor no se puede tener acceso de ninguna manera.
proxycfg -d -p proxy-server-list optional-bypass-list | Este comando especifica uno o varios servidores proxy y una lista opcional de hosts a los que se debería poder obtener acceso directamente. Si no se ha definido un servidor proxy para el protocolo determinado, la opción -d especifica que se podría obtener acceso directamente al servidor.
proxycfg -u | Este comando importa la configuración de proxy de Internet Explorer del usuario actual. WinHTTP no admite el descubrimiento automático ni la configuración de proxy basada en secuencias de comandos.

En la siguiente tabla se describe cómo usar tanto los parámetros proxy-server-list como optional-bypass-list.

Parámetro Descripción
proxy-server-list

Los proxies se especifican en una cadena delimitada por el espacio. Las listas de proxy pueden contener el número de puerto usado para acceder al proxy.

Los servidores proxy pueden recogerse en una lista para usar un protocolo específico. Los protocolos válidos son HTTP o HTTPS. La sintaxis de una lista de proxies que especifica un protocolo es:

"protocol=http://proxy_name"

donde protocol puede ser tanto "http" como "https" y proxy_name se corresponde con el nombre del servidor proxy. Por ejemplo, la cadena "http=http://http_proxy_name:80", especifica que el protocolo es "HTTP", el nombre del servidor proxy es "http_proxy_name" y que el número de puerto para el servidor es 80. Un ejemplo de una lista de proxies que especifique el protocolo HTTPS es: "https=http://https_proxy_name".

Si el servidor proxy utiliza el número de puerto predeterminado para el protocolo, el número de puerto puede omitirse.

Si el nombre del proxy aparece por sí mismo en la lista, la utilidad proxycfg.exe utilizará ese proxy como el predeterminado para cualquier protocolo que no tenga especificado el proxy. Por ejemplo, la lista "http=http://http_proxy other_proxy" especifica el uso del servidor http_proxy para cualquier operación de HTTP y el otro servidor proxy (other_proxy) para cualquier operación de HTTPS.

optional-bypass-list

Esta lista contiene los nombres de host o direcciones IP que sean conocidas localmente.

Esta lista contiene caracteres comodín, "*", que provocan que la aplicación omita el servidor proxy para las direcciones que se ajusten al patrón especificado. Por ejemplo, tanto "*.example.com" como "*.org" son patrones de caracteres comodín aceptables. Los caracteres comodín deben ser los caracteres situados más a la izquierda en la lista, por lo que "miservidor.*" no sería aceptable.

Para enumerar varias nombres de host y direcciones, sepárelas con espacios en blanco o puntos y coma en la cadena de omisión de proxy. Si la macro "<local>" está especificada, la función omite cualquier nombre de host que contenga un punto.

Ejemplos

El siguiente es el comando más común utilizado con la utilidad proxycfg.exe. Este comando especifica el uso del servidor proxy denominado "miproxy" para obtener acceso tanto a los servidores HTTP como HTTPS y también omite cualquier nombre de host que no incluyan un punto. En este caso, la opción -d no surtirá efecto.

proxycfg -d -p myproxy "<local>"

Compare el comando anterior con el siguiente comando, que especifica el uso de un servidor proxy denominado "miproxy" para obtener acceso tanto a servidores HTTP como HTTPS y a no omitir los servidores.

proxycfg -p myproxy

A continuación se expone un ejemplo de un comando más complejo utilizado por la utilidad proxycfg.exe. Este comando especifica el uso del servidor proxy denominado "http_proxy" para obtener acceso a servidores HTTP y el uso del servidor denominado "https_proxy" para obtener acceso a los servidores HTTPS. Este comando también especifica los sitios de intranet locales (por ejemplo, los nombres de host sin punto) así como cualquier sito en el dominio "*.example.com" que omiten el proxy.

proxycfg -p "http=http_proxy https=https_proxy" "<local>;*.example.com"