Referencia del esquema XML de Microsoft Office Project 2003

Referencia del esquema XML de Microsoft Office Project 2003

A continuación, desarrollaremos la referencia XML de Microsoft Office Project 2003. Esta documentación abarca los siguientes puntos:

  • Esquema XML de Project
    El esquema XML de Project se presenta en nueve secciones principales para el elemento complejo y los tipos de datos, como <Project>, <Calendar> y <Task>. Esta página incluye vínculos a dichas secciones, que se han organizado según existen como datos en Project, Microsoft Office Project Server 2003 y en las bases de datos OLE.
  • Estructura XML de Project
    La estructura jerárquica de elementos se muestra de manera similar para cada una de las nueve secciones principales. Los temas de la estructura XML ofrecen la manera más sencilla de consultar las relaciones entre elementos principales y secundarios e incluye vínculos a los temas de referencia de cada elemento. Los temas de los elementos abarcan la descripción, los tipos de datos, los elementos principales y segundarios y las notas.
  • Resumen de XML para Project
    Este resumen contiene información sobre como se utiliza XML en Project, una descripción general de los elementos y los tipos del esquema XML de Project y muestras de los códigos VBA para utilizar Project con un documento, un archivo o una cadena DOM XML.
  • Lista en orden alfabético de elementos y tipos
    Cada uno de los elementos se documenta en un tema que enumera los elementos principales y secundarios, el tipo y las notas.


Esquema XML de Microsoft Office Project 2003

Esquema XML de Microsoft Office Project 2003

El esquema XML de los tipos de datos y elementos complejos de Project se muestra en los siguientes temas:

Elementos complejos

  1. Esquema XML del elemento <Project>
  2. Esquema XML del elemento <OutlineCode>
  3. Esquema XML del elemento <WBSMask>
  4. Esquema XML del elemento <ExtendedAttribute>
  5. Esquema XML del elemento <Calendar>
  6. Esquema XML del elemento <Task>
  7. Esquema XML del elemento <Resource>
  8. Esquema XML del elemento <Assignment>

Tipos de datos de proyecto

Estructura y esquema XML del elemento <TimephasedDataType>

Mostrar Vea también


Estructura XML de Microsoft Office Project 2003

Estructura XML de Microsoft Office Project 2003

Mostrar Vea también

Resumen de XML de Project
Esquema XML de Project

La estructura XML de los elementos complejos y los tipos de datos de Project se describe en los siguientes temas:

Elementos complejos

  • Estructura XML del elemento <Project>
  • Estructura XML del elemento <OutlineCode>
  • Estructura XML del elemento <WBSMask>
  • Estructura XML del elemento <ExtendedAttribute>
  • Estructura XML del elemento <Calendar>
  • Estructura XML del elemento <Task>
  • Estructura XML del elemento <Resource>
  • Estructura XML del elemento <Assignment>

Tipos de datos de proyecto

Estructura y esquema XML del elemento <TimephasedDataType>


Lista en orden alfabético de los elementos y tipos

Lista en orden alfabético de los elementos y tipos

A continuación, se incluye una lista con los elementos y tipos de datos ordenados alfabéticamente del esquema XML de Microsoft Office Project 2003.

Los tipos de datos del esquema estándar definidos en http://www.w3.org/2001/XMLSchema (integer, string, Boolean, etc.) no se incluyen en la lista. Sólo figura un tipo de dato adicional en Project: <TimephasedDataType>.

Los atributos no se han incluido en la lista, puesto que sólo se utilizan atributos de esquema estándar (name, minOccurs, maxOccurs, type, base y default).

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project

Mostrar A

<AccrueAt> (elemento)

<ActiveDirectoryGUID> (elemento)

<ActualCost> (elemento)

<ActualDuration> (elemento)

<ActualFinish> (elemento)

<ActualOvertimeCost> (elemento)

<ActualOvertimeWork> (elemento)

<ActualOvertimeWorkProtected> (elemento)

<ActualsInSync> (elemento)

<ActualStart> (elemento)

<ActualWork> (elemento)

<ActualWorkProtected> (elemento)

<ACWP> (elemento)

<AdminProject> (elemento)

<Alias> (elemento)

<AllLevelsRequired> (elemento)

<AppendNewValues> (elemento)

<Assignment> (elemento)

<Assignments> (elemento)

<Author> (elemento)

<AutoAddNewResourcesAndTasks> (elemento)

<Autolink>(elemento)

<AvailabilityPeriod> (elemento)

<AvailabilityPeriods> (elemento)

<AvailableFrom> (elemento)

<AvailableTo> (elemento)

<AvailableUnits> (elemento)

Mostrar B

<BaseCalendarUID> (elemento)

<Baseline> (elemento)

<BaselineForEarnedValue> (elemento)

<BCWP> (elemento)

<BCWS> (elemento)

<BookingType> (elemento)

<BookingType> (elemento)

Mostrar C

<CalculationType> (elemento)

<Calendar> (elemento)

<Calendars> (elemento)

<CalendarUID> (elemento)

<CanLevel> (elemento)

<Category> (elemento)

<Code> (elemento)

<Company> (elemento)

<Confirmed> (elemento)

<ConstraintDate> (elemento)

<ConstraintType> (elemento)

<Contact> (elemento)

<Cost> (elemento)

<CostPerUse> (elemento)

<CostRateTable> (elemento)

<CostVariance> (elemento)

<CreateDate> (elemento)

<CreationDate> (elemento)

<Critical> (elemento)

<CriticalSlackLimit> (elemento)

<CrossProject> (elemento)

<CrossProjectName> (elemento)

<CurrencyDigits> (elemento)

<CurrencySymbol> (elemento)

<CurrencySymbolPosition> (elemento)

<CurrentDate> (elemento)

<CV> (elemento)

Mostrar D

<DaysPerMonth> (elemento)

<DayType> (elemento)

<DayWorking> (elemento)

<Deadline> (elemento)

<Default> (elemento)

<DefaultFinishTime> (elemento)

<DefaultFixedCostAccrual> (elemento)

<DefaultOvertimeRate> (elemento)

<DefaultStandardRate> (elemento)

<DefaultStartTime> (elemento)

<DefaultTaskEVMethod> (elemento)

<DefaultTaskType> (elemento)

<Delay> (elemento)

<Duration> (elemento)

<DurationFormat> (elemento)

Mostrar E

<EarlyFinish> (elemento)

<EarlyStart> (elemento)

<EarnedValueMethod> (elemento)

<EditableActualCosts> (elemento)

<EffortDriven> (elemento)

<EmailAddress> (elemento)

<Enterprise> (elemento)

<EnterpriseOutlineCodeAlias> (elemento)

<Estimated> (elemento)

<EstimatedDuration> (elemento)

<ExtendedAttribute> (elemento)

<ExtendedAttributes> (elemento)

<ExtendedCreationDate> (elemento)

<ExternalTask> (elemento)

<ExternalTaskProject> (elemento)

Mostrar F

<FieldID> (elemento)

<FieldName> (elemento)

<Finish> (elemento)

<Finish> (elemento)

<FinishDate> (elemento)

<FinishVariance> (elemento)

<FiscalYearStart> (elemento)

<FixedCost> (elemento)

<FixedCostAccrual> (elemento)

<FixedMaterial> (elemento)

<Formula> (elemento)

<FreeSlack> (elemento)

<FromDate> (elemento)

<FromTime> (elemento)

<FYStartDate> (elemento)

Mostrar G - H

<GenerateCodes> (elemento)

<Group> (elemento)

<HasFixedRateUnits> (elemento)

<HideBar> (elemento)

<HonorConstraints> (elemento)

<Hyperlink> (elemento)

<HyperlinkAddress> (elemento)

<HyperlinkSubAddress> (elemento)

Mostrar I

<ID> (elemento)

<IgnoreResourceCalendar> (elemento)

<Initials> (elemento)

<InsertedProjectsLikeSummary> (elemento)

<Interim> (elemento)

<IsBaseCalendar> (elemento)

<IsEnterprise>

<IsGeneric> (elemento)

<IsInactive> (elemento)

<IsNull> (elemento)

<IsSubproject> (elemento)

<IsSubprojectReadOnly> (elemento)

Mostrar L

<LagFormat> (elemento)

<LastSaved> (elemento)

<LateFinish> (elemento)

<LateStart> (elemento)

<LeafOnly> (elemento)

<Length> (elemento)

<Level> (elemento)

<LevelAssignments> (elemento)

<LevelingCanSplit> (elemento)

<LevelingDelay> (elemento)

<LevelingDelayFormat> (elemento)

<LinkedFields> (elemento)

<LinkLag> (elemento)

Mostrar M

<Manager> (elemento)

<Mask> (elemento)

<Masks> (elemento)

<MaterialLabel> (elemento)

<MaxUnits> (elemento)

<MicrosoftProjectServerURL> (elemento)

<Milestone> (elemento)

<MinutesPerDay> (elemento)

<MinutesPerWeek> (elemento)

<MoveCompletedEndsBack> (elemento)

<MoveCompletedEndsForward> (elemento)

<MoveRemainingStartsBack> (elemento)

<MoveRemainingStartsForward> (elemento)

<MultipleCriticalPaths> (elemento)

Mostrar N

<Name> (elemento)

<NewTasksEffortDriven> (elemento)

<NewTasksEstimated> (elemento)

<NewTaskStartDate> (elemento)

<Notes> (elemento)

<NTAccount> (elemento)

<Number> (elemento)

Mostrar O

<OnlyTableValuesAllowed> (elemento)

<OutlineCode> (elemento)

<OutlineCodes> (elemento)

<OutlineLevel> (elemento)

<OutlineNumber> (elemento)

<OverAllocated> (elemento)

<OvertimeCost> (elemento)

<OvertimeRate> (elemento)

<OvertimeRateFormat> (elemento)

<OvertimeWork> (elemento)

Mostrar P

<PeakUnits> (elemento)

<PercentComplete> (elemento)

<PercentWorkComplete> (elemento)

<PhoneticAlias> (elemento)

<Phonetics> (elemento)

<PhysicalPercentComplete> (elemento)

<PredecessorLink> (elemento)

<PredecessorUID> (elemento)

<Prefix> (elemento)

<PreLeveledFinished> (elemento)

<PreLeveledStart> (elemento)

<Priority> (elemento)

<Project> (elemento)

<ProjectExternallyEdited> (elemento)

Mostrar R

<Rate> (elemento)

<Rates> (elemento)

<RatesFrom> (elemento)

<RatesTo> (elemento)

<RateTable> (elemento)

<Recurring> (elemento)

<RegularWork> (elemento)

<RegularWork> (elemento)

<RemainingCost> (elemento)

<RemainingDuration> (elemento)

<RemainingOvertimeCost> (elemento)

<RemainingOvertimeWork> (elemento)

<RemainingWork>

<RemoveFileProperties> (elemento)

<Resource> (elemento)

<Resources> (elemento)

<ResourceSubstitutionEnabled> (elemento)

<ResourceUID> (elemento)

<ResponsePending> (elemento)

<RestrictValues> (elemento)

<Resume> (elemento)

<ResumeValid> (elemento)

<Revision> (elemento)

<Rollup> (elemento)

<RollupType> (elemento)

Mostrar S

<ScheduleFromStart> (elemento)

<Separator> (elemento)

<SplitsInProgressTasks> (elemento)

<SpreadActualCost> (elemento)

<SpreadPercentComplete> (elemento)

<StandardRate> (elemento)

<StandardRateFormat> (elemento)

<Start> (elemento)

<StartDate> (elemento)

<StartVariance> (elemento)

<StatusDate> (elemento)

<Stop> (elemento)

<Subject> (elemento)

<SubprojectName> (elemento)

<Summary> (elemento)

<SV> (elemento)

Mostrar T

<Task> (elemento)

<Tasks> (elemento)

<TaskUID> (elemento)

<TaskUpdatesResource> (elemento)

<TimePeriod> (elemento)

<TimephasedData> (elemento)

<TimephasedDataType> (estructura y esquema)

<Title> (elemento)

<ToDate> (elemento)

<TotalSlack> (elemento)

<ToTime> (elemento)

<Type> (elemento)

Mostrar U - V

<UID> (elemento)

<Unit> (elemento)

<Units> (elemento)

<UpdateNeeded> (elemento)

<VAC> (elemento)

<Value> (elemento)

<ValueID> (elemento)

<ValueList> (elemento)

<ValuelistSortOrder> (elemento)

<Values> (elemento)

<VerifyUniqueCodes> (elemento)

Mostrar W

<WBS> (elemento)

<WBSLevel> (elemento)

<WBSMask> (elemento)

<WBSMasks> (elemento)

<WeekDay> (elemento)

<WeekDaysgt; (elemento)

<WeekStartDay> (elemento)

<Work> (elemento)

<WorkContour> (elemento)

<WorkFormat> (elemento)

<WorkGroup> (elemento)

<WorkingTimes> (elemento)

<WorkVariance> (elemento)


Resumen del esquema XML de Microsoft Office Project 2003

Resumen del esquema XML de Microsoft Office Project 2003

Esta referencia proporciona la información necesaria para entender la estructura y los elementos individuales del esquema XML de Project. Además de las descripciones de cada elemento dentro del esquema, se detalla la estructura general de éste y se incluyen algunas macros de ejemplo que muestran cómo utilizar el Document Object Model (DOM) de XML para obtener acceso al esquema XML de Project.

Nota Para garantizar que todos los elementos necesarios y la configuración predeterminada se incluyen al crear un proyecto en XML, se recomienda comenzar guardando un proyecto vacío que pueda utilizar como una plantilla en XML.

Anexar datos XML a proyectos existentes

Cuando Project anexa datos XML a un proyecto existente, el identificador exclusivo de una tarea de resumen aumenta de 0 a 1. Entonces, Project busca identificadores exclusivos duplicados en cualquier parte de los datos XML anexados; si los encuentra, se otorgan nuevos identificadores exclusivos. Este proceso puede hacer que las asignaciones, las tareas, los recursos y los vínculos entre proyectos se disocien de los datos originales.

Nota Para garantizar que los datos no acaban en ubicaciones inesperadas, se recomienda separarlos en componentes tan pequeños como sea posible: una tarea, un recurso, una asignación, etc. antes de anexar. También puede crear una solución personalizada mediante Visual Basic para Aplicaciones (VBA) y MSXML de Project. Consulte la Ayuda sobre VBA de Project para obtener más información.

Para consultar ejemplos de cómo utilizar VBA en Project para abrir y guardar datos XML, consulte Utilizar archivos XML con Project.

Elementos y tipos de datos XML de Project

Los siguientes tipos de elementos de definición de esquema XML (XSD, XML Schema Definition) se utilizan en el esquema XML de Project:

Tipos de elementos | Descripción
schema | Contiene la definición del esquema.
annotation | Define una anotación.
complexType | Tipo de definición para elementos que contiene elementos y atributos. Estos datos pueden contener elementos y atributos.
documentation | Especifica información que los usuarios pueden leer o utilizar en el elemento de anotación.
sequence | Necesita que los elementos del grupo aparezcan en la secuencia especificada del elemento contenedor.
element | Declara un elemento.
simpleType | Definición de tipo de un valor que se puede utilizar como contenido de un elemento o atributo. Este tipo de datos no puede contener elementos ni tener atributos.
restriction | Define restricciones en una definición Type simple.
enumeration | Conjunto especificado de valores de un elemento. Los datos están restringidos a los valores específicos descritos.

Los siguientes tipos de datos se utilizan en el esquema XML de Project:

Tipos de datos | Descripción
integer | Secuencia de dígitos decimales con un signo inicial opcional (+ o -). Este tipo de datos se deriva de los decimales.
float | Número de punto flotante de 32 bits de precisión única.
string | Cadena de carácter.
datetime | Instancia específica de tiempo.
time | Instancia de tiempo que ocurre cada día.
duration | Duración de tiempo.
Boolean | Valor booleano, que es True o False.
decimal | Número de precisión arbitrario.
TimephasedDataType | Tipo de datos complejo que contiene información acerca de una tarea, un recurso o una asignación distribuida en el tiempo. El elemento <TimephasedData> es de este tipo.

El esquema XML de Project

Los temas de esta referencia del esquema de XML explican cada uno de los elementos del esquema XML de Project. El esquema se divide en secciones por conceptos de datos en relación con su existencia en Project, Microsoft Office Project Server 2003 y las bases de datos OLE, en lugar de basarse en la organización literal del propio esquema real. Por ejemplo:

<xsd:element name="Project">
   <xsd:complexType>
      <xsd:sequence>
         <xsd:element name="UID" minOccurs="0">
            <xsd:simpleType>
               <xsd:restriction base="xsd:string">
                  <xsd:maxLength value="16" />
               </xsd:restriction>
            </xsd:simpleType>
         </xsd:element>
         <xsd:element name="CreationDate">
         </xsd:element>
      </xsd:sequence>
   </xsd:complexType>
</xsd:element>

Los elementos del ejemplo mostrado arriba se incluyen en el tema Estructura XML del elemento <Project>. Los elementos <UID> y <CreationDate> disponen de sus propios temas descriptivos, a los que se puede hacer referencia desde la lista de la estructura XML o desde la Lista en orden alfabético de los elementos y tipos.

El elemento <UID> es un elemento secundario no sólo de <Project>, sino también de otros tipos complejos, como <Calendar>, <Resource>, <Assignment> y <Task>. En el tema de descripción de cada elemento se incluye una lista de los elementos principales.

A continuación, se incluye un ejemplo más complejo:

<xsd:element name="Calendars">
...
   <xsd:element name="Weekday">
      <xsd:complexType>
         <xsd:sequence>
            <xsd:element name="DayWorking" minOccurs="0">
            <xsd:element name="DayType" minOccurs="0">
            ...
            <xsd:element name="WorkingTimes" minOccurs="0">
            ...
               <xsd:complexType>
                  <xsd:sequence>
                     <xsd:choice>
                        <xsd:element name="WorkingTime" minOccurs="0" maxOccurs="5">
                        ...
                           <xsd:element name="FromTime" minOccurs="0">
                           <xsd:element name="ToTime" minOccurs="0">
            ...
         </xsd:sequence>
      </xsd:complexType>
   </xsd:element>
...
</xsd:element>

En los temas Estructura XML del elemento <Calendar> y Lista en orden alfabético de los elementos y tipos se incluyen vínculos a los temas de los elementos que figuran en el ejemplo anterior. El elemento <WorkingTimes> (obsérvese el uso del plural) es un conjunto del elemento singular <WorkingTime>, definido por <FromTime> y <ToTime>. En general, es más fácil ver las relaciones entre elementos principales y secundarios en los temas de la estructura XML, que en el propio esquema.


Utilizar archivos XML con Microsoft Office Project 2003

Utilizar archivos XML con Microsoft Office Project 2003

Los archivos de Project pueden guardarse con formato XML haciendo clic en Guardar como en el menú Archivo, o bien guardándolos en un archivo XML o en un documento DOM (Document Object Model) mediante Visual Basic para Aplicaciones (VBA). En Project, se puede abrir directamente un archivo XML que sea válido, de acuerdo con el esquema XML de Project. También se puede abrir un archivo XML, un documento DOM o una cadena SOAP válidos mediante VBA.

A continuación, se incluyen muestras de códigos para utilizar XML con VBA en Project. Para utilizar un documento XML DOM, defina una referencia en el Editor de Visual Basic de Project para Microsoft XML. Se recomienda utilizar Microsoft XML 4 (suele instalarse en C:\WINDOWS\system32\msxml4.dll) o Microsoft XML 5 (se instala con Office 2003 en C:\Archivos de programa\Archivos comunes\Microsoft Shared\OFFICE11\msxml5.dll. En cualquier caso, el espacio de nombre de la biblioteca es MSXML2.

Para conocer recomendaciones sobre cómo crear una plantilla XML válida y cómo anexar datos XML a un proyecto existente, consulte Resumen de XML de Project.

Mostrar Abrir un proyecto desde un documento XML DOM

La siguiente muestra de código indica cómo transformar un documento DOM en un documento XML DOM de Project y abrirlo en Project. Este método resulta de utilidad al transformar un documento XML que contenga datos del proyecto que no se ajusten al esquema de intercambio de datos de Project.

Public Sub fileopen_xmldom(xml As String)

    On Error GoTo err_fileopen_xmldom

    Dim app As New MSProject.Application
    Dim xmlDom, xslDom, projDom, xslFileName As String

    'Load the XML string parameter into a DOM document
    Set xmlDom = CreateObject("MSXML2.DOMDocument")
    xmlDom.async = False
    xmlDom.loadXML xml

    'Specify an XSL template file name
    xslFileName = "C:\project\xml\project.xsl"

    'Load the XSL template into a DOM document
    Set xslDom = CreateObject("MSXML2.DOMDocument")
    xslDom.async = False
    xslDom.Load xslFileName

    'Transform the XML input into a project XML document
    Set projDom = CreateObject("MSXML2.DOMDocument")
    projDom.Load xmlDom.transformNode(xslDom)

    'Open a project from the XML DOM document
    app.FileOpen FormatID:="MSProject.XMLDOM", XMLName:=projDom

exit_fileopen_xmldom:
    Exit Sub

err_fileopen_xmldom:
    MsgBox "error: " & Err.Description
    GoTo exit_fileopen_xmldom
End Sub

Public Sub Fileopen_xmldom_test()
    Dim xmlDom, XMLfileName As String
    XMLfileName = "C:\proj10\xml\xmldemo\x1.xml"
    Set xmlDom = CreateObject("MSXML2.DOMdocument")
    xmlDom.async = False
    xmlDom.Load XMLfileName
    fileopen_xmldom (xmlDom.xml)
End Sub

Mostrar Abrir un proyecto desde un archivo XML

En la siguiente muestra de código se detalla cómo utilizar un archivo de documento XML de Project creado por una aplicación de otro fabricante para crear un proyecto. Este ejemplo supone que el archivo creado por una aplicación de otro fabricante ya contiene XML válido que se ajusta al esquema XML de Project.
Public Sub fileopen_xmlfile()

    On Error GoTo err_fileopen_xmlfile

    Dim app As New MSProject.Application, xmlFile As String

    'Specify a Microsoft Project XML file name
    xmlFile = "C:\project\xml\someProject.xml"

    'Open a project from the XML file
    app.FileOpen Name:=xmlFile, FormatID:="MSProject.XML"

exit_fileopen_xmlfile:
    Exit Sub

err_fileopen_xmlfile:
    MsgBox "error: " & Err.Description
    GoTo exit_fileopen_xmlfile

End Sub

Mostrar Abrir un proyecto desde una cadena que contiene XML

La siguiente muestra de código detalla cómo utilizar Simple Object Access Protocol (SOAP) para llamar a una página Web que devuelve una cadena XML que se ajusta al esquema XML de Project.

Public Sub openxml_xmlstring(xmlRequest As String)

    On Error GoTo err_openxml_xmlstring

    Dim app As New MSProject.Application
    Dim XMLHttp As XMLHttp
    Dim xmlResponse As String, URL As String

    'Specify the web page to call
    URL = "http://myserver/getProjectXML.asp"

    'Create the SOAP client and call the page
    Set XMLHttp = New XMLHttp
    XMLHttp.Open "POST", URL, False
    XMLHttp.send xmlRequest
    xmlResponse = XMLHttp.responseXML.xml

    'Open a project from the response string
    app.OpenXML xmlResponse

exit_openxml_xmlstring:
    Exit Sub

err_openxml_xmlstring:
    MsgBox "error: " & Err.Description
    GoTo exit_openxml_xmlstring

End Sub

Mostrar Guardar un proyecto en un documento XML DOM

La siguiente muestra de código indica cómo guardar un proyecto como un documento XML DOM que se ajuste al esquema XML de Project. Esto permitirá a los desarrolladores utilizar las propiedades y los métodos del DOM para manipular y extraer datos del proyecto.
Public Sub filesaveas_xmldom()

    On Error GoTo err_filesaveas_xmldom

    Dim app As New MSProject.Application
    Dim doc

    'Create an XML DOM document
    Set doc = CreateObject("MSXML2.DOMDocument")

    'Save the project to the DOM document
    app.FileSaveAs FormatID:="MSProject.XMLDOM", XMLName:=doc

exit_filesaveas_xmldom:
    Exit Sub

err_filesaveas_xmldom:
    MsgBox "error: " & Err.Description
    GoTo exit_filesaveas_xmldom

End Sub

Mostrar Guardar un archivo de proyecto como un archivo XML

La siguiente muestra de código muestra cómo guardar datos de Project como un archivo XML que se ajuste al esquema XML de Project. Esta muestra de código se puede utilizar para dejar un documento XML de Project en un recurso compartido de archivo para que un proceso asíncrono pueda tomarlo y utilizarlo posteriormente.
Public Sub filesaveas_xmlfile()

    On Error GoTo err_filesaveas_xmlfile

    Dim app As New MSProject.Application, xmlFile As String

    'Specify a Microsoft Project XML file name
    xmlFile = "C:\path to location\fileName.xml"

    'Open a project from the XML file
    app.FileSaveAs Name:=xmlFile, FormatID:="MSProject.XML"

exit_filesaveas_xmlfile:
    Exit Sub

err_filesaveas_xmlfile:
    MsgBox "error: " & Err.Description
    GoTo exit_filesaveas_xmlfile

End Sub


Imprimir

Imprimir

Es posible que le resulte útil imprimir una serie de temas del archivo de Ayuda HTML (.chm) compilado. Además de imprimir temas individuales, se pueden imprimir también una serie de subtemas recogidos bajo un encabezado del archivo .chm.

  1. Haga clic con el botón secundario en el título o tema que represente el libro de nivel máximo y, a continuación, haga clic en Imprimir.
  2. En el cuadro de diálogo Imprimir tema, seleccione Imprimir el tema seleccionado y sus subtemas.

Nota En el caso de que los subtemas incluyan contenido oculto de forma predeterminada, el contenido oculto no se imprimirá. Puede imprimir el contenido oculto del tema de nivel máximo haciendo clic en Mostrar todo antes de imprimir.


Esquema XML del elemento <Project>

Esquema XML del elemento <Project>

A continuación se muestra el esquema del elemento <Project> para Microsoft Office Project 2003. Los detalles del esquema de <TimephasedDataType>, <Calendar>, etc., se mostrarán en temas separados.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <Project>
<Project> (elemento)
<?xml version="1.0" encoding="UTF-8" ?>
<!--
    The Microsoft Project 2003 XML Data Interchange Schema

    Revision date:	2003-03-04

    This schema defines the XML import/export format for project data in
    Microsoft Project 2003.  Localized documentation can be found in either the
    language-specific subfolder in either"\Program Files\Microsoft Office\Office"
    or "\Program Files\Microsoft Office\Office11" folder or the appropriate
    Updates to this document, if any, can be found at http://www.microsoft.com/spanish/project.

    Microsoft may have patents, patent applications, trademarks, copyrights,
    or other intellectual property rights covering subject	matter in this
    document. Except as expressly provided in any written	license agreement
    from Microsoft, the furnishing of this document does not give you any
    license to these patents, trademarks, copyrights, or other intellectual
    property.

    (c) 2003 Microsoft Corporation. All rights reserved.
-->
<xsd:schema xmlns="http://schemas.microsoft.com/project"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://schemas.microsoft.com/project"
elementFormDefault="qualified">
    <xsd:annotation>
        <xsd:documentation>The full project schema definition from the project level down,
        starting with data type definitions.</xsd:documentation>
        <xsd:appinfo>The Microsoft Project Data Interchange Schema for Microsoft Project 10.
        </xsd:appinfo>
    </xsd:annotation>
    <!-- data type definitions - @TimephasedData schema -->
    <xsd:complexType name="TimephasedDataType">
        ...
    </xsd:complexType>
    <!-- @Project schema -->
    <xsd:element name="Project">
        <xsd:annotation>
            <xsd:documentation>The project is the top level element of the document.
            </xsd:documentation>
        </xsd:annotation>
        <xsd:complexType>
            <xsd:sequence>
                <xsd:element name="UID" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The unique ID of the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="16" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="Name" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The name of the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="255" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="Title" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The title of the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="512" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="Subject" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The subject of the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="512" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="Category" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The category of the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="512" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="Company" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The company that owns the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="512" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="Manager" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The manager of the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="512" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="Author" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The author of the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="512" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="CreationDate" type="xsd:dateTime" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The date that the project was created.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="Revision" type="xsd:integer" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The number of times a project has been saved.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="LastSaved" type="xsd:dateTime" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The date that the project was last saved.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="ScheduleFromStart" type="xsd:boolean" default="true" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether the project is schduled from the start date or finish date.
                        </xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="StartDate" type="xsd:dateTime" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The start date of the project. Required if ScheduleFromStart is true.
                        </xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="FinishDate" type="xsd:dateTime" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The finish date of the project. Required if ScheduleFromStart is false.
                        </xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="FYStartDate" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Fiscal Year starting month. Values are:
                        1=January, 2=February, 3=March, 4=April, 5=May, 6=June, 7=July,
                        8=August, 9=September, 10=October, 11=November, 12=December </xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="1" />
                            <xsd:enumeration value="2" />
                            <xsd:enumeration value="3" />
                            <xsd:enumeration value="4" />
                            <xsd:enumeration value="5" />
                            <xsd:enumeration value="6" />
                            <xsd:enumeration value="7" />
                            <xsd:enumeration value="8" />
                            <xsd:enumeration value="9" />
                            <xsd:enumeration value="10" />
                            <xsd:enumeration value="11" />
                            <xsd:enumeration value="12" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="CriticalSlackLimit" type="xsd:integer" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The number of days past its end date that a task can go
                        before Microsoft Project marks that task as a critical task.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="CurrencyDigits" type="xsd:integer" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The number of digits after the decimal symbol.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="CurrencySymbol" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The currency symbol used in the project.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:string">
                            <xsd:maxLength value="20" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="CurrencySymbolPosition" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The position of the currency symbol.  Values are:
                        0=Before, 1=After, 2=Before With Space, 3=After with space.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="0" />
                            <xsd:enumeration value="1" />
                            <xsd:enumeration value="2" />
                            <xsd:enumeration value="3" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="CalendarUID" type="xsd:integer" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The project calendar.  Refers to a valid UID in the
                        Calendars element of the Microsoft Project XML Schema.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="DefaultStartTime" type="xsd:time" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default start time of new tasks.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="DefaultFinishTime" type="xsd:time" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default finish time of new tasks.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="MinutesPerDay" type="xsd:integer" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The number of minutes per day.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="MinutesPerWeek" type="xsd:integer" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The number of minutes per week.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="DaysPerMonth" type="xsd:integer" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The number of days per month.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="DefaultTaskType" default="1" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default type of new tasks. Values are:
                        0=Fixed Units, 1=Fixed Duration, 2=Fixed Work.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="0" />
                            <xsd:enumeration value="1" />
                            <xsd:enumeration value="2" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="DefaultFixedCostAccrual" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default from where fixed costs are accrued.  Values are:
                        1=Start, 2=Prorated, 3=End</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="1" />
                            <xsd:enumeration value="2" />
                            <xsd:enumeration value="3" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="DefaultStandardRate" type="xsd:float" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default standard rate for new resources.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="DefaultOvertimeRate" type="xsd:float" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default overtime rate for new resources.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="DurationFormat" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The format for expressing the bulk duration.  Values are:
                        3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo, 19=%, 20=e%, 21=null,
                        35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?, 42=ew?, 43=mo?, 44=emo?, 51=%?, 52=e%? and
                        53=null.</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="3" />
                            <xsd:enumeration value="4" />
                            <xsd:enumeration value="5" />
                            <xsd:enumeration value="6" />
                            <xsd:enumeration value="7" />
                            <xsd:enumeration value="8" />
                            <xsd:enumeration value="9" />
                            <xsd:enumeration value="10" />
                            <xsd:enumeration value="11" />
                            <xsd:enumeration value="12" />
                            <xsd:enumeration value="19" />
                            <xsd:enumeration value="20" />
                            <xsd:enumeration value="21" />
                            <xsd:enumeration value="35" />
                            <xsd:enumeration value="36" />
                            <xsd:enumeration value="37" />
                            <xsd:enumeration value="38" />
                            <xsd:enumeration value="39" />
                            <xsd:enumeration value="40" />
                            <xsd:enumeration value="41" />
                            <xsd:enumeration value="42" />
                            <xsd:enumeration value="43" />
                            <xsd:enumeration value="44" />
                            <xsd:enumeration value="51" />
                            <xsd:enumeration value="52" />
                            <xsd:enumeration value="53" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="WorkFormat" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default work unit format. Values are:
                        1=m, 2=h, 3=d, 4=w, 5=mo</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="1" />
                            <xsd:enumeration value="2" />
                            <xsd:enumeration value="3" />
                            <xsd:enumeration value="4" />
                            <xsd:enumeration value="5" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="EditableActualCosts" type="xsd:boolean" default="false" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether or not actual costs are editable.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="HonorConstraints" type="xsd:boolean" default="true" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether tasks honour their constraint dates.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="EarnedValueMethod" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default method for calculating earned value. Values are:
                        0=Percent Complete, 1=Physical Percent Complete</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="0" />
                            <xsd:enumeration value="1" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="InsertedProjectsLikeSummary" type="xsd:boolean" default="true" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether to calculate subtasks as summary tasks.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="MultipleCriticalPaths" type="xsd:boolean" default="false" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether multiple critical paths are calculated.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="NewTasksEffortDriven" type="xsd:boolean" default="true" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether new tasks are effort driven.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="NewTasksEstimated" type="xsd:boolean" default="true" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether to show the estimated duration by default.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="SplitsInProgressTasks" type="xsd:boolean" default="true" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether in-progress tasks can be split.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="SpreadActualCost" type="xsd:boolean" default="true" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether actual costs are spread to the status date.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="SpreadPercentComplete" type="xsd:boolean" default="false" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether percent complete is spread to the status date.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="TaskUpdatesResource" type="xsd:boolean" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether updates to tasks update resources.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="FiscalYearStart" type="xsd:boolean" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Specifies whether to use fiscal year numbering</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="WeekStartDay" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Start day of the week. Values are:
                        0=Sunday, 1=Monday, 2=Tuesday, 3=Wednesday, 4=Thursday, 5=Friday, 6=Saturday</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="0" />
                            <xsd:enumeration value="1" />
                            <xsd:enumeration value="2" />
                            <xsd:enumeration value="3" />
                            <xsd:enumeration value="4" />
                            <xsd:enumeration value="5" />
                            <xsd:enumeration value="6" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="MoveCompletedEndsBack" type="xsd:boolean" default="false" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>
                            Specifies whether the end of completed portions of tasks scheduled to begin after the
                            status date but begun early should be moved back to the status date.
                        </xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="MoveRemainingStartsBack" type="xsd:boolean" default="false" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>
                            Specifies whether the beginning of remaining portions of tasks scheduled to begin after the
                            status date but begun early should be moved back to the status date.
                        </xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="MoveRemainingStartsForward" type="xsd:boolean" default="false" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>
                            Specifies whether the beginning of remaining portions of tasks scheduled to have begun late
                            should be moved up to the status date.
                        </xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="MoveCompletedEndsForward" type="xsd:boolean" default="false" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>
                            Specifies whether the end of completed portions of tasks scheduled to have been completed
                            before the status date but begun late should be moved up to the status date.
                        </xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="BaselineForEarnedValue" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The specific baseline used to calculate Variance values.  Values are:
                        0=Baseline, 1=Baseline 1, 2=Baseline 2, 3=Baseline 3, 4=Baseline 4, 5=Baseline 5, 6=Baseline 6,
                        7=Baseline 7, 8=Baseline 8, 9=Baseline 9, 10=Baseline 10</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="0" />
                            <xsd:enumeration value="1" />
                            <xsd:enumeration value="2" />
                            <xsd:enumeration value="3" />
                            <xsd:enumeration value="4" />
                            <xsd:enumeration value="5" />
                            <xsd:enumeration value="6" />
                            <xsd:enumeration value="7" />
                            <xsd:enumeration value="8" />
                            <xsd:enumeration value="9" />
                            <xsd:enumeration value="10" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="AutoAddNewResourcesAndTasks" type="xsd:boolean" default="true" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether to automatically add new resources to the resource pool.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="StatusDate" type="xsd:dateTime" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Date used for calculation and reporting.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="CurrentDate" type="xsd:dateTime" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The system date that the XML was generated.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="MicrosoftProjectServerURL" type="xsd:boolean" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether the project was created by a Project Server user as opposed to an NT user.
                        </xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="Autolink" type="xsd:boolean" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether to autolink inserted or moved tasks.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="NewTaskStartDate" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default date for new tasks start.  Values are:
                        0=Project Start Date, 1=Current Date</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="0" />
                            <xsd:enumeration value="1" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="DefaultTaskEVMethod" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>The default earned value method for tasks.  Values are:
                        0=Percent Complete, 1=Physical Percent Complete</xsd:documentation>
                    </xsd:annotation>
                    <xsd:simpleType>
                        <xsd:restriction base="xsd:integer">
                            <xsd:enumeration value="0" />
                            <xsd:enumeration value="1" />
                        </xsd:restriction>
                    </xsd:simpleType>
                </xsd:element>
                <xsd:element name="ProjectExternallyEdited" type="xsd:boolean" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether the project XML was edited.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="ExtendedCreationDate" type="xsd:dateTime" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Date used for calculation and reporting.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="ActualsInSync" type="xsd:boolean" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether all actual work has been synchronized with the project.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="RemoveFileProperties" type="xsd:boolean" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether to remove all file properties on save.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <xsd:element name="AdminProject" type="xsd:boolean" minOccurs="0">
                    <xsd:annotation>
                        <xsd:documentation>Whether the project is an administrative project.</xsd:documentation>
                    </xsd:annotation>
                </xsd:element>
                <!-- @OutlineCode schema -->
                <xsd:element name="OutlineCodes" minOccurs="0">
                    ...
                </xsd:element>
                <!-- @WBSMask schema -->
                <xsd:element name="WBSMasks" minOccurs="0">
                    ...
                </xsd:element>
                <!-- @ExtendedAttribute schema -->
                <xsd:element name="ExtendedAttributes" minOccurs="0">
                    ...
                </xsd:element>
                <!-- @Calendar schema -->
                <xsd:element name="Calendars" minOccurs="0">
                    ...
                </xsd:element>
                <!-- @Task schema -->
                <xsd:element name="Tasks" minOccurs="0">
                    ...
                </xsd:element>
                <!-- @Resource schema -->
                <xsd:element name="Resources" minOccurs="0">
                    ...
                </xsd:element>
                <!-- @Assignment schema -->
                <xsd:element name="Assignments" minOccurs="0">
                    ...
                </xsd:element>
            </xsd:sequence>
        </xsd:complexType>
    </xsd:element>
</xsd:schema>


Estructura XML del elemento <Project>

Estructura XML del elemento <Project>

A continuación se detalla la estructura del elemento <Project> para Microsoft Office Project 2003. Los detalles de la estructura de los elementos secundarios de tipo complejo (calendarios, tareas, etc.) se indicarán en temas separados.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Esquema XML del elemento <Project>

Estructura

<Project>
      <UID/>
      <Name/>
      <Title/>
      <Subject/>
      <Category/>
      <Company/>
      <Manager/>
      <Author/>
      <CreationDate/>
      <Revision/>
      <LastSaved/>
      <ScheduleFromStart/>
      <StartDate/>
      <FinishDate/>
      <FYStartDate/>
      <CriticalSlackLimit/>
      <CurrencyDigits/>
      <CurrencySymbol/>
      <CurrencySymbolPosition/>
      <CalendarUID/>
      <DefaultStartTime/>
      <DefaultFinishTime/>
      <MinutesPerDay/>
      <MinutesPerWeek/>
      <DaysPerMonth/>
      <DefaultTaskType/>
      <DefaultFixedCostAccrual/>
      <DefaultStandardRate/>
      <DefaultOvertimeRate/>
      <DurationFormat/>
      <WorkFormat/>
      <EditableActualCosts/>
      <HonorConstraints/>
      <EarnedValueMethod/>
      <InsertedProjectsLikeSummary/>
      <MultipleCriticalPaths/>
      <NewTasksEffortDriven/>
      <NewTasksEstimated/>
      <SplitsInProgressTasks/>
      <SpreadActualCost/>
      <SpreadPercentComplete/>
      <TaskUpdatesResource/>
      <FiscalYearStart/>
      <WeekStartDay/>
      <MoveCompletedEndsBack/>
      <MoveRemainingStartsBack/>
      <MoveRemainingStartsForward/>
      <MoveCompletedEndsForward/>
      <BaselineForEarnedValue/>
      <AutoAddNewResourcesAndTasks/>
      <StatusDate/>
      <CurrentDate/>
      <MicrosoftProjectServerURL/>
      <Autolink/>
      <NewTaskStartDate/>
      <DefaultTaskEVMethod/>
      <ProjectExternallyEdited/>
      <ExtendedCreationDate/>
      <ActualsInSync/>
      <RemoveFileProperties/>
      <AdminProject/>
      <OutlineCodes>
            . . .
      </OutlineCodes>
      <WBSMasks>
            . . .
      </WBSMasks>
      <ExtendedAttributes>
            . . .
      </ExtendedAttributes>
      <Calendars>
            . . .
      </Calendars>
      <Tasks>
            . . .
      </Tasks>
      <Resources>
            . . .
      </Resources>
      <Assignments>
            . . .
      </Assignments>
</Project>


<Assignments> (elemento)

<Assignments> (elemento)

Conjunto de asignaciones que conforman el proyecto. Debe existir una asignación como mínimo en cada conjunto <Assignments>.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Project>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Assignment> | Opcional | Define una asignación del proyecto.


<Author> (elemento)

<Author> (elemento)

Autor del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<AutoAddNewResourcesAndTasks> (elemento)

<AutoAddNewResourcesAndTasks> (elemento)

Indica si hay que agregar nuevos recursos al fondo de recursos de forma automática.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | True
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Autolink> (elemento)

<Autolink> (elemento)

Indica si hay que vincular automáticamente las tareas insertadas o movidas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<BaselineForEarnedValue> (elemento)

<BaselineForEarnedValue> (elemento)

Línea de base específica que se utiliza para calcular los valores de variación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Línea de base
1 | Línea de base 1
2 | Línea de base 2
3 | Línea de base 3
4 | Línea de base 4
5 | Línea de base 5
6 | Línea de base 6
7 | Línea de base 7
8 | Línea de base 8
9 | Línea de base 9
10 | Línea de base 10
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Calendars> (elemento)

<Calendars> (elemento)

Conjunto de calendarios asociados al proyecto.

Los calendarios se utilizan para definir períodos laborables y no laborables estándar. Un proyecto debe tener un calendario base. Las tareas y los recursos pueden disponer de sus propios calendarios basados en un calendario base.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Project>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Calendar> | Requerido | El calendario de un proyecto.


<CalendarUID> (elemento)

<CalendarUID> (elemento)

Consulte un identificador exclusivo (UID) válido para el calendario utilizado en el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>
<Task>
<Resource>


<Category> (elemento)

<Category> (elemento)

Categoría a la que pertenece el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Company> (elemento)

<Company> (elemento)

Nombre de la organización que creó el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<CreationDate> (element)

<CreationDate> (element)

Fecha de creación del proyecto, el recurso o la asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>
<Resource>
<Assignment>


<CriticalSlackLimit> (elemento)

<CriticalSlackLimit> (elemento)

Número de días después de la fecha de fin que pueden transcurrir antes de que Microsoft Office Project 2003 marque la tarea como crítica.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<CurrencyDigits> (elemento)

<CurrencyDigits> (elemento)

Número de dígitos que aparecen después del decimal cuando se muestran valores de moneda en Microsoft Office Project 2003.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Sin dígitos después del decimal: 0 €
1 | Un dígito después del decimal: 0,0 €
2 | Dos dígitos después del decimal; 0,00 €
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<CurrencySymbol> (elemento)

<CurrencySymbol> (elemento)

Símbolo de moneda utilizado para representar el tipo de moneda utilizado en el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(20)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<CurrencySymbolPosition> (elemento)

<CurrencySymbolPosition> (elemento)

Posición en la que se sitúa el símbolo de la moneda.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Delante, sin espacio (predeterminado): €0
1 | Detrás, sin espacio: 0€
2 | Delante, con espacio: € 0
3 | Detrás, con espacio: 0 €
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<CurrentDate> (elemento)

<CurrentDate> (elemento)

Fecha del sistema en la que se creó el XML.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DaysPerMonth> (elemento)

<DaysPerMonth> (elemento)

Número predeterminado de días laborables por mes.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DefaultFinishTime> (elemento)

<DefaultFinishTime> (elemento)

Hora de fin predeterminada de todas las tareas nuevas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Time
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DefaultFixedCostAccrual> (elemento)

<DefaultFixedCostAccrual> (elemento)

Valor predeterminado desde el que se acumulan los costos fijos. Los valores son: 1=Comienzo, 2=Prorrateo, 3=Fin.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
1 | Comienzo
2 | Prorrateo
3 | Fin
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DefaultOvertimeRate> (elemento)

<DefaultOvertimeRate> (elemento)

Tasa predeterminada de horas extra para recursos nuevos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DefaultStandardRate> (elemento)

<DefaultStandardRate> (elemento)

Tasa predeterminada estándar para recursos nuevos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DefaultStartTime> (elemento)

<DefaultStartTime> (elemento)

Hora predeterminada de comienzo de todas las tareas nuevas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Time
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DefaultTaskEVMethod> (elemento)

<DefaultTaskEVMethod> (elemento)

Método de valor acumulado predeterminado de las tareas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Porcentaje completado
1 | Porcentaje físico completado
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DefaultTaskType> (elemento)

<DefaultTaskType> (elemento)

Tipo predeterminado de tareas nuevas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Unidades fijas (predeterminado); el número de recursos (Unidades de asignación) permanece constante, independientemente de la cantidad de trabajo o de la duración de la tarea
1 | Duración fija; la duración de la tarea permanece constante, independientemente del número de recursos (Unidades de asignación) asignados o de la cantidad de trabajo
2 | Trabajo fijo; la cantidad de trabajo permanece constante, independientemente de cualquier cambio en la duración o en el número de recursos (Unidades de asignación) asignados a la tarea
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | 1
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<DurationFormat> (element)

<DurationFormat> (element)

En el caso de un elemento <Project>, <DurationFormat> indica el formato predeterminado de todas las duraciones del proyecto.

En el caso de un elemento <Task>, se trata del formato utilizado para mostrar la duración de la tarea.

En el caso de un elemento <Baseline>, es el formato para expresar la duración de la línea de base de tarea.

En el caso de un elemento <ExtendedAttribute>, es el formato para expresar la duración del atributo extendido.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
3 | m
4 | mt
5 | h
6 | ht
7 | d
8 | dt
9 | s
10 | st
11 | me
12 | met
19 | %
20 | e%
21 | nulo
35 | m?
36 | mt?
37 | h?
38 | ht?
39 | d?
40 | dt?
41 | s?
42 | st?
43 | me?
44 | met?
51 | %?
52 | e%?
53 | nulo
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>
<Task>
<Baseline>
<ExtendedAttribute>

Mostrar Vea también

Esquema XML del elemento <Project>
Estructura XML del elemento <Project>

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Esquema XML del elemento <Resource>
Estructura XML del elemento <Resource>

Esquema XML del elemento <Assignment>
Estructura XML del elemento <Assignment>

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

Notas

Se puede incluir un elemento <DurationFormat> dentro de <Baseline> o <ExtendedAttribute> de un elemento <Resource> o <Assignment>, así como de un elemento <Task>. Se utilizaría para anular el formato de duración predeterminado del elemento <Project>.


<EarnedValueMethod> (elemento)

<EarnedValueMethod> (elemento)

En el caso de un elemento <Project>, <EarnedValueMethod> es el método predeterminado para calcular el valor acumulado.

En el caso de un elemento <Task>, indica el tipo de método de valor acumulado que se utilizará en una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Método de valor acumulado:
0 | Utilizar % completado
1 | Utilizar % físico completado
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>
<Task>


<EditableActualCosts> (elemento)

<EditableActualCosts> (elemento)

Indica si Microsoft Office Project 2003 calcula automáticamente los costos reales.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<ExtendedAttributes> (elemento)

<ExtendedAttributes> (elemento)

Conjunto de definiciones de atributos extendidos (campo personalizado) asociado al proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Project>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<ExtendedAttribute> | Opcional | Valor de un atributo extendido.


<FinishDate> (elemento)

<FinishDate> (elemento)

La fecha de fin del proyecto. Necesario si ScheduleFromStart es False.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<FiscalYearStart> (elemento)

<FiscalYearStart> (elemento)

Especifica si se utilizará la numeración del año fiscal

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<FYStartDate> (elemento)

<FYStartDate> (elemento)

Mes en el que comienza el año fiscal.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
1 | Enero (predeterminado)
2 | Febrero
3 | Marzo
4 | Abril
5 | Mayo
6 | Junio
7 | Julio
8 | Agosto
9 | Septiembre
10 | Octubre
11 | Noviembre
12 | Diciembre
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<HonorConstraints> (elemento)

<HonorConstraints> (elemento)

Indica si Microsoft Office Project 2003 programa las tareas según las fechas de delimitación en lugar de las dependencias entre tareas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | True
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<InsertedProjectsLikeSummary> (elemento)

<InsertedProjectsLikeSummary> (elemento)

Indica si los proyectos insertados se tratan como tareas de resumen en lugar de como proyectos independientes para el cálculo de la programación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | True
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<LastSaved> (elemento)

<LastSaved> (elemento)

Fecha en la que se guardó el proyecto por última vez.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Manager> (elemento)

<Manager> (elemento)

Jefe del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<MicrosoftProjectServerURL> (elemento)

<MicrosoftProjectServerURL> (elemento)

Indica si el proyecto fue creado por un usuario de Microsoft Office Project Server 2003 o de Microsoft Windows NT.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<MinutesPerDay> (elemento)

<MinutesPerDay> (elemento)

Número predeterminado de minutos por día.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<MinutesPerWeek> (elemento)

<MinutesPerWeek> (elemento)

Número predeterminado de minutos por semana.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<MoveCompletedEndsBack> (elemento)

<MoveCompletedEndsBack> (elemento)

Indica si el final de las partes completadas de las tareas cuyo comienzo está programado para después de la fecha de estado debería moverse a la fecha de estado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>

Mostrar Vea también

Esquema XML del elemento <Project>
Estructura XML del elemento <Project>

Notas

Experimentará un error de redondeo con este elemento. El valor de trabajo interno tiene ocho dígitos, que perderá 0,001 segundos por cada minuto, lo que provocará un error de redondeo.


<MoveCompletedEndsForward> (elemento)

<MoveCompletedEndsForward> (elemento)

Indica si el final de las partes completadas de las tareas programadas para finalizar antes de la fecha de estado pero que comienzan tarde debería moverse a la fecha de estado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>

Mostrar Vea también

Esquema XML del elemento <Project>
Estructura XML del elemento <Project>

Notas

Experimentará un error de redondeo con este elemento. El valor de trabajo interno tiene ocho dígitos, que perderá 0,001 segundos por cada minuto, lo que provocará un error de redondeo.


<MoveRemainingStartsBack> (elemento)

<MoveRemainingStartsBack> (elemento)

Indica si el comienzo de las partes restantes de las tareas cuyo comienzo está programado para después de la fecha de estado debería moverse a la fecha de estado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>

Mostrar Vea también

Esquema XML del elemento <Project>
Estructura XML del elemento <Project>

Notas

Experimentará un error de redondeo con este elemento. El valor de trabajo interno tiene ocho dígitos, que perderá 0,001 segundos por cada minuto, lo que provocará un error de redondeo.


<MoveRemainingStartsForward> (elemento)

<MoveRemainingStartsForward> (elemento)

Indica si el comienzo de las partes restantes de las tareas programadas para comenzar tarde debería moverse a la fecha de estado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>

Mostrar Vea también

Esquema XML del elemento <Project>
Estructura XML del elemento <Project>

Notas

Experimentará un error de redondeo con este elemento. El valor de trabajo interno tiene ocho dígitos, que perderá 0,001 segundos por cada minuto, lo que provocará un error de redondeo.


<MultipleCriticalPaths> (elemento)

<MultipleCriticalPaths> (elemento)

Indica si Microsoft Office Project 2003 calcula y muestra una ruta crítica para cada red independiente de tareas dentro de un proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Name> (elemento)

<Name> (elemento)

Nombre del proyecto, el calendario, el recurso o la tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(255): para <Project>
 | String(512): para el resto de elementos principales
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>
<Calendar>
<Resource>
<Task>

Mostrar Vea también

Esquema XML del elemento <Project>
Estructura XML del elemento <Project>

Esquema XML del elemento <Calendar>
Estructura XML del elemento <Calendar>

Esquema XML del elemento <Resource>
Estructura XML del elemento <Resource>

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>


<NewTasksEffortDriven> (elemento)

<NewTasksEffortDriven> (elemento)

Indica si las tareas nuevas están condicionadas por el esfuerzo.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | True
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<NewTasksEstimated> (elemento)

<NewTasksEstimated> (elemento)

Indica si las tareas nuevas tienen duraciones estimadas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | True
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<NewTaskStartDate> (elemento)

<NewTaskStartDate> (elemento)

Fecha de comienzo predeterminada de una tarea nueva.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Fecha de comienzo del proyecto
1 | Fecha actual
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<OutlineCodes> (elemento)

<OutlineCodes> (elemento)

Esta sección almacena información relacionada con el conjunto de códigos de esquema personalizados asociados al proyecto. Estos códigos pueden asociarse a más de un proyecto (códigos de empresa).

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Project>

Mostrar Elementos secundarios

Lista de elementos secundarios

Elemento | Requerido/Opcional | Descripción
<OutlineCode> | Opcional | Uno de los conjuntos de códigos de esquema personalizados.


<Project> (elemento)

<Project> (elemento)

<Project> es el elemento de nivel máximo del documento. Almacena todos los datos de cada proyecto, incluidos los calendarios, las asignaciones, las tareas, los recursos, los atributos extendidos, la estructura de descomposición del trabajo (códigos EDT) y los códigos de esquema personalizados.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Complex Type
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos secundarios

Lista de elementos secundarios

Elemento | Requerido/Opcional | Descripción
<UID> | Opcional | Identificador exclusivo del proyecto.
<Name> | Opcional | Nombre del proyecto.
<Title> | Opcional | Título del proyecto.
<Subject> | Opcional | Asunto del proyecto.
<Category> | Opcional | Categoría a la que pertenece el proyecto.
<Company> | Opcional | Nombre de la organización que creó el proyecto.
<Manager> | Opcional | Jefe del proyecto.
<Author> | Opcional | Autor del proyecto.
<CreationDate> | Opcional | Fecha de creación del proyecto.
<Revision> | Opcional | Número de veces que se ha guardado el proyecto.
<LastSaved> | Opcional | Fecha en la que se guardó el proyecto por última vez.
<ScheduleFromStart> | Opcional | Indica si el proyecto está programado a partir de la fecha de comienzo o de la de fin.
<StartDate> | Opcional | Fecha y hora de comienzo programadas para un proyecto; necesario si ScheduleFromStart tiene el valor True.
<FinishDate> | Opcional | Fecha y hora de fin programadas para un proyecto; necesario si ScheduleFromStart está definido en False.
<FYStartDate> | Opcional | Mes en el que comienza el año fiscal.
<CriticalSlackLimit> | Opcional | Número de días después de la fecha de fin que pueden transcurrir antes de que Microsoft Office Project 2003 marque la tarea como crítica.
<CurrencyDigits> | Opcional | Número de dígitos que aparecen después del decimal cuando se muestran valores de moneda en Project.
<CurrencySymbol> | Opcional | Símbolo de moneda utilizado para representar el tipo de moneda utilizado en el proyecto.
<CurrencySymbolPosition> | Opcional | Indica la posición del símbolo de moneda respecto al valor de moneda.
<CalendarUID> | Opcional | Identificador exclusivo del calendario utilizado en el proyecto.
<DefaultStartTime> | Opcional | Hora predeterminada de comienzo de todas las tareas nuevas.
<DefaultFinishTime> | Opcional | Hora predeterminada de fin de todas las tareas nuevas.
<MinutesPerDay> | Opcional | Número predeterminado de minutos por día.
<MinutesPerWeek> | Opcional | Número predeterminado de minutos por semana.
<DaysPerMonth> | Opcional | Número predeterminado de días laborables por mes.
<DefaultTaskType> | Opcional | Tipo predeterminado de todas las tareas nuevas del proyecto.
<DefaultFixedCostAccrual> | Opcional | Punto de medición predeterminado cuando se acumulan los costos fijos.
<DefaultStandardRate> | Opcional | Tasa predeterminada estándar para recursos nuevos.
<DefaultOvertimeRate> | Opcional | Tasa predeterminada de horas extra para recursos nuevos.
<DurationFormat> | Opcional | Formato predeterminado de todas las duraciones del proyecto.
<WorkFormat> | Opcional | Formato predeterminado de todas las duraciones de trabajo del proyecto.
<EditableActualCosts> | Opcional | Indica si Project calcula automáticamente los costos reales.
<HonorConstraints> | Opcional | Indica si Project programa las tareas según las fechas de delimitación en lugar de las dependencias entre tareas.
<EarnedValueMethod> | Opcional | Método predeterminado para calcular el valor acumulado.
<InsertedProjectsLikeSummary> | Opcional | Indica si los proyectos insertados se tratan como tareas de resumen en lugar de como proyectos independientes para el cálculo de la programación.
<MultipleCriticalPaths> | Opcional | Indica si Project calcula y muestra una ruta crítica para cada red independiente de tareas dentro de un proyecto.
<NewTasksEffortDriven> | Opcional | Indica si las tareas nuevas están condicionadas por el esfuerzo.
<NewTasksEstimated> | Opcional | Indica si las tareas nuevas tienen duraciones estimadas.
<SplitsInProgressTasks> | Opcional | Indica si las tareas en curso se pueden dividir.
<SpreadActualCost> | Opcional | Indica si los costos reales se extienden a la fecha de estado.
<SpreadPercentComplete> | Opcional | Indica si el porcentaje completado se extiende a la fecha de estado.
<TaskUpdatesResource> | Opcional | Indica si las actualizaciones de las tareas actualizan los recursos.
<FiscalYearStart> | Opcional | Indica si se utiliza la numeración del año fiscal.
<WeekStartDay> | Opcional | Día de comienzo de la semana.
<MoveCompletedEndsBack> | Opcional | Indica si el final de las partes completadas de las tareas cuyo comienzo está programado para después de la fecha de estado debería moverse a la fecha de estado.
<MoveRemainingStartsBack> | Opcional | Indica si el comienzo de las partes restantes de las tareas cuyo comienzo está programado para después de la fecha de estado debería moverse a la fecha de estado.
<MoveRemainingStartsForward> | Opcional | Indica si el comienzo de las partes restantes de las tareas programadas para comenzar tarde debería moverse a la fecha de estado.
<MoveCompletedEndsForward> | Opcional | Indica si el final de las partes completadas de las tareas programadas para finalizar antes de la fecha de estado pero que comienzan tarde debería moverse a la fecha de estado.
<BaselineForEarnedValue> | Opcional | Línea de base específica que se utiliza para calcular los valores de variación.
<AutoAddNewResourcesAndTasks> | Opcional | Indica si hay que agregar nuevos recursos al fondo de recursos de forma automática.
<StatusDate> | Opcional | Fecha utilizada para los cálculos y la creación de informes.
<CurrentDate> | Opcional | Fecha del sistema en la que se creó el XML.
<MicrosoftProjectServerURL> | Opcional | Indica si el proyecto fue creado por un usuario de Microsoft Office Project Server 2003 o de Microsoft Windows NT.
<Autolink> | Opcional | Indica si hay que vincular automáticamente las tareas insertadas o movidas.
<NewTaskStartDate> | Opcional | Fecha de comienzo predeterminada de una tarea nueva.
<DefaultTaskEVMethod> | Opcional | Método de valor acumulado predeterminado de las tareas.
<ProjectExternallyEdited> | Opcional | Indica si el proyecto se ha modificado externamente.
<ExtendedCreationDate> | Opcional | Fecha utilizada para los cálculos y la creación de informes.
<ActualsInSync> | Opcional | Indica si el trabajo actual se ha sincronizado con el proyecto.
<RemoveFileProperties> | Opcional | Indica si se eliminarán todas las propiedades de los archivos al guardar.
<AdminProject> | Opcional | Indica si el proyecto es un proyecto administrativo.
<OutlineCodes> | Opcional | Conjunto de definiciones de códigos de esquema asociados al proyecto. Estos códigos pueden asociarse a cualquier número de proyectos.
<WBSMasks> | Opcional | Tabla de entradas que definen una máscara de código de esquema.
<ExtendedAttributes> | Opcional | Conjunto de definiciones de atributo extendido (campo personalizado) asociadas a un proyecto.
<Calendars> | Opcional | Conjunto de calendarios asociados al proyecto.
<Tasks> | Opcional | Conjunto de tareas que componen el proyecto.
<Resources> | Opcional | Conjunto de recursos que componen el proyecto.
<Assignments> | Opcional | Conjunto de asignaciones que componen el proyecto.

Mostrar Vea también

Esquema XML del elemento <Project>
Estructura XML del elemento <Project>

Notas

Nota Experimentará un error de redondeo con los elementos <MoveCompletedEndsBack>, <MoveRemainingStartsBack>, <MoveRemainingStartsForward> y <MoveCompletedEndsForward>. Los valores de trabajo interno de estos elementos cuentan con ocho dígitos; que perderán 0,001 segundos por cada minuto, lo que provocará un error de redondeo.


<ProjectExternallyEdited> (elemento)

<ProjectExternallyEdited> (elemento)

Indica si se el proyecto XML se ha modificado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Resources> (elemento)

<Resources> (elemento)

Conjunto de recursos que conforman el proyecto. Debe haber un recurso como mínimo en cada conjunto de recursos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Project>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Resource> | Opcional | Definición de un recurso.


<Revision> (elemento)

<Revision> (elemento)

Número de veces que se ha guardado el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<ScheduleFromStart> (elemento)

<ScheduleFromStart> (elemento)

Indica si el proyecto está programado a partir de la fecha de comienzo o de la de fin.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | True
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<SplitsInProgressTasks> (elemento)

<SplitsInProgressTasks> (elemento)

Indica si las tareas en curso se pueden dividir.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | True
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<SpreadActualCost> (elemento)

<SpreadActualCost> (elemento)

Indica si los costos reales se extienden a la fecha de estado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | True
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<SpreadPercentComplete> (elemento)

<SpreadPercentComplete> (elemento)

Indica si el porcentaje completado se extiende a la fecha de estado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<StartDate> (elemento)

<StartDate> (elemento)

Fecha de comienzo del proyecto. Requerido si <ScheduleFromStart> se define en True.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<StatusDate> (elemento)

<StatusDate> (elemento)

Fecha utilizada para los cálculos y la creación de informes.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Subject> (elemento)

<Subject> (elemento)

Asunto del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Tasks> (elemento)

<Tasks> (elemento)

Conjunto de tareas que componen el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Project>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Task> | Opcional | Debe haber, al menos, una tarea en cada conjunto de éstas.

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Notas

Si existe un conjunto <Tasks> en un proyecto, debe haber una tarea en él como mínimo.


<TaskUpdatesResource> (elemento)

<TaskUpdatesResource> (elemento)

Indica si las actualizaciones de las tareas actualizan los recursos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<Title> (elemento)

<Title> (elemento)

Título del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<UID> (elemento)

<UID> (elemento)

El elemento <UID> es un identificador exclusivo. Puede utilizarse en el registro de datos de cualquiera de sus elementos principales.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(16): para <Project>
 | Integer: para los demás elementos principales
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>
<Calendar>
<Resource>
<Assignment>
<Task>
<ExtendedAttribute>
<TimephasedData>

Mostrar Vea también

Esquema XML del elemento <Project>
Estructura XML del elemento <Project>

Esquema XML del elemento <Calendar>
Estructura XML del elemento <Calendar>

Esquema XML del elemento <Resource>
Estructura XML del elemento <Resource>

Esquema XML del elemento <Assignment>
Estructura XML del elemento <Assignment>

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

Estructura y esquema XML del elemento <TimephasedDataType>

Notas

El elemento <UID> sólo es una cadena en el caso del elemento <Project>. Para los demás elementos principales, será un entero.


<WBSMasks> (elemento)

<WBSMasks> (elemento)

Tabla de entradas que definen una máscara de código de esquema.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Project>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<VerifyUniqueCodes> | Opcional | Indica si los códigos de estructura detallada de trabajo (EDT) son exclusivos en cada nueva tarea.
<GenerateCodes> | Opcional | Indica si se generan códigos EDT para las tareas nuevas.
<Prefix> | Opcional | Prefijo de todos los códigos EDT.
<WBSMask> | Opcional | La máscara WBS se aplica a todas las tareas del proyecto.


<WeekStartDay> (elemento)

<WeekStartDay> (elemento)

Día de comienzo de la semana.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Domingo
1 | Lunes
2 | Martes
3 | Miércoles
4 | Jueves
5 | Viernes
6 | Sábado
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<WorkFormat> (elemento)

<WorkFormat> (elemento)

Formato predeterminado de todas las duraciones de trabajo del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
1 | m
2 | h
3 | d
4 | s
5 | me
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


Esquema XML del elemento <OutlineCode>

Esquema XML del elemento <OutlineCode>

A continuación, se muestra el esquema del elemento <OutlineCode> para Microsoft Office Project 2003. Se trata de un elemento secundario del esquema <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <OutlineCode>
<OutlineCodes> (elemento)
<?xml version="1.0"?>
   ...
<!-- @OutlineCode schema -->
<xsd:element name="OutlineCodes" minOccurs="0">
    <xsd:annotation>
        <xsd:documentation>The collection of outline code definitions associated with the project.  These codes may be associated only with this project, or may be common among several projects (enterprise codes).</xsd:documentation>
    </xsd:annotation>
    <xsd:complexType>
        <xsd:sequence>
            <xsd:element name="OutlineCode" minOccurs="0" maxOccurs="unbounded">
                <xsd:annotation>
                    <xsd:documentation>The individual outline codes.</xsd:documentation>
                </xsd:annotation>
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element name="FieldID" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Coresponds to the field number of outline code.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="FieldName" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The name of the custom outline code.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Alias" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The alias of the custom outline code.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="PhoneticAlias" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The phonetic pronunciation of the alias of the custom outline code.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Values" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The values of the table associated with this outline code.</xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence minOccurs="0" maxOccurs="unbounded">
                                    <xsd:element name="Value">
                                        <xsd:annotation>
                                            <xsd:documentation>The individual values.</xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:complexType>
                                            <xsd:all>
                                                <xsd:element name="ValueID" type="xsd:integer" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The unique ID of the outline code value across the project.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="ParentValueID" type="xsd:integer" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The value of the parent node of the outline code.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="Value" type="xsd:string" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The actual value.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="Description" type="xsd:string" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>A description of this value.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                            </xsd:all>
                                        </xsd:complexType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="Enterprise" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Indicates whether the custom outline code is an enterprise custom outline code.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="EnterpriseOutlineCodeAlias" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>A reference to another custom field for which this is an alias.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ResourceSubstitutionEnabled" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the custom outline code can be used by the Resource Substitution Wizard in Microsoft Project.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="LeafOnly" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether or not values specified in this outline code field must be leaf values.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="AllLevelsRequired" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>New codes must have all levels present.  Not available for Enterprise Codes.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OnlyTableValuesAllowed" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether values specified must come from values table.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Masks" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The table of entries that define the outline code mask.</xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="Mask" minOccurs="0" maxOccurs="unbounded">
                                        <xsd:annotation>
                                            <xsd:documentation>The four elements of the mask constitute the format in which the outline code must appear.</xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:complexType>
                                            <xsd:sequence>
                                                <xsd:element name="Level" type="xsd:integer" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The level of the mask.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="Type" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The type of mask. Values are: 0=Numbers, 1=Upper Case Letters, 2=Lower Case Letters, 3=Characters</xsd:documentation>
                                                    </xsd:annotation>
                                                    <xsd:simpleType>
                                                        <xsd:restriction base="xsd:integer">
                                                            <xsd:enumeration value="0" />
                                                            <xsd:enumeration value="1" />
                                                            <xsd:enumeration value="2" />
                                                            <xsd:enumeration value="3" />
                                                        </xsd:restriction>
                                                    </xsd:simpleType>
                                                </xsd:element>
                                                <xsd:element name="Length" type="xsd:integer" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The maximum length in characters of the outline code values.  If length is any, the value is zero.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="Separator" type="xsd:string" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The separator value of the code values.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                            </xsd:sequence>
                                        </xsd:complexType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                    </xsd:sequence>
                </xsd:complexType>
            </xsd:element>
        </xsd:sequence>
    </xsd:complexType>
</xsd:element>


Estructura XML del elemento <OutlineCode>

Estructura XML del elemento <OutlineCode>

A continuación se detalla la estructura del elemento <OutlineCode> para Microsoft Office Project 2003.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <Project>

Estructura

<Project>
            . . .
      <OutlineCodes>
            <OutlineCode>
                  <FieldID/>
                  <FieldName/>
                  <Alias/>
                  <PhoneticAlias/>
                  <Values>
                        <Value>
                              <ValueID>
                              <ParentValueID>
                              <Value>
                              <Description>
                        </Value>
                  </Values>
                  <Enterprise/>
                  <EnterpriseOutlineCodeAlias/>
                  <ResourceSubstitutionEnabled/>
                  <LeafOnly/>
                  <AllLevelsRequired/>
                  <OnlyTableValuesAllowed/>
                  <Masks>
                        <Mask>
                              <Level/>
                              <Type/>
                              <Length/>
                              <Separator/>
                        </Mask>
                  </Masks>
            </OutlineCode>
      </OutlineCodes>
</Project>


<Alias> (elemento)

<Alias> (elemento)

Alias del campo personalizado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String: para <OutlineCode>
 | String(50): para <ExtendedAttribute>
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>
<OutlineCode>

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

<PhoneticAlias> (elemento)


<AllLevelsRequired> (elemento)

<AllLevelsRequired> (elemento)

Indica si los códigos nuevos deben presentar todos los niveles. No se utiliza para los códigos de esquema de empresa personalizados.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<OutlineCode>


<Description> (elemento)

<Description> (elemento)

En el caso de <OutlineCode>, indica la descripción del código de esquema personalizado.

En el caso de <ExtendedAttribute>, se refiere a la descripción del valor de la lista.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Value>

Mostrar Vea también

<OutlineCode> (elemento)
<ExtendedAttribute> (elemento)
<Values> (elemento)


<Enterprise> (elemento)

<Enterprise> (elemento)

Indica si el código de esquema personalizado es un código de esquema personalizado de empresa.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<OutlineCode>

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

<EnterpriseOutlineCodeAlias> (elemento)


<EnterpriseOutlineCodeAlias> (elemento)

<EnterpriseOutlineCodeAlias> (elemento)

Referencia a otro campo personalizado del que éste es un alias.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<OutlineCode>

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

<Enterprise> (elemento)


<FieldID> (elemento)

<FieldID> (elemento)

En el caso de un elemento <OutlineCode>, <FieldID> identifica el número de campo del código de esquema al que se refiere.

En el caso de un elemento <ExtendedAttribute>, indica el nombre localizado del campo personalizado; no debería utilizarse para identificar exclusividad entre las distintas versiones.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<OutlineCode>
<ExtendedAttribute>

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

<FieldName> (elemento)


<FieldName> (elemento)

<FieldName> (elemento)

En el caso de un elemento <OutlineCode>, <FieldName> es el nombre del código de esquema personalizado.

En el caso de un elemento <ExtendedAttribute>, se refiere al nombre del campo personalizado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<OutlineCode>
<ExtendedAttribute>

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

<FieldID> (elemento)


<LeafOnly> (elemento)

<LeafOnly> (elemento)

Indica si los valores especificados en el código de esquema personalizado deben ser valores de hoja.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<OutlineCode>


<Length> (elemento)

<Length> (elemento)

Longitud máxima, en caracteres, de los valores de código de esquema (de 1 a 255). Si no hay longitud, el valor es cero.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Mask>
<WBSMask>


<Level> (elemento)

<Level> (elemento)

Nivel asignado a cada elemento OutlineCode o WBSMask que empiece por 1.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Mask>
<WBSMask>


<Mask> (elemento)

<Mask> (elemento)

Indica si el código de esquema personalizado debe utilizarse con todos los recursos y las tareas relacionados.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Masks>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Level> | Opcional | Nivel asignado a cada código de esquema personalizado, empezando por 1.
<Type> | Opcional | Tipo de cadena de código de las tareas de primer nivel.
<Length> | Opcional | Longitud máxima, en caracteres, de los valores de código de esquema (de 1 a 255). Si no hay longitud, el valor es cero.
<Separator> | Opcional | Carácter utilizado para separar los niveles de códigos de esquema personalizados.

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

Notas

Los cuatro elementos de la máscara constituyen el formato en el que debe aparecer el código de esquema.


<Masks> (elemento)

<Masks> (elemento)

Tabla de entradas que definen la máscara de código de esquema.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<OutlineCode>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Mask> | Opcional | Indica si el código de esquema personalizado debe utilizarse con todos los recursos y las tareas relacionados.


<OnlyTableValuesAllowed> (elemento)

<OnlyTableValuesAllowed> (elemento)

Indica si el valor de código de esquema personalizado debe proceder de la tabla de valores.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<OutlineCode>


<OutlineCode> (elemento)

<OutlineCode> (elemento)

Indica el valor de un código de esquema. Son necesarios dos datos; un puntero retrocede hasta la tabla de códigos de esquema especificada por el identificador exclusivo o el identificador de campo y el valor que especifica el valor o un puntero que retrocede hasta la lista de valores.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<OutlineCodes>
<Resource>
<Task>

Mostrar Elementos secundarios

Lista de elementos secundarios

Elemento | Requerido/Opcional | Descripción
<FieldID> | Opcional | Número del campo al que hace referencia el código de esquema.
<FieldName> | Opcional | Nombre del código de esquema personalizado.
<Alias> | Opcional | Alias del código de esquema personalizado.
<PhoneticAlias> | Opcional | Contiene información fonética de un código de esquema personalizado en Hiragana o Katakana; se utiliza sólo en la versión en japonés de Microsoft Office Project 2003.
<Values> | Opcional | Conjunto de datos reales del código de esquema personalizado.
<Enterprise> | Opcional | Indica si el código de esquema personalizado es un código de esquema personalizado de empresa.
<EnterpriseOutlineCodeAlias> | Opcional | Hace referencia a otro campo personalizado del que éste es un alias.
<ResourceSubstitutionEnabled> | Opcional | Indica si el código de esquema personalizado se utiliza con el Asistente para la sustitución de recursos de Project. Sólo se usa con códigos de esquema personalizados de empresa.
<LeafOnly> | Opcional | Indica si los valores especificados en el código de esquema personalizado deben ser valores de hoja.
<AllLevelsRequired> | Opcional | Indica si los códigos nuevos deben presentar todos los niveles. No se utiliza para los códigos de esquema personalizados de empresa.
<OnlyTableValuesAllowed> | Opcional | Indica si el valor de código de esquema personalizado debe proceder de la tabla de valores.
<Masks> | Opcional | Indica si el código de esquema personalizado debe utilizarse con todos los recursos y las tareas relacionados.


<ParentValueID> (elemento)

<ParentValueID> (elemento)

Identificador exclusivo del nodo primario del código de esquema personalizado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Value>

Mostrar Vea también

<OutlineCode> (elemento)
<Values> (elemento)


<PhoneticAlias> (elemento)

<PhoneticAlias> (elemento)

Contiene información fonética de un código de esquema personalizado en Hiragana o Katakana; se utiliza sólo en la versión en japonés de Microsoft Office Project 2003.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>
<OutlineCode>

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

<Alias> (elemento)


<ResourceSubstitutionEnabled> (elemento)

<ResourceSubstitutionEnabled> (elemento)

Indica si el código de esquema personalizado se utiliza con el Asistente para la sustitución de recursos de Microsoft Project Edición Professional 2003. Sólo se usa con códigos de esquema personalizados de empresa.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<OutlineCode>


<Separator> (elemento)

<Separator> (elemento)

Carácter utilizado para separar los niveles de códigos de esquema personalizados o la máscara de EDT.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
A continuación se indican algunos valores de ejemplo; no obstante, cualquier símbolo puede utilizarse como separador de un código de esquema personalizado o de una máscara de WBS:
. | Punto (predeterminado)
- | Signo menos
+ | Signo más
/ | Barra oblicua
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Mask>
<WBSMask>


<Type> (elemento)

<Type> (elemento)

Como elemento secundario de los elementos <Mask> o <WBSMask>, <Type> es el tipo de cadena de código para tareas de primer nivel (números o letras, o caracteres desordenados).

En el caso de un elemento <Task>, <Type> es el tipo de tarea (unidades fijas, duración fija o trabajo fijo).

En el caso de un elemento <PredecessorLink>, indica el tipo de vínculo de la tarea (FF, FC, CF o CC).

En el caso de un elemento <Resource>, se refiere al tipo de recurso (material o de trabajo).

En el caso de un elemento <TimephasedData>, <Type> es uno de los 76 tipos de datos de fase temporal.

Mostrar Propiedades de elemento de <Mask> o <WBSMask>

Propiedad | Valor
Tipo de datos | Integer
Tipo de cadena de código de las tareas de primer nivel:
0 | Números (ordenados); un código EDT numérico para este nivel (predeterminado).
1 | Mayúsculas (ordenadas); códigos EDT alfabéticos en mayúsculas (por ejemplo, A, B y C para las tres primeras tareas de resumen del proyecto).
2 | Minúsculas (ordenadas); códigos EDT alfabéticos en minúsculas (por ejemplo, a, b y c para las tres primeras tareas de resumen del proyecto).
3 | Caracteres (sin ordenar); cualquier combinación de números y letras en mayúsculas o minúsculas (por ejemplo, Arqu1, Const1 o Insp1 para las tres primeras tareas de resumen del proyecto). Microsoft Office Project 2003 muestra un asterisco (*) en el campo de esquema personalizado hasta que escriba o especifique una cadena de caracteres para este código.
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Propiedades de elemento de <Task>

Propiedad | Valor
Tipo de datos | Integer
Tipo de tarea:
0 | Unidades fijas
1 | Duración fija
2 | Trabajo fijo
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Propiedades de elemento de <PredecessorLink>

Propiedad | Valor
Tipo de datos | Integer
Tipo de vínculo de tarea:
0 | FF (Fin a fin)
1 | FC (Fin a comienzo)
2 | CF (Comienzo a fin)
3 | CC (Comienzo a comienzo)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Propiedades de elemento de <Resource>

Propiedad | Valor
Tipo de datos | Integer
Tipo de recurso (trabajo o material):
0 | Material (suministros consumibles, como acero, hormigón o arena)
1 | Trabajo (personas y equipamiento)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Propiedades de elemento de <TimephasedDataType>

Propiedad | Valor
Tipo de datos | Integer
Tipo de datos de fase temporal:
1 | Trabajo restante de la asignación
2 | Trabajo real de la asignación
3 | Trabajo real de horas extra de la asignación
4 | Trabajo previsto de la asignación
5 | Costo previsto de la asignación
6 | Costo real de la asignación
7 | Trabajo previsto del recurso
8 | Costo previsto del recurso
9 | Trabajo previsto de la tarea
10 | Costo previsto de la tarea
11 | Porcentaje completado de la tarea
16 | Trabajo previsto 1 de la asignación
17 | Costo previsto 1 de la asignación
18 | Trabajo previsto 1 de la tarea
19 | Costo previsto 1 de la tarea
20 | Trabajo previsto 1 del recurso
21 | Costo previsto 1 del recurso
22 | Trabajo previsto 2 de la asignación
23 | Costo previsto 2 de la asignación
24 | Trabajo previsto 2 de la tarea
25 | Costo previsto 2 de la tarea
26 | Trabajo previsto 2 del recurso
27 | Costo previsto 2 del recurso
28 | Trabajo previsto 3 de la asignación
29 | Costo previsto 3 de la asignación
30 | Trabajo previsto 3 de la tarea
31 | Costo previsto 3 de la tarea
32 | Trabajo previsto 3 del recurso
33 | Costo previsto 3 del recurso
34 | Trabajo previsto 4 de la asignación
35 | Costo previsto 4 de la asignación
36 | Trabajo previsto 4 de la tarea
37 | Costo previsto 4 de la tarea
38 | Trabajo previsto 4 del recurso
39 | Costo previsto 4 del recurso
40 | Trabajo previsto 5 de la asignación
41 | Costo previsto 5 de la asignación
42 | Trabajo previsto 5 de la tarea
43 | Costo previsto 5 de la tarea
44 | Trabajo previsto 5 del recurso
45 | Costo previsto 5 del recurso
46 | Trabajo previsto 6 de la asignación
47 | Costo previsto 6 de la asignación
48 | Trabajo previsto 6 de la tarea
49 | Costo previsto 6 de la tarea
50 | Trabajo previsto 6 del recurso
51 | Costo previsto 6 del recurso
52 | Trabajo previsto 7 de la asignación
53 | Costo previsto 7 de la asignación
54 | Trabajo previsto 7 de la tarea
55 | Costo previsto 7 de la tarea
56 | Trabajo previsto 7 del recurso
57 | Costo previsto 7 del recurso
58 | Trabajo previsto 8 de la asignación
59 | Costo previsto 8 de la asignación
60 | Trabajo previsto 8 de la tarea
61 | Costo previsto 8 de la tarea
62 | Trabajo previsto 8 del recurso
63 | Costo previsto 8 del recurso
64 | Trabajo previsto 9 de la asignación
65 | Costo previsto 9 de la asignación
66 | Trabajo previsto 9 de la tarea
67 | Costo previsto 9 de la tarea
68 | Trabajo previsto 9 del recurso
69 | Costo previsto 9 del recurso
70 | Trabajo previsto 10 de la asignación
71 | Costo previsto 10 de la asignación
72 | Trabajo previsto 10 de la tarea
73 | Costo previsto 10 de la tarea
74 | Trabajo previsto 10 del recurso
75 | Costo previsto 10 del recurso
76 | Porcentaje físico completado
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Mask>
<WBSMask>
<Task>
<PredecessorLink>
<Resource>
<TimephasedData>

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Esquema XML del elemento <Resource>
Estructura XML del elemento <Resource>

Estructura y esquema XML del elemento <TimephasedDataType>


<Value> (elemento)

<Value> (elemento)

En el caso de un elemento <OutlineCode>, <Value> es el valor real del código de esquema personalizado.

En el caso de un elemento <ExtendedAttribute>, se refiere al valor real de un atributo extendido.

En el caso de un elemento <TimephasedData>, es el valor de cada unidad en el registro de datos de fase temporal.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ValueList> (elemento)
<Values> (elemento)
<Value> (elemento)
<ExtendedAttribute> (elemento)
<TimephasedData> (elemento)

Mostrar Elementos secundarios para <OutlineCode>

Elemento | Requerido/Opcional | Descripción
<ValueID> | Opcional | Identificador exclusivo del código de esquema personalizado.
<ParentValueID> | Opcional | Identificador exclusivo del nodo primario del código de esquema personalizado.
<Value> | Opcional | Valor real del código de esquema personalizado.
<Description> | Opcional | Descripción del código de esquema personalizado.

Mostrar Elementos secundarios para <ExtendedAttribute>

Elemento | Requerido/Opcional | Descripción
<ID> | Requerido | Identificador exclusivo del valor en todo el proyecto.
<Value> | Requerido | Valor real.
<Description> | Opcional | Descripción del valor de la lista.

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

<OutlineCode> (elemento)

Estructura y esquema XML del elemento <TimephasedDataType>

<Assignment> (elemento)
<Baseline> (elemento)
<Resource> (elemento)
<Task> (elemento)

Notas

<Value> es un elemento recurrente en <OutlineCode> como parte del elemento <Values> y en <ExtendedAttribute> como parte de una <ValueList>.

Los elementos <TimephasedData> tienen lugar en los elementos <Assignment>, <Baseline>, <Resource> y <Task>.

Los elementos secundarios de <Value> pueden aparecer en cualquier orden.


<ValueID> (elemento)

<ValueID> (elemento)

En el caso de un elemento <OutlineCode>, <ValueID> es el identificador exclusivo de un código de esquema personalizado.

En el caso de un elemento <ExtendedAttribute>, es el identificador exclusivo del valor de un atributo extendido en todo el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Value>

Mostrar Vea también

Esquema XML del elemento <OutlineCode>
Estructura XML del elemento <OutlineCode>

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

<OutlineCode> (elemento)
<Values> (elemento)
<ValueList> (elemento)

Notas

<ValueID> es un elemento secundario del elemento <Value> en un elemento <OutlineCode>. <Values> es un conjunto de elementos <Value>.

<ExtendedAttribute> también contiene un elemento <Value>, pero en este caso, el valor forma parte de un conjunto <ValueList>; un valor <ExtendedAttribute> cuenta con un elemento <ID> y no, <ValueID>.


<Values> (elemento)

<Values> (elemento)

Conjunto de valores asociados al código de esquema personalizado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<OutlineCode>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Value> | Requerido | Valor real del código de esquema personalizado.


Esquema XML del elemento <WBSMask>

Esquema XML del elemento <WBSMask>

A continuación, se muestra el esquema del elemento <WBSMask> para Microsoft Office Project 2003. Se trata de un elemento secundario del esquema <Project>.

Mostrar Vea también

Resumen del esquema XML para Project
Resumen de la estructura XML para Project
Esquema XML del elemento <Project>
Estructura XML del elemento <WBSMask>
<WBSMasks> (elemento)
<?xml version="1.0"?>
   ...

<!-- @WBSMasks schema -->
<xsd:element name="WBSMasks" minOccurs="0">
    <xsd:annotation>
        <xsd:documentation>The table of entries that define the outline code mask.</xsd:documentation>
    </xsd:annotation>
    <xsd:complexType>
        <xsd:sequence>
            <xsd:element name="VerifyUniqueCodes" type="xsd:boolean" default="false" minOccurs="0">
                <xsd:annotation>
                    <xsd:documentation>Whether WBS codes are unique for new tasks.</xsd:documentation>
                </xsd:annotation>
            </xsd:element>
            <xsd:element name="GenerateCodes" type="xsd:boolean" default="false" minOccurs="0">
                <xsd:annotation>
                    <xsd:documentation>Whether WBS codes are generated for new tasks.</xsd:documentation>
                </xsd:annotation>
            </xsd:element>
            <xsd:element name="Prefix" minOccurs="0">
                <xsd:annotation>
                    <xsd:documentation>The prefix for all WBS codes.</xsd:documentation>
                </xsd:annotation>
                <xsd:simpleType>
                    <xsd:restriction base="xsd:string">
                        <xsd:maxLength value="50" />
                    </xsd:restriction>
                </xsd:simpleType>
            </xsd:element>
            <xsd:element name="WBSMask" minOccurs="0" maxOccurs="unbounded">
                <xsd:annotation>
                    <xsd:documentation>The WBS Mask that is applied to all tasks in the Project.</xsd:documentation>
                </xsd:annotation>
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element name="Level" type="xsd:integer">
                            <xsd:annotation>
                                <xsd:documentation>The level of the mask.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Type">
                            <xsd:annotation>
                                <xsd:documentation>The type of the node value.
                                The values are: 0=Numbers, 1=Uppercase Letters, 2=Lowercase Letters, 3=Characters.</xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                    <xsd:enumeration value="3" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Length" type="xsd:string">
                            <xsd:annotation>
                                <xsd:documentation>The maximum length in characters.
                                This element is omitted when length is "any".</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Separator" type="xsd:string">
                            <xsd:annotation>
                                <xsd:documentation>The separator character of the node.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                    </xsd:sequence>
                </xsd:complexType>
            </xsd:element>
        </xsd:sequence>
    </xsd:complexType>
</xsd:element>


Estructura XML del elemento <WBSMasks>

Estructura XML del elemento <WBSMasks>

A continuación se detalla la estructura del elemento <WBSMasks> para Microsoft Office Project 2003.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Esquema XML del elemento <WBSMask>
Estructura XML del elemento <Project>

Estructura

<Project>
      . . .
      <WBSMasks>
            <VerifyUniqueCodes/>
            <GenerateCodes/>
            <Prefix/>
            <WBSMask>
                  <Level/>
                  <Type/>
                  <Length/>
                  <Separator/>
            </WBSMask>
    </WBSMasks>
    . . .
</Project>


<GenerateCodes> (elemento)

<GenerateCodes> (elemento)

Indica si se generan códigos EDT para las tareas nuevas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<WBSMasks>


<Prefix> (elemento)

<Prefix> (elemento)

Prefijo de todos los códigos EDT.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(50)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<WBSMasks>


<VerifyUniqueCodes> (elemento)

<VerifyUniqueCodes> (elemento)

Indica si los códigos de estructura de descomposición del trabajo (EDT) son exclusivos en cada nueva tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<WBSMasks>


<WBSMask> (elemento)

<WBSMask> (elemento)

Máscara de estructura detallada de trabajo (EDT) que se aplica a todas las tareas del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<WBSMasks>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Level> | Requerido | Nivel asignado a cada nivel de EDT, empezando por 1.
<Type> | Requerido | Tipo de cadena de código de las tareas de primer nivel.
<Length> | Requerido | Longitud máxima en caracteres de los valores de la máscara EDT, de 1 a 255. Si no hay longitud, el valor es cero.
<Separator> | Requerido | Carácter utilizado para separar la máscara EDT.


Esquema XML del elemento <ExtendedAttribute>

Esquema XML del elemento <ExtendedAttribute>

A continuación, se muestra el esquema del elemento <ExtendedAttribute> para Microsoft Office Project 2003. Se trata de un elemento secundario del esquema <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Esquema XML del elemento <Project>
Estructura XML del elemento <ExtendedAttribute>
<ExtendedAttributes> (elemento)
<?xml version="1.0"?>
   ...

<!-- @ExtendedAttribute schema -->
<xsd:element name="ExtendedAttributes" minOccurs="0">
    <xsd:annotation>
        <xsd:documentation>The collection of extended attribute (custom field) definitions
        associated with the project.</xsd:documentation>
    </xsd:annotation>
    <xsd:complexType>
        <xsd:sequence>
            <xsd:element name="ExtendedAttribute" minOccurs="0" maxOccurs="unbounded">
                <xsd:annotation>
                    <xsd:documentation>Each of the individual entries in the extended attributes definition
                    collection.  There are no limits to the number of children that may appear, but project
                    will only understand Flag1-Flag10, etc.  This must appear once in each ExtendedAttributes
                    collection.</xsd:documentation>
                </xsd:annotation>
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element name="FieldID" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>This corresponds to the PID of the custom field.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="FieldName" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The name of the custom field.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Alias" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The alias of the custom field</xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="50" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="PhoneticAlias" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The phonetic pronunciation of the alias of the
                                custom field</xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="50" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="RollupType" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>How rollups are calculated. Values are: 0=Maximum
                                (OR for flag fields), 1=Minimum (AND for flag fields), 2=Count all, 3=Sum,
                                4=Average, 5=Average First Sublevel, 6=Count First Sublevel, 7=Count
                                Nonsummaries</xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                    <xsd:enumeration value="3" />
                                    <xsd:enumeration value="4" />
                                    <xsd:enumeration value="5" />
                                    <xsd:enumeration value="6" />
                                    <xsd:enumeration value="7" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="CalculationType" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether rollups are calculated for task and group summary rows.
                                Values are: 0=None, 1=Rollup, 2=Calculation</xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Formula" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The formula that Microsoft Project uses to populate the
                                custom task field.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RestrictValues" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>If RestrictValues=True then only values in the list are
                                allowed in the file</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ValuelistSortOrder" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>How value lists are sorted. Values are:
                                0=Descending, 1=Ascending</xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="AppendNewValues" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>If AppendNewValues=True then any new values added in a project
                                are automatically appended to the list.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Default" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>This points to the default value in the list.
                                Not present if no default is set.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ValueList" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>When values of extended attributes are specified as
                                properties of elements in the schema, they may either be specified by values
                                or by references to the values contained in this list.  Applications may
                                assume ordering of the list by ordering specified here.</xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="Value" maxOccurs="unbounded">
                                        <xsd:annotation>
                                            <xsd:documentation>The values that make up the value list.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:complexType>
                                            <xsd:all>
                                                <xsd:element name="ID" type="xsd:integer">
                                                    <xsd:annotation>
                                                        <xsd:documentation>Unique ID of value across
                                                        the project.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="Value" type="xsd:string" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The actual value.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="Description" type="xsd:string" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The description of the value
                                                        in the list.</xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                            </xsd:all>
                                        </xsd:complexType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                    </xsd:sequence>
                </xsd:complexType>
            </xsd:element>
        </xsd:sequence>
    </xsd:complexType>
</xsd:element>


Estructura XML del elemento <ExtendedAttribute>

Estructura XML del elemento <ExtendedAttribute>

A continuación se detalla la estructura del elemento <ExtendedAttribute> para Microsoft Office Project 2003.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <Project>

Estructura

<Project>
            . . .
      <ExtendedAttributes>
            <ExtendedAttribute>
                  <FieldID/>
                  <FieldName/>
                  <Alias/>
                  <PhoneticAlias/>
                  <RollupType/>
                  <CalculationType/>
                  <Formula/>
                  <RestrictValues/>
                  <ValuelistSortOrder/>
                  <AppendNewValues/>
                  <Default/>
                  <ValueList>
                        <Value>
                              <ID>
                              <Value>
                              <Description>
                        </Value>
                  </ValueList>
            </ExtendedAttribute>
      </ExtendedAttributes>
            . . .
</Project>


<AppendNewValues> (elemento)

<AppendNewValues> (elemento)

Indica si los valores nuevos agregados al proyecto se agregan automáticamente a la lista.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>


<CalculationType> (elemento)

<CalculationType> (elemento)

Indica si se calculan valores resumidos para las filas de resumen de grupos y de tareas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Ninguno
1 | Resumen
2 | Cálculo
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>


<Default> (elemento)

<Default> (elemento)

Hace referencia al identificador del valor predeterminado de la lista. No se utiliza si no se ha establecido un valor predeterminado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>


<ExtendedAttribute> (elemento)

<ExtendedAttribute> (elemento)

Un atributo extendido es un campo personalizado. La definición dependerá de si se ha definido un atributo extendido dentro de un conjunto <ExtendedAttributes> o de un elemento <Task>, <Resource> o <Assignment>. En general, puede haber un número ilimitado de atributos extendidos, según las limitaciones descritas a continuación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<ExtendedAttributes>
<Task>
<Resource>
<Assignment>

Mostrar Elementos secundarios para el conjunto <ExtendedAttributes>

Los atributos extendidos se definen con los elementos siguientes. No hay límite para el número de nodos secundarios que pueden aparecer, pero Microsoft Office Project 2003 sólo aceptará los nombres predeterminados de los atributos extendidos (por ejemplo, Indicador1, Indicador2).
Elemento | Requerido/Opcional | Descripción
<FieldID> | Opcional | Nombre localizado del campo. No debe utilizarse para identificar exclusividad entre las versiones.
<FieldName> | Opcional | Nombre del campo personalizado.
<Alias> | Opcional | Alias del campo personalizado.
<PhoneticAlias> | Opcional | Contiene información fonética de un atributo extendido en Hiragana o Katakana; se utiliza sólo en la versión en japonés de Project.
<RollupType> | Opcional | Indica el método utilizado para calcular los valores resumidos.
<CalculationType> | Opcional | Indica si se calculan valores resumidos para las filas de resumen de grupos y de tareas.
<Formula> | Opcional | Fórmula que Project utiliza para rellenar el campo personalizado.
<RestrictValues> | Opcional | Indica si sólo los valores de la lista se admiten en el archivo.
<AppendNewValues> | Opcional | Indica si los valores nuevos agregados al proyecto se agregan automáticamente a la lista.
<Default> | Opcional | Hace referencia al identificador del valor predeterminado de la lista. No se utiliza si no se ha establecido un valor predeterminado.
<ValueList> | Opcional | El conjunto de valores de atributos extendidos.

Mostrar Elementos secundarios de un elemento <Task>, <Resource> o <Assignment>

Elemento | Requerido/Opcional | Descripción
<UID> | Opcional | Identificador exclusivo del atributo extendido.
<FieldID> | Opcional | Identificador de campo del atributo extendido.
<Value> | Opcional | Valor real del atributo extendido.
<ValueID> | Opcional | Identificador del valor en la tabla de consulta del atributo extendido.
<DurationFormat> | Opcional | Enumeración del formato de duración del atributo extendido (día, semana, mes, etc.).

Mostrar Vea también

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Esquema XML del elemento <Resource>
Estructura XML del elemento <Resource>

Esquema XML del elemento <Assignment>
Estructura XML del elemento <Assignment>

Notas

En el caso del conjunto <ExtendedAttributes> Se precisan dos fechas; un puntero para volver a la tabla del atributo extendido especificado por el identificador exclusivo o el identificador del campo y el valor que se especifica con el valor o un puntero para volver a la lista de valores.

Nota Al cargar un proyecto almacenado como datos XML, Microsoft Office Project 2003 reconocerá un máximo de 5000 elementos <ValueList> y 128 elementos <Indicators>. El resto se omitirá.


<Formula> (elemento)

<Formula> (elemento)

Fórmula que Microsoft Office Project 2003 utiliza para rellenar el campo de tarea personalizado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>


<ID> (elemento)

<ID> (elemento)

En el caso de un elemento <Resource>, <ID> es el identificador de posición de un recurso dentro de la lista de recursos.

En el caso de un elemento <Task>, se trata del identificador de posición de la tarea en la lista de tareas.

En el caso de un elemento <Value>, es el identificador exclusivo del valor en todo el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>
<Task>
<Value>


<RestrictValues> (elemento)

<RestrictValues> (elemento)

Indica si sólo los valores de la lista se admiten en el archivo.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>


<RollupType> (elemento)

<RollupType> (elemento)

Indica el método utilizado para calcular los valores resumidos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Máximo (O para los campos Indicador)
1 | Mínimo (Y para los campos Indicador)
2 | Contar todos
3 | Suma
4 | Promedio
5 | Promedio de primer subnivel
6 | Contar primer subnivel
7 | Contar no resumidas
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>


<ValueList> (elemento)

<ValueList> (elemento)

Si se especifican los valores de los atributos extendidos como propiedades de elementos en el esquema, es posible que se encuentren especificados por valores o referencias a los valores incluidos en esta lista. Las aplicaciones pueden asumir la ordenación de la lista especificada en <ValueListSortOrder>.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<ExtendedAttribute>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Value> | Requerido | Valor real de un atributo extendido.

Mostrar Vea también

Esquema XML del elemento <ExtendedAttribute>
Estructura XML del elemento <ExtendedAttribute>

Esquema XML del elemento <OutlineCode>

Notas

El elemento <ValueList> incluye valores para un elemento <ExtendedAttribute>. Los elementos <Value> se incluyen en el conjunto <Values> del elemento <OutlineCode>.


<ValueListSortOrder> (elemento)

<ValueListSortOrder> (elemento)

Indica cómo se ordenan las listas de valores.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Descendente
1 | Ascendente
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<ExtendedAttribute>


Esquema XML del elemento <Calendar>

Esquema XML del elemento <Calendar>

A continuación, se muestra el esquema del elemento <Calendar> para Microsoft Office Project 2003. Se trata de un elemento secundario del esquema <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Esquema XML del elemento <Project>

Estructura XML del elemento <Calendar>
<Calendars> (elemento)

<?xml version="1.0"?>
    ...
<!-- @Calendar schema -->
<xsd:element name="Calendars" minOccurs="0">
    <xsd:annotation>
        <xsd:documentation>The collection of calendars that is associated with the
        project.</xsd:documentation>
    </xsd:annotation>
    <xsd:complexType>
        <xsd:sequence>
            <xsd:element name="Calendar" minOccurs="1" maxOccurs="unbounded">
                <xsd:annotation>
                    <xsd:documentation>Calendars are used to define standard working and
                    non-working times. Projects must have one base calendar. Tasks and resources
                    may have their own non-base calendars which are based on a base calendar.
                    </xsd:documentation>
                </xsd:annotation>
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element name="UID" type="xsd:integer">
                            <xsd:annotation>
                                <xsd:documentation>The unique identifier of the calendar.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Name" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The name of the calendar.</xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="IsBaseCalendar" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the calendar is a base calendar.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="BaseCalendarUID" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The unique identifier of the base calendar
                                on which this calendar depends. Only applicable if the calendar is
                                not a base calendar.</xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="WeekDays" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The collection of Weekdays that defines this calendar.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="WeekDay" minOccurs="0" maxOccurs="unbounded">
                                        <xsd:annotation>
                                            <xsd:documentation>A weekday either defines regular days
                                            of the week or exception days in the calendar.</xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:complexType>
                                            <xsd:sequence>
                                                <xsd:element name="DayType" minOccurs="1">
                                                     <xsd:annotation>
                                                         <xsd:documentation>The type of day.
                                                         Values are: 0=Exception, 1=Monday, 2=Tuesday,
                                                         3=Wednesday, 4=Thursday, 5=Friday, 6=Saturday,
                                                         7=Sunday</xsd:documentation>
                                                     </xsd:annotation>
                                                     <xsd:simpleType>
                                                         <xsd:restriction base="xsd:integer">
                                                             <xsd:enumeration value="0" />
                                                             <xsd:enumeration value="1" />
                                                             <xsd:enumeration value="2" />
                                                             <xsd:enumeration value="3" />
                                                             <xsd:enumeration value="4" />
                                                             <xsd:enumeration value="5" />
                                                             <xsd:enumeration value="6" />
                                                             <xsd:enumeration value="7" />
                                                         </xsd:restriction>
                                                     </xsd:simpleType>
                                                </xsd:element>
                                                <xsd:element name="DayWorking" type="xsd:boolean" minOccurs="0">
                                                     <xsd:annotation>
                                                         <xsd:documentation>Whether the specified date or day
                                                         type is working.</xsd:documentation>
                                                     </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="TimePeriod" minOccurs="0">
                                                     <xsd:annotation>
                                                         <xsd:documentation>Defines a contiguous set of exception days.
                                                         </xsd:documentation>
                                                     </xsd:annotation>
                                                     <xsd:complexType>
                                                         <xsd:sequence>
                                                             <xsd:element name="FromDate" type="xsd:dateTime" minOccurs="0">
                                                                 <xsd:annotation>
                                                                     <xsd:documentation>The beginning of the exception time.
                                                                     </xsd:documentation>
                                                                 </xsd:annotation>
                                                             </xsd:element>
                                                             <xsd:element name="ToDate" type="xsd:dateTime" minOccurs="0">
                                                                 <xsd:annotation>
                                                                     <xsd:documentation>The end of the exception time.
                                                                     </xsd:documentation>
                                                                 </xsd:annotation>
                                                             </xsd:element>
                                                         </xsd:sequence>
                                                     </xsd:complexType>
                                                </xsd:element>
                                                <xsd:element name="WorkingTimes" minOccurs="0">
                                                     <xsd:annotation>
                                                         <xsd:documentation>The collection of working times that define the time worked
                                                         on the weekday.  One of these must be present, and there may be no more than five.
                                                         </xsd:documentation>
                                                     </xsd:annotation>
                                                     <xsd:complexType>
                                                         <xsd:sequence>
                                                             <xsd:choice>
                                                                 <xsd:element name="WorkingTime" minOccurs="0" maxOccurs="5">
                                                                     <xsd:annotation>
                                                                         <xsd:documentation>Defines the working time during the weekday.
                                                                         </xsd:documentation>
                                                                     </xsd:annotation>
                                                                     <xsd:complexType>
                                                                         <xsd:sequence>
                                                                             <xsd:element name="FromTime" type="xsd:time" minOccurs="0">
                                                                                <xsd:annotation>
                                                                                <xsd:documentation>The beginning of the working time.
                                                                                </xsd:documentation>
                                                                                </xsd:annotation>
                                                                             </xsd:element>
                                                                             <xsd:element name="ToTime" type="xsd:time" minOccurs="0">
                                                                                <xsd:annotation>
                                                                                <xsd:documentation>The end of the working  time.
                                                                                </xsd:documentation>
                                                                                </xsd:annotation>
                                                                             </xsd:element>
                                                                         </xsd:sequence>
                                                                     </xsd:complexType>
                                                                 </xsd:element>
                                                             </xsd:choice>
                                                         </xsd:sequence>
                                                     </xsd:complexType>
                                                </xsd:element>
                                            </xsd:sequence>
                                        </xsd:complexType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                    </xsd:sequence>
                </xsd:complexType>
            </xsd:element>
        </xsd:sequence>
    </xsd:complexType>
</xsd:element>


Estructura XML del elemento <Calendar>

Estructura XML del elemento <Calendar>

A continuación se detalla la estructura del elemento <Calendar> para Microsoft Office Project 2003.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <Project>

Esquema XML del elemento <Calendar>

Estructura

<Project>
            . . .
      <Calendars>
            <Calendar>
                  <UID/>
                  <Name/>
                  <IsBaseCalendar/>
                  <BaseCalendarUID/>
                  <WeekDays>
                        <WeekDay>
                              <DayType/>
                              <DayWorking/>
                              <TimePeriod>
                                    <FromDate/>
                                    <ToDate/>
                              </TimePeriod>
                              <WorkingTimes>
                                    <WorkingTime/>
                                          <FromTime/>
                                          <ToTime/>
                                    </WorkingTime>
                              </WorkingTimes>
                        </WeekDay>
                  </WeekDays>
            </Calendar>
      </Calendars>
            . . .
</Project>


<BaseCalendarUID> (elemento)

<BaseCalendarUID> (elemento)

Identificador exclusivo del calendario base del que depende este calendario. Sólo se utiliza si este calendario no es un calendario base.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Calendar>


<Calendar> (elemento)

<Calendar> (elemento)

El calendario se utiliza para definir los horarios laborables y no laborables estándar. Un proyecto debe contar con un calendario base. Las tareas y los recursos pueden disponer de sus propios calendarios, basados en el calendario base.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 1
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Calendars>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<UID> | Requerido | Identificador exclusivo del calendario.
<Name> | Opcional | Nombre del calendario.
<IsBaseCalendar> | Opcional | Indica si el calendario es un calendario base.
<BaseCalendarUID> | Opcional | Identificador exclusivo del calendario base del que depende este calendario. Sólo se utiliza si este calendario no es un calendario base.
<WeekDays> | Opcional | El tipo de día laborable (un día de la semana o una excepción).


<DayType> (elemento)

<DayType> (elemento)

Tipo de día laborable.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Excepción
1 | Lunes
2 | Martes
3 | Miércoles
4 | Jueves
5 | Viernes
6 | Sábado
7 | Domingo
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<WeekDay>


<DayWorking> (elemento)

<DayWorking> (elemento)

Indica si la fecha especificada o el tipo de día es un día laborable.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<WeekDay>


<FromDate> (elemento)

<FromDate> (elemento)

Comienzo del período de excepción.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<TimePeriod>


<FromTime> (elemento)

<FromTime> (elemento)

Comienzo del período laborable.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<WorkingTime>


<IsBaseCalendar> (elemento)

<IsBaseCalendar> (elemento)

Indica si el calendario es un calendario base.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Calendar>


<TimePeriod> (elemento)

<TimePeriod> (elemento)

Define un conjunto de días de excepción.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<WeekDay>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<FromDate> | Opcional | Comienzo del período de excepción.
<ToDate> | Opcional | Fin del período de excepción.


<ToDate> (elemento)

<ToDate> (elemento)

Fin del período de excepción.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<TimePeriod>


<ToTime> (elemento)

<ToTime> (elemento)

Fin del período laborable.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<WorkingTime>


<WeekDay> (elemento)

<WeekDay> (elemento)

Día de la semana que define tanto los días de la semana normales como los días excepcionales del calendario.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<WeekDays>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<DayType> | Requerido | Tipo de día laborable (excepción o de lunes a domingo)
<DayWorking> | Opcional | Indica si la fecha especificada o el tipo de fecha es un día laborable.
<TimePeriod> | Opcional | Define un conjunto de días de excepción.
<WorkingTimes> | Opcional | Conjunto de horas laborables que definen el tiempo trabajado.


<WeekDays> (elemento)

<WeekDays> (elemento)

Conjunto de días de la semana que definen este calendario.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Calendar>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<WeekDay> | Opcional | Tipo de día laborable.


<WorkingTime> (elemento)

<WorkingTime> (elemento)

Define el tiempo trabajado en un día laborable. Debe estar presente uno de los siguientes y no puede haber más de cinco.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 1
Número máximo de apariciones | 5
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<WorkingTimes>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<FromTime> | Opcional | Comienzo del período laborable.
<ToTime> | Opcional | Fin del período laborable.


<WorkingTimes> (elemento)

<WorkingTimes> (elemento)

Conjunto de horas laborables que definen el tiempo trabajado en un día laborable. Debe estar presente uno de los siguientes y no puede haber más de cinco.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<WeekDay>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<WorkingTime> | Requerido | Hora laborable (puede haber de una a cinco al día).


Esquema XML del elemento <Task>

Esquema XML del elemento <Task>

A continuación, se muestra el esquema del elemento <Task> para Microsoft Office Project 2003. Se trata de un elemento secundario del esquema <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <Task>
<Tasks> (elemento)
<?xml version="1.0"?>
   ...
<!-- @Task schema -->
<xsd:element name="Tasks" minOccurs="0">
    <xsd:annotation>
        <xsd:documentation>The collection of tasks that make up the project.
        </xsd:documentation>
    </xsd:annotation>
    <xsd:complexType>
        <xsd:sequence>
            <xsd:element name="Task" minOccurs="0" maxOccurs="unbounded">
                <xsd:annotation>
                    <xsd:documentation>There must be at least one task in each Tasks collection.
                    </xsd:documentation>
                </xsd:annotation>
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element name="UID" type="xsd:integer">
                            <xsd:annotation>
                                <xsd:documentation>The unique ID of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ID" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The position identifier of the task within the list of tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Name" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The name of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Type" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The type of task.
                                Values are: 0=Fixed Units, 1=Fixed Duration, 2=Fixed Work.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="IsNull" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies whether the task is null.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="CreateDate" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The date that the task was created.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Contact" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The contact person for the task.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="WBS" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The work breakdown structure code of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="WBSLevel" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The rightmost WBS level of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OutlineNumber" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The outline number of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="OutlineLevel" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The outline level of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Priority" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The priority of the task from 0 to 1000.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Start" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The scheduled start date of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Finish" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The scheduled finish date of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Duration" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The planned duration of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="DurationFormat" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The format for expressing the Duration of the Task.
                                Values are: 3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo, 19=%,
                                20=e%, 21=null, 35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?, 42=ew?,
                                43=mo?, 44=emo?, 51=%?, 52=e%? and 53=null.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="3" />
                                    <xsd:enumeration value="4" />
                                    <xsd:enumeration value="5" />
                                    <xsd:enumeration value="6" />
                                    <xsd:enumeration value="7" />
                                    <xsd:enumeration value="8" />
                                    <xsd:enumeration value="9" />
                                    <xsd:enumeration value="10" />
                                    <xsd:enumeration value="11" />
                                    <xsd:enumeration value="12" />
                                    <xsd:enumeration value="19" />
                                    <xsd:enumeration value="20" />
                                    <xsd:enumeration value="21" />
                                    <xsd:enumeration value="35" />
                                    <xsd:enumeration value="36" />
                                    <xsd:enumeration value="37" />
                                    <xsd:enumeration value="38" />
                                    <xsd:enumeration value="39" />
                                    <xsd:enumeration value="40" />
                                    <xsd:enumeration value="41" />
                                    <xsd:enumeration value="42" />
                                    <xsd:enumeration value="43" />
                                    <xsd:enumeration value="44" />
                                    <xsd:enumeration value="51" />
                                    <xsd:enumeration value="52" />
                                    <xsd:enumeration value="53" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Work" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of scheduled work for the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Stop" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The date that the task was stopped.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Resume" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The date that the task resumed.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ResumeValid" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task can be resumed.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="EffortDriven" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is effort-driven.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Recurring" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is a recurring task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OverAllocated" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is overallocated.
                                This element is informational only.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Estimated" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is estimated.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Milestone" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is a milestone.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Summary" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is a summary task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Critical" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is in the critical chain.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="IsSubproject" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is an inserted project.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="IsSubprojectReadOnly" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the inserted project is read-only.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="SubprojectName" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The source location of the inserted project.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="ExternalTask" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is external.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ExternalTaskProject" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The source location and task identifier of the external task.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="EarlyStart" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The early start date of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="EarlyFinish" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The early finish date of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="LateStart" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The late start date of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="LateFinish" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The late finish date of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="StartVariance" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The variance of the task start date from
                                the baseline start date as minutes x 1000.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="FinishVariance" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The variance of the task finish date from
                                the baseline finish date as minutes x 1000.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="WorkVariance" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The variance of task work from the baseline
                                task work as minutes x 1000.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="FreeSlack" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of free slack.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="TotalSlack" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of total slack.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="FixedCost" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The fixed cost of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="FixedCostAccrual" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>How the fixed cost is accrued against the task.
                                Values are: 1=Start, 2=Prorated and 3=End.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                    <xsd:enumeration value="3" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="PercentComplete" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The percentage of the task duration completed.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="PercentWorkComplete" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The percentage of the task work completed.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Cost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The projected or scheduled cost of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OvertimeCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The sum of the actual and remaining overtime cost of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OvertimeWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of overtime work scheduled for the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualStart" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual start date of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualFinish" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual finish date of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualDuration" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual duration of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual cost of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualOvertimeCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual overtime cost of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual work for the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualOvertimeWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual overtime work for the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RegularWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of non-overtime work scheduled for the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingDuration" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of time required to complete the unfinished portion of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The remaining projected cost of completing the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The remaining work scheduled to complete the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingOvertimeCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The remaining overtime cost projected to finish the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingOvertimeWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The remaining overtime work scheduled to finish the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ACWP" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual cost of work performed on the task to-date.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="CV" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Earned value cost variance.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ConstraintType" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The constraint on the start or finish date of the task.
                                Values are: 0=As Soon As Possible, 1=As Late As Possible, 2=Must Start On, 3=Must Finish On,
                                4=Start No Earlier Than, 5=Start No Later Than, 6=Finish No Earlier Than and 7=Finish No Later Than
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                    <xsd:enumeration value="3" />
                                    <xsd:enumeration value="4" />
                                    <xsd:enumeration value="5" />
                                    <xsd:enumeration value="6" />
                                    <xsd:enumeration value="7" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="CalendarUID" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The task calendar.Refers to a valid UID in the Calendars element of
                                the Microsoft Project XML Schema.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ConstraintDate" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The date argument for the task constraint type.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Deadline" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The deadline for the task to be completed.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="LevelAssignments" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether leveling can adjust assignments.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="LevelingCanSplit" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether leveling can split the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="LevelingDelay" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The delay caused by leveling the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="LevelingDelayFormat" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The format for expressing the duration of the delay.
                                Values are: 3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo, 19=%,
                                20=e%, 21=null, 35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?, 42=ew?,
                                43=mo?, 44=emo?, 51=%?, 52=e%? and 53=null.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="3" />
                                    <xsd:enumeration value="4" />
                                    <xsd:enumeration value="5" />
                                    <xsd:enumeration value="6" />
                                    <xsd:enumeration value="7" />
                                    <xsd:enumeration value="8" />
                                    <xsd:enumeration value="9" />
                                    <xsd:enumeration value="10" />
                                    <xsd:enumeration value="11" />
                                    <xsd:enumeration value="12" />
                                    <xsd:enumeration value="19" />
                                    <xsd:enumeration value="20" />
                                    <xsd:enumeration value="21" />
                                    <xsd:enumeration value="35" />
                                    <xsd:enumeration value="36" />
                                    <xsd:enumeration value="37" />
                                    <xsd:enumeration value="38" />
                                    <xsd:enumeration value="39" />
                                    <xsd:enumeration value="40" />
                                    <xsd:enumeration value="41" />
                                    <xsd:enumeration value="42" />
                                    <xsd:enumeration value="43" />
                                    <xsd:enumeration value="44" />
                                    <xsd:enumeration value="51" />
                                    <xsd:enumeration value="52" />
                                    <xsd:enumeration value="53" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="PreLeveledStart" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The start date of the task before it was leveled.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="PreLeveledFinish" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The finish date of the task before it was leveled.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Hyperlink" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The title of the hyperlink associated with the task.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="HyperlinkAddress" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The hyperlink associated with the task.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="HyperlinkSubAddress" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The document bookmark of the hyperlink associated with the task.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="IgnoreResourceCalendar" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task ignores the resource calendar.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Notes" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Text notes associated with the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="HideBar" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the GANTT bar of the task is hidden when displayed in Microsoft Project.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Rollup" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the task is rolled up.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="BCWS" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The budgeted cost of work scheduled for the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="BCWP" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The budgeted cost of work performed on the task to-date.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="PhysicalPercentComplete" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The percentage complete value entered by the Project Manager.
                                This can be used as an alternative for calculating BCWP.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="EarnedValueMethod" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The method for calculating earned value.
                                Values are: 0=Percent Complete, 1=Physical Percent Complete
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="PredecessorLink" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>Defines the predecessor task of the task that contains it.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="PredecessorUID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique identifier of the predecessor task.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Type" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The link type.  Values are 0=FF, 1=FS, 2=SF and 3=SS
                                            </xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:simpleType>
                                            <xsd:restriction base="xsd:integer">
                                                <xsd:enumeration value="0" />
                                                <xsd:enumeration value="1" />
                                                <xsd:enumeration value="2" />
                                                <xsd:enumeration value="3" />
                                            </xsd:restriction>
                                        </xsd:simpleType>
                                    </xsd:element>
                                    <xsd:element name="CrossProject" type="xsd:boolean" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>Whether the predecessor is part of another project.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="CrossProjectName" type="xsd:string" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The external predecessor project.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="LinkLag" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The amount of lag in tenths of a minute.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="LagFormat" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The format for expressing the lag format.
                                            Values are: 3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo, 19=%,
                                            20=e%, 35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?, 42=ew?, 43=mo?,
                                            44=emo?, 51=%? and 52=e%?
                                            </xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:simpleType>
                                            <xsd:restriction base="xsd:integer">
                                                <xsd:enumeration value="3" />
                                                <xsd:enumeration value="4" />
                                                <xsd:enumeration value="5" />
                                                <xsd:enumeration value="6" />
                                                <xsd:enumeration value="7" />
                                                <xsd:enumeration value="8" />
                                                <xsd:enumeration value="9" />
                                                <xsd:enumeration value="10" />
                                                <xsd:enumeration value="11" />
                                                <xsd:enumeration value="12" />
                                                <xsd:enumeration value="19" />
                                                <xsd:enumeration value="20" />
                                                <xsd:enumeration value="35" />
                                                <xsd:enumeration value="36" />
                                                <xsd:enumeration value="37" />
                                                <xsd:enumeration value="38" />
                                                <xsd:enumeration value="39" />
                                                <xsd:enumeration value="40" />
                                                <xsd:enumeration value="41" />
                                                <xsd:enumeration value="42" />
                                                <xsd:enumeration value="43" />
                                                <xsd:enumeration value="44" />
                                                <xsd:enumeration value="51" />
                                                <xsd:enumeration value="52" />
                                                <xsd:enumeration value="53" />
                                            </xsd:restriction>
                                        </xsd:simpleType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="ActualWorkProtected" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies the duration through which actual work is protected.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualOvertimeWorkProtected" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies the duration through which actual overtime work is protected.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ExtendedAttribute" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>The value of an extended attribute.  Two pieces of data are necessary -
                                a pointer back to the extended attribute table which is specified either by the unique ID or
                                the Field ID, and the value which is specified either with the value, or a pointer back to the value list.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="UID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique ID of the value in the extended attribute collection.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="FieldID" type="xsd:string" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The PID of the custom field.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Value" type="xsd:string" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The actual value of the extended attribute.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="ValueID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The ID of the value in the extended attribut lookup table.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="DurationFormat" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The format for expressing the bulk duration.
                                            Values are: 3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo,
                                            19=%, 20=e%, 21=null, 35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?,
                                            42=ew?, 43=mo?, 44=emo?, 51=%?, 52=e%? and 53=null.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:simpleType>
                                            <xsd:restriction base="xsd:integer">
                                                <xsd:enumeration value="3" />
                                                <xsd:enumeration value="4" />
                                                <xsd:enumeration value="5" />
                                                <xsd:enumeration value="6" />
                                                <xsd:enumeration value="7" />
                                                <xsd:enumeration value="8" />
                                                <xsd:enumeration value="9" />
                                                <xsd:enumeration value="10" />
                                                <xsd:enumeration value="11" />
                                                <xsd:enumeration value="12" />
                                                <xsd:enumeration value="19" />
                                                <xsd:enumeration value="20" />
                                                <xsd:enumeration value="21" />
                                                <xsd:enumeration value="35" />
                                                <xsd:enumeration value="36" />
                                                <xsd:enumeration value="37" />
                                                <xsd:enumeration value="38" />
                                                <xsd:enumeration value="39" />
                                                <xsd:enumeration value="40" />
                                                <xsd:enumeration value="41" />
                                                <xsd:enumeration value="42" />
                                                <xsd:enumeration value="43" />
                                                <xsd:enumeration value="44" />
                                                <xsd:enumeration value="51" />
                                                <xsd:enumeration value="52" />
                                                <xsd:enumeration value="53" />
                                            </xsd:restriction>
                                        </xsd:simpleType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="Baseline" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>The collection of baseline values of the task.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="TimephasedData" type="TimephasedDataType" minOccurs="0" maxOccurs="unbounded">
                                        <xsd:annotation>
                                            <xsd:documentation>The time phased data block associated with the task baseline.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Number" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique number of the baseline data record.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Interim" type="xsd:boolean" default="false" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>Whether this is an Interim Baseline.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Start" type="xsd:dateTime" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The scheduled start date of the task when the baseline was saved.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Finish" type="xsd:dateTime" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The scheduled finish date of the task when the baseline was saved.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Duration" type="xsd:duration" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The scheduled duration of the task when the baseline was saved.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="DurationFormat" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The format for expressing the Duration of the Task baseline.
                                            Values are: 3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo, 19=%, 20=e%,
                                            21=null, 35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?, 42=ew?, 43=mo?, 44=emo?,
                                            51=%?, 52=e%? and 53=null.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:simpleType>
                                            <xsd:restriction base="xsd:integer">
                                                <xsd:enumeration value="3" />
                                                <xsd:enumeration value="4" />
                                                <xsd:enumeration value="5" />
                                                <xsd:enumeration value="6" />
                                                <xsd:enumeration value="7" />
                                                <xsd:enumeration value="8" />
                                                <xsd:enumeration value="9" />
                                                <xsd:enumeration value="10" />
                                                <xsd:enumeration value="11" />
                                                <xsd:enumeration value="12" />
                                                <xsd:enumeration value="19" />
                                                <xsd:enumeration value="20" />
                                                <xsd:enumeration value="21" />
                                                <xsd:enumeration value="35" />
                                                <xsd:enumeration value="36" />
                                                <xsd:enumeration value="37" />
                                                <xsd:enumeration value="38" />
                                                <xsd:enumeration value="39" />
                                                <xsd:enumeration value="40" />
                                                <xsd:enumeration value="41" />
                                                <xsd:enumeration value="42" />
                                                <xsd:enumeration value="43" />
                                                <xsd:enumeration value="44" />
                                                <xsd:enumeration value="51" />
                                                <xsd:enumeration value="52" />
                                                <xsd:enumeration value="53" />
                                            </xsd:restriction>
                                        </xsd:simpleType>
                                    </xsd:element>
                                    <xsd:element name="EstimatedDuration" type="xsd:boolean" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>Whether the baseline duration of the task was estimated.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Work" type="xsd:duration" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The scheduled work of the task when the baseline was saved.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Cost" type="xsd:decimal" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The projected cost of the task when the baseline was saved.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="BCWS" type="xsd:float" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The budgeted cost of work scheduled for the task.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="BCWP" type="xsd:float" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The budgeted cost of work performed on the task to-date.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="OutlineCode" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>The value of an outline code.  Two pieces of data are necessary -
                                a pointer back to the outline code table which is specified either by the unique ID or the Field ID,
                                and the value which is specified either with the value, or a pointer back to the value list.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="UID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique ID of the value in the outline code collection.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="FieldID" type="xsd:string" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The field ID in the localised language.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="ValueID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique ID in the value list associated with the definition in the
                                            outline code collection.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="TimephasedData" type="TimephasedDataType" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>The time phased data block associated with the task.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                    </xsd:sequence>
                </xsd:complexType>
            </xsd:element>
        </xsd:sequence>
    </xsd:complexType>
</xsd:element>


Estructura XML del elemento <Task>

Estructura XML del elemento <Task>

A continuación se detalla la estructura del elemento <Task> para Microsoft Office Project 2003, que es un elemento secundario del elemento <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <Project>

Esquema XML del elemento <Task>

Estructura

<Project>
      . . .
      <Tasks>
            <Task>
                  <UID/>
                  <ID/>
                  <Name/>
                  <Type/>
                  <IsNull/>
                  <CreateDate/>
                  <Contact/>
                  <WBS/>
                  <WBSLevel/>
                  <OutlineNumber/>
                  <OutlineLevel/>
                  <Priority/>
                  <Start/>
                  <Finish/>
                  <Duration/>
                  <DurationFormat/>
                  <Work/>
                  <Stop/>
                  <Resume/>
                  <ResumeValid/>
                  <EffortDriven/>
                  <Recurring/>
                  <OverAllocated/>
                  <Estimated/>
                  <Milestone/>
                  <Summary/>
                  <Critical/>
                  <IsSubproject/>
                  <IsSubprojectReadOnly/>
                  <SubprojectName/>
                  <ExternalTask/>
                  <ExternalTaskProject/>
                  <EarlyStart/>
                  <EarlyFinish/>
                  <LateStart/>
                  <LateFinish/>
                  <StartVariance/>
                  <FinishVariance/>
                  <WorkVariance/>
                  <FreeSlack/>
                  <TotalSlack/>
                  <FixedCost/>
                  <FixedCostAccrual/>
                  <PercentComplete/>
                  <PercentWorkComplete/>
                  <Cost/>
                  <OvertimeCost/>
                  <OvertimeWork/>
                  <ActualStart/>
                  <ActualFinish/>
                  <ActualDuration/>
                  <ActualCost/>
                  <ActualOvertimeCost/>
                  <ActualWork/>
                  <ActualOvertimeWork/>
                  <RegularWork/>
                  <RemainingDuration/>
                  <RemainingCost/>
                  <RemainingWork/>
                  <RemainingOvertimeCost/>
                  <RemainingOvertimeWork/>
                  <ACWP/>
                  <CV/>
                  <ConstraintType/>
                  <CalendarUID/>
                  <ConstraintDate/>
                  <Deadline/>
                  <LevelAssignments/>
                  <LevelingCanSplit/>
                  <LevelingDelay/>
                  <LevelingDelayFormat/>
                  <PreLeveledStart/>
                  <PreLeveledFinish/>
                  <Hyperlink/>
                  <HyperlinkAddress/>
                  <HyperlinkSubAddress/>
                  <IgnoreResourceCalendar/>
                  <Notes/>
                  <HideBar/>
                  <Rollup/>
                  <BCWS/>
                  <BCWP/>
                  <PhysicalPercentComplete/>
                  <EarnedValueMethod/>
                  <PredecessorLink>
                        <PredecessorUID/>
                        <Type/>
                        <CrossProject/>
                        <CrossProjectName/>
                        <LinkLag/>
                        <LagFormat/>
                  </PredecessorLink>
                  <ActualWorkProtected/>
                  <ActualOvertimeWorkProtected/>
                  <ExtendedAttribute>
                        <UID/>
                        <FieldID/>
                        <Value/>
                        <ValueID/>
                        <DurationFormat/>
                  </ExtendedAttribute>
                  <Baseline>
                        <TimephasedData>
                              <Type/>
                              <UID/>
                              <Start/>
                              <Finish/>
                              <Unit/>
                              <Value/>
                        </TimephasedData>
                        <Number/>
                        <Interim/>
                        <Start/>
                        <Finish/>
                        <Duration/>
                        <DurationFormat/>
                        <EstimatedDuration/>
                        <Work/>
                        <Cost/>
                        <BCWS/>
                        <BCWP/>
                  </Baseline>
                  <OutlineCode>
                        <UID/>
                        <FieldID/>
                        <ValueID/>
                  </OutlineCode>
                  <TimephasedData>
                        <Type/>
                        <UID/>
                        <Start/>
                        <Finish/>
                        <Unit/>
                        <Value/>
                  </TimephasedData>
            </Task>
      </Tasks>
      . . .
</Project>


<ActualCost> (elemento)

<ActualCost> (elemento)

En el caso de un elemento <Task>, <ActualCost> se refiere a los costos contraídos por el trabajo realizado por todos los recursos en una tarea, junto con cualquier otro costo registrado que esté asociado a la tarea.

En el caso de un elemento <Resource>, se trata de la suma de los costos contraídos por el trabajo realizado por un recurso en todas las tareas asignadas.

En el caso de un elemento <Assignment>, es el costo en el que se ha incurrido por el trabajo ya realizado por un recurso en una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<ActualDuration> (elemento)

<ActualDuration> (elemento)

Duración del tiempo de trabajo real de una tarea hasta el momento, en función de la duración programada y del trabajo restante actual o porcentaje completado. La duración real se puede calcular de dos maneras, según el porcentaje completado o la duración restante.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<ActualFinish> (elemento)

<ActualFinish> (elemento)

En el caso de un elemento <Task>, <ActualFinish> se refiere a la fecha y hora en que se finaliza una tarea realmente.

En el caso de un elemento <Assignment>, se trata de la fecha y hora en que se ha completado realmente una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>


<ActualOvertimeCost> (elemento)

<ActualOvertimeCost> (elemento)

En el caso de un elemento <Task>, <ActualOvertimeCost> se refiere a los costos en los que se ha incurrido por el trabajo de horas extra ya realizado en una tarea por todos los recursos asignados.

En el caso de un elemento <Resource>, se trata del costo en el que se ha incurrido por el trabajo de horas extra ya realizado por un recurso en todas las tareas asignadas.

En el caso de un elemento <Assignment>, se refiere al costo en el que se ha incurrido por el trabajo de horas extra ya realizado por un recurso en una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<ActualOvertimeWork> (elemento)

<ActualOvertimeWork> (elemento)

En el caso de un elemento <Task>, <ActualOvertimeWork> se refiere a la cantidad real de trabajo de horas extra ya realizado por todos los recursos asignados a una tarea.

En el caso de un elemento <Resource>, se refiere a la cantidad real de trabajo de horas extra ya realizado por todas las asignaciones asignadas a un recurso.

En el caso de un elemento <Assignment>, se trata de la cantidad real de trabajo de horas extra ya realizado por un recurso en una tarea asignada.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<ActualStart> (elemento)

<ActualStart> (elemento)

En el caso de un elemento <Task>, <ActualStart> indica la fecha y hora en la que ha comenzado una tarea realmente.

En el caso de un elemento <Assignment>, se trata de la fecha y hora en la que ha comenzado una asignación realmente.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>


<ActualWork> (elemento)

<ActualWork> (elemento)

En el caso de un elemento <Task>, <ActualWork> indica la cantidad de trabajo que ya han realizado los recursos asignados a una tarea.

En el caso de un elemento <Resource>, es la cantidad real de trabajo que ya se ha realizado en todas las asignaciones de un recurso.

En el caso de un elemento <Assignment>, es la cantidad total de trabajo programado que un recurso ha realizado en una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<ACWP> (elemento)

<ACWP> (elemento)

CRTR es el costo real del trabajo realizado hasta la fecha de estado del proyecto o la fecha actual.

En el caso de un elemento <Task>, <ACWP> se refiere a los costos en los que se incurre por el trabajo ya realizado en una tarea.

En el caso de un elemento <Resource>, indica la suma de los valores CRTR para todas las asignaciones de un recurso.

En el caso de un elemento <Assignment>, se refiere a los costos en los que se ha incurrido por el trabajo ya realizado por un recurso en una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<Baseline> (elemento)

<Baseline> (elemento)

Conjunto de valores de línea de base asociados a la tarea, el recurso o la asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>

Mostrar Elementos secundarios para <Task>

Lista de elementos secundarios de <Baseline> para <Task>

Elemento | Requerido/Opcional | Descripción
<TimephasedData> | Opcional | Bloque de datos de fase temporal asociado a la línea de base de la tarea.
<Number> | Requerido | Número exclusivo del registro de datos de línea de base.
<Interim> | Opcional | Indica si la línea de base es una línea de base provisional.
<Start> | Opcional | Fecha de comienzo programada de la tarea al guardar la línea de base.
<Finish> | Opcional | Fecha de fin programada de la tarea al guardar la línea de base.
<Duration> | Opcional | Duración programada de la tarea al guardar la línea de base.
<DurationFormat> | Opcional | Formato para expresar la duración de la línea de base de la tarea.
<EstimatedDuration> | Opcional | Indica si la duración de la tarea es estimada.
<Work> | Opcional | Trabajo programado de la tarea al guardar la línea de base.
<Cost> | Opcional | Costo previsto de la tarea al guardar la línea de base.
<BCWS> | Opcional | Costos de línea de base de fase temporal acumulados hasta la fecha de estado o la fecha actual; también se conoce como costo presupuestado del trabajo programado.
<BCWP> | Opcional | Valor acumulado del porcentaje completado de fase temporal de la tarea multiplicado por el costo previsto de fase temporal de la tarea hasta la fecha de estado o la fecha actual; también se denomina costo presupuestado del trabajo realizado.

Mostrar Elementos secundarios para <Resource>

Lista de elementos secundarios de <Baseline> para <Resource>

Elemento | Requerido/Opcional | Descripción
<Number> | Requerido | Número exclusivo del registro de datos de línea de base.
<Work> | Opcional | Trabajo asignado al recurso al guardar la línea de base.
<Cost> | Opcional | Costo previsto del recurso al guardar la línea de base.
<BCWS> | Opcional | Costo presupuestado del trabajo programado para el recurso.
<BCWP> | Opcional | Costo presupuestado del trabajo realizado por el recurso en el proyecto hasta la fecha.

Mostrar Elementos secundarios para <Assignment>

Lista de elementos secundarios de <Baseline> para <Assignment>

Elemento | Requerido/Opcional | Descripción
<TimephasedData> | Opcional | Bloque de datos asociado a la línea de base de la tarea.
<Number> | Requerido | Número exclusivo del registro de datos de línea de base.
<Start> | Opcional | Fecha de comienzo programada de la asignación al guardar la línea de base.
<Finish> | Opcional | Fecha de fin programada de la asignación al guardar la línea de base.
<Work> | Opcional | Cantidad total de trabajo programado en la asignación al guardar la línea de base.
<Cost> | Opcional | Costo total previsto de la asignación al guardar la línea de base.
<BCWS> | Opcional | Costo presupuestado del trabajo programado en la asignación.
<BCWP> | Opcional | Costo presupuestado del trabajo realizado hasta la fecha en la asignación.


<BCWP> (elemento)

<BCWP> (elemento)

CPTR indica el costo presupuestado del trabajo realizado.

En el caso de un elemento <Task>, indica el valor acumulado del porcentaje completado de fase temporal de la tarea multiplicado por el costo provisional de fase temporal de la tarea, hasta la fecha de estado o la fecha actual.

En el caso de un elemento <Resource>, consiste en el resumen de los valores CPTR de un recurso para todas las tareas asignadas, calculado hasta la fecha de estado o la fecha actual.

En el caso de un elemento <Assignment>, se trata del costo presupuestado del trabajo realizado en la asignación hasta la fecha.

En el caso de un elemento <Baseline> de <Task>, indica el valor acumulado del porcentaje completado de fase temporal de la tarea multiplicado por el costo provisional de fase temporal de la tarea, hasta la fecha de estado o la fecha actual.

En el caso de un elemento <Baseline> de <Resource>, se trata del costo presupuestado del trabajo realizado por el recurso en el proyecto hasta la fecha.

En el caso de un elemento <Baseline> de <Assignment>, se trata del costo presupuestado del trabajo realizado en la asignación hasta la fecha.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>
<Baseline>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Esquema XML del elemento <Resource>
Estructura XML del elemento <Resource>

Esquema XML del elemento <Assignment>
Estructura XML del elemento <Assignment>

<Baseline> (elemento)
<BCWS> (elemento)
<PhysicalPercentComplete> (elemento)


<BCWS> (elemento)

<BCWS> (elemento)

CPTP es el costo presupuestado del trabajo programado.

En el caso de un elemento <Task>, indica los costos de fase temporal acumulados hasta la fecha de estado o la fecha actual.

En el caso de un elemento <Resource>, se trata del resumen de los valores CPTP de un recurso para todas las tareas asignadas.

En el caso de un elemento <Assignment>, es el costo presupuestado del trabajo en la asignación.

En el caso de un elemento <Baseline> de <Task>, indica los costos de fase temporal acumulados hasta la fecha de estado o la fecha actual.

En el caso de un elemento <Baseline> de <Resource>, es el costo presupuestado del trabajo realizado por el recurso.

En el caso de un elemento <Baseline> de <Assignment>, es el costo presupuestado del trabajo en la asignación hasta la fecha.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>
<Baseline>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Esquema XML del elemento <Resource>
Estructura XML del elemento <Resource>

Esquema XML del elemento <Assignment>
Estructura XML del elemento <Assignment>

<Baseline> (elemento)
<BCWP> (elemento)


<ConstraintDate> (elemento)

<ConstraintDate> (elemento)

Indica la fecha de comienzo o de fin delimitado según se define en la tarea <ConstraintType>. Necesario a menos que el tipo de delimitación esté definido como Lo más tarde posible o Lo antes posible.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>

Mostrar Vea también

<ConstraintType> (elemento)


<ConstraintType> (elemento)

<ConstraintType> (elemento)

Delimitación en la fecha de comienzo o de fin de la tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Lo antes posible
1 | Lo más tarde posible
2 | Debe comenzar el
3 | Debe finalizar el
4 | No comenzar antes del
5 | No comenzar después del
6 | No finalizar antes del
7 | No finalizar después del
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

<ConstraintDate> (elemento)

Notas

Precisa que <ConstraintDate> se encuentre definido en la misma tarea, a menos que <ConstraintType> esté definido en 0 o 1.


<Contact> (elemento)

<Contact> (elemento)

Nombre del responsable de una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Cost> (elemento)

<Cost> (elemento)

En el caso de un elemento <Task>, <Cost> se refiere al costo total programado, o previsto, de una tarea basado en los costos contraídos por el trabajo realizado por todos los recursos asignados a la tarea y en los costos planeados para el trabajo restante de la asignación.

En el caso de un elemento <Task>, <Cost> indica el costo programado total de un recurso para todas las tareas asignadas, basado en los costos contraídos por el trabajo realizado por el recurso en todas las tareas asignadas, además de los costos planeados del trabajo restante.

En el caso de un elemento <Assignment>, se trata del costo total programado de la asignación cuando se guarda la línea de base.

En el caso de un elemento <Baseline>, indica el costo total programado (o previsto) de una asignación, en función de los costos contraídos por el trabajo realizado por el recurso en una tarea y los costos planeados para el trabajo restante de la asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>
<Baseline>

Mostrar Vea también

<Baseline> (elemento)


<CreateDate> (elemento)

<CreateDate> (elemento)

Fecha y hora en que se agregó una tarea a un proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Critical> (elemento)

<Critical> (elemento)

Indica si una tarea puede posponerse según la programación o si está en la ruta crítica.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<CrossProject> (elemento)

<CrossProject> (elemento)

Indica si la tarea predecesora forma parte de otro proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<PredecessorLink>


<CrossProjectName> (elemento)

<CrossProjectName> (elemento)

Proyecto predecesor externo.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<PredecessorLink>


<CV> (elemento)

<CV> (elemento)

Los campos VC (variación de costo) muestran la diferencia entre lo que debería haber costado conseguir el nivel de conclusión y lo que ha costado realmente hasta la fecha de estado o la fecha actual.

En el caso de un elemento <Task>, <CV> indica la variación de costo que se ha aplicado a una tarea.

En el caso de un elemento <Resource>, se refiere a la variación de costo aplicado a un recurso.

En el caso de un elemento <Assignment>, es la variación de costo que se aplica a una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<Deadline> (elemento)

<Deadline> (elemento)

Fecha especificada como fecha límite de la tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Duration> (elemento)

<Duration> (elemento)

En el caso de un elemento <Task>, <Duration> representa el período de tiempo total de trabajo activo.

En el caso de un elemento <Baseline> de una tarea, indica la duración programada de la tarea cuando se guarda la línea de base.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | TimeSpan
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Baseline>
<Assignment>

Mostrar Vea también

<Baseline> (elemento)


<EarlyFinish> (elemento)

<EarlyFinish> (elemento)

Fecha más próxima en la que una tarea puede finalizar en función de las fechas de fin anticipado de las tareas predecesoras y sucesoras, de otras delimitaciones y de cualquier retraso por redistribución.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<EarlyStart> (elemento)

<EarlyStart> (elemento)

Fecha más próxima en la que una tarea puede comenzar en función de las fechas de comienzo anticipado de las tareas predecesoras y sucesoras y de otras delimitaciones.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<EffortDriven> (elemento)

<EffortDriven> (elemento)

Indica si la programación de una tarea está condicionada por el esfuerzo.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Estimated> (elemento)

<Estimated> (elemento)

Indica si la duración de la tarea está marcada como una estimación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<EstimatedDuration> (elemento)

<EstimatedDuration> (elemento)

Indica si la duración prevista de la tarea es estimada.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Baseline>


<ExternalTask> (elemento)

<ExternalTask> (elemento)

Indica si la tarea está vinculada desde otro proyecto o si tiene su origen en el proyecto actual.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<ExternalTaskProject> (elemento)

<ExternalTaskProject> (elemento)

Origen de una tarea externa.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Finish> (elemento)

<Finish> (elemento)

En el caso de un elemento <Task>, <Finish> indica la fecha y la hora en que se ha programado que se complete una tarea.

En el caso de un elemento <Resource>, se trata de la fecha y la hora en que se ha programado que se complete una tarea.

En el caso de un elemento <Assignment>, se trata de la fecha y la hora en que se ha programado que se complete una tarea.

En el caso de un elemento <Baseline>, indica la fecha de fin programada para la tarea, el recurso o la asignación al guardar la línea de base.

En el caso de un elemento <TimephasedData>, <Finish> es la fecha de fin del período de datos de fase temporal de la tarea, el recurso, la asignación o la línea de base.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>
<Baseline>
<TimephasedData>

Mostrar Vea también

Estructura y esquema XML del elemento <TimephasedDataType>


<FinishVariance> (elemento)

<FinishVariance> (elemento)

En el caso de un elemento <Task>, <FinishVariance> es la cantidad de tiempo que representa la diferencia entre la fecha de fin prevista y la fecha de fin actual de una tarea.

En el caso de un elemento <Assignment>, es la diferencia entre la fecha de fin prevista y la fecha de fin programada de una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>


<FixedCost> (elemento)

<FixedCost> (elemento)

Gasto de tareas no asociado a un costo de recursos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<FixedCostAccrual> (elemento)

<FixedCostAccrual> (elemento)

Indica cómo se cargan o acumulan los costos fijos al costo de una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
1 | Comienzo; los costos se acumulan en cuanto comienza la tarea, como se indica por la fecha especificada en el campo Comienzo real.
2 | Prorrateo (predeterminado); los costos se acumulan cuando, según la programación, se va a realizar el trabajo y a medida que se informa del trabajo real.
3 | Fin; no se incurre en costos hasta que el trabajo restante sea cero.
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<FreeSlack> (elemento)

<FreeSlack> (elemento)

Cantidad de tiempo que se puede retrasar una tarea sin que se retrase ninguna tarea sucesora. Si la tarea no tiene sucesoras, la demora permisible es la cantidad de tiempo que se puede retrasar sin que se retrase la fecha de fin de todo el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<HideBar> (elemento)

<HideBar> (elemento)

Indica si las barras de Gantt y de calendario de una tarea están ocultas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Hyperlink> (elemento)

<Hyperlink> (elemento)

El título o el texto explicativo de un hipervínculo asociado a una tarea, un recurso o una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<HyperlinkAddress> (elemento)

<HyperlinkAddress> (elemento)

La dirección de un hipervínculo asociado a una tarea, un recurso o una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<HyperlinkSubAddress> (elemento)

<HyperlinkSubAddress> (elemento)

En el caso de un hipervínculo asociado a una tarea, un recurso o una asignación, el elemento <HyperlinkSubAddress> se refiere a una ubicación específica dentro de un documento.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<IgnoreResourceCalendar> (elemento)

<IgnoreResourceCalendar> (elemento)

Indica si la programación de la tarea tiene en cuenta los calendarios de los recursos asignados a la misma.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Interim> (elemento)

<Interim> (elemento)

Indica si la línea de base es una línea de base provisional de una tarea, un recurso o una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | False
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Baseline>


<IsNull> (elemento)

<IsNull> (elemento)

Especifica si un elemento <Task> o <Resource> es nulo.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>
<Task>


<IsSubproject> (elemento)

<IsSubproject> (elemento)

Indica si la tarea es un proyecto insertado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<IsSubprojectReadOnly> (elemento)

<IsSubprojectReadOnly> (elemento)

Indica si el proyecto insertado es de sólo lectura.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<LagFormat> (elemento)

<LagFormat> (elemento)

Formato de la posposición especificada en <LinkLag>.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Formato:
3 | m
4 | mt
5 | h
6 | ht
7 | d
8 | dt
9 | s
10 | st
11 | me
12 | met
19 | %
20 | %t
35 | m?
36 | mt?
37 | h?
38 | ht?
39 | d?
40 | dt?
41 | s?
42 | st?
43 | me?
44 | met?
51 | %?
52 | %t?
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<PredecessorLink>

Mostrar Vea también

<LinkLag> (elemento)


<LateFinish> (elemento)

<LateFinish> (elemento)

Fecha límite en que puede finalizar una tarea sin que se retrase el final del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<LateStart> (elemento)

<LateStart> (elemento)

Fecha límite en que puede comenzar una tarea sin que se retrase el final del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<LevelAssignments> (elemento)

<LevelAssignments> (elemento)

Indica si la función de redistribución puede retrasar y dividir asignaciones individuales (en vez de tareas enteras) para resolver las sobreasignaciones.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<LevelingCanSplit> (elemento)

<LevelingCanSplit> (elemento)

Indica si la función de redistribución de recursos puede ocasionar divisiones en el trabajo restante de una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<LevelingDelay> (elemento)

<LevelingDelay> (elemento)

En el caso de un elemento <Task>, <LevelingDelay> indica la cantidad de tiempo que se va a retrasar una tarea desde su fecha de comienzo anticipada con motivo de la redistribución de recursos.

En el caso de un elemento <Assignment>, es la cantidad total de trabajo programado que un recurso debe realizar en una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Esquema XML del elemento <Assignment>
Estructura XML del elemento <Assignment>

<LevelingDelayFormat> (elemento)

Notas

Un elemento <LevelingDelay> precisa que se especifique el elemento <LevelingDelayFormat>. Por ejemplo, un retraso de distribución de 3 días en una tarea se indicaría de la siguiente manera:

<Task>
     ...
   <LevelingDelay>3</LevelingDelay>
   <LevelingDelayFormat>7</LevelingDelayFormat>
     ...
</Task>


<LevelingDelayFormat> (elemento)

<LevelingDelayFormat> (elemento)

<LevelingDelayFormat> indica el formato para expresar la duración de <LevelingDelay> en una tarea o asignación.

Formato para expresar la duración del retraso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
3 | m
4 | mt
5 | h
6 | ht
7 | d
8 | dt
9 | s
10 | st
11 | me
12 | met
19 | %
20 | %t
21 | nulo
35 | m?
36 | mt?
37 | h?
38 | ht?
39 | d?
40 | dt?
41 | s?
42 | st?
43 | me?
44 | met?
51 | %?
52 | %t
53 | nulo
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Esquema XML del elemento <Assignment>
Estructura XML del elemento <Assignment>

Notas

Vea el tema <LevelingDelay> (elemento) para conocer un ejemplo.


<LinkLag> (elemento)

<LinkLag> (elemento)

Posposición en décimas de minuto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<PredecessorLink>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Notas

<LinkLag> precisa que <LagFormat> se especifique.


<Milestone> (elemento)

<Milestone> (elemento)

En el caso de un elemento <Task>, <Milestone> indica si una tarea es un hito.

En el caso de un elemento <Assignment>, indica si la tarea de la asignación es un hito.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>


<Notes> (elemento)

<Notes> (elemento)

Notas especificadas sobre una tarea, un recurso o una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<Number> (elemento)

<Number> (elemento)

Número exclusivo del registro de datos de línea de base de una tarea, un recurso o una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Baseline>


<OutlineLevel> (elemento)

<OutlineLevel> (elemento)

Número que indica el nivel de una tarea en la jerarquía de esquema del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

<OutlineNumber> (elemento)

Notas

Nota El elemento <OutlineLevel> es un número sencillo, como 2. <OutlineNumber> es una cadena que indica la posición de la tarea en la jerarquía del esquema, por ejemplo, "5.2.6".


<OutlineNumber> (elemento)

<OutlineNumber> (elemento)

Indica la posición exacta de una tarea en el esquema. Por ejemplo, "7.2" indica que una tarea es la segunda subtarea por debajo de la tarea de resumen de nivel superior séptima.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

<OutlineLevel> (elemento)

Notas

El elemento <OutlineNumber> es una cadena que indica la posición de la tarea en la jerarquía del esquema, por ejemplo, "5.2.6". <OutlineLevel> es un número sencillo, como el 2.


<Overallocated> (elemento)

<Overallocated> (elemento)

En el caso de un elemento <Task>, <Overallocated> indica si a un recurso asignado a una tarea se le ha asignado más trabajo del que se puede realizar en la tarea teniendo en cuenta una capacidad de trabajo normal.

En el caso de un elemento <Assignment>, <Overallocated> indica si un recurso está asignado a más trabajo en una tarea específica del que puede realizar a la capacidad normal de trabajo.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>


<OvertimeCost> (elemento)

<OvertimeCost> (elemento)

En el caso de un elemento <Task>, <OvertimeCost> es la suma del costo de trabajo de horas extra real de la tarea.

En el caso de un elemento <Resource>, es el costo total de horas extra de un recurso en todas las tareas asignadas.

En el caso de un elemento <Assignment>, es el costo total de horas extra de una asignación de recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<OvertimeWork> (elemento)

<OvertimeWork> (elemento)

En el caso de un elemento <Task>, <OvertimeWork> es la cantidad de horas extra programadas que deben realizar todos los recursos asignados a una tarea y que se cargarán a la tasa de horas extra.

En el caso de un elemento <Resource>, es la cantidad de horas extra que hay que realizar en todas las tareas asignadas a un recurso y cargadas a la tasa de horas extra de éste.

En el caso de un elemento <Assignment>, es la cantidad de horas extra que debe realizar un recurso en una tarea; cargadas a la tasa de horas extra de éste.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<PercentComplete> (elemento)

<PercentComplete> (elemento)

Porcentaje de la duración completada de la tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<PercentWorkComplete> (elemento)

<PercentWorkComplete> (elemento)

En el caso de un elemento <Task>, <PercentWorkComplete> es el estado actual de una tarea, expresado como porcentaje de trabajo finalizado de la tarea.

En el caso de un elemento <Resource>, es el estado actual de todas las tareas asignadas a un recurso, expresado como porcentaje total del trabajo del recurso que ha finalizado.

En el caso de un elemento <Assignment>, es el estado actual de una asignación, expresado como el porcentaje de trabajo finalizado de una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<PhysicalPercentComplete> (elemento)

<PhysicalPercentComplete> (elemento)

Porcentaje físico del trabajo total de una tarea que se ha completado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

<BCWP> (elemento)

Notas

<PhysicalPercentComplete> puede utilizarse como alternativa para calcular el elemento <BCWP> (coste presupuestado de trabajo realizado).


<PredecessorLink> (elemento)

<PredecessorLink> (elemento)

Define la tarea predecesora de la que depende esta tarea para su fecha de comienzo o de fin.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Task>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<PredecessorUID> | Opcional | Número de identificador exclusivo de la tarea predecesora.
<Type> | Opcional | Tipo del vínculo de la tarea predecesora (FF, FC, CF, CC).
<CrossProject> | Opcional | Indica si la tarea predecesora forma parte de otro proyecto.
<CrossProjectName> | Opcional | Proyecto predecesor externo.
<LinkLag> | Opcional | Período de posposición.
<LagFormat> | Opcional | Indica el formato de la posposición especificada en <LinkLag>.


<PredecessorUID> (elemento)

<PredecessorUID> (elemento)

El número de identificación exclusivo para la tarea predecesora de la que depende esta tarea para su fecha de comienzo y de fin.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<PredecessorLink>


<PreLeveledFinish> (elemento)

<PreLeveledFinish> (elemento)

Fecha de fin que tenía una tarea antes de que se realizase la redistribución de recursos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<PreLeveledStart> (elemento)

<PreLeveledStart> (elemento)

Fecha de comienzo que tenía una tarea antes de que se produjese la redistribución de recursos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Priority> (elemento)

<Priority> (elemento)

Indica el nivel de importancia asignado a una tarea, 500 significa prioridad normal. Cuanto más alto sea el número, mayor es la prioridad:

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Prioridad más baja; la tarea se redistribuirá siempre
1000 | Prioridad más alta; la tarea no se redistribuirá nunca
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Recurring> (elemento)

<Recurring> (elemento)

Indica si una tarea es una tarea repetitiva.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<RegularWork> (elemento)

<RegularWork> (elemento)

En el caso de un elemento <Task>, <RegularWork> indica la cantidad total de trabajo que no es de horas extra que deberán emplear todos los recursos asignados a una tarea.

En el caso de un elemento <Resource>, es la cantidad total de trabajo programado que no es de horas extra que se debe realizar en todas las asignaciones de un recurso.

En el caso de un elemento <Assignment>, es la cantidad total de trabajo programado que no es de horas extra que un recurso debe realizar en una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<RemainingCost> (element)

<RemainingCost> (element)

En el caso de un elemento <Task>, <RemainingCost> es el gasto programado restante de una tarea en el que incurrirán los recursos asignados a una tarea al finalizar el trabajo programado restante.

En el caso de un elemento <Resource>, es el gasto programado restante en el que se incurrirá para finalizar el trabajo restante asociado a un recurso.

En el caso de un elemento <Assignment>, indica los costos asociados a finalizar todo el trabajo programado restante por cualquiera de los recursos de una tarea concreta.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<RemainingDuration> (elemento)

<RemainingDuration> (elemento)

Período de tiempo necesario necesario para completar la parte no finalizada de una tarea. La duración restante se puede calcular de dos maneras, según el porcentaje completado o la duración real.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<RemainingOvertimeCost> (elemento)

<RemainingOvertimeCost> (elemento)

En el caso de un elemento <Task>, <RemainingOvertimeCost> es el gasto programado de horas extra restante para una tarea.

En el caso de un elemento <Resource>, es el gasto de horas extra programados restantes en que se incurrirá para que un recurso finalice el trabajo de horas extra planeado restante en todas las tareas asignadas.

En el caso de un elemento <Assignment>, es el gasto programado de horas extra restante de una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<RemainingOvertimeWork> (elemento)

<RemainingOvertimeWork> (elemento)

En el caso de un elemento <Task>, <RemainingOvertimeWork> es la cantidad de horas extra restante programadas para que todos los recursos asignados completen una tarea.

En el caso de un elemento <Resource>, es la cantidad de horas extra restante que precisa un recurso para finalizar todas las tareas.

En el caso de un elemento <Assignment>, es la cantidad de trabajo de horas extra pendiente en una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<RemainingWork> (elemento)

<RemainingWork> (elemento)

En el caso de un elemento <Task>, <RemainingWork> es la cantidad total de trabajo que no es de horas extra que realizarán todos los recursos asignados a una tarea.

En el caso de un elemento <Resource>, es la cantidad de tiempo, u horas por persona, que un recurso necesita para finalizar todas las tareas asignadas.

En el caso de un elemento <Assignment>, es la cantidad de tiempo que necesita un recurso asignado a una tarea para completar una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<Resume> (elemento)

<Resume> (elemento)

En el caso de un elemento <Task>, <Resume> es la fecha en la que está programado que la parte restante de una tarea se reanude.

En el caso de un elemento <Assignment>, es la fecha en la que se ha reanudado la asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>


<ResumeValid> (elemento)

<ResumeValid> (elemento)

Indica si la tarea se puede reanudar.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Rollup> (elemento)

<Rollup> (elemento)

Indica si la barra de tareas de resumen muestra barras resumidas o si la información de las barras de Gantt de las subtareas se resumirá en la barra de tareas de resumen.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>

Mostrar Vea también

Esquema XML del elemento <Task>
Estructura XML del elemento <Task>

Notas

<Rollup> debe definirse en True para que las subtareas se resuman en tareas de resumen.


<Start> (elemento)

<Start> (elemento)

En el caso de un elemento <Task>, <Start> es la fecha y hora programadas para que comience una tarea.

En el caso de un elemento <Resource>, es la fecha y hora programadas para que comience una tarea.

En el caso de un elemento <Assignment>, es la fecha y hora programadas para que comience una tarea.

En el caso de un elemento <Baseline>, es la fecha y hora de comienzo programadas para una tarea, un recurso o una asignación cuando se guarda la línea de base.

En el caso de un elemento <TimephasedData>, <Start> es la fecha y hora de comienzo del período de datos de fase temporal de la tarea, el recurso, la asignación o la línea de base.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>
<Baseline>
<TimephasedData>

Mostrar Vea también

Estructura y esquema XML del elemento <TimephasedDataType>


<StartVariance> (elemento)

<StartVariance> (elemento)

En el caso de un elemento <Task>, <StartVariance> indica la diferencia entre la fecha de comienzo prevista de una tarea y la fecha de comienzo programada actualmente.

En el caso de un elemento <Assignment>, es la diferencia entre la fecha de comienzo prevista de una asignación y la fecha de comienzo programada actualmente.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>


<Stop> (elemento)

<Stop> (elemento)

En el caso de un elemento <Task>, <Stop> es la fecha que representa el fin de la parte real de una tarea.

En el caso de un elemento <Assignment>, es la fecha en la que se ha detenido la asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Assignment>


<SubprojectName> (elemento)

<SubprojectName> (elemento)

Ubicación de origen del proyecto insertado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Summary> (elemento)

<Summary> (elemento)

Indica si una tarea es una tarea de resumen.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Task> (elemento)

<Task> (elemento)

Debe haber, al menos, una tarea en cada conjunto de éstas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Tasks>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<UID> | Requerido | Identificador exclusivo de la tarea.
<ID> | Opcional | Identificador de posición de la tarea en la lista de tareas.
<Name> | Opcional | Nombre de la tarea.
<Type> | Opcional | Tipo de tarea.
<IsNull> | Opcional | Indica si una tarea es nula.
<CreateDate> | Opcional | Fecha y hora en que se agregó una tarea a un proyecto.
<Contact> | Opcional | Nombre del responsable de una tarea.
<WBS> | Opcional | Código exclusivo (EDT) utilizado para representar la posición de una tarea dentro de la estructura jerárquica del proyecto.
<WBSLevel> | Opcional | Nivel situado más a la derecha de la tarea. Por ejemplo, si el nivel de la tarea era A.01.03, el nivel más a la derecha sería 03.
<OutlineNumber> | Opcional | Número que indica el nivel de una tarea en la jerarquía de esquema del proyecto.
<OutlineLevel> | Opcional | Indica la posición de una tarea en el esquema.
<Priority> | Opcional | Indica el nivel de importancia asignado a una tarea.
<Start> | Opcional | Fecha y hora en que se ha programado el comienzo de una tarea.
<Finish> | Opcional | Fecha y hora en que se ha programado la finalización de una tarea.
<Duration> | Opcional | Duración total del período laborable activo de una tarea.
<DurationFormat> | Opcional | Formato utilizado para mostrar la duración de la tarea.
<Work> | Opcional | Cantidad total de trabajo programado que todos los recursos asignados deben realizar en una tarea.
<Stop> | Opcional | Fecha que representa el final de la parte real de una tarea.
<Resume> | Opcional | Fecha en la que se ha programado la reanudación de la parte restante de una tarea.
<ResumeValid> | Opcional | Indica si la tarea se puede reanudar.
<EffortDriven> | Opcional | Indica si la programación de una tarea está condicionada por el esfuerzo.
<Recurring> | Opcional | Indica si una tarea es una tarea repetitiva.
<OverAllocated> | Opcional | Indica si un recurso asignado a una tarea tiene más trabajo asignado del que puede realizar a la capacidad normal de trabajo.
<Estimated> | Opcional | Indica si la duración de la tarea está marcada como una estimación.
<Milestone> | Opcional | Indica si una tarea es un hito.
<Summary> | Opcional | Indica si una tarea es una tarea de resumen.
<Critical> | Opcional | Indica si una tarea puede posponerse según la programación o si está en la ruta crítica.
<IsSubproject> | Opcional | Indica si la tarea es un proyecto insertado.
<IsSubprojectReadOnly> | Opcional | Indica si el proyecto insertado es de sólo lectura.
<SubprojectName> | Opcional | Ubicación de origen del proyecto insertado.
<ExternalTask> | Opcional | Indica si la tarea está vinculada desde otro proyecto o si tiene su origen en el proyecto actual.
<ExternalTaskProject> | Opcional | Origen de una tarea externa.
<EarlyStart> | Opcional | Fecha más próxima en la que una tarea puede comenzar en función de las fechas de comienzo anticipado de las tareas predecesoras y sucesoras y de otras delimitaciones.
<EarlyFinish> | Opcional | Fecha más próxima en la que una tarea puede finalizar en función de las fechas de fin anticipado de las tareas predecesoras y sucesoras, de otras delimitaciones y de cualquier retraso por redistribución.
<LateStart> | Opcional | Fecha límite en que puede comenzar una tarea sin que se retrase el final del proyecto.
<LateFinish> | Opcional | Fecha límite en que puede finalizar una tarea sin que se retrase el final del proyecto.
<StartVariance> | Opcional | Diferencia entre la fecha de comienzo prevista y la fecha de comienzo programada de una tarea.
<FinishVariance> | Opcional | Cantidad de tiempo que representa la diferencia entre la fecha de fin prevista y la fecha de fin actual de una tarea.
<WorkVariance> | Opcional | Diferencia entre el trabajo previsto y el trabajo programado de una tarea.
<FreeSlack> | Opcional | Cantidad de tiempo que se puede retrasar una tarea sin retrasar ninguna tarea sucesora.
<TotalSlack> | Opcional | Cantidad de tiempo que se puede retrasar una tarea sin que se retrase la fecha de fin de un proyecto.
<FixedCost> | Opcional | Gasto de tareas no asociado a un costo de recursos.
<FixedCostAccrual> | Opcional | Indica cómo se cargan o acumulan los costos fijos al costo de una tarea.
<PercentComplete> | Opcional | Estado actual de una tarea, expresado como el porcentaje de la duración de la misma que se ha completado.
<PercentWorkComplete> | Opcional | Estado actual de una tarea, expresado como el porcentaje del trabajo de la misma que se ha completado.
<Cost> | Opcional | Coste total programado o proyectado de una tarea.
<OvertimeCost> | Opcional | Suma del costo real de horas extra de la tarea.
<OvertimeWork> | Opcional | Cantidad programada de horas extra que deben realizar todos los recursos asignados a una tarea y que se carga a las tasas de horas extra.
<ActualStart> | Opcional | Fecha y hora en que una tarea ha comenzado realmente.
<ActualFinish> | Opcional | Fecha y hora en que una tarea ha finalizado realmente.
<ActualDuration> | Opcional | Duración del período laborable real de una tarea hasta ese momento, en función de la duración programada y del trabajo restante actual o del porcentaje completado.
<ActualCost> | Opcional | Costos contraídos por el trabajo realizado por todos los recursos en una tarea, junto con cualquier otro costo registrado que esté asociado a la tarea.
<ActualOvertimeCost> | Opcional | Costos contraídos por el trabajo de horas extra realizado en una tarea por todos los recursos asignados.
<ActualWork> | Opcional | Cantidad de trabajo realizado por los recursos asignados a una tarea.
<ActualOvertimeWork> | Opcional | Cantidad real de trabajo de horas extra realizado por todos los recursos asignados a una tarea.
<RegularWork> | Opcional | Cantidad total de trabajo programado que no es de horas extra que todos los recursos asignados a una tarea deben realizar.
<RemainingDuration> | Opcional | Cantidad total de trabajo programado que no es de horas extra que todos los recursos asignados a una tarea deben realizar.
<RemainingCost> | Opcional | Cantidad de tiempo necesaria para completar la parte sin finalizar de una tarea.
<RemainingWork> | Opcional | Gasto programado restante de una tarea que se contraerá al completar el trabajo programado restante por todos los recursos asignados a una tarea.
<RemainingOvertimeCost> | Opcional | Gasto de horas extra programado restante de una tarea.
<RemainingOvertimeWork> | Opcional | Cantidad de horas extra restante programada para que todos los recursos asignados completen una tarea.
<ACWP> | Opcional | Costos contraídos por el trabajo realizado en una tarea, hasta la fecha de estado del proyecto o la fecha actual.
<CV> | Opcional | Diferencia entre el costo necesario para alcanzar el nivel de finalización de la tarea actual y el costo real.
<ConstraintType> | Opcional | Delimitación en una tarea programada.
<CalendarUID> | Opcional | Hace referencia a un identificador válido en un calendario de Project.
<ConstraintDate> | Opcional | Indica la fecha de comienzo y de fin delimitadas tal y como se definen en TaskConstraintType.
<Deadline> | Opcional | Fecha especificada como fecha límite de la tarea.
<LevelAssignments> | Opcional | Indica si la función de redistribución puede retrasar y dividir asignaciones individuales (en vez de tareas enteras) para resolver las sobreasignaciones.
<LevelingCanSplit> | Opcional | Indica si la función de redistribución de recursos puede ocasionar divisiones en el trabajo restante de una tarea.
<LevelingDelay> | Opcional | Período de tiempo que va a retrasarse una tarea respecto a la fecha de comienzo anticipado como resultado de una redistribución de recursos.
<LevelingDelayFormat> | Opcional | Formato para expresar la duración del retraso.
<PreLeveledStart> | Opcional | Fecha de comienzo que tenía una tarea antes de que se produjese la redistribución de recursos.
<PreLeveledFinish> | Opcional | Fecha de fin que tenía una tarea antes de que se realizase la redistribución de recursos.
<Hyperlink> | Opcional | Título o texto explicativo de un hipervínculo asociado a una tarea.
<HyperlinkAddress> | Opcional | Dirección de un hipervínculo asociado a una tarea.
<HyperlinkSubAddress> | Opcional | Ubicación específica en un documento dentro de un hipervínculo asociado a una tarea.
<IgnoreResourceCalendar> | Opcional | Indica si la programación de la tarea tiene en cuenta los calendarios de los recursos asignados a la misma.
<Notes> | Opcional | Notas especificadas sobre una tarea.
<HideBar> | Opcional | Indica si las barras de Gantt y de calendario de una tarea están ocultas.
<Rollup> | Opcional | Indica si la barra de tareas de resumen muestra barras resumidas o si la información de las barras de Gantt de las subtareas se resumirá en la barra de tareas de resumen.
<BCWS> | Opcional | Costos de línea de base de fase temporal acumulados hasta la fecha de estado o la fecha actual; también se conoce como costo presupuestado del trabajo programado.
<BCWP> | Opcional | Valor acumulado del porcentaje completado de fase temporal de la tarea multiplicado por el costo previsto de fase temporal de la tarea hasta la fecha de estado o la fecha actual; también se denomina costo presupuestado del trabajo realizado.
<PhysicalPercentComplete> | Opcional | Porcentaje físico del trabajo total de una tarea que se ha completado.
<EarnedValueMethod> | Opcional | Indica el método de valor acumulado que se utilizará.
<PredecessorLink> | Opcional | Define la tarea predecesora de la tarea que la contiene.
<ActualWorkProtected> | Opcional | Especifica la duración del período en que el trabajo real estará protegido.
<ActualOvertimeWorkProtected> | Opcional | Especifica la duración del período en que el trabajo de horas extra real estará protegido.
<ExtendedAttribute> | Opcional | Valor de un atributo extendido.
<Baseline> | Opcional | Conjunto de valores de línea de base de la tarea.
<OutlineCode> | Opcional | Valor de un código de esquema.
<TimephasedData> | Opcional | Bloque de datos de fase temporal asociado a la tarea.


<TimephasedData> (elemento)

<TimephasedData> (elemento)

<TimephasedData> es información relativa a una tarea, un recurso o una asignación distribuida a lo largo del tiempo. Los datos de fase temporal pueden asociarse también a la línea de base de una tarea o asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | TimephasedDataType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>
<Baseline>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Type> | Opcional | Uno de los 76 tipos de datos de fase temporal.
<UID> | Requerido | Identificador exclusivo del registro de datos de fase temporal.
<Start> | Opcional | Fecha de comienzo del registro de datos de fase temporal.
<Finish> | Opcional | Fecha de fin del registro de datos de fase temporal.
<Unit> | Opcional | Unidad de tiempo del registro de datos de fase temporal.
<Value> | Opcional | Valor de cada unidad del registro de datos de fase temporal.

Mostrar Vea también

<Baseline> (elemento)
Estructura y esquema XML del elemento <TimephasedDataType>


<TotalSlack> (elemento)

<TotalSlack> (elemento)

Cantidad de tiempo que se puede retrasar una tarea sin que se retrase la fecha de fin de un proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<WBS> (elemento)

<WBS> (elemento)

Código exclusivo (estructura detallada de trabajo) utilizado para representar la posición de una tarea dentro de la estructura jerárquica del proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<WBSLevel> (elemento)

<WBSLevel> (elemento)

Nivel situado más a la derecha de la tarea. Por ejemplo, si el nivel de la tarea era A.01.03, el nivel más a la derecha sería 03.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>


<Work> (elemento)

<Work> (elemento)

En el caso de un elemento <Task>, <Work> es la cantidad total de trabajo programado que todos los recursos asignados deben realizar en una tarea.

En el caso de un elemento <Resource>, es la cantidad total de trabajo programado que un recurso debe realizar en todas las tareas asignadas.

En el caso de un elemento <Assignment>, es la cantidad total de trabajo programado que un recurso debe realizar en una tarea.

En el caso de un elemento <Baseline>, es el trabajo programado para una tarea, un recurso o una asignación cuando se guarda la línea de base.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>
<Baseline>

Mostrar Vea también

<Baseline> (elemento)


<WorkVariance> (elemento)

<WorkVariance> (elemento)

En el caso de un elemento <Task>, <WorkVariance> es la diferencia entre el trabajo previsto de una tarea y el trabajo programado actualmente.

En el caso de un elemento <Resource>, es la diferencia entre el trabajo previsto total de un recurso y el trabajo programado actualmente.

En el caso de un elemento <Assignment>, es la variación del trabajo asignado y el trabajo previsto, expresado en minutos multiplicados por 1000.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


Esquema XML del elemento <Resource>

Esquema XML del elemento <Resource>

A continuación, se muestra el esquema del elemento <Resource> para Microsoft Office Project 2003. Se trata de un elemento secundario del esquema <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <Resource>
<Resources> (elemento)
<?xml version="1.0"?>
   ...
<!-- @Resource schema -->
<xsd:element name="Resources" minOccurs="0">
    <xsd:annotation>
        <xsd:documentation>The collection of resources that make up the project.
        </xsd:documentation>
    </xsd:annotation>
    <xsd:complexType>
        <xsd:sequence>
            <xsd:element name="Resource" minOccurs="0" maxOccurs="unbounded">
                <xsd:annotation>
                    <xsd:documentation>There must be at least one resource in each Resources collection.
                    </xsd:documentation>
                </xsd:annotation>
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element name="UID" type="xsd:integer">
                            <xsd:annotation>
                                <xsd:documentation>The unique identifier of the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ID" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The position identifier of the resource within the list of resources.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Name" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The name of the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Type" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The type of resource. Values are: 0=Material, 1=Work
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="IsNull" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies whether the resource is null.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Initials" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The initials of the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Phonetics" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The phonetic spelling of the resource name.
                                For use with Japanese only.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="NTAccount" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The NT account associated with the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="MaterialLabel" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The unit of measure for the material resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Code" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The code or other information about the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Group" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The group to which the resource belongs.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="WorkGroup" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The type of workgroup to which the resource belongs.
                                Values are: 0=Default, 1=None, 2=Email, 3=Web
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                    <xsd:enumeration value="3" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="EmailAddress" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The email address of the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Hyperlink" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The title of the hyperlink associated with the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="HyperlinkAddress" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The hyperlink associated with the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="HyperlinkSubAddress" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The document bookmark of the hyperlink associated with the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="512" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="MaxUnits" type="xsd:float" default="1.0" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The maximum number of units that the resource is available.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="PeakUnits" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The largest number of units assigned to the resource at any time.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OverAllocated" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the resource is overallocated.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="AvailableFrom" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The first date that the resource is available.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="AvailableTo" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The last date the resource is available.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Start" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The scheduled start date of the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Finish" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The scheduled finish date of the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="CanLevel" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Whether the resource can be leveled.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="AccrueAt" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>How cost is accrued against the resource.
                                Values are: 1=Start, 2=End, 3=Prorated
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                    <xsd:enumeration value="3" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Work" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The total work assigned to the resource across all assigned tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RegularWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of non-overtime work assigned to the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OvertimeWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of overtime work assigned to the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of actual work performed by the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of remaining work required to complete all assigned tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualOvertimeWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of actual overtime work performed by the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingOvertimeWork" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The amount of remaining overtime work required to complete all tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="PercentWorkComplete" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The percentage of work completed across all tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="StandardRate" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The standard rate of the resource.
                                This value is as of the current date if a rate table exists for the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="StandardRateFormat" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The units used by Microsoft Project to display the standard rate.
                                1=m, 2=h, 3=d, 4=w, 5=mo, 7=y, 8=material resource rate (or blank symbol specified)
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                    <xsd:enumeration value="3" />
                                    <xsd:enumeration value="4" />
                                    <xsd:enumeration value="5" />
                                    <xsd:enumeration value="7" />
                                    <xsd:enumeration value="8" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="Cost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The total project cost for the resource across all assigned tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OvertimeRate" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The overtime rate of the resource.
                                This value is as of the current date if a rate table exists for the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="OvertimeRateFormat" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The units used by Microsoft Project to display the overtime rate.
                                1=m, 2=h, 3=d, 4=w, 5=mo, 7=y
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="1" />
                                    <xsd:enumeration value="2" />
                                    <xsd:enumeration value="3" />
                                    <xsd:enumeration value="4" />
                                    <xsd:enumeration value="5" />
                                    <xsd:enumeration value="7" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="OvertimeCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The total overtime cost for the resource including actual and remaining overtime costs.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="CostPerUse" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The cost per use of the resource. This value is as of the current date if a rate table
                                exists for the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual cost incurred by the resource across all assigned tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualOvertimeCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual overtime cost incurred by the resource across all assigned tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The remaining projected cost of the resource to complete all assigned tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="RemainingOvertimeCost" type="xsd:decimal" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The remaining projected overtime cost of the resource to complete all assigned tasks.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="WorkVariance" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The difference between the baseline work and the work as minutes x 1000.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="CostVariance" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The difference between the baseline cost and the cost.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="SV" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Earned value schedule variance, through the project status date.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="CV" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Earned value cost variance, through the project status date.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ACWP" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The actual cost of the work performed by the resource for the project to-date.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="CalendarUID" type="xsd:integer" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The resource calendar.Refers to a valid UID in the Calendars element of
                                the Microsoft Project XML Schema.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="Notes" type="xsd:string" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Text notes associated with the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="BCWS" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The budget cost of work scheduled for the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="BCWP" type="xsd:float" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The budgeted cost of of the work performed by the resource for the project to-date.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="IsGeneric" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies whether the resource is generic.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="IsInactive" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies whether the resource is set to inactive.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="IsEnterprise" type="xsd:boolean" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies whether the resource is an Enterprise resource.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="BookingType" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies the booking type of the resource. 1=Commited, 2=Proposed
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:integer">
                                    <xsd:enumeration value="0" />
                                    <xsd:enumeration value="1" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="ActualWorkProtected" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies the duration through which actual work is protected.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActualOvertimeWorkProtected" type="xsd:duration" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>Specifies the duration through which actual overtime work is protected.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ActiveDirectoryGUID" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The Active Directory GUID for the resource.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:simpleType>
                                <xsd:restriction base="xsd:string">
                                    <xsd:maxLength value="16" />
                                </xsd:restriction>
                            </xsd:simpleType>
                        </xsd:element>
                        <xsd:element name="CreationDate" type="xsd:dateTime" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>The date that the resource was created.
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                        <xsd:element name="ExtendedAttribute" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>The value of an extended attribute.  Two pieces of data are necessary -
                                a pointer back to the extended attribute table which is specified either by the unique ID or the Field ID,
                                and the value which is specified either with the value, or a pointer back to the value list.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="UID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique ID of the value in the extended attribute collection.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="FieldID" type="xsd:string" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The PID of the custom field.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Value" type="xsd:string" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The actual value of the extended attribute.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="ValueID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The ID of the value in the extended attribut lookup table.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="DurationFormat" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The format for expressing the bulk duration.
                                            Values are: 3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo, 19=%,
                                            20=e%, 21=null, 35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?, 42=ew?,
                                            43=mo?, 44=emo?, 51=%?, 52=e%? and 53=null.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:simpleType>
                                            <xsd:restriction base="xsd:integer">
                                                <xsd:enumeration value="3" />
                                                <xsd:enumeration value="4" />
                                                <xsd:enumeration value="5" />
                                                <xsd:enumeration value="6" />
                                                <xsd:enumeration value="7" />
                                                <xsd:enumeration value="8" />
                                                <xsd:enumeration value="9" />
                                                <xsd:enumeration value="10" />
                                                <xsd:enumeration value="11" />
                                                <xsd:enumeration value="12" />
                                                <xsd:enumeration value="19" />
                                                <xsd:enumeration value="20" />
                                                <xsd:enumeration value="21" />
                                                <xsd:enumeration value="35" />
                                                <xsd:enumeration value="36" />
                                                <xsd:enumeration value="37" />
                                                <xsd:enumeration value="38" />
                                                <xsd:enumeration value="39" />
                                                <xsd:enumeration value="40" />
                                                <xsd:enumeration value="41" />
                                                <xsd:enumeration value="42" />
                                                <xsd:enumeration value="43" />
                                                <xsd:enumeration value="44" />
                                                <xsd:enumeration value="51" />
                                                <xsd:enumeration value="52" />
                                                <xsd:enumeration value="53" />
                                            </xsd:restriction>
                                        </xsd:simpleType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="Baseline" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>The baseline values for the resources.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="Number" type="xsd:integer">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique number of the baseline data record.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Work" type="xsd:duration" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The work assigned the resource when the baseline is saved.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="Cost" type="xsd:float" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The projected cost for the resource when the baseline was saved.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="BCWS" type="xsd:float" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The budget cost of work scheduled for the resource.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="BCWP" type="xsd:float" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The budgeted cost of of the work performed by the resource for the project to-date.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="OutlineCode" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>The value of an outline code.  Two pieces of data are necessary - a pointer back to
                                the outline code table which is specified either by the unique ID or the Field ID, and the value which is
                                specified either with the value, or a pointer back to the value list.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="UID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique ID of the value in the outline code collection.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="FieldID" type="xsd:string" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The field ID in the localised language.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                    <xsd:element name="ValueID" type="xsd:integer" minOccurs="0">
                                        <xsd:annotation>
                                            <xsd:documentation>The unique ID in the value list associated with the definition
                                            in the outline code collection.</xsd:documentation>
                                        </xsd:annotation>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="AvailabilityPeriods" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>A collection of periods during which the resource is available.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="AvailabilityPeriod" minOccurs="0" maxOccurs="unbounded">
                                        <xsd:annotation>
                                            <xsd:documentation>The period the resource is available.
                                            </xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:complexType>
                                            <xsd:sequence>
                                                <xsd:element name="AvailableFrom" type="xsd:dateTime" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The date that the resource becomes available for the specified period.
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="AvailableTo" type="xsd:dateTime" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The last date that the resource is available for the specified period.
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="AvailableUnits" type="xsd:float" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The percentage that the resource is available during the specified period.
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                            </xsd:sequence>
                                        </xsd:complexType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="Rates" minOccurs="0">
                            <xsd:annotation>
                                <xsd:documentation>A collection of periods and the rates associated with each one.
                                </xsd:documentation>
                            </xsd:annotation>
                            <xsd:complexType>
                                <xsd:sequence>
                                    <xsd:element name="Rate" minOccurs="0" maxOccurs="25">
                                        <xsd:annotation>
                                            <xsd:documentation>The definition of a time period, and the rates applicable for
                                            the resource during that period.</xsd:documentation>
                                        </xsd:annotation>
                                        <xsd:complexType>
                                            <xsd:sequence>
                                                <xsd:element name="RatesFrom" type="xsd:dateTime">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The date that the rate becomes effective.
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="RatesTo" type="xsd:dateTime">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The last date that the rate is effective.
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="RateTable" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The unique identifier of the rate table for the resource.
                                                        Values are: 0=A, 1=B, 2=C, 3=D, 4=E</xsd:documentation>
                                                    </xsd:annotation>
                                                    <xsd:simpleType>
                                                        <xsd:restriction base="xsd:integer">
                                                            <xsd:enumeration value="0" />
                                                            <xsd:enumeration value="1" />
                                                            <xsd:enumeration value="2" />
                                                            <xsd:enumeration value="3" />
                                                            <xsd:enumeration value="4" />
                                                        </xsd:restriction>
                                                    </xsd:simpleType>
                                                </xsd:element>
                                                <xsd:element name="StandardRate" type="xsd:decimal" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The standard rate for the resource for the period specified.
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="StandardRateFormat" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The units used by Microsoft Project to display the standard rate.
                                                        1=m, 2=h, 3=d, 4=w, 5=mo, 7=y
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                    <xsd:simpleType>
                                                        <xsd:restriction base="xsd:integer">
                                                            <xsd:enumeration value="1" />
                                                            <xsd:enumeration value="2" />
                                                            <xsd:enumeration value="3" />
                                                            <xsd:enumeration value="4" />
                                                            <xsd:enumeration value="5" />
                                                            <xsd:enumeration value="7" />
                                                        </xsd:restriction>
                                                    </xsd:simpleType>
                                                </xsd:element>
                                                <xsd:element name="OvertimeRate" type="xsd:decimal" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The overtime rate for the resource for the period specified.
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                                <xsd:element name="OvertimeRateFormat" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The units used by Microsoft Project to display the overtime rate.
                                                        1=m, 2=h, 3=d, 4=w, 5=mo, 7=y</xsd:documentation>
                                                    </xsd:annotation>
                                                    <xsd:simpleType>
                                                        <xsd:restriction base="xsd:integer">
                                                            <xsd:enumeration value="1" />
                                                            <xsd:enumeration value="2" />
                                                            <xsd:enumeration value="3" />
                                                            <xsd:enumeration value="4" />
                                                            <xsd:enumeration value="5" />
                                                            <xsd:enumeration value="7" />
                                                        </xsd:restriction>
                                                    </xsd:simpleType>
                                                </xsd:element>
                                                <xsd:element name="CostPerUse" type="xsd:decimal" minOccurs="0">
                                                    <xsd:annotation>
                                                        <xsd:documentation>The cost per use of the resource.
                                                        This value is as of the current date if a rate table exists for the resource.
                                                        </xsd:documentation>
                                                    </xsd:annotation>
                                                </xsd:element>
                                            </xsd:sequence>
                                        </xsd:complexType>
                                    </xsd:element>
                                </xsd:sequence>
                            </xsd:complexType>
                        </xsd:element>
                        <xsd:element name="TimephasedData" type="TimephasedDataType" minOccurs="0" maxOccurs="unbounded">
                            <xsd:annotation>
                                <xsd:documentation>The time phased data
                                </xsd:documentation>
                            </xsd:annotation>
                        </xsd:element>
                    </xsd:sequence>
                </xsd:complexType>
            </xsd:element>
        </xsd:sequence>
    </xsd:complexType>
</xsd:element>


Estructura XML del elemento <Resource>

Estructura XML del elemento <Resource>

A continuación se detalla la estructura del elemento <Resource> para Microsoft Office Project 2003, que es un elemento secundario del elemento <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <Project>

Esquema XML del elemento <Resource>

Estructura

<Project>
            . . .
      <Resources>
            <Resource>
                  <UID/>
                  <ID/>
                  <Name/>
                  <Type/>
                  <IsNull/>
                  <Initials/>
                  <Phonetics/>
                  <NTAccount/>
                  <MaterialLabel/>
                  <Code/>
                  <Group/>
                  <WorkGroup/>
                  <EmailAddress/>
                  <Hyperlink/>
                  <HyperlinkAddress/>
                  <HyperlinkSubAddress/>
                  <MaxUnits/>
                  <PeakUnits/>
                  <OverAllocated/>
                  <AvailableFrom/>
                  <AvailableTo/>
                  <Start/>
                  <Finish/>
                  <CanLevel/>
                  <AccrueAt/>
                  <Work/>
                  <RegularWork/>
                  <OvertimeWork/>
                  <ActualWork/>
                  <RemainingWork/>
                  <ActualOvertimeWork/>
                  <RemainingOvertimeWork/>
                  <PercentWorkComplete/>
                  <StandardRate/>
                  <StandardRateFormat/>
                  <Cost/>
                  <OvertimeRate/>
                  <OvertimeRateFormat/>
                  <OvertimeCost/>
                  <CostPerUse/>
                  <ActualCost/>
                  <ActualOvertimeCost/>
                  <RemainingCost/>
                  <RemainingOvertimeCost/>
                  <WorkVariance/>
                  <CostVariance/>
                  <SV/>
                  <CV/>
                  <ACWP/>
                  <CalendarUID/>
                  <Notes/>
                  <BCWS/>
                  <BCWP/>
                  <IsGeneric/>
                  <IsInactive/>
                  <IsEnterprise/>
                  <BookingType/>
                  <ActualWorkProtected/>
                  <ActualOvertimeWorkProtected/>
                  <ActiveDirectoryGUID/>
                  <CreationDate/>
                  <ExtendedAttribute>
                        <UID/>
                        <FieldID/>
                        <Value/>
                        <ValueID/>
                        <DurationFormat/>
                  </ExtendedAttribute>
                  <Baseline>
                        <Number/>
                        <Work/>
                        <Cost/>
                        <BCWS/>
                        <BCWP/>
                  </Baseline>
                  <OutlineCode>
                        <UID/>
                        <FieldID/>
                        <ValueID/>
                  </OutlineCode>
                  <AvailabilityPeriods>
                        <AvailabilityPeriod>
                              <AvailableFrom/>
                              <AvailableTo/>
                              <AvailableUnits/>
                        </AvailabilityPeriod>
                  </AvailabilityPeriods>
                  <Rates>
                        <Rate>
                              <RatesFrom/>
                              <RatesTo/>
                              <RateTable/>
                              <StandardRate/>
                              <StandardRateFormat/>
                              <OvertimeRate/>
                              <OvertimeRateFormat/>
                              <CostPerUse/>
                        </Rate>
                  </Rates>
                  <TimephasedData>
                        <Type/>
                        <UID/>
                        <Start/>
                        <Finish/>
                        <Unit/>
                        <Value/>
                  </TimephasedData>
            </Resource>
      </Resources>
                  . . .
</Project>


<AccrueAt> (elemento)

<AccrueAt> (elemento)

Indica cómo y cuándo se van a cargar o acumular los costos estándar y de horas extra de los recursos al costo de una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
1 | Comienzo; los costos se acumulan en cuanto comienza la tarea, como se indica por la fecha especificada en el campo Comienzo real.
2 | Fin; no se incurre en costos hasta que el trabajo restante es cero.
3 | Prorrateo (predeterminado); los costos se acumulan cuando, según la programación, se va a realizar el trabajo y cuando se informa del trabajo real.
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<AvailabilityPeriod> (elemento)

<AvailabilityPeriod> (elemento)

Define el período en el que un recurso está disponible.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<AvailabilityPeriods>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<AvailableFrom> | Opcional | Fecha de comienzo en la que el recurso se encuentra disponible para trabajar en las unidades especificadas para el período de tiempo actual.
<AvailableTo> | Opcional | Fecha de fin en la que el recurso se encuentra disponible para trabajar en las unidades especificadas para el período de tiempo actual.
<AvailableUnits> | Opcional | Porcentaje de disponibilidad del recurso durante el período especificado.


<AvailabilityPeriods> (elemento)

<AvailabilityPeriods> (elemento)

Conjunto de períodos durante los cuales se encuentra disponible el recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Resource>

Mostrar Elementos secundarios

Lista de elementos secundarios

Elemento | Requerido/Opcional | Descripción
<AvailabilityPeriod> | Opcional | Define un período en el que el recurso se encuentra disponible.


<AvailableFrom> (elemento)

<AvailableFrom> (elemento)

Fecha de comienzo en la que el recurso se encuentra disponible para trabajar en las unidades especificadas para el período de tiempo actual.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<AvailabilityPeriod>
<Resource>


<AvailableTo> (elemento)

<AvailableTo> (elemento)

Fecha de fin en la que el recurso se encuentra disponible para trabajar en las unidades especificadas para el período de tiempo actual.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<AvailabilityPeriod>
<Resource>


<AvailableUnits> (elemento)

<AvailableUnits> (elemento)

Porcentaje de disponibilidad del recurso durante el período especificado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<AvailabilityPeriod>


<CanLevel> (elemento)

<CanLevel> (elemento)

Indica si se puede llevar a cabo la redistribución de los recursos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<Code> (elemento)

<Code> (elemento)

Código, abreviatura o número especificado como parte de la información de un recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<CostPerUse> (elemento)

<CostPerUse> (elemento)

Costo que se acumula cada vez que se utiliza un recurso. Indica si a partir de la fecha actual existe una tabla de tasas para el recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Rate>
<Resource>


<CostVariance> (elemento)

<CostVariance> (elemento)

Diferencia entre el costo previsto y el costo total de un recurso o una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>
<Assignment>


<EmailAddress> (elemento)

<EmailAddress> (elemento)

Dirección de correo electrónico de un recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<Group> (elemento)

<Group> (elemento)

Nombre del grupo al que pertenece el recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<Initials> (elemento)

<Initials> (elemento)

Iniciales de un nombre de recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<IsGeneric> (elemento)

<IsGeneric> (elemento)

Indica si el recurso es un recurso genérico en el nivel de empresa.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<IsInactive> (elemento)

<IsInactive> (elemento)

Indica si el recurso es un usuario activo (habilitado) o inactivo.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<MaterialLabel> (elemento)

<MaterialLabel> (elemento)

Unidad de medida especificada para un recurso material, por ejemplo, toneladas, cajas o metros cúbicos. Se utiliza junto con las <Units> de asignación del recurso material y sólo está disponible si el <Type> del recurso está establecido en 1 (recurso de trabajo).

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<MaxUnits> (elemento)

<MaxUnits> (elemento)

Porcentaje máximo, o número de unidades, que representa la cantidad máxima a la que un recurso puede realizar cualquier tarea durante el período de tiempo actual.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
0,00-0,99 | El recurso está disponible un 0%-99% para la tarea especificada.
1,00 | El recurso está disponible un 100% para la tarea especificada (predeterminado).
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | 1,0
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<NTAccount> (elemento)

<NTAccount> (elemento)

El nombre de cuenta de Microsoft Windows NT de un recurso; por ejemplo: nombre_dominio\nombre_usuario.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<OvertimeRate> (elemento)

<OvertimeRate> (elemento)

Tasa de pago del trabajo de horas extra realizado por un recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Rate>
<Resource>


<OvertimeRateFormat> (elemento)

<OvertimeRateFormat> (elemento)

Unidades utilizadas para mostrar la tasa de horas extra.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Unidades:
1 | m
2 | h
3 | d
4 | s
5 | me
7 | a
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Rate>
<Resource>


<PeakUnits> (elemento)

<PeakUnits> (elemento)

Porcentaje máximo, o número de unidades, para el que un recurso está asignado en cualquier momento relativo a todas las tareas asignadas a él.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<Phonetics> (elemento)

<Phonetics> (elemento)

Contiene información fonética de los nombres de los recursos en Hiragana o Katakana; se utiliza sólo en la versión en japonés de Microsoft Office Project 2003.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(512)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<Rate> (elemento)

<Rate> (elemento)

Definición de un período de tiempo y las tasas aplicables para el recurso durante ese período.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 25
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Rates>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<RatesFrom> | Requerido | Fecha en la que la tasa comienza a estar disponible.
<RatesTo> | Requerido | Última fecha en la que la tasa está disponible.
<RateTable> | Opcional | Identificador exclusivo de la tabla de tasas de costo del recurso.
<StandardRate> | Opcional | Tasa de pago estándar del recurso durante el período definido.
<StandardRateFormat> | Opcional | Unidades utilizadas para mostrar la tasa estándar.
<OvertimeRate> | Opcional | Tasa de horas extra del recurso durante el período definido.
<OvertimeRateFormat> | Opcional | Unidades utilizadas para mostrar la tasa de horas extra.
<CostPerUse> | Opcional | Costo por uso del recurso.


<Rates> (elemento)

<Rates> (elemento)

Conjunto de períodos y tasas de pago asociados a cada período.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Resource>

Mostrar Elementos secundarios

Elemento | Requerido/Opcional | Descripción
<Rate> | Opcional | Definición de un período de tiempo y las tasas aplicables para el recurso durante ese período.


<RatesFrom> (elemento)

<RatesFrom> (elemento)

Fecha en la que la tasa del recurso comienza a estar disponible.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Rate>


<RatesTo> (elemento)

<RatesTo> (elemento)

Última fecha en la que la tasa del recurso está disponible.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 1
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Rate>


<RateTable> (elemento)

<RateTable> (elemento)

Identificador exclusivo de la tabla de tasas de costo del recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | A
1 | B
2 | C
3 | D
4 | E
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Rate>


<Resource> (elemento)

<Resource> (elemento)

Recurso del proyecto. Debe haber un recurso como mínimo en cada conjunto de recursos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Resources>

Mostrar Elementos secundarios

Lista de elementos secundarios

Elemento | Requerido/Opcional | Descripción
<UID> | Requerido | Identificador exclusivo del recurso.
<ID> | Opcional | Identificador de posición del recurso dentro de la lista de recursos.
<Name> | Opcional | Nombre del recurso; debe ser exclusivo de la empresa, esté o no activo.
<Type> | Opcional | Tipo de recurso (trabajo o material).
<IsNull> | Opcional | Indica si el recurso es un recurso nulo.
<Initials> | Opcional | Iniciales de un nombre de recurso.
<Phonetics> | Opcional | Contiene información fonética de los nombres de los recursos en Hiragana o Katakana; se utiliza sólo en la versión en japonés de Microsoft Office Project 2003.
<NTAccount> | Opcional | El nombre de cuenta de Microsoft Windows NT de un recurso.
<MaterialLabel> | Opcional | Unidad de medida indicada para un recurso de material, por ejemplo, toneladas, cajas o metros cúbicos.
<Code> | Opcional | Código, abreviatura o número especificado como parte de la información de un recurso.
<Group> | Opcional | Nombre del grupo al que pertenece el recurso.
<WorkGroup> | Opcional | Sistema de mensajería utilizado para comunicarse con el equipo de un proyecto.
<EmailAddress> | Opcional | Dirección de correo electrónico de un recurso.
<Hyperlink> | Opcional | Título o texto explicativo de un hipervínculo asociado a un recurso.
<HyperlinkAddress> | Opcional | Dirección de un hipervínculo asociado a un recurso.
<HyperlinkSubAddress> | Opcional | Ubicación específica en un documento dentro de un hipervínculo asociado a un recurso.
<MaxUnits> | Opcional | Porcentaje máximo, o número de unidades, que representa la cantidad máxima a la que un recurso puede realizar cualquier tarea durante el período de tiempo actual.
<PeakUnits> | Opcional | Porcentaje máximo, o número de unidades, para el que un recurso está asignado en cualquier momento relativo a todas las tareas asignadas a él.
<OverAllocated> | Opcional | Indica si un recurso está asignado para realizar más trabajo en todas las tareas asignadas del que puede a la capacidad normal de trabajo.
<AvailableFrom> | Opcional | Fecha de comienzo en la que el recurso se encuentra disponible para trabajar en las unidades especificadas para el período de tiempo actual.
<AvailableTo> | Opcional | Fecha de fin en la que el recurso se encuentra disponible para trabajar en las unidades especificadas para el período de tiempo actual.
<Start> | Opcional | Fecha y hora que se ha programado para que un recurso comience el trabajo en todas las tareas asignadas.
<Finish> | Opcional | Fecha y hora que se ha programado para que un recurso complete el trabajo de todas las tareas asignadas.
<CanLevel> | Opcional | Indica si se puede llevar a cabo redistribución de recursos con un recurso.
<AccrueAt> | Opcional | Indica cómo y cuándo se van a cargar, o acumular, los costos estándar y de horas extra de los recursos al costo de una tarea.
<Work> | Opcional | Cantidad total de trabajo programado que un recurso debe realizar en todas las tareas asignadas.
<RegularWork> | Opcional | Cantidad total de trabajo programado que no es de horas extra que se debe realizar en todas las asignaciones de un recurso.
<OvertimeWork> | Opcional | Cantidad de horas extra que hay que realizar en todas las tareas asignadas a un recurso y cargadas a la tasa de horas extra de éste.
<ActualWork> | Opcional | Cantidad real de trabajo que ya se ha realizado en todas las asignaciones de un recurso.
<RemainingWork> | Opcional | Cantidad de tiempo, u horas por persona, que un recurso necesita para finalizar todas las tareas asignadas.
<ActualOvertimeWork> | Opcional | Cantidad real de trabajo de horas extra que se ha realizado en todas las asignaciones de un recurso.
<RemainingOvertimeWork> | Opcional | Cantidad restante de horas extra que un recurso necesita para finalizar todas las tareas.
<PercentWorkComplete> | Opcional | Estado actual de todas las tareas asignadas a un recurso, expresado como porcentaje total del trabajo del recurso que ha finalizado.
<StandardRate> | Opcional | Tasa de pago del trabajo normal que no es de horas extra realizado por un recurso.
<StandardRateFormat> | Opcional | Unidades utilizadas para mostrar la tasa estándar.
<Cost> | Opcional | Costo programado total de un recurso para todas las tareas asignadas, basado en los costos contraídos por el trabajo realizado por el recurso en todas las tareas asignadas, además de los costos planeados del trabajo restante.
<OvertimeRate> | Opcional | Tasa de pago del trabajo de horas extra realizado por un recurso.
<OvertimeRateFormat> | Opcional | Unidades utilizadas para mostrar la tasa de horas extra.
<OvertimeCost> | Opcional | Costo total de horas extra de un recurso en todas las tareas asignadas.
<CostPerUse> | Opcional | Costo que se acumula cada vez que se utiliza un recurso.
<ActualCost> | Opcional | Suma de los costos contraídos por el trabajo realizado por un recurso en todas las tareas asignadas.
<ActualOvertimeCost> | Opcional | Costo contraído por el trabajo de horas extra realizado por un recurso en todas las tareas asignadas.
<RemainingCost> | Opcional | Gastos programados restantes que se contraerán para finalizar el trabajo restante asignado a un recurso.
<RemainingOvertimeCost> | Opcional | Gastos de horas extra programados restantes que se contraerán para que un recurso finalice el trabajo de horas extra planeado restante en todas las tareas asignadas.
<WorkVariance> | Opcional | Diferencia entre el trabajo previsto total de un recurso y el trabajo programado actualmente.
<CostVariance> | Opcional | Diferencia entre el costo previsto y el costo total de un recurso.
<SV> | Opcional | Diferencia en costo entre el progreso real y el plan previsto de todas las tareas asignadas del recurso hasta la fecha de estado o la fecha actual. También se denomina variación de programación del valor acumulado.
<CV> | Opcional | Diferencia entre lo que le debería haber costado al recurso conseguir el nivel actual de finalización y lo que le ha costado realmente hasta la fecha de estado o la fecha actual.
<ACWP> | Opcional | La suma de los valores de costo real del trabajo realizado (CRTR) de todas las asignaciones de un recurso hasta la fecha de estado o la fecha actual.
<CalendarUID> | Opcional | Identificador exclusivo del calendario asociado a este recurso.
<Notes> | Opcional | Notas sobre un recurso.
<BCWS> | Opcional | El resumen de los valores de CPTP de un recurso para todas las tareas asignadas; también se denomina costo presupuestado del trabajo programado.
<BCWP> | Opcional | El resumen de los valores de CPTR de un recurso para todas las tareas asignadas, calculado hasta la fecha de estado o la fecha actual; también se denomina costo presupuestado del trabajo realizado.
<IsGeneric> | Opcional | Indica si el recurso es un recurso genérico en el nivel de empresa.
<IsInactive> | Opcional | Indica si el recurso es un usuario activo (habilitado) o inactivo.
<IsEnterprise> | Opcional | Especifica si el recurso es un recurso de empresa.
<BookingType> | Opcional | Especifica el tipo de reserva del recurso (comprometido o propuesto).
<ActualWorkProtected> | Opcional | Especifica la duración del período en que el trabajo real estará protegido.
<ActualOvertimeWorkProtected> | Opcional | Especifica la duración del período en que el trabajo de horas extra real estará protegido.
<ActiveDirectoryGUID> | Opcional | GUID de Active Directory del recurso.
<CreationDate> | Opcional | Fecha de creación del proyecto, el recurso o la asignación.
<ExtendedAttribute> | Opcional | Definición de campo personalizado asociada a un recurso.
<Baseline> | Opcional | Conjunto de estimaciones de proyecto utilizadas por motivos de seguimiento.
<OutlineCode> | Opcional | Etiqueta personalizada definida para un recurso que permite contar con una estructura de proyecto alternativa.
<AvailabilityPeriods> | Opcional | Conjunto de fechas en las que un recurso está disponible.
<Rates> | Opcional | Conjunto de tasas de pago del recurso.
<TimephasedData> | Opcional | Bloque de datos de fase temporal asociado al recurso.


<StandardRate> (elemento)

<StandardRate> (elemento)

Tasa de pago del trabajo normal que no es de horas extra realizado por un recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Rate>
<Resource>


<StandardRateFormat> (elemento)

<StandardRateFormat> (elemento)

Unidades utilizadas para mostrar la tasa estándar.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
1 | m
2 | h
3 | d
4 | s
5 | me
7 | a
8 | tasa de recursos materiales (o símbolo de espacio especificado)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Rate>
<Resource>


<SV> (elemento)

<SV> (elemento)

Diferencia en costo entre el progreso real y el plan previsto de todas las tareas asignadas del recurso hasta la fecha de estado o la fecha actual. También se denomina variación de programación del valor acumulado.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Decimal
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<WorkGroup> (elemento)

<WorkGroup> (elemento)

Sistema de mensajería utilizado para comunicarse con el equipo de un proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Predeterminado
1 | Ninguno; en este proyecto no se utiliza sistema de mensajería de grupo de trabajo
2 | Sólo correo electrónico
3 | Web (Microsoft Office Project Web Access 2003)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


Esquema XML del elemento <Assignment>

Esquema XML del elemento <Assignment>

A continuación, se muestra el esquema del elemento <Assignment> para Microsoft Office Project 2003. Se trata de un elemento secundario del esquema <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <Assignment>
<Assignments> (elemento)
<?xml version="1.0"?>
   ...
<!-- @Assignment schema -->
<xsd:element name="Assignments" minOccurs="0">
<xsd:annotation>
    <xsd:documentation>The collection of assignments that make up the project.
    </xsd:documentation>
</xsd:annotation>
<xsd:complexType>
    <xsd:sequence>
        <xsd:element name="Assignment" minOccurs="0" maxOccurs="unbounded">
            <xsd:annotation>
                <xsd:documentation>There must be at least one assignment in each Assignments collection.
                </xsd:documentation>
            </xsd:annotation>
            <xsd:complexType>
                <xsd:sequence>
                    <xsd:element name="UID" type="xsd:integer">
                        <xsd:annotation>
                            <xsd:documentation>The unique identifier of the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="TaskUID" type="xsd:integer" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The unique identifier of the task.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ResourceUID" type="xsd:integer" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The unique identifier of the resource.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="PercentWorkComplete" type="xsd:integer" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The amount of work completed on the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ActualCost" type="xsd:decimal" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The actual cost incurred on the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ActualFinish" type="xsd:dateTime" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The actual finish date of the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ActualOvertimeCost" type="xsd:decimal" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The actual overtime cost incurred on the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ActualOvertimeWork" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The actual amount of overtime work incurred on the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ActualStart" type="xsd:dateTime" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The actual start date of the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ActualWork" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The actual amount of work incurred on the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ACWP" type="xsd:float" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The actual cost of work performed on the assignment to-date.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Confirmed" type="xsd:boolean" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Whether the Resource has accepted all of his or her assignments.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Cost" type="xsd:decimal" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The projected or scheduled cost of the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="CostRateTable" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The cost rate table used for the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:simpleType>
                            <xsd:restriction base="xsd:integer">
                                <xsd:enumeration value="0" />
                                <xsd:enumeration value="1" />
                                <xsd:enumeration value="2" />
                                <xsd:enumeration value="3" />
                                <xsd:enumeration value="4" />
                            </xsd:restriction>
                        </xsd:simpleType>
                    </xsd:element>
                    <xsd:element name="CostVariance" type="xsd:float" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The difference between the cost and baseline cost for a resource.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="CV" type="xsd:float" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Earned value cost variance.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Delay" type="xsd:integer" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The amount that the assignment is delayed.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Finish" type="xsd:dateTime" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The scheduled finish date of the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="FinishVariance" type="xsd:integer" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The variance of the assignment finish date from the baseline finish date.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Hyperlink" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The title of the hyperlink associated with the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:simpleType>
                            <xsd:restriction base="xsd:string">
                                <xsd:maxLength value="512" />
                            </xsd:restriction>
                        </xsd:simpleType>
                    </xsd:element>
                    <xsd:element name="HyperlinkAddress" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The hyperlink associated with the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:simpleType>
                            <xsd:restriction base="xsd:string">
                                <xsd:maxLength value="512" />
                            </xsd:restriction>
                        </xsd:simpleType>
                    </xsd:element>
                    <xsd:element name="HyperlinkSubAddress" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The document bookmark of the hyperlink associated with the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:simpleType>
                            <xsd:restriction base="xsd:string">
                                <xsd:maxLength value="512" />
                            </xsd:restriction>
                        </xsd:simpleType>
                    </xsd:element>
                    <xsd:element name="WorkVariance" type="xsd:float" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The variance of assignment work from the baseline work as minutes x 1000.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="HasFixedRateUnits" type="xsd:boolean" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Whether the Units are Fixed Rate.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="FixedMaterial" type="xsd:boolean" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Whether the consumption of the assigned material resource occurs in a single, fixed amount.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="LevelingDelay" type="xsd:integer" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The delay caused by leveling.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="LevelingDelayFormat" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The format for expressing the duration of the delay.
                            Values are: 3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo, 19=%, 20=e%, 21=null,
                            35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?, 42=ew?, 43=mo?, 44=emo?, 51=%?, 52=e%? and 53=null.
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:simpleType>
                            <xsd:restriction base="xsd:integer">
                                <xsd:enumeration value="3" />
                                <xsd:enumeration value="4" />
                                <xsd:enumeration value="5" />
                                <xsd:enumeration value="6" />
                                <xsd:enumeration value="7" />
                                <xsd:enumeration value="8" />
                                <xsd:enumeration value="9" />
                                <xsd:enumeration value="10" />
                                <xsd:enumeration value="11" />
                                <xsd:enumeration value="12" />
                                <xsd:enumeration value="19" />
                                <xsd:enumeration value="20" />
                                <xsd:enumeration value="21" />
                                <xsd:enumeration value="35" />
                                <xsd:enumeration value="36" />
                                <xsd:enumeration value="37" />
                                <xsd:enumeration value="38" />
                                <xsd:enumeration value="39" />
                                <xsd:enumeration value="40" />
                                <xsd:enumeration value="41" />
                                <xsd:enumeration value="42" />
                                <xsd:enumeration value="43" />
                                <xsd:enumeration value="44" />
                                <xsd:enumeration value="51" />
                                <xsd:enumeration value="52" />
                                <xsd:enumeration value="53" />
                            </xsd:restriction>
                        </xsd:simpleType>
                    </xsd:element>
                    <xsd:element name="LinkedFields" type="xsd:boolean" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Whether the Project is linked to another OLE object.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Milestone" type="xsd:boolean" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Whether the assignment is a milestone.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Notes" type="xsd:string" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Text notes associated with the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Overallocated" type="xsd:boolean" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Whether the assignment is overallocated.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="OvertimeCost" type="xsd:decimal" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The sum of the actual and remaining overtime cost of the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="OvertimeWork" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The scheduled overtime work scheduled for the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="RegularWork" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The amount of non-overtime work scheduled for the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="RemainingCost" type="xsd:decimal" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The remaining projected cost of completing the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="RemainingOvertimeCost" type="xsd:decimal" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The remaining projected overtime cost of completing the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="RemainingOvertimeWork" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The remaining overtime work scheduled to complete the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="RemainingWork" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The remaining work scheduled to complete the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ResponsePending" type="xsd:boolean" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>True if a response has not been received for a TeamAssign message.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Start" type="xsd:dateTime" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The scheduled start date of the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Stop" type="xsd:dateTime" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The date that the assignment was stopped.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Resume" type="xsd:dateTime" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The date that the assignment resumed.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="StartVariance" type="xsd:integer" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The variance of the assignment start date from the baseline start date.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Units" type="xsd:float" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The number of units for the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="UpdateNeeded" type="xsd:boolean" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>True if the resource assigned to a task needs to be updated as to the status of the task.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="VAC" type="xsd:float" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The difference between basline cost and total cost.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="Work" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The amount of scheduled work for the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="WorkContour" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The work contour of the assignment.
                            Values are: 0=Flat, 1=Back Loaded, 2=Front Loaded, 3=Double Peak, 4=Early Peak, 5=Late Peak,
                            6=Bell, 7=Turtle, 8=Contoured
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:simpleType>
                            <xsd:restriction base="xsd:integer">
                                <xsd:enumeration value="0" />
                                <xsd:enumeration value="1" />
                                <xsd:enumeration value="2" />
                                <xsd:enumeration value="3" />
                                <xsd:enumeration value="4" />
                                <xsd:enumeration value="5" />
                                <xsd:enumeration value="6" />
                                <xsd:enumeration value="7" />
                                <xsd:enumeration value="8" />
                            </xsd:restriction>
                        </xsd:simpleType>
                    </xsd:element>
                    <xsd:element name="BCWS" type="xsd:float" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The budgeted cost of work on the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="BCWP" type="xsd:float" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The budgeted cost of work performed on the assignment to-date.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="BookingType" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Specifies the booking type of the assignment. 1=Commited, 2=Proposed
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:simpleType>
                            <xsd:restriction base="xsd:integer">
                                <xsd:enumeration value="0" />
                                <xsd:enumeration value="1" />
                            </xsd:restriction>
                        </xsd:simpleType>
                    </xsd:element>
                    <xsd:element name="ActualWorkProtected" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Specifies the duration through which actual work is protected.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ActualOvertimeWorkProtected" type="xsd:duration" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>Specifies the duration through which actual overtime work is protected.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="CreationDate" type="xsd:dateTime" minOccurs="0">
                        <xsd:annotation>
                            <xsd:documentation>The date that the assignment was created.</xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                    <xsd:element name="ExtendedAttribute" minOccurs="0" maxOccurs="unbounded">
                        <xsd:annotation>
                            <xsd:documentation>The value of an extended attribute.  Two pieces of data are necessary -
                            a pointer back to the extended attribute table which is specified either by the unique ID or the
                            Field ID, and the value which is specified either with the value, or a pointer back to the value list.
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:complexType>
                            <xsd:sequence>
                                <xsd:element name="UID" type="xsd:integer" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The unique ID of the value in the extended attribute collection.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="FieldID" type="xsd:string" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The field ID in the localised language.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="Value" type="xsd:string" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The actual value of the extended attribute.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="ValueID" type="xsd:integer" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The ID of the value in the extended attribut lookup table.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="DurationFormat" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The format for expressing the bulk duration.
                                        Values are: 3=m, 4=em, 5=h, 6=eh, 7=d, 8=ed, 9=w, 10=ew, 11=mo, 12=emo, 19=%, 20=e%,
                                        21=null, 35=m?, 36=em?, 37=h?, 38=eh?, 39=d?, 40=ed?, 41=w?, 42=ew?, 43=mo?, 44=emo?,
                                        51=%?, 52=e%? and 53=null.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                    <xsd:simpleType>
                                        <xsd:restriction base="xsd:integer">
                                            <xsd:enumeration value="3" />
                                            <xsd:enumeration value="4" />
                                            <xsd:enumeration value="5" />
                                            <xsd:enumeration value="6" />
                                            <xsd:enumeration value="7" />
                                            <xsd:enumeration value="8" />
                                            <xsd:enumeration value="9" />
                                            <xsd:enumeration value="10" />
                                            <xsd:enumeration value="11" />
                                            <xsd:enumeration value="12" />
                                            <xsd:enumeration value="19" />
                                            <xsd:enumeration value="20" />
                                            <xsd:enumeration value="21" />
                                            <xsd:enumeration value="35" />
                                            <xsd:enumeration value="36" />
                                            <xsd:enumeration value="37" />
                                            <xsd:enumeration value="38" />
                                            <xsd:enumeration value="39" />
                                            <xsd:enumeration value="40" />
                                            <xsd:enumeration value="41" />
                                            <xsd:enumeration value="42" />
                                            <xsd:enumeration value="43" />
                                            <xsd:enumeration value="44" />
                                            <xsd:enumeration value="51" />
                                            <xsd:enumeration value="52" />
                                            <xsd:enumeration value="53" />
                                        </xsd:restriction>
                                    </xsd:simpleType>
                                </xsd:element>
                            </xsd:sequence>
                        </xsd:complexType>
                    </xsd:element>
                    <xsd:element name="Baseline" minOccurs="0" maxOccurs="unbounded">
                        <xsd:annotation>
                            <xsd:documentation>The collection of baseline values associated with the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                        <xsd:complexType>
                            <xsd:sequence>
                                <xsd:element name="TimephasedData" type="TimephasedDataType" minOccurs="0" maxOccurs="unbounded">
                                    <xsd:annotation>
                                        <xsd:documentation>The time phased data associated with the Baseline.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="Number" type="xsd:string">
                                    <xsd:annotation>
                                        <xsd:documentation>The unique number of the baseline data record.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="Start" type="xsd:string" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The scheduled start date of the assignment when the baseline was saved.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="Finish" type="xsd:string" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The scheduled finish date of the assignment when the baseline was saved.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="Work" type="xsd:duration" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The total amount of work scheduled on the assignment when the baseline was saved.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="Cost" type="xsd:string" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The total projected cost of the assignment when the baseline was saved.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="BCWS" type="xsd:float" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The budgeted cost of work on the assignment.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                                <xsd:element name="BCWP" type="xsd:float" minOccurs="0">
                                    <xsd:annotation>
                                        <xsd:documentation>The budgeted cost of work performed on the assignment to-date.
                                        </xsd:documentation>
                                    </xsd:annotation>
                                </xsd:element>
                            </xsd:sequence>
                        </xsd:complexType>
                    </xsd:element>
                    <xsd:element name="TimephasedData" type="TimephasedDataType" minOccurs="0" maxOccurs="unbounded">
                        <xsd:annotation>
                            <xsd:documentation>The time phased data associated with the assignment.
                            </xsd:documentation>
                        </xsd:annotation>
                    </xsd:element>
                </xsd:sequence>
            </xsd:complexType>
        </xsd:element>
    </xsd:sequence>
</xsd:complexType>


Estructura XML del elemento <Assignment>

Estructura XML del elemento <Assignment>

A continuación se detalla la estructura del elemento <Assignment> para Microsoft Office Project 2003, el cual es un elemento secundario del elemento <Project>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project
Estructura XML del elemento <Project>

Esquema XML del elemento <Assignment>

Estructura

<Project>
            . . .
      <Assignments>
            <Assignment>
                  <UID/>
                  <TaskUID/>
                  <ResourceUID/>
                  <PercentWorkComplete/>
                  <ActualCost/>
                  <ActualFinish/>
                  <ActualOvertimeCost/>
                  <ActualOvertimeWork/>
                  <ActualStart/>
                  <ActualWork/>
                  <ACWP/>
                  <Confirmed/>
                  <Cost/>
                  <CostRateTable/>
                  <CostVariance/>
                  <CV/>
                  <Delay/>
                  <Finish/>
                  <FinishVariance/>
                  <Hyperlink/>
                  <HyperlinkAddress/>
                  <HyperlinkSubAddress/>
                  <WorkVariance/>
                  <HasFixedRateUnits/>
                  <FixedMaterial/>
                  <LevelingDelay/>
                  <LevelingDelayFormat/>
                  <LinkedFields/>
                  <Milestone/>
                  <Notes/>
                  <Overallocated/>
                  <OvertimeCost/>
                  <OvertimeWork/>
                  <RegularWork/>
                  <RemainingCost/>
                  <RemainingOvertimeCost/>
                  <RemainingOvertimeWork/>
                  <RemainingWork/>
                  <ResponsePending/>
                  <Start/>
                  <Stop/>
                  <Resume/>
                  <StartVariance/>
                  <Units/>
                  <UpdateNeeded/>
                  <VAC/>
                  <Work/>
                  <WorkContour/>
                  <BCWS/>
                  <BCWP/>
                  <BookingType/>
                  <ActualWorkProtected/>
                  <ActualOvertimeWorkProtected/>
                  <CreationDate/>
                  <ExtendedAttribute>
                        <UID/>
                        <FieldID/>
                        <Value/>
                        <ValueID/>
                        <DurationFormat/>
                  </ExtendedAttribute>
                  <Baseline>
                        <TimephasedData>
                              <Type/>
                              <UID/>
                              <Start/>
                              <Finish/>
                              <Unit/>
                              <Value/>
                        </TimephasedData>
                        <Number/>
                        <Start/>
                        <Finish/>
                        <Work/>
                        <Cost/>
                        <BCWS/>
                        <BCWP/>
                  </Baseline>
                  <TimephasedData>
                        <Type/>
                        <UID/>
                        <Start/>
                        <Finish/>
                        <Unit/>
                        <Value/>
                  </TimephasedData>
            </Assignment>
      </Assignments>
</Project>


<Assignment> (elemento)

<Assignment> (elemento)

Debe haber, al menos, una asignación en cada conjunto <Assignments>.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | ComplexType
Número mínimo de apariciones | 0
Número máximo de apariciones | Ilimitado
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | Sequence

Mostrar Elementos principales

<Assignments>

Mostrar Elementos secundarios

Lista de elementos secundarios

Elemento | Requerido/Opcional | Descripción
<UID> | Requerido | Identificador exclusivo de la asignación.
<TaskUID> | Opcional | Identificador exclusivo de la tarea.
<ResourceUID> | Opcional | Identificador exclusivo del recurso.
<PercentWorkComplete> | Opcional | Estado actual de una asignación, expresado como el porcentaje del trabajo de la asignación que se ha realizado.
<ActualCost> | Opcional | Costo en que se ha incurrido por el trabajo ya realizado por un recurso en una tarea.
<ActualFinish> | Opcional | Fecha y hora de finalización real de una asignación.
<ActualOvertimeCost> | Opcional | Costo incurrido por el trabajo de horas extra realizado por un recurso en una tarea.
<ActualOvertimeWork> | Opcional | Cantidad real de trabajo de horas extra que ha realizado un recurso en una tarea asignada.
<ActualStart> | Opcional | Fecha y hora de comienzo real de una asignación.
<ActualWork> | Opcional | Cantidad de trabajo que ya ha realizado un recurso en una tarea.
<ACWP> | Opcional | Costos contraídos por el trabajo que un recurso ha realizado en una tarea hasta la fecha de estado del proyecto o la fecha actual; también se denomina costo real del trabajo realizado (CRTR).
<Confirmed> | Opcional | Indica si un recurso asignado a una tarea ha aceptado o rechazado la asignación de la misma.
<Cost> | Opcional | Costo total programado (o proyectado) para una asignación.
<CostRateTable> | Opcional | Indica la tabla de tasas de costo que debe utilizarse para un recurso en una asignación.
<CostVariance> | Opcional | Diferencia entre el costo previsto y el costo total de una asignación.
<CV> | Opcional | Diferencia entre lo que debería costar alcanzar el nivel actual de finalización de la asignación y lo que ha costado realmente.
<Delay> | Opcional | Período de tiempo que debe esperar un recurso después de la fecha de comienzo de la tarea antes de empezar a trabajar en una asignación.
<Finish> | Opcional | Fecha y hora que se ha programado para que un recurso asignado complete el trabajo de una tarea.
<FinishVariance> | Opcional | Diferencia entre la fecha de fin prevista y la fecha de fin programada de una asignación.
<Hyperlink> | Opcional | Título o texto explicativo de un hipervínculo asociado a una asignación.
<HyperlinkAddress> | Opcional | Dirección de un hipervínculo asociado a una asignación.
<HyperlinkSubAddress> | Opcional | Ubicación específica en un documento dentro de un hipervínculo asociado a una asignación.
<WorkVariance> | Opcional | Diferencia entre el trabajo previsto y el trabajo programado de una asignación.
<HasFixedRateUnits> | Opcional | Indica si una asignación tiene unidades de tasa fijas.
<FixedMaterial> | Opcional | Indica si el consumo del recurso material asignado es una cantidad fija única.
<LevelingDelay> | Opcional | Cantidad de tiempo que se va a retrasar una asignación con respecto a la fecha de comienzo programada como resultado de una redistribución de recursos.
<LevelingDelayFormat> | Opcional | Formato para expresar la duración del retraso.
<LinkedFields> | Opcional | Indica si hay vínculos OLE a la asignación.
<Milestone> | Opcional | Indica si la tarea de asignación es un hito.
<Notes> | Opcional | Notas sobre una asignación.
<Overallocated> | Opcional | Indica si un recurso está asignado a más trabajo en una tarea específica del que puede realizar a la capacidad normal de trabajo.
<OvertimeCost> | Opcional | Costo total de horas extra de una asignación de recursos.
<OvertimeWork> | Opcional | Cantidad de horas extra que deberá realizar un recurso en una tarea y que se cargará a la tasa de horas extra del recurso.
<RegularWork> | Opcional | Cantidad total de trabajo programado que no es de horas extra que debe realizar un recurso asignado a una tarea.
<RemainingCost> | Opcional | Costos asociados a la finalización por parte de los recursos de todo el trabajo restante programado en una tarea específica.
<RemainingOvertimeCost> | Opcional | Gasto de horas extra restante programado de una asignación.
<RemainingOvertimeWork> | Opcional | Cantidad de trabajo de horas extra restante en una asignación.
<RemainingWork> | Opcional | Cantidad de tiempo que un recurso asignado a una tarea necesita para completar una asignación.
<ResponsePending> | Opcional | Indica si se ha recibido una respuesta a un mensaje enviado a un recurso asignado a una tarea informándole de la asignación.
<Start> | Opcional | Fecha y hora en las que un recurso asignado está programado para comenzar a trabajar en una tarea.
<Stop> | Opcional | Fecha en la que se detuvo la asignación.
<Resume> | Opcional | Fecha en la que se reanudó la asignación.
<StartVariance> | Opcional | Diferencia entre la fecha de comienzo prevista y la fecha de comienzo programada de una asignación.
<Units> | Opcional | Número de unidades para las que se asigna un recurso a una tarea, expresado como porcentaje.
<UpdateNeeded> | Opcional | Indica si debe enviarse un mensaje de actualización de equipo al recurso asignado a una tarea porque ha cambiado la fecha de comienzo, la fecha de fin o la reasignación de recursos.
<VAC> | Opcional | Variación en finalización (VAF) entre el costo previsto y el costo total de una asignación en una tarea.
<Work> | Opcional | Cantidad total de trabajo programado que un recurso debe realizar en una tarea.
<WorkContour> | Opcional | Indica cómo se distribuye el trabajo a lo largo de la duración de una asignación.
<BCWS> | Opcional | Costo presupuestado del trabajo programado en la asignación.
<BCWP> | Opcional | Costo presupuestado del trabajo realizado hasta la fecha en la asignación.
<BookingType> | Opcional | Especifica el tipo de reserva de la asignación (comprometida o propuesta).
<ActualWorkProtected> | Opcional | Especifica la duración del período en que el trabajo real estará protegido.
<ActualOvertimeWorkProtected> | Opcional | Especifica la duración del período en que el trabajo de horas extra real estará protegido.
<CreationDate> | Opcional | Fecha de creación de la asignación.
<ExtendedAttribute> | Opcional | Valor de un atributo extendido (campo personalizado).
<Baseline> | Opcional | Conjunto de valores previstos asociados a la asignación.
<TimephasedData> | Opcional | Datos de fase temporal asociados a la asignación.


<Confirmed> (elemento)

<Confirmed> (elemento)

Indica si un recurso asignado a una tarea ha aceptado o rechazado la asignación de la tarea en respuesta a un mensaje de asignación de tareas al recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<CostRateTable> (elemento)

<CostRateTable> (elemento)

Indica la tabla de tasas de costo que debe utilizarse para un recurso en una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | A (predeterminado)
1 | B
2 | C
3 | D
4 | E
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<Delay> (elemento)

<Delay> (elemento)

Período de tiempo que debe esperar un recurso después de la fecha de comienzo de la tarea antes de empezar a trabajar en una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<FixedMaterial> (elemento)

<FixedMaterial> (elemento)

Indica si el consumo del recurso material asignado es una cantidad fija única.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<HasFixedRateUnits> (elemento)

<HasFixedRateUnits> (elemento)

Indica si una asignación tiene unidades de tasa fijas.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<LinkedFields> (elemento)

<LinkedFields> (elemento)

Indica si hay vínculos OLE a la asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<ResourceUID> (elemento)

<ResourceUID> (elemento)

Identificador exclusivo del recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<ResponsePending> (elemento)

<ResponsePending> (elemento)

Indica si se ha recibido una respuesta a un mensaje enviado a un recurso asignado a una tarea informándole de la asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<TaskUID> (elemento)

<TaskUID> (elemento)

Identificador exclusivo de la tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<Units> (elemento)

<Units> (elemento)

El número de unidades por el que un recurso está asignado a una tarea, expresado como un porcentaje, asumiendo que el valor Capacidad máxima de un recurso es 100%.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>

Mostrar Vea también

Esquema XML del elemento <Assignment>
Estructura XML del elemento <Assignment>

Ejemplo

A continuación, se asigna el recurso número 3 a la tarea 22, al 50%

<Assignment>
      ...
   <TaskUID>22</TaskUID>
   <ResourceUID>3</ResourceUID>
   <Units>0.5</Units>
      ...
</Assignment>


<UpdateNeeded> (elemento)

<UpdateNeeded> (elemento)

Indica si debe enviarse un mensaje de actualización de equipo al recurso asignado a una tarea porque ha cambiado la fecha de comienzo, la fecha de fin o la asignación de recursos.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<VAC> (elemento)

<VAC> (elemento)

Variación en finalización (VAF) entre el costo previsto y el costo total de una asignación en una tarea.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Float
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


<WorkContour> (elemento)

<WorkContour> (elemento)

Indica cómo se distribuye el trabajo a lo largo de la duración de una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | Uniforme (predeterminado)
1 | Creciente
2 | Decreciente
3 | Dos picos
4 | Pico inicial
5 | Pico final
6 | Campana
7 | Campana achatada
8 | Personalizado
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Assignment>


Estructura y esquema XML del elemento <TimephasedDataType>

Estructura y esquema XML del elemento <TimephasedDataType>

Los datos de fase temporal constituyen un tipo de datos complejo definido en el esquema de Microsoft Office Project 2003. El elemento <TimephasedData> es de tipo <TimephasedDataType> y contiene información relativa a una tarea, un recurso o una asignación distribuida en el tiempo. A continuación se detalla la estructura y el esquema de <TimephasedDataType>.

Mostrar Vea también

Resumen del esquema XML de Project
Resumen de la estructura XML de Project

<TimephasedData> (elemento)

Estructura

<TimephasedDataType>
      <Type />
      <UID />
      <Start />
      <Finish />
      <Unit />
      <Value />
</TimephasedDataType>

Mostrar Esquema del elemento <TimephasedDataType>

<?xml version="1.0"?>
    ...
<!-- data type definitions - @TimephasedData schema -->
<xsd:complexType name="TimephasedDataType">
    <xsd:annotation>
        <xsd:documentation>The definition of the time phased data block.
        </xsd:documentation>
    </xsd:annotation>
    <xsd:sequence>
        <xsd:element name="Type" minOccurs="0">
            <xsd:annotation>
                <xsd:documentation>
                The type of task timephased data. Values are:
                    1=Assignment Remaining Work
                    2=Assignment Actual Work
                    3=Assignment Actual Overtime Work
                    4=Assignment Baseline Work
                    5=Assignment Baseline Cost
                    6=Assignment Actual Cost
                    7=Resource Baseline Work
                    8=Resource Baseline Cost
                    9=Task Baseline Work
                    10=Task Baseline Cost
                    11=Task Percent Complete
                    16=Assignment Baseline 1 Work
                    17=Assignment Baseline 1 Cost
                    18=Task Baseline 1 Work
                    19=Task Baseline 1 Cost
                    20=Resource Baseline 1 Work
                    21=Resource Baseline 1 Cost
                    22=Assignment Baseline 2 Work
                    23=Assignment Baseline 2 Cost
                    24=Task Baseline 2 Work
                    25=Task Baseline 2 Cost
                    26=Resource Baseline 2 Work
                    27=Resource Baseline 2 Cost
                    28=Assignment Baseline 3 Work
                    29=Assignment Baseline 3 Cost
                    30=Task Baseline 3 Work
                    31=Task Baseline 3 Cost
                    32=Resource Baseline 3 Work
                    33=Resource Baseline 3 Cost
                    34=Assignment Baseline 4 Work
                    35=Assignment Baseline 4 Cost
                    36=Task Baseline 4 Work
                    37=Task Baseline 4 Cost
                    38=Resource Baseline 4 Work
                    39=Resource Baseline 4 Cost
                    40=Assignment Baseline 5 Work
                    41=Assignment Baseline 5 Cost
                    42=Task Baseline 5 Work
                    43=Task Baseline 5 Cost
                    44=Resource Baseline 5 Work
                    45=Resource Baseline 5 Cost
                    46=Assignment Baseline 6 Work
                    47=Assignment Baseline 6 Cost
                    48=Task Baseline 6 Work
                    49=Task Baseline 6 Cost
                    50=Resource Baseline 6 Work
                    51=Resource Baseline 6 Cost
                    52=Assignment Baseline 7 Work
                    53=Assignment Baseline 7 Cost
                    54=Task Baseline 7 Work
                    55=Task Baseline 7 Cost
                    56=Resource Baseline 7 Work
                    57=Resource Baseline 7 Cost
                    58=Assignment Baseline 8 Work
                    59=Assignment Baseline 8 Cost
                    60=Task Baseline 8 Work
                    61=Task Baseline 8 Cost
                    62=Resource Baseline 8 Work
                    63=Resource Baseline 8 Cost
                    64=Assignment Baseline 9 Work
                    65=Assignment Baseline 9 Cost
                    66=Task Baseline 9 Work
                    67=Task Baseline 9 Cost
                    68=Resource Baseline 9 Work
                    69=Resource Baseline 9 Cost
                    70=Assignment Baseline 10 Work
                    71=Assignment Baseline 10 Cost
                    72=Task Baseline 10 Work
                    73=Task Baseline 10 Cost
                    74=Resource Baseline 10 Work
                    75=Resource Baseline 10 Cost
                    76=Physical Percent Complete
                </xsd:documentation>
            </xsd:annotation>
            <xsd:simpleType>
                <xsd:restriction base="xsd:integer">
                    <xsd:enumeration value="1" />
                    <xsd:enumeration value="2" />
                    <xsd:enumeration value="3" />
                    <xsd:enumeration value="4" />
                    <xsd:enumeration value="5" />
                    <xsd:enumeration value="6" />
                    <xsd:enumeration value="7" />
                    <xsd:enumeration value="8" />
                    <xsd:enumeration value="9" />
                    <xsd:enumeration value="10" />
                    <xsd:enumeration value="11" />
                    <xsd:enumeration value="16" />
                    <xsd:enumeration value="17" />
                    <xsd:enumeration value="18" />
                    <xsd:enumeration value="19" />
                    <xsd:enumeration value="20" />
                    <xsd:enumeration value="21" />
                    <xsd:enumeration value="22" />
                    <xsd:enumeration value="23" />
                    <xsd:enumeration value="24" />
                    <xsd:enumeration value="25" />
                    <xsd:enumeration value="26" />
                    <xsd:enumeration value="27" />
                    <xsd:enumeration value="28" />
                    <xsd:enumeration value="29" />
                    <xsd:enumeration value="30" />
                    <xsd:enumeration value="31" />
                    <xsd:enumeration value="32" />
                    <xsd:enumeration value="33" />
                    <xsd:enumeration value="34" />
                    <xsd:enumeration value="35" />
                    <xsd:enumeration value="36" />
                    <xsd:enumeration value="37" />
                    <xsd:enumeration value="38" />
                    <xsd:enumeration value="39" />
                    <xsd:enumeration value="40" />
                    <xsd:enumeration value="41" />
                    <xsd:enumeration value="42" />
                    <xsd:enumeration value="43" />
                    <xsd:enumeration value="44" />
                    <xsd:enumeration value="45" />
                    <xsd:enumeration value="46" />
                    <xsd:enumeration value="47" />
                    <xsd:enumeration value="48" />
                    <xsd:enumeration value="49" />
                    <xsd:enumeration value="50" />
                    <xsd:enumeration value="51" />
                    <xsd:enumeration value="52" />
                    <xsd:enumeration value="53" />
                    <xsd:enumeration value="54" />
                    <xsd:enumeration value="55" />
                    <xsd:enumeration value="56" />
                    <xsd:enumeration value="57" />
                    <xsd:enumeration value="58" />
                    <xsd:enumeration value="59" />
                    <xsd:enumeration value="60" />
                    <xsd:enumeration value="61" />
                    <xsd:enumeration value="62" />
                    <xsd:enumeration value="63" />
                    <xsd:enumeration value="64" />
                    <xsd:enumeration value="65" />
                    <xsd:enumeration value="66" />
                    <xsd:enumeration value="67" />
                    <xsd:enumeration value="68" />
                    <xsd:enumeration value="69" />
                    <xsd:enumeration value="70" />
                    <xsd:enumeration value="71" />
                    <xsd:enumeration value="72" />
                    <xsd:enumeration value="73" />
                    <xsd:enumeration value="74" />
                    <xsd:enumeration value="75" />
                    <xsd:enumeration value="76" />
                </xsd:restriction>
            </xsd:simpleType>
        </xsd:element>
        <xsd:element name="UID" type="xsd:integer">
            <xsd:annotation>
                <xsd:documentation>The unique identifier of the timephased data record.
                </xsd:documentation>
            </xsd:annotation>
        </xsd:element>
        <xsd:element name="Start" type="xsd:dateTime" minOccurs="0">
            <xsd:annotation>
                <xsd:documentation>The start date of the timephased data period.
                </xsd:documentation>
            </xsd:annotation>
        </xsd:element>
        <xsd:element name="Finish" type="xsd:dateTime" minOccurs="0">
            <xsd:annotation>
                <xsd:documentation>The finish date of the timephased data period.
                </xsd:documentation>
            </xsd:annotation>
        </xsd:element>
        <xsd:element name="Unit" minOccurs="0">
            <xsd:annotation>
                <xsd:documentation>The time unit of the timephased data period.
                Values are: 0=m, 1=h, 2=d, 3=w, 5=mo, 8=y
                </xsd:documentation>
            </xsd:annotation>
            <xsd:simpleType>
                <xsd:restriction base="xsd:integer">
                    <xsd:enumeration value="0" />
                    <xsd:enumeration value="1" />
                    <xsd:enumeration value="2" />
                    <xsd:enumeration value="3" />
                    <xsd:enumeration value="5" />
                    <xsd:enumeration value="8" />
                </xsd:restriction>
            </xsd:simpleType>
        </xsd:element>
        <xsd:element name="Value" type="xsd:string" minOccurs="0">
            <xsd:annotation>
                <xsd:documentation>The value per unit of time for the timephased data period.
                </xsd:documentation>
            </xsd:annotation>
        </xsd:element>
    </xsd:sequence>
</xsd:complexType>


<Unit> (elemento)

<Unit> (elemento)

Unidad de tiempo del período de datos de fase temporal.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
0 | m
1 | h
2 | d
3 | s
5 | m
8 | a
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<TimephasedData>

Mostrar Vea también

Estructura y esquema XML del elemento <TimephasedDataType>


<ActiveDirectoryGUID> (elemento)

<ActiveDirectoryGUID> (elemento)

GUID de Active Directory del recurso.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | String(16)
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<ActualOvertimeWorkProtected> (elemento)

<ActualOvertimeWorkProtected> (elemento)

Especifica el tiempo durante el cual se ha protegido el trabajo de horas extra real para una tarea, un recurso o una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<ActualsInSync> (elemento)

<ActualsInSync> (elemento)

Indica si el trabajo actual se ha sincronizado con el proyecto.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<ActualWorkProtected> (elemento)

<ActualWorkProtected> (elemento)

Especifica el tiempo durante el cual se protege el trabajo real para una tarea, un recurso o una asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Duration
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Task>
<Resource>
<Assignment>


<AdminProject> (elemento)

<AdminProject> (elemento)

Indica si el proyecto es un proyecto administrativo.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<BookingType> (elemento)

<BookingType> (elemento)

Especifica el tipo de reserva del recurso o la asignación.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Integer
1 | Comprometido
2 | Propuesto
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>
<Assignment>


<ExtendedCreationDate> (elemento)

<ExtendedCreationDate> (elemento)

Fecha utilizada para los cálculos y la creación de informes.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | DateTime
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>


<IsEnterprise> (elemento)

<IsEnterprise> (elemento)

Indica si el recurso es un recurso de empresa.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Resource>


<RemoveFileProperties> (elemento)

<RemoveFileProperties> (elemento)

Indica si se eliminarán todas las propiedades del archivo al guardar.

Mostrar Propiedades de elemento

Propiedad | Valor
Tipo de datos | Boolean
Número mínimo de apariciones | 0
Número máximo de apariciones | 1
Valor predeterminado | N/A
Resumen | False
Nillable | False
Delimitaciones del elemento | N/A

Mostrar Elementos principales

<Project>